20:15:24 <n0ano> #startmeeting
20:15:25 <openstack> Meeting started Thu Feb 23 20:15:24 2012 UTC.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:15:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:15:43 <n0ano> #topic orchestration session at Folsom summit
20:15:56 <n0ano> Well, Don Dugger would be me :-)
20:16:16 <sriramhere> Oh Sorry Don, this is my first time, and didnt get your irc id
20:16:40 <n0ano> NP, I like to confuse people (clearly it's working :-)
20:16:55 <n0ano> I think we need to setup a blueprint and make a proposal for the summit
20:17:23 <sriramhere> :)
20:17:37 <sriramhere> do we have any drafts yet?
20:17:46 <sriramhere> or previous bps?
20:18:08 <sriramhere> i am looking at http://wiki.openstack.org/EssexSchedulerImprovements
20:18:22 <n0ano> I haven't done anything yet, I believe that Sandy Walsh had one for the Essex summit, we could redo that for Folsom
20:18:35 <sriramhere> Shall i take a first crack at it?
20:18:39 <sriramhere> and u can do a review?
20:19:20 <sriramhere> disclaimer - i havent done any bps yet. i am getting involved only now, but would like to take it on, if thats ok with u/ team
20:19:20 <n0ano> That would certainly work for me.
20:19:30 <sriramhere> great!
20:19:56 <n0ano> we seem to work on the swim lesson plan, throw people in the deep end and see if they swim
20:20:04 <sriramhere> gr8
20:20:42 <sriramhere> let me get a version by Monday, so we go through review iterations couple of times before next thurs - is that a reasaonle time line?
20:20:43 <n0ano> There seem to be 2 separate areas for orchestration, scheduler enhancements (what I'm interested in) and message/process serialization.
20:21:17 <n0ano> sure, will you be talking specifically about scheduler or also address the serialziation issues?
20:21:47 <sriramhere> i will start with scheduler. my intiial gut tellsme it might require two. i might be wrong
20:22:08 <sriramhere> i will start with that, then may be combine both if thats correct
20:22:12 <n0ano> let's start from there and see where we go, I think that be fine.
20:22:17 <sriramhere> cool
20:22:19 <mikeyp> (sorry, I'm late)
20:22:50 <n0ano> NP, we're talking about creating a blueprint for an orchestration session at the Folsom summit
20:23:08 <n0ano> sriramhere, has agreed to start one by Monday that we can then review
20:23:54 <mikeyp> The Essex bluebrint is still valid for the most port.
20:24:23 <n0ano> that's what I was thinking, just update that a little bit for Folsom
20:24:39 <n0ano> do you have a direct link to the Essex blueprint?
20:24:45 <sriramhere> anything specific that is missing?
20:24:56 <sriramhere> no i dont - can u please point me that?
20:25:27 <mikeyp> #link http://wiki.openstack.org/NovaOrchestration
20:27:42 <sriramhere> thx,
20:28:21 <mikeyp> The essex presentation is also archived #link http://www.youtube.com/watch?v=lTZJXjRtuSU
20:28:47 <n0ano> so, shall we have sriramhere update the Orch. BP and see if we can use that as a basis for a talk at the Folsom summit?
20:30:39 <mikeyp> sounds like a plan.  maoy and beekhof both had proposals on implementation, so they will likely have some feedback
20:31:02 <sriramhere> gr8, wat more do i need to watch out for / look for?
20:32:08 <mikeyp> I think it will mostly involve the implications of the tactical scheduler enhancements
20:32:30 <mikeyp> don't have much real world experience with those yet
20:33:43 <sriramhere> i ll check out existing systems like yagi. and try to include the enhancements
20:34:32 <sriramhere> do we need to worry abt scoping now?
20:34:55 <n0ano> what was your concern?
20:36:39 <sriramhere> n0ano - is that question for me or mikeyp?
20:36:58 <n0ano> sriramhere, sorry, yes was to you, what is your scoping conern?
20:38:04 <sriramhere> scoping - i wanted to know if the BP should inlcude any scoping - for instance features only for Folsom, or can start big, and can be contained/ scoped as Folsom, Folsom+ features
20:39:30 <sriramhere> scheduler improvements - one can do keep doing this forever. my assumtion is BP shoul contain what we are proposing for Folsom alone
20:40:05 <sriramhere> and may be call out some as Folsom+ if doesn't appear to be fit
20:40:38 <n0ano> as long as we don't restrict ourselves too much focusing on Folsom would be good, there will be an G summit for followon work
20:41:13 <sriramhere> ok - thats good to know, think big then:)
20:41:59 <n0ano> in that case:
20:42:19 <n0ano> #action sriramhere to update Orchestration blueprint for a Folsom session
20:42:46 <n0ano> anything else we want to discuss
20:43:09 <sriramhere> request to give appropriate permissions
20:43:16 <sriramhere> i am good otherwise
20:44:26 <n0ano> I'm not sure about the permissions issue, we might need someone more knowledgble about Launchpad than I if there's an issue there
20:45:14 <sriramhere> ok
20:45:32 <sriramhere> thanks. cu all
20:45:46 <n0ano> In that case I'll thank everyone and I'll be here next week.
20:46:02 <n0ano> #endmeeting