21:03:00 <ttx> #startmeeting
21:03:01 <openstack> Meeting started Tue Feb  7 21:03:00 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:09 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:38 <ttx> #topic Actions from last week
21:04:25 <ttx> * jaypipes to assign or defer glance-bittorrent-delivery
21:04:31 <ttx> Looks like that was done
21:05:10 <ttx> actually, everything was done, so let's talk about something else
21:05:21 <ttx> #topic Keystone status
21:05:27 <ttx> zns: o/
21:05:32 <termie> \o
21:05:35 <heckj> o/
21:05:39 <zns> ttx: hi. termie also here?
21:05:42 <zns> yes.
21:05:45 <ttx> #link https://launchpad.net/keystone/+milestone/essex-4
21:05:49 <termie> we've got the redux branches for devstack and keystone green in gerrit
21:06:04 <ttx> do we have a rough ETA for the merge ?
21:06:11 <termie> ready to merge once we agree upon what we consider "blockers" for merge
21:06:21 <ttx> Looking at: https://bugs.launchpad.net/keystone/+bugs?field.tag=redux
21:06:26 <ttx> termie: What needs to go in *before* we can merge ?
21:06:26 <termie> right now i think the "ksl" team have a different opinion on that than zns
21:06:32 <heckj> I've got the total list of discussed elements in there, but there's not yet agreement on what's a blocker
21:06:43 <heckj> termie: ++
21:06:45 <termie> so we're planning on finishing that discussion with zns today, assuming he has time
21:07:16 <zns> termie: I do. I didn't know we had a disconnect on that. I'm available to talk through that.
21:07:17 <ttx> How are you marking the blockers ? E4 targeting ? Or Critical/High "redux-tagged" ?
21:07:39 <heckj> ttx: Critical & tagged with redux
21:07:47 <ttx> heckj: ok, works for me.
21:07:58 <termie> heckj: made a bunch of launchpad bugs and uglied up our etherpad :p
21:07:59 <heckj> (the current bug list may need to be updated after the conversation this afternoon)
21:08:06 <ttx> I'd really prefer to see the redux branch merged ASAP, ideally before next week...
21:08:11 <ttx> ...so that the buglist can be clearly reviewed to only include issues still affecting ksl
21:08:20 <termie> me also
21:08:25 <heckj> +100
21:08:36 <termie> i don't think most of these things are actually blockers, so assuming we can convince zns i think we should be on track
21:09:03 <termie> and we can be _very_ persuasive
21:09:10 * termie winks
21:09:25 <ttx> #action zns, heckj and termie to define list of blockers before redux merging
21:09:34 <ttx> zns: who is working on https://blueprints.launchpad.net/keystone/+spec/keystone-test-refactor ?
21:09:48 <ttx> (if it still makes sense)
21:10:03 <zns> ttx: I don't think anyone is. Doesn't make sense if we're merging soon...
21:10:21 <heckj> zns: retarget or kill?
21:10:28 <zns> kill
21:10:29 <ttx> zns: OK, we should probably remove it from targets
21:10:36 * heckj (does that)
21:10:39 <ttx> ack
21:10:51 <ttx> Anything else on Keystone ?
21:11:02 <termie> keystone is dead, long live keystone!
21:11:18 <zns> Nothing else :-)
21:11:37 <ttx> notmyname: is the fire drill over ?
21:11:44 <notmyname> almost
21:11:47 <notmyname> not yet
21:11:52 <ttx> we can do Glance first.
21:11:57 <ttx> #topic Glance status
21:12:05 <ttx> jaypipes: yo
21:12:14 <ttx> #link https://launchpad.net/glance/+milestone/essex-4
21:13:16 <ttx> jaypipes: around ?
21:14:02 <jaypipes> ttx: yup
21:14:21 <ttx> About https://blueprints.launchpad.net/glance/+spec/progressbar-upload-image
21:14:26 <ttx> jaypipes: the series goal is not set to accepted -- shall I confirm it ?
21:14:37 <jaypipes> ttx: yes, ty
21:14:49 <ttx> jaypipes: Your medium/low E4-targeted bugs list looks under control
21:15:10 <jaypipes> ttx: ya, nothing too exciting.
21:15:11 <ttx> Are you reasonably happy with the current state of Glance ? Or do you think the bug list doesn't really reflect reality ?
21:15:22 <jaypipes> ttx: no, I'm happy with it.
21:15:59 <ttx> jaypipes: Anything else ?
21:16:21 <jaypipes> ttx: nope
21:16:40 <ttx> Questions on Glance ?
21:18:03 <ttx> notmyname: ready ?
21:18:06 <notmyname> ok
21:18:12 <ttx> #topic Swift status
21:18:17 <ttx> #link https://launchpad.net/swift/+milestone/1.4.6
21:18:22 <ttx> Thanks for filling that up.
21:18:33 <notmyname> np
21:18:45 <ttx> notmyname: Anything else you still wait on that would not be listed ?
21:19:15 <notmyname> no, I'm not aware of any other new features (ie blueprints) that should get added
21:19:41 <ttx> notmyname: When it's ready, push the changelog, then the new version number to master... I'll cut the milestone-proposed branch from the changelog commit.
21:19:59 <ttx> notmyname: does that sound like a plan ?
21:20:01 <notmyname> will do. the plan is to do that tomorrow
21:20:09 <ttx> great
21:20:10 <notmyname> then have it ready by EOD friday
21:20:42 <ttx> notmyname: hmm, that's your EOD, right
21:21:16 <notmyname> yes. I'll let you know (email?) when we're ok with it
21:21:18 <ttx> I might need to find someone to push it, I'll be busy packing and traveling to my vacation spot by EOD friday
21:21:55 <ttx> but that should work.
21:22:01 <ttx> notmyname: Anything else ?
21:22:33 <notmyname> I'll be in santa clara next week at cloud connect. I'm happy to talk to anyone about swift while I'm there
21:22:36 <notmyname> that's all
21:22:44 <ttx> Questions on Swift ?
21:23:25 <ttx> #topic Nova status
21:23:31 <ttx> vishy: hey
21:23:36 <ttx> #link https://launchpad.net/nova/+milestone/essex-4
21:23:48 <ttx> Looks like more FFes have been accepted ?
21:23:52 <vishy> hi
21:24:17 <ttx> and you play the jaypipes and update the list at the last minute.
21:24:21 <vishy> ttx: I'm not totally sure how to manage covering stuff that is cleanup related
21:24:25 <vishy> ttx: sorry :)
21:24:36 <vishy> jaypipes has been coaching me
21:24:52 <ttx> I think it's good to track cleanups as blueprints as well. Leaves a good trace on the milestone page
21:25:17 <ttx> most of those last features added are harmless, I suppose...
21:25:20 <vishy> ttx: for example https://blueprints.launchpad.net/nova/+spec/keystone-export-rewrite
21:25:35 <ttx> ... but remember the idea of feature freeze is to focus on testing and bugs, not on adding as many harmless features as we can :)
21:25:58 <vishy> ttx: agreed
21:26:02 <ttx> vishy: sounds good to me
21:26:17 <vishy> ttx: We have three FFes that haven't submitted code yet
21:26:20 <ttx> so this is blocked by KSL merge ?
21:26:32 <ttx> (the two blocked ones)
21:26:39 <vishy> ttx: yes, waiting on the merge
21:26:52 <vishy> ttx: the second one may have to wait for folsom
21:27:02 <vishy> ttx: depending on how the migration script is written
21:27:03 <ttx> what you need from the merge is already in the redux branch ?
21:27:19 <vishy> ttx: true, so perhaps blocked isn't the best description
21:27:25 <vishy> ttx: more like waiting
21:27:31 <ttx> vishy: I can live with "Blocked"
21:27:35 <vishy> ttx: the people doing the work are focusing on the ksl merge first
21:27:52 <ttx> fast-cloning-for-xenserver, heterogeneous-tilera-architecture-support look "almost in"
21:28:01 <ttx> libvirt-resize and remove-ajaxterm are proposed, need review
21:28:12 <vishy> all 4 of those are really close
21:28:17 <vishy> i expect them all in by tomorrow
21:28:20 <ttx> zeromq-rpc-driver, nexenta-volume-driver, netapp-volume-driver have no code proposed yet
21:28:26 <ttx> Do we have an ETA for them ?
21:28:36 <vishy> sounds like we will se a prop for zeromq by tomorrowish
21:28:38 <ewindisch> ttx: I just completed today
21:28:54 <vishy> netapp had a prop in but it was missing code, so I assume next day or two there as well
21:28:59 <vishy> nexenta I have no idea
21:29:28 <ttx> OK, we should reach to them
21:29:46 <vishy> i will send an email asking for status
21:30:01 <ttx> #action vishy to reach to Oleg nexenta-volume-driver ETA
21:30:10 <ttx> I think we should remove https://blueprints.launchpad.net/nova/+spec/consolidate-testing-infrastructure since there is no visible progress on it.
21:30:15 <vishy> the last one, which I marked deferred, was the one from comstud
21:30:32 <vishy> although, based on the last email, I'd like to at least see the code before we decide yes or no on that one
21:30:38 <ttx> ogelbukh: ETA on  nexenta-volume-driver ?
21:31:37 <ogelbukh> going to get it to review by friday
21:31:41 <ttx> oubiwann: OK to defer consolidate-testing-infrastructure ?
21:31:48 <ttx> ogelbukh: sounds good
21:32:12 <ttx> vishy: sounds like we should defer https://blueprints.launchpad.net/nova/+spec/openstack-api-ssl too. Haven't seen much activity there
21:32:21 <vishy> ttx: yeah
21:32:31 <vishy> ttx: although man, it seems like that is kinda vital for some people
21:32:47 <vishy> ttx: so I don't know why we haven't seen a prop.  I guess there is always the nginx in front route
21:33:00 <ttx> Let's defer both, and see if that triggers something
21:33:10 <vishy> ttx: should i retarget comstud's blueprint to e-4?
21:33:31 <ttx> vishy: yes, I prefer to have it in scope rather than under the radar line
21:34:09 <ttx> Maybe marked Blocked until we know if that will be accepted (with a note on the whiteboard saying why it's blocked)
21:34:21 <ttx> What's the state of https://blueprints.launchpad.net/nova/+spec/nova-sweep ?
21:34:59 <vishy> done
21:35:42 <vishy> haven't heard anything on that one
21:35:52 <vishy> my comment in the whiteboard still applies
21:36:06 <vishy> as a helper script e-4 is fine, but anything more than that is definitely Folsom
21:36:22 <vishy> lets leave it until friday, and I will defer it if we don't hear anything
21:36:29 <ttx> ok
21:36:59 <ttx> vishy: Should I mark scaling-zones blocked like proposed above ?
21:37:15 <vishy> already did it
21:37:30 <ttx> refresh fail
21:37:40 <ttx> vishy: status on https://blueprints.launchpad.net/nova/+spec/optional-host-and-admin-information ? Not started ?
21:38:25 <vishy> ttx: anthony is working on that. Discovered that it really hard for admins via dashboard because ther is no way to find out where an instance is running
21:38:51 <vishy> I think it is Not Started right now, but it is a pretty small change.
21:38:55 <ttx> ack
21:39:02 <ttx> All in all it doesn't look too bad -- critical path goes through redux branch merge, so we need that in ASAP.
21:39:21 <vishy> ttx: agreed. Our whole team is focusing on that for the next 3 days
21:39:29 <ttx> vishy: Anything else ?
21:39:50 <vishy> ttx: I will be sending out an email update soon
21:39:57 <vishy> ttx: no other notes for the meeting
21:40:00 <ttx> Nova subteam leads: anything on your side ?
21:40:10 <ttx> Anyone: Questions on Nova ?
21:40:13 <deshantm> Is xenserver live migration (https://blueprints.launchpad.net/nova/+spec/xenapi-live-migration) targeted for essex? I know it depends on host aggregates
21:40:34 <ttx> deshantm: no it's not
21:41:17 <ttx> definitely not something I'd add during a feature-frozen period.
21:41:39 <vishy> deshantm: definitely not essx
21:41:49 <vishy> I mean it would be cool, it is just pushing it
21:41:53 <vishy> f1 i think
21:42:31 <ttx> devcamcar: around ?
21:42:37 <devcamcar> o/
21:42:42 <ttx> #topic Horizon status
21:42:48 <ttx> #link https://launchpad.net/horizon/+milestone/essex-4
21:42:55 <ttx> Looking good so far ?
21:43:05 <devcamcar> we've been churning through buts quickly
21:43:14 <ttx> buts ?
21:43:15 <devcamcar> most of the blue prints are very small in scope
21:43:35 <ttx> devcamcar: Do you have an ETA for ec2-credentials-download and improve-visual-design ?
21:43:40 <devcamcar> some of the ux table changes may not land
21:43:45 <devcamcar> ec2 credentials is in review i believe
21:43:56 <devcamcar> improve visual design will be closed soon
21:44:14 <ttx> ok, so before mid-E4
21:44:16 <ohnoimdead> table changes are done afaik
21:44:18 <ttx> sounds good.
21:44:30 <devcamcar> ohnoimdead: things like https://bugs.launchpad.net/bugs/884473
21:44:31 <uvirtbot> Launchpad bug 884473 in horizon "UX Improvements: Overall Table Changes - Add table menu to add/remove columns" [High,Confirmed]
21:44:45 <ttx> Your list of 50+ open E4-targeted bugs is a bit scary.
21:44:53 <ttx> devcamcar: Do you think you can fix all of them before the end of the month ?
21:45:09 <devcamcar> we've been averaging 40-50 fixes per milestone
21:45:14 <devcamcar> seems doable
21:45:23 * ttx takes bets
21:45:24 <devcamcar> i do need to go back over the remaining items and ensure priority is still accurate
21:45:47 <ttx> ok
21:45:51 <ttx> devcamcar: Anything else ?
21:46:04 <devcamcar> goal will be for at least everything medium or higher to land
21:46:13 <devcamcar> i see a few mediums that can be lowered
21:46:17 <devcamcar> i'll review with the gang
21:46:18 <ohnoimdead> devcamcar: how do you feel about punting the swift ui improvements out of e4?
21:47:08 <devcamcar> would like to see it land but we will do what must be done
21:47:19 <ttx> Questions for Horizon ?
21:48:00 <ttx> #topic Incubated projects and other Team reports
21:48:10 <ttx> danwent, troytoman: yo
21:48:18 <troytoman> o/
21:48:22 <danwent> hi
21:48:27 <danwent> troy, you go first :)
21:48:45 <troytoman> with melange we are just focused on bug fixing and finalizing a 1.0 api
21:49:06 <troytoman> also working with dan went to improve quantum manager test coverage, etc
21:49:10 <ttx> troytoman: do you plan to file for Core inclusion ?
21:49:31 <troytoman> under discussion. know we need to make a decision soon
21:49:44 <ttx> yes, before the end of the month in all cases.
21:49:57 <troytoman> understood
21:50:20 <ttx> danwent: what news ?
21:50:27 <danwent> https://launchpad.net/quantum/+milestone/essex-4
21:50:33 <danwent> we're making a big push around testing.
21:50:47 <danwent> trying to get some system/integration tests into devstack repo (debo is leading this)
21:51:02 <danwent> and drastically improving coverage in Quantum Manager code in nvoa
21:51:04 <danwent> nova
21:51:18 <danwent> also will be welcoming a few new plugins to the server codebase.
21:51:29 <ttx> danwent: I kinda expected you'd file for Core this week ?
21:51:29 <danwent> working with horizon team to try and clean things up for essex
21:51:40 <danwent> I was planning on next tuesday
21:51:46 <danwent> is there a PPB meeting?
21:51:52 <ttx> Waiting for me to be in vacation, I see
21:52:02 <ttx> There is a PPB meeting if there is something to discuss.
21:52:02 <danwent> ah, sorry.  can wait another week if you prefer.
21:52:35 <danwent> but yes, we're planning on applying for inclusion in core.  Plan was to do it next week, but I'm flexible.  ping me if you have suggestions.
21:52:38 <ttx> can't hurt to propose early, in case the board asks for some time to review
21:52:45 <danwent> exactly my thinking
21:53:09 <ttx> and I can give my vote by email if needed.
21:53:19 <danwent> great, thanks (i hope) :)
21:53:24 <ttx> danwent: anything else ?
21:53:25 <danwent> that's really all from my end.
21:53:35 <ttx> Any other team lead with a status report ? annegentle, mtaylor ?
21:56:44 <ttx> hmm, guess not
21:56:52 <ttx> #topic Open discussion
21:57:08 <ttx> Note that I won't be here next week, so I will ask another release team member to run the show
21:57:20 <ttx> OpenStack@FOSDEM went well, I think, if you exclude the cold.
21:58:02 <ttx> Anything else, anyone ?
21:58:06 <deshantm> ttx: were any slides or videos related to openstack posted anywhere?
21:58:10 <deshantm> (for fosem)
21:59:19 <ttx> deshantm: my presentation is at http://ubuntuone.com/7gWt56Ue24mpkgIRJbO4gT
21:59:33 <annegentle> here, late :) We're working on releasing api.openstack.org, hopefully linking to The FreeCloud.
21:59:36 <ttx> Will see if we can make presenters upload theirs to the devroom wiki
22:00:19 <annegentle> The Free Cloud (freak loud!) should launch soon - hopefully next week.
22:01:36 <ttx> ok then.
22:01:43 <ttx> Let's leave the room to netstackers.
22:01:46 <annegentle> also look for a Foundation meet up at Cloud Connect - see http://wiki.openstack.org/Governance/Foundation, Feb 15th at 4:30
22:01:47 <ttx> #endmeeting