21:03:23 <ttx> #startmeeting
21:03:24 <openstack> Meeting started Tue Nov 29 21:03:23 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:37 <ttx> Our agenda for today: http://wiki.openstack.org/Meetings/TeamMeeting
21:03:54 <ttx> Note that we'll discuss the new core repositories for client projects after the project updates, so stay around after your project topic is done...
21:04:04 <ttx> #topic Actions from previous meeting(s)
21:04:16 <ttx> * mtaylor devcamcar to discuss and converge to a common view on the need to split repos for horizon (or not)
21:04:24 <ttx> mtaylor: Did you discuss that yet ?
21:04:52 <ttx> * Keystone devs to help with bug 891442
21:04:53 <uvirtbot> Launchpad bug 891442 in horizon "renaming of api_key causes several unhandled exceptions" [Critical,Confirmed] https://launchpad.net/bugs/891442
21:05:10 <ttx> dolphm: not sure if your help is still needed there ?
21:06:05 <dolphm> ttx: don't believe so
21:06:33 <ttx> Hmm, let's talk back about it during the horizon topic, hopefully we'll have devcamcar in by then
21:06:39 <ttx> #topic Keystone status
21:06:43 <mtaylor> hi ttx
21:06:49 <ttx> mtaylor: ah
21:07:10 <ttx> mtaylor: let's discuss that at the split repo topic
21:07:18 <mtaylor> ttx: great
21:07:19 <ttx> #link https://launchpad.net/keystone/+milestone/essex-2
21:07:28 <ttx> dolphm: is the status on there current ?
21:07:38 <dolphm> keystone updates -- we're focusing mostly on open bugs (yay!), doc improvements (yay!) and finally paying more attention to integration efforts
21:08:07 <notmyname> ttx: here
21:08:18 <dolphm> ttx: yes, those statii (-es? lol) look accurate?
21:08:31 <ttx> So service-endpoint-location endpoint-identifiers are not started yet ?
21:09:17 <dolphm> I'm not aware of any code published for locations, and we're still discussing endpoint identifiers
21:09:25 <ttx> (Remember the E2 changes need to be proposed and merged by December 13.)
21:09:39 <ttx> Looking at the general essex roadmap, there is a blueprint without a milestone target:
21:09:44 <ttx> https://blueprints.launchpad.net/keystone/+spec/keystone-domains
21:09:50 <ttx> dolphm: Should that be targeted to essex-3 ?
21:10:14 <ttx> (since that's you last feature milestone, iirc)
21:10:37 <dolphm> ttx: endpoint-identifiers probably should be... in exchange, we may be addressing https://blueprints.launchpad.net/keystone/+spec/portable-identifiers sooner rather than later
21:10:45 <dolphm> (as the endpoint-identifiers mentions)
21:11:38 <ttx> dolphm: should keystone-domains be targeted to E3 ?
21:12:13 <ttx> or you don't know when is HP committed to it ?
21:12:18 <jsavak> ttx: (hi) - that's a HP question
21:12:40 <dolphm> yeah, i don't have any visibility on keystone-domains myself
21:12:49 <ttx> ok, will try to break the bug IRC wall and get more status updates
21:12:53 <ttx> big*
21:12:59 <ttx> dolphm: Anything else ?
21:13:11 <jsavak> also I'm wondering if  https://blueprints.launchpad.net/keystone/+spec/endpoint-identifiers and https://blueprints.launchpad.net/keystone/+spec/portable-identifiers can be merged
21:13:39 <ttx> jsavak: noted
21:13:43 <ttx> In other news, we cut a 2011.3.1 "Diablo+" tarball last week:
21:13:48 <ttx> https://launchpad.net/keystone/diablo/2011.3.1
21:13:54 <ttx> Questions for Keystone ?
21:14:05 <dolphm> yes, i have an open question for keystone consumers / CI peeps -- we'd like to directly support a CI effort in the long run... is openstack-integration-tests the best place to do that?
21:14:48 <jaypipes> dolphm: yep
21:15:07 <jaypipes> dolphm: it's handled the same as all core projects... gerrit-ified and all.
21:15:16 <dolphm> is it the *only* such effort we should support?
21:15:26 <reed> #info <dolphm> keystone updates -- we're focusing mostly on open bugs (yay!), doc improvements (yay!) and finally paying more attention to integration efforts
21:15:31 <jaypipes> dolphm: yes.
21:15:46 <dolphm> cool -- will do
21:15:47 <jaypipes> dolphm: or rather, the only one that the QA team is focusing on.
21:15:54 <dolphm> fair enough
21:15:56 <ttx> Other questions for Keystone ?
21:16:00 <jaypipes> dolphm: awesome, thx
21:16:04 <dolphm> i'll be joining those meetings then
21:16:21 <ttx> #topic Swift status
21:16:25 <ttx> notmyname: o/
21:16:28 <notmyname> hi
21:16:53 <notmyname> swift 1.4.4 was released last thursday
21:17:01 <reed> #info  swift 1.4.4 was released last thursday
21:17:04 <notmyname> we recommend you upgrade
21:17:10 <ttx> notmyname: do you agree that the next version will be called 1.4.5 ?
21:17:26 <pvo> drumroll
21:17:28 <notmyname> ttx: I have no reason to think otherwise right now
21:17:35 <ttx> No ETA yet, I suspect ?
21:17:44 <notmyname> ttx: of course, that can quickly get in to other topics :-)
21:17:53 <ttx> #action ttx to create swift/1.4.5 milestone, no ETA yet
21:17:55 <notmyname> no ETA for the next version of swift yet
21:18:03 <ttx> notmyname: Anything else ?
21:18:15 <notmyname> I'm currently working on getting better visibility into progress and tasks and such
21:18:35 <notmyname> I'l be in the bay area next week. come to the meetup to talk swift
21:18:48 <ttx> Questions on Swift ?
21:18:58 <reed> notmyname, visibility into progress? can you elaborate?
21:19:22 <notmyname> reed: better coordination with internal project management tools and expternal, openstack ones.
21:19:31 <reed> cool. thanks
21:19:34 <notmyname> reed: and better visibility on what's being worked on and planned
21:20:00 <notmyname> reed: so it's easier to coordinate between companies
21:20:21 <ttx> #topic Glance status
21:20:24 <reed> #info <notmyname> I'm currently working on getting better visibility into progress and tasks and such [to the community]
21:20:28 <ttx> jaypipes: yo
21:20:33 <jaypipes> ttx: oy
21:20:36 <ttx> #link https://launchpad.net/glance/+milestone/essex-2
21:20:44 <ttx> Progress on features looks good...
21:21:08 <jaypipes> ttx: meh. got a bunch of reviews currently in progress.
21:21:17 <ttx> Looking at the general essex plan at: https://blueprints.launchpad.net/glance/essex
21:21:27 <ttx> You still have glance-xml and gzip-compression in plan, with no milestone...
21:21:33 <jaypipes> ttx: ran into a bunch of issues with our Keystone functional tests that required fixes to Keystone.
21:21:40 <ttx> jaypipes: Should I unset the series goal for them ? Or do you have someone committed to do them ?
21:21:55 <jaypipes> ttx: you can unset those. sorry for not doing that earlier.
21:21:59 <ttx> willdo
21:22:16 <ttx> #action ttx to unset glance-xml and gzip-compression
21:22:27 <ttx> jaypipes: "required", so it's ok now ?
21:22:45 <dolphm> jaypipes: thanks for those :)
21:22:46 * ttx likes the dependency tree at https://blueprints.launchpad.net/glance/+spec/api-2
21:23:07 <ttx> jaypipes: feeling confident that this tree can all be completed in E3 ?
21:23:20 <jaypipes> dolphm: yeah, no worries. mostly just version skew.
21:23:31 <ttx> (Lots of small blueprints, I suspect)
21:23:58 <jaypipes> ttx: no, it's going to be tough. I've been trying to get the third version of the 2.0 API proposal done. 90% there.
21:24:07 <jaypipes> ttx: everything depends on signoff on the 2.0 proposal.
21:24:41 <glenc> my bad
21:24:46 <ttx> jaypipes: so it may overflow on E4 ?
21:25:17 <jaypipes> ttx: perhaps, yes.
21:25:22 <ttx> ok
21:25:24 <jaypipes> glenc: not your fault.
21:25:27 <ttx> jaypipes: Anything else ?
21:25:45 <jaypipes> ttx: no, not right now. thx.
21:25:46 <glenc> jaypipes: but I do have some stuff I need to run by you - I'll contact you tomorrow
21:25:53 <jaypipes> glenc: cool.
21:26:24 <ttx> Questions on Glance ?
21:26:50 <ttx> #topic Nova status
21:26:54 <ttx> vishy: yo
21:27:01 <ttx> #link https://launchpad.net/nova/+milestone/essex-2
21:27:07 <vishy> hi
21:27:10 <ttx> Progress looks good in general
21:27:19 <vishy> yes we need some reviews
21:27:30 <ttx> Right, two essential blueprints look blocked in review:
21:27:37 <ttx> nova-vm-state-management -> https://review.openstack.org/#change,1695
21:27:41 <ttx> nova-volume-snapshot-backup-api -> https://review.openstack.org/#change,1202
21:27:48 <vishy> the first is the big one
21:27:58 <vishy> the second we are waiting on updates from the author
21:28:11 * vishy wishes we had a WIP flag
21:28:24 <ttx> mtaylor: ^ :)
21:28:45 <vishy> the other stuff seems to be implemented/on track
21:28:53 <mtaylor> vishy: yes! it's on the CI roadmap with high priority
21:28:58 <ttx> vishy: on the general Essex plan, are you making progress with the subteams ?
21:29:08 <ttx> Or do you need help in getting feedback from them ?
21:29:18 <mtaylor> vishy: I will have the blueprint about it done today
21:29:34 <vishy> titan team.  Anyone know how much more uuid related changes are needed?
21:29:39 <vishy> * many
21:29:50 <vishy> ttx: I haven't received any feedback
21:29:51 <bcwaldon> coming to a close, very close to being done
21:30:16 <westmaas> bcwaldon: next round don't need as many changes?
21:30:21 <ttx> vishy: would going to thei
21:30:24 <vishy> and not much is targeted to e-3 yet
21:30:29 <ttx> r team meeting help ?
21:30:30 <bcwaldon> we're up around 40 branches at this point already in, with a few more left to do
21:30:37 <bcwaldon> westmaas: correct
21:30:42 <ttx> vishy: or they don't have any ?
21:30:43 <vishy> so maybe i should start threatening violence
21:30:58 <ttx> if violence means "less features" i'm all for it
21:31:06 <vishy> I've been attending meetings as I can
21:31:19 <vishy> I just want the features actually targetted
21:31:24 <ttx> I'm concerned about disk-configuration-parity (feature parity team / sleepsonthefloor)
21:31:25 <vishy> and assigned
21:31:38 <westmaas> vishy: is the uuid story a problem?
21:31:42 <ttx> and separate-nova-volumeapi (Nova API team, bcwaldon)
21:31:46 <vishy> westmaas: no
21:31:47 <westmaas> s/story/bp/
21:31:49 <westmaas> ok
21:31:51 <soren> I'm not sure it's going to scale to have the PTL to attend other's team meetings..
21:32:02 <vishy> soren: cloning?
21:32:16 <soren> vishy: Clones still need to grow up. PEople always forget that.
21:32:38 <vishy> soren: well I would appreciate general updates occasionally
21:32:52 <vishy> soren: but mostly if the subteam leads just stay on top of their blueprints
21:32:57 <vishy> that would probably be enough
21:33:01 <soren> It should be.
21:33:04 <soren> That's my point :)
21:33:15 <vishy> ttx: what is your concern about those two?
21:33:34 <ttx> vishy: they are marked essential, so I suppose they are extra-important for you
21:33:55 <ttx> and they won't happen if nobody is committed to work on them
21:34:00 <vishy> they are
21:34:10 <tr3buchet> didn't they figure out how to accelerate the growth rate of clones
21:34:19 <vishy> which means I will probably have to do them myself!
21:34:21 <vishy> :)
21:34:51 <ttx> vishy: if teams don't produce anything and don't report up, they should be disbanded. Having them becomes a distraction
21:35:05 <vishy> ttx: true
21:35:06 <Vek> or new leaders appointed.
21:35:16 <vishy> ttx: know there are things going on
21:35:20 <ttx> Vek: depends if the problem is leadership or membership
21:35:30 <Vek> point.
21:35:30 <vishy> ttx: they just haven't congealed into specific tasks
21:35:39 <ttx> vishy: ok, will talk to you about that this week
21:35:51 <vishy> ttx: cool.  Open to suggestions
21:36:03 <vishy> maybe we need a mandatory team-lead meeting?
21:36:03 <ttx> #action ttx and vishy to discuss how to solve Nova's team structure
21:36:13 <ttx> In other news, https://blueprints.launchpad.net/nova/+spec/consolidate-testing-infrastructure is in the plan, without a milestone set
21:36:14 <tr3buchet> vishy: that seems like a good idea
21:36:19 <ttx> soren, oubiwann: do you have a target milestone for that ?
21:36:35 <soren> ttx: When's the next milestone again?
21:36:38 <ttx> E2
21:36:42 <ttx> Dec 15
21:36:43 <soren> "when"
21:36:46 <vishy> soren: ah yes I pinged you about that yesterday.
21:36:56 <soren> vishy: Yeah. I suck. I know :)
21:36:59 <vishy> soren: i wanted to make sure you thought it was correct before I approved it
21:37:14 <vishy> although apparently i already accepted for essex :)
21:37:19 <ttx> vishy: could you approve/set prio ?
21:37:21 <soren> Yes, I saw that too :)
21:37:24 <soren> I think E2 is doable.
21:37:34 <vishy> soren: no qualms with approving it?
21:37:40 <ttx> vishy: soren is in drivers so it's auto-approved to Essex
21:37:46 * soren smells a trick questino
21:37:48 <vishy> oh!
21:37:49 <soren> question, even.
21:37:57 <soren> ttx: I didn't touch it!
21:38:00 <ttx> vishy: he is supposed to know what he is doing
21:38:11 <vishy> soren: no, just wanted to make sure it fits in with your testing refactor
21:38:15 <ttx> you didn't set the series goal to essex ?
21:38:22 <soren> I think it must have been vishy. It was approved when I first went and looked.
21:38:30 <ttx> heh
21:38:37 <vishy> i might have done it
21:38:40 <ttx> vishy: Anything else ?
21:38:41 <soren> Anyways.
21:38:49 <vishy> yes I want to talk about ppas
21:38:55 <soren> Yes, I think it definitely falls within the testing refactor.
21:38:58 <vishy> but I don't know if i should save that until the end.
21:39:15 <ttx> #action vishy to set E2/prio/approval on consolidate-testing-infrastructure
21:39:29 <ttx> vishy: save it, if it's general
21:39:47 <ttx> Questions on Nova ?
21:39:51 <mtaylor> vishy: ping me when you start talking about that
21:40:04 <ttx> devcamcar: around now ?
21:40:51 <ttx> skipping Horizon, we'll be back if devcamcar or someone else shows up to represent Horizon
21:40:57 <ttx> #topic Status on new core repositories
21:41:09 <ttx> So, for E2 we are introducing new repositories for several core projects
21:41:20 <ttx> For Nova for example we are adding novaclient as an additional release deliverable
21:41:34 <ttx> I'd like to go over the list and get status, see if we are on track for that for E2
21:41:47 <ttx> mtaylor: For Nova, we have novaclient being added -- how is that going so far ?
21:42:22 <mtaylor> ttx: novaclient is in and good to go
21:42:29 <ttx> Do we have tarball CI jobs up yet ?
21:42:34 <ttx> or just the repo ?
21:42:34 <mtaylor> ttx: it's gerrit-ified and cutting tarballs
21:42:39 <ttx> ok
21:42:51 <ttx> We'll probably need milestone-proposed jobs
21:42:55 <ttx> I'll check that
21:43:15 <ttx> For Horizon, there was a proposal to split the django lib and the reference implementation, where are we with that ?
21:43:25 <mtaylor> we are not doing that at the moment
21:43:32 <mtaylor> there are workflow issues that need to be solved
21:43:39 <ttx> #action ttx to check the need for MP jenkins jobs on novaclient
21:43:48 <mtaylor> I have a todo list item to present devcamcar with some options of how it could work
21:43:54 <ttx> mtaylor: so we keep a single tarball for e2 ?
21:44:03 <mtaylor> ttx: yes.
21:44:23 <ttx> mtaylor: ok, but it would be good to have the final form by E3
21:44:33 <mtaylor> ttx: ok. noted
21:44:37 <ttx> whatever that is
21:44:41 <mtaylor> ++
21:44:45 <ttx> mtaylor: Do we need client splits for other projects (Keystone, Swift, Glance) ?
21:44:47 <mtaylor> we need to pull python-keystoneclient in to the fold, split out quantum client and glance client, and I think we'll be in good shape
21:45:14 <ttx> those are still TODOs, right ?
21:45:14 <zns> Yes. Would like to do that for Keystone.
21:45:38 <troytoman> mtaylor: we should get Melange set up right from the start
21:45:38 <ttx> mtaylor: but on track for E2 ?
21:45:43 <mtaylor> zns: is the 4P repo the one we should work on bringing in?
21:45:45 <mtaylor> troytoman: ++
21:45:50 <mtaylor> ttx: glance is not
21:46:05 <mtaylor> ttx: I think we can get quantum, keystone and melange on track by E2
21:46:13 <zns> mtaylor: that's a good start. I've added Keystone code to novaclient, but we can start with 4P.
21:46:14 <ttx> glance is... done ? or not on track ?
21:46:40 <mtaylor> zns: cool. I'll try to arrange
21:47:00 <mtaylor> ttx: glance client is a little bit more integrated into glance, I need to chat with jaypipes about splitting strategy
21:47:00 <Vek> glance client is still tightly attached to glance, afaik
21:47:16 <ttx> mtaylor: ok, let's keep horizon and glance for E3 then
21:47:22 <ttx> mtaylor: anything needed on swift side ?
21:47:50 <mtaylor> ttx: I think similar to glance- notmyname said it's doable, but not on the immediate todo list
21:48:04 <ttx> ok
21:48:13 <notmyname> step one, make a client library
21:48:27 <ttx> any other remark on that topic ?
21:48:58 <ttx> #topic Incubated projects and other Team reports
21:49:04 <ttx> danwent, troytoman: o/
21:49:15 <danwent> i'll let troy go first :P
21:49:22 <ttx> Anything interesting in Melange and Quantum land ?
21:49:31 <troytoman> we plan to have Melange moved into gerrit tomorrow afternoon
21:49:53 <troytoman> otherwise, cleaning up docs and other items to make it more accessible
21:49:54 <anotherjesse> related to the cli extraction I've been talking to various folks about how to make the CLI tools work the same way - http://wiki.openstack.org/CLIAuth
21:50:18 <reed> #info <troytoman> we plan to have Melange moved into gerrit tomorrow afternoon
21:50:26 <reed> #info <anotherjesse> related to the cli extraction I've been talking to various folks about how to make the CLI tools work the same way - http://wiki.openstack.org/CLIAuth
21:50:33 * Vek wonders whatever happened to his blueprint about auth
21:51:02 <troytoman> not much else to report at this point
21:51:04 <Vek> (because getting auth to work the same way across all the tools was part of my goal when I wrote that up...)
21:51:08 <danwent> for quantum, we are trimming essex-2 a bit: https://launchpad.net/quantum/+milestone/essex-2
21:51:21 <danwent> main code changes for quantum that need to get into nova are already under review.
21:51:26 <ttx> danwent: looks more reasonable :)
21:51:36 <danwent> mtaylor: let's chat about quantum client lib offline
21:51:42 <danwent> or you can come to netstack meeting next
21:51:50 <ttx> Any other team lead with a status report ?
21:51:52 <anotherjesse> Vek: link?
21:51:58 <zns> Vek: been heavily focused on Keystone itself and middleware testing. Not much on the client yet.
21:52:05 <danwent> and a heads up to the horizon folks, we'll probably be pinging you about some quantum related changes this week.  can target either e2 or e3
21:52:08 <mtaylor> danwent: yes! I've been meaning to find you to chat about that - yours is actually probably one of the easiest to deal with :)
21:52:17 <annegentle> Docs team working on a blueprint for API reference pages… see http://heckj.github.com/api-site-mock/# for a mockup.
21:52:26 <Vek> anotherjesse: looking up now.
21:52:30 <reed> #info <annegentle> Docs team working on a blueprint for API reference pages… see http://heckj.github.com/api-site-mock/# for a mockup.
21:52:42 <ttx> annegentle: looks nice
21:52:45 <Vek> anotherjesse: http://wiki.openstack.org/ClientAuthenticationPlugin
21:52:49 <tr3buchet> troytoman: danwent: can you guys put some current status info for quantum and melange on http://etherpad.openstack.org/nova-network-team
21:53:16 <annegentle> I want one more level of navigation added, but as a wireframe it's going to be useful.
21:53:17 <ttx> devcamcar: still not around ?
21:53:29 <dolphm> annegentle: very cool!
21:53:38 <danwent> tr3buchet: I assume this is limited to quantum changes affecting nova, not quantum changes in general?
21:53:52 <annegentle> We experimenting with WADL as source for this output.
21:54:02 <dolphm> annegentle: how is this being built?
21:54:24 <dolphm> thanks ^^
21:54:24 <annegentle> dolphm: this is a wireframe made with copy/paste for review :) the actual building will be based on the reqs gathered.
21:54:31 <tr3buchet> danwent: yes correct
21:54:39 <ttx> OK, switching to open discussion, as we have a few things to discuss there
21:54:43 <ttx> #topic Open discussion
21:54:44 <tr3buchet> danwent: i assume you have plenty of etherpads floating around for the rest
21:54:50 <ttx> vishy: you wanted to mention PPAs ?
21:54:53 <danwent> tre3buchet:  indeed.  sounds like a plan
21:54:59 <tr3buchet> awesome
21:55:07 <ttx> dolphm: <<"Status" is a male noun of the Fourth Declension in Latin, and as such the plural is "status", spelled identically>>
21:55:22 <vishy> yes
21:55:26 <anotherjesse> Vek: that seems like it would make doing the what the CLI Auth page is talking about easier.  the cli auth page is talking about what the interface for users is, whereas the CAP page is about how you would then implement it
21:55:34 <ttx> vishy: go for it
21:55:35 <dolphm> psh, i studied latin, i'll stick with statii
21:55:38 <vishy> in my mind we have a big problem with our ppa
21:55:46 <vishy> and we need to fix it
21:55:53 <ttx> which ppa ?
21:55:55 <Vek> *nod*
21:55:57 <vishy> we are still providing a release ppa
21:56:00 <vishy> and it is broken
21:56:03 <salv-orlando> ttx: second declension
21:56:10 <reed> https://en.wiktionary.org/wiki/status#Latin
21:56:17 <vishy> i would like to replace all of our ppas
21:56:24 <vishy> with a stable ppa
21:56:31 <vishy> mtaylor: ping
21:56:39 * mtaylor agrees with vishy
21:56:41 * annegentle cheers
21:56:51 <vishy> i don't want to have people installing a bunch of stuff that doesn't work
21:56:59 <mtaylor> having a ppa up there with broken packages isn't doing anybody any favors
21:57:00 <ttx> vishy: I agree we should remove the release PPA. But..
21:57:04 <vishy> and currently there is no option for people running on lucid
21:57:16 <ttx> I don't want to have people installing a bunch of stuff nobody actually maintains
21:57:27 <vishy> ttx: well we already have that :)
21:57:32 <mtaylor> I think that we have people maintaining stable/diablo now
21:57:51 <dolphm> reed: that shows statii (stat-longI), right?
21:57:52 <mtaylor> and that is at least more maintained than the current diablo packages in openstack-release
21:57:53 <vishy> we might as well give them something that is a best effort at working rather than something that is totally broken
21:58:04 <zul> we are going to be releasing a stable/diablo we just have to get through some bureacracy
21:58:12 <markmc> vishy, how about doing releases from stable/diablo and pushing ppas of those?
21:58:13 <mtaylor> zul: for lucid?
21:58:17 <markmc> right, what zul said
21:58:19 <zul> mtaylor: oneiric
21:58:21 <ttx> mtaylor: my point is that they maintain a branch for backports... not necessarily something that is supposed to be run in production
21:58:22 <mtaylor> right.
21:58:24 <glenc> Tu es adhuc bene litteratus, sed fallitur.
21:58:26 <markmc> vishy, rather than e.g. nightly builds of stable/diablo
21:58:34 <reed> dolphm, not for the noun
21:58:40 <vishy> markmc: I'm ok with that
21:58:43 <dolphm> reed: just noticed that :P
21:58:58 <zul> and we might have a ppa that has a weekly snapshot of stable/diablo soon as well
21:58:59 <vishy> markmc: mainly i just want to give people an option who aren't running on oneiric
21:59:14 <mtaylor> yeah. that's the important bit.
21:59:15 <zul> so we will be testing stable/diablo for oneiric
21:59:20 <markmc> ttx, any release from stable/diablo should be as production ready as 2011.3
21:59:34 * dolphm happily ignored latin conjugation in highschool
21:59:36 <vishy> zul: is it possible to have a stable/diablo for lucid?
21:59:39 <markmc> ttx, or put it this way, we wouldn't release from stable/diablo until we were confident of it being production ready
21:59:58 <vishy> markmc, ttx: any release would be better than 2011.3 :)
22:00:02 <vladimir3p> and natty?
22:00:03 * Vek 's high school did not have latin, or in fact most other foreign languages...
22:00:05 <zul> vishy: i dont know..
22:00:23 <ttx> markmc: I still think it's "less good" than something the distros would provide.
22:00:28 <vishy> we already have all of the infrastructure (backports etc.) in place for a lucid ppa
22:00:35 <mtaylor> ttx: distros don't provide for pre-oneiric
22:00:35 <ttx> compare stable/diablo and the current SRUs on Oneiric
22:00:39 <markmc> ttx, oh, I agree with that
22:00:41 <vishy> it just needs the nova code to be updated.
22:00:59 <markmc> ttx, it's less bad than 2011.3 from upstream, too though
22:01:06 <ttx> markmc: so if it ends up being "better but not good enough for production", I'd rather just scrap them
22:01:12 <vishy> if that means a 2011.3.1 release that is fine?
22:01:42 <markmc> ttx, well - 2011.3.x releases would be useful IMHO
22:01:51 <ttx> until someone maintains a true distribution of openstack for old stable versions of distros
22:01:59 <markmc> ttx, if release PPAs are useful at all, then a release PPA of 2011.3.x would be useful too
22:02:15 * dolphm tried unsuccessfully to sign up for Canadian
22:02:18 <mtaylor> I think we should cut packages from 2011.3.1 and upload them to the release ppa. whatever we do for essex, the diablo release exists and people are trying to sue it
22:02:19 <mtaylor> use it
22:02:33 <ttx> this all needs a discussion. I'll explain why I think this is a bad idea
22:02:53 <ttx> but that would probably delay the net guys by a few hours
22:02:55 <markmc> ttx, perhaps separate out doing 2011.3.x releases from the usefulness of release PPAs
22:03:02 <dolphm> a bad idea for keystone, or for every project?
22:03:17 <ttx> A bad idea for openstack itself as an upstreal
22:03:18 <ttx> m
22:03:39 <markmc> which one is a bad idea? 2011.3.x releases or release PPAs?
22:03:39 <vishy> if I can't get by in on updating the ppa
22:03:45 <vishy> i think we need to delete it
22:03:48 <vishy> and someone else can make one
22:03:55 <ttx> so far we had a model where we put out releases and downstreams make them production-ready and updateable
22:04:01 <vishy> but there is a lot of backporting effort that will be hard to redo
22:04:03 <markmc> vishy, e.g. Kiall :)
22:04:04 <Kiall> vishy: that already happened ;)
22:04:13 <mtaylor> ttx: I do not believe that model has worked
22:04:26 <ttx> #action ttx or vishy to start a discussion on release PPA
22:04:49 <vishy> Kiall: you have a lucid ready version of stable/diablo?
22:04:51 <ttx> mtaylor: I think we'll just end up spreading our resourecs and lower end quality as a result
22:05:04 <ttx> but let's close this meeting and let the netstack guys in
22:05:10 <Kiall> vishy: nope.. I havent done any bar oneiric
22:05:10 <markmc> ttx, which one is a bad idea? 2011.3.x releases or release PPAs? or both?
22:05:12 <reed> kool
22:05:33 <mtaylor> ttx: I think that it's clear people want this ppa. at the moment, Kiall is maintaining one. and I'd really love to avoid the sentence:
22:05:48 <mtaylor> "the openstack release ppa is broken, please see this person's ppa for working packages"
22:05:55 <ttx> If there is a need, a company should make a distro around it
22:06:01 <reed> mtaylor, indeed
22:06:18 <mtaylor> no
22:06:20 <mtaylor> I disagree ttx
22:06:27 <reed> better none than a broken one
22:06:29 <mtaylor> this is theoretically a community project
22:06:30 <jog0> why is the https://launchpad.net/~nova-core/+archive/trunk nova 2 weeks old also?
22:06:37 <Kiall> mtaylor: even I agree there... People use my PPA doesnt look good for ubuntu or openstack...
22:06:37 <mtaylor> there is community making pacakges
22:06:46 <mtaylor> how about we actually embrace that
22:06:57 <ttx> mtaylor: we should have that discussion on the ML
22:07:02 <mtaylor> instead of deferring to theoretical companies who do not exist
22:07:02 <ttx> and close this meeting.
22:07:06 <reed> yes, this is ml material
22:07:09 <ttx> #endmeeting