16:06:52 <bcwaldon> #startmeeting
16:06:53 <openstack> Meeting started Wed Nov  2 16:06:52 2011 UTC.  The chair is bcwaldon. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:06:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:07:10 <nati2> bcwaldon: thanks
16:07:16 <bcwaldon> no problem :)
16:07:21 <nati2> Our team reported 49 bugs https://bugs.launchpad.net/openstack-qa/+bugs?search=Search&field.bug_reporter=nati-ueno
16:07:31 <bcwaldon> #link https://bugs.launchpad.net/openstack-qa/+bugs?search=Search&field.bug_reporter=nati-ueno
16:07:56 <nati2> Some of it is already fixed for essex but not for diablo. I'll reqeust backport merge them in next week.
16:08:25 <nati2> That's all from me :) Any questions for unit testing.
16:09:37 <nati2> Our team almost finished unit test working. And code is now on our repos. https://github.com/ntt-pf-lab/nova/branches  (including about 1400 test cases)  #paste again
16:09:48 <bcwaldon> #link https://github.com/ntt-pf-lab/nova/branches
16:10:02 <nati2> ok let's go to next topic.  bcwaldon: Thanks again
16:10:13 <nati2> #topic integration-tests
16:10:39 <nati2> : westmaas would you report current progress?
16:10:49 <dwalleck> westmaas: Are you there? Or do you want me to give the update?
16:10:52 <westmaas> nati2: sure thing
16:10:56 <westmaas> dwalleck: please do
16:11:29 <dwalleck> Sure. This morning I merge propped the tests from the Zodiac suite into the integration suite
16:11:39 <nati2> dwalleck++
16:11:46 <dwalleck> There's still quite a few more to bring in, but I ran out of time :)
16:11:54 <bcwaldon> dwalleck: I'll be looking at your review later today
16:12:04 <dwalleck> I just wanted to make sure I got something in before the meeting today
16:12:11 <dwalleck> bcwaldon: sounds good
16:12:55 <westmaas> definitely looking for input on how this merge lines up with the goals I outlined and rohit added to
16:13:23 <KenWhite-RAX> dwalleck: do you have a count on how many you merged?
16:13:44 <dwalleck> Definitely. There's also some directory shifting that I still may want to do. I'll have to talk with bcwaldon and westmaas
16:13:57 <bcwaldon> I'll be here :) I definitely want that done asap
16:14:04 <dwalleck> KenWhite-Rax: I think it ended up being about 25? And another 35 are pending
16:14:26 <KenWhite-RAX> dwalleck:  thanks
16:15:00 <rohitk> dwalleck: I would like to contribute to the o-i-t branch, but i don't think the tests are in 'runnable' state, we now have kong+zodiac style tests right? Can we zero in on zodiac style tests
16:16:11 <donaldngo_hp> i had to do quite a bit of modifications to get the kong tests to run on our system
16:16:14 <dwalleck> rohitk: I'm fine with that. I verified this morning that they were runnable via nose this morning (given that you have a valid config file)
16:16:30 <dwalleck> Which is just an auth endpoint and some valid image/flavor ids
16:17:01 <dwalleck> Right now it also assumes you are using keystone for auth, but I can easily add a feature flag to make that switchable
16:17:09 <nati2> dwalleck: Do you mean , we can use nose style for test writing?
16:18:00 <dwalleck> nati: You could, but I meant that using the nosetest runner, my tests work (I think nose is the test runner for everything under the hood)
16:18:36 <dwalleck> I can add to the README and send an email with more details once the inital commit gets hammered out
16:19:03 <dwalleck> westmaas, bcwaldon: Does that sound sane?
16:19:28 <bcwaldon> yeah, we can get rid of run_tests
16:19:41 <rohitk> dwalleck: after your review #1251 gets merged how can I run the zodiac tests
16:19:48 <bcwaldon> dwalleck: we do need to figure out test skipping based on config variables, though
16:19:58 <westmaas> run_tests.sh nova should do it, It hink
16:20:04 <nati2_> dwalleck: gotcha thanks
16:20:08 <rohitk> ok
16:20:11 <dwalleck> bcwaldon: Can do
16:20:47 <westmaas> I think we still might have value in the runner, depending on how we set up options and the like
16:20:54 <westmaas> but I'm not married to that notion
16:21:02 <nati2_> do we have any coding standard for integration-test tool? something like pep8
16:21:02 <bcwaldon> we do need to commit to one or the other, though
16:21:40 <rohitk> nati2_: I think any openstack python code must comply with pep8
16:21:42 <bcwaldon> now that I think about it, nose won't be good enough for us if we want to support tags like we have from kong
16:21:54 <dwalleck> nati2_: I started a HACKING file for that. There was a bit of controversy, so I trimmed it down a bit
16:22:00 <dwalleck> bcwaldon: Nose supports tags
16:22:12 <nati2_> dwalleck: rohitk: gotcha thanks
16:22:13 <bcwaldon> dwalleck: ah, excellent, I'll talk to you later about that then
16:22:15 <dwalleck> I think nose is the under the hood testrunner for kong
16:22:33 <dwalleck> Sounds good
16:23:04 <westmaas> nati2_: we should use pep8, that should get added to the hacking file
16:23:11 <bcwaldon> westmaas: ++
16:23:34 <westmaas> nati2_: but we don't gate on that yet, I don't think
16:23:49 <westmaas> we can ask monty to set that up for us once we are sure there are no errors
16:24:04 <nati2_> So current merge request  should do pep8 also #link https://review.openstack.org/#patch,sidebyside,1251,2,nova/services/nova/json/images_json_client.py
16:24:14 <nati2_> westmaas: cool
16:24:15 <bcwaldon> westmaas: do you want me to get rid of all the existing pep8 errors and lock that down?
16:24:21 <westmaas> bcwaldon: sure
16:24:34 <bcwaldon> #action bcwaldon to establish pep8 gating on master
16:25:16 <westmaas> and I'd like comments from everyone on dwalleck's merge prop, whether you are core or not, thanks!
16:25:52 <westmaas> ok, so I was supposed to make a poll last week
16:26:03 <westmaas> for the name of these tests
16:26:05 <bcwaldon> #topic Name Change
16:26:08 <westmaas> I will actually do that today
16:26:11 <rohitk> westmaas: how will the kong+stacktester configs and other core stuff be affected after zodiac merge? asking so that i can be clear what kind of tests the branch should produce
16:26:23 <bcwaldon> #action westmaas to send out poll for changing the suite name
16:26:46 <rohitk> in the current o-i-t branch, like will kong/ be removed?
16:26:52 <westmaas> rohitk: that merge only adds, so nothing should change
16:27:08 <westmaas> rohitk: I don't want to remove until we move the tests over
16:27:14 <westmaas> rohitk: does that seem reasonable?
16:27:17 <rohitk> westmaas: yup
16:27:47 <westmaas> rohitk: at that point we should just go through the gong tests and pull tests over and delete them until there are none left in kong, or at least only ones that we don't want to support
16:29:01 <rohitk> westmaas: got it but i was also thinking about config.py and other stacktester stuff, will there be rewrite/merge/replace-with-zodiac for such things too
16:29:34 <westmaas> rohitk: there should be, yes.  however we want to get in the config and tagging should be done next
16:29:51 <dwalleck> rohitk: I think that merge should be very smooth
16:30:22 <rohitk> westmaas: dwalleck: will stay updated with the merges, thanks
16:30:27 <donaldngo_hp> are we having one config file for both kong and zodiac?
16:31:03 <nati2_> donaldngo_hp: for next step. I suppose
16:31:22 <westmaas> donaldngo_hp: yep, with kong directory just going away as quickly as possible
16:31:29 <dwalleck> donaldngo: That would be the goal. The long term goal is that everything is quickly merged
16:31:39 <nati2_> dwalleck++
16:32:00 <donaldngo_hp> cool
16:32:06 <nati2_> Our team want to start adding new test cases for integration-tests
16:32:28 <nati2_> Is there anybody goint to add new test cases now?
16:32:47 <nati2_> We wanna use zodiac now. Do you have comment on that?
16:32:50 <dwalleck> nati2_: myself and my team are going to be adding many in the next weeks
16:33:21 <nati2_> dwalleck: Could you share the list in order to avoid depilation works?
16:33:40 <rohitk> nati2_ ++
16:33:40 <nati2_> dwalleck: and which test framework will you use?
16:34:08 <dwalleck> nati2_: Sure. Actually, westmaas had an idea to use bugs against the openstack-integration-test project to track test development
16:34:18 <dwalleck> Which could be another possibility
16:34:23 <nati2_> ah it is cool
16:34:47 <rohitk> dwalleck: I think thats consistent with the way nati2_ is doing for unit-tests
16:34:59 <dwalleck> nati2_: I'll be developing under what was the zodiac tests. The goal is to move anything that was in kong over
16:35:11 <nati2_> dwalleck:  ok would you report bug?
16:35:43 <dwalleck> And add many additional things. nati2_: Sure. I'll have them in by end of tomorrow.
16:35:59 <nati2_> Ah, if all of new test implementer will use zodiac, how about make zodiac offical one?
16:36:16 <nati2_> and all test will be merged for zodiac style
16:36:25 <rohitk> dwalleck: If I want to write a test case for o-i-t (after zodiac merge), am I right by saying only the relative imports of the configs, clients and other stuff will change?
16:36:54 <rohitk> and the rest of the style- requests, object creation would stay same?
16:37:08 <dwalleck> rohtik: That should be right. The interfaces for the services shouldn't be changing really
16:37:21 <dwalleck> Just some possible shuffling of directory structure and naming
16:37:30 <rohitk> dwalleck: awesome
16:37:45 <KenWhite-RAX> nati2_: ++
16:38:12 <dwalleck> And if we can get enough feedback, I'd love to get that sorted out as fast as possible so we can reach a point of architecture stability
16:38:36 <nati2_> ok let's vote. please #agreed for zodiac as openstack-qa official framework.
16:38:56 <rohitk> #agree (agreed in the last meeting too)
16:39:03 <nati2_> #agree
16:39:05 <dwalleck> #agree
16:39:12 <KenWhite-RAX> #agree
16:39:39 <nati2_> donaldngo_hp: Do you have any thought>
16:39:52 <donaldngo_hp> we are merging kong into zodiac right?
16:39:54 <bcwaldon> #disagree
16:40:18 <donaldngo_hp> so  zodiac is just the new name for the combined framework?
16:40:27 <bcwaldon> hold on, yeah, what are we agreeing on here?
16:40:55 <dwalleck> donaldngo_hp: No, that's not the name of the final suite
16:41:25 <nati2_> I think if new test implementer will use zodiac, let's zodiac style as default style
16:41:26 <donaldngo_hp> so what are we voting on ?
16:41:29 <dwalleck> I would say before everyone votes, take a look at the merge prop first
16:41:30 <rohitk> i agreed for the test writing style :-)
16:41:40 <bcwaldon> dwalleck: ++ that's why I #disagree
16:41:43 <dwalleck> Make sure this is what you want to sign up for
16:41:43 <westmaas> I think we can agree that what gets merged is the example and path we should follow
16:41:48 <westmaas> dwalleck++
16:42:00 <nati2_> ok let's vote next meeting
16:42:15 <dwalleck> Because once I get started, I'm running :D
16:42:29 <nati2_> Until next meeting, each member should check the merge prop
16:43:26 <westmaas> sounds good
16:43:32 <dwalleck> And make comments, and we can discuss this on the mailing list as well
16:43:41 <nati2_> gotcha
16:43:55 <donaldngo_hp> cool
16:44:00 <nati2_> OK any other topics for integration tests?
16:44:14 <rohitk> we should be integrating the framework than just copying over
16:44:26 <dwalleck> rohitk: Right
16:44:27 <nati2_> rohitk: yes I agree
16:44:34 <dwalleck> That's the plan
16:45:14 <nati2_> If we can decide test framework, it will be very effective.
16:45:31 <donaldngo_hp> would it make sense to start from a single test and have everyone get on board with what there invidual needs are
16:45:52 <nati2_> donaldngo_hp: Yes it make sence. So this is long time goal.
16:46:13 <rohitk> I just feel the service layer from zodiac is a good feature for flexibility into the o-i-t
16:46:18 <bcwaldon> well we've already proposed several tests w/ this merge prop, so it's *not* long term
16:46:21 <donaldngo_hp> ive only played with the kong tests but i had to do a lot of changes like reworking the endpoint calls so that it uses an ssl
16:46:31 <nati2_> donaldngo_hp: And also, we should have official recommendations for new test implementer.
16:47:20 <donaldngo_hp> i suggest we start with a simple test like the swift auth call to get the token and have that as the first test inside this "framework"
16:47:44 <donaldngo_hp> then have everyone look at what we have and decide on what we need like config files, nameing conventions, coding style ect
16:48:07 <donaldngo_hp> once we all agree then its a checking, review, drop and run type of framework
16:48:45 <donaldngo_hp> what do you guys think?
16:48:49 <nati2_> donaldngo_hp: I think you can see the simple example on each test frameworks.
16:49:17 <donaldngo_hp> i can see the examples but my concern is that we want to make everyone happy
16:49:47 <donaldngo_hp> and having so much tests being merged and added just doesnt make it easy
16:50:02 <nati2_> donaldngo_hp: IMO, Test implementer's will is most important
16:50:33 <donaldngo_hp> what's test implementer?
16:50:42 <nati2_> donaldngo_hp: test senarios
16:50:49 <westmaas> dwalleck: can you identify 1-5 tests that highlight the important parts of your proposal?
16:51:01 <rohitk> nati2_++, If I can design a complex integration test quickly and easily then i have the vote for the framework
16:51:11 <dwalleck> westmaas: Sure. Want me to just send that out to the list with some explanation?
16:51:39 <westmaas> well I think donaldngo_hp would prefer those be the only tests in this particular merge prop, since the goal here is to define what we will use for everything else
16:52:12 <westmaas> we don't necessarily have to do it that way, but it might focus the discussion a bit
16:52:37 <dwalleck> Okay, I can do that. I'll pull all tests from my merge prop except for those
16:52:47 <westmaas> nati2_: do you buy that?
16:52:52 <dwalleck> I'll get that done today and then send something out when it's done
16:53:13 <nati2_> westmaas: gotcha
16:53:24 <westmaas> donaldngo_hp: work for you?
16:53:30 <donaldngo_hp> sounds good
16:54:21 <westmaas> great
16:54:26 <westmaas> thanks dwalleck!
16:54:34 <nati2_> dwalleck++
16:54:38 <dwalleck> westmaas: No problem. I'll hustle
16:54:56 <nati2_> Ok any other topics for integration-tests?
16:54:56 <westmaas> what names should be on the poll I create later?
16:55:01 <westmaas> I've heard...
16:55:11 <westmaas> openstack-functional-tests
16:55:13 <westmaas> kong
16:55:20 <westmaas> stackmonkey
16:55:20 <nati2_> StackTester ?
16:55:22 <westmaas> stacktester
16:55:24 <donaldngo_hp> openstack-storm
16:55:31 <westmaas> openstack-storm
16:55:47 <bcwaldon> storm is an awesome name
16:55:56 <nati2_> storm++
16:56:07 <bcwaldon> just 'storm', not openstack-storm
16:56:08 <westmaas> ok, will make the poll right after lunch
16:56:11 <bcwaldon> or thunder
16:56:12 <bcwaldon> damn
16:56:31 <westmaas> anything else?
16:56:35 <bcwaldon> I'll get back to you
16:56:36 <rohitk> openstack-storm sounds like a cool 'project' name
16:56:45 <rohitk> we have horizon now
16:56:47 <bcwaldon> tsuname
16:56:49 <bcwaldon> tsunami
16:56:50 <nati2_> We should construct a strong openstack which win the storm :)
16:57:28 <nati2_> Ahh, tsunami is very horrible... personally, i don't see the world
16:57:32 <rohitk> stacktester sounds simple and relevant
16:57:35 <bcwaldon> yeah, maybe not that one
16:58:02 <rohitk> openstacktester would be good but looong
16:58:09 <donaldngo_hp> storm is cool it relates to cloud computing. i guess we have to take it to a vote
16:58:26 <rohitk> vote, vote, poll!
16:58:27 <nati2_> yep storm is cool :) Short
16:58:34 <westmaas> will make it soon promise!
16:58:36 <nati2_> and cool
16:58:41 <westmaas> ready to end?
16:58:46 <nati2_> yep
16:58:46 <bcwaldon> #endmeeting