22:01:57 <danwent> #startmeeting
22:01:58 <openstack> Meeting started Tue Oct 25 22:01:57 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:30 <danwent> everybody here?
22:02:37 <bhall> I am :)
22:02:37 <danwent> salv is out today
22:02:41 <edgarmagana> Hello Everybody!
22:03:02 <danwent> well, i know troy is there, so let's start with melange
22:03:06 <danwent> #topic melange status
22:03:07 <somik> :o
22:03:15 <danwent> troy?
22:03:39 <danwent> #info based on discussion in previous openstack team meeting, melange merge into nova is still waiting
22:04:04 <danwent> mmm… maybe troy is not here.
22:04:21 <danwent> #action #danwent contact troytoman about melange packaging
22:04:31 <danwent> anything else that anyone has on melange?
22:04:37 <troytoman> back
22:04:41 <danwent> just in time :)
22:05:06 <troytoman> merge is still waiting. vishy and I are going to nail down the path forward
22:05:24 <troytoman> i promised blueprints that are not done (mac address creation and /interfaces)
22:05:32 <troytoman> those are still in draft mode
22:05:38 <troytoman> that's it, i think
22:05:44 <danwent> ok, any questions for troy?
22:05:56 <danwent> troy, any comments on packaging?  my question above?
22:06:08 <danwent> or does that depend on merging into nova?
22:06:30 <troytoman> it may depend. sounds like they might revisit if melange should merge or be separate
22:06:39 <troytoman> so it could impact packaging
22:06:44 <danwent> ok, i guess we'll wait until the dust settles there
22:06:50 <danwent> ok, sounds like we're good on melange
22:06:55 <danwent> #topic quantum status
22:07:05 <danwent> btw, I forgot to post the agenda link earlier.
22:07:09 <danwent> #link: agenda: http://wiki.openstack.org/Network/Meeting
22:07:28 <danwent> essex-1 is only two weeks out
22:07:37 <danwent> milestone is looking a bit sparse in general: https://launchpad.net/quantum/+milestone/essex-1
22:08:19 <danwent> if there is anything (bug or feature) that you are targeting for this release, please target something to this milestone by thursday
22:08:58 <danwent> any other updates on essex-1?
22:09:00 <edgarmagana> dan: you mean this Thursday 27th?
22:09:33 <edgarmagana> or the next one?
22:09:38 <danwent> edgar: by target I just meant create a blueprint or bug and associate it with the milestone.
22:09:50 <edgarmagana> dan: got it
22:09:53 <danwent> yes, the 27th, at least for any major work (i.e., work that will take a while to review or might disrupt other code)
22:10:09 <danwent> if it is a small bug fix, it is fine to target it to a release later in the cycle
22:10:25 <danwent> Ok, want to cover the major reviews we have outstanding
22:10:54 <danwent> #info review:  tyler just submitted the new quantum packaging for review.  this is a major change, so please look it over and make sure you are OK with it.
22:11:02 <danwent> anyone have the link handy?
22:11:09 <bhall> just a sec
22:11:18 <markvoelker> This one? https://review.openstack.org/1094
22:11:19 <bhall> https://review.openstack.org/#change,1094
22:11:25 <bhall> damn, beat me to it
22:11:27 <bhall> :)
22:11:28 <danwent> :)
22:11:29 <markvoelker> =)
22:11:50 <danwent> packaging is a really key deliverable for essex-1, so we want to get reviews on this quickly.
22:12:19 <danwent> #info: review bhall also submitted DHCP changes for QuantumManager (this is also much of the code to get L3 routing + NAT working as well)
22:12:25 <danwent> brad, you have the link?
22:12:33 <bhall> yup, sec
22:12:47 <bhall> https://review.openstack.org/#change,916
22:13:10 <danwent> I'm really hoping more quantum folks will get up to speed on the QuantumManager code, so it would be great to have people do a review, even if they aren't a nova core dev.
22:13:33 <danwent> any other reviews outstanding?
22:14:10 <danwent> Ok, is Carl P here?
22:14:22 <danwent> I don't see his handle...
22:14:49 <danwent> #action #danwent contact Carl P about functional testing for essex-1, have him send to ML
22:15:05 <danwent> anything else to report on packaging, other than the in progress review?
22:15:19 <markvoelker> Nothing from me...
22:15:35 <bhall> danwent: one more review
22:15:51 <danwent> bhall: please use info tag so it shows up in agenda
22:16:04 <bhall> #info review on switching to update port/net calls: https://review.openstack.org/#change,929
22:16:14 <markvoelker> Does that work if you're not the chair?
22:16:33 <danwent> yes, I believe everything but "agreed" works even if you are not chair
22:16:40 <markvoelker> cool
22:16:49 <danwent> so everyone should feel free to use "info" and "link"
22:17:09 <danwent> #info from salvatore:  Operational status: spec published, received good feedback. Will update specification according to feedback received during this week.
22:17:20 <danwent> #info: from salvatore: API framework: work in progress, and in good shape. I have now code that can run both v1.0 and v1.1 APIs. Unit tests pass (note: I’m running the whole set of API unit tests against both versions. This is a bit paranoid at the moment, but might come handy in the future)
22:17:35 <danwent> #info: from salvatore:  Nova-network feature parity: willing to investigate what it will take to get to parity on AWS-style security groups. Posted a reply to Brad initial mail on the ML.
22:17:54 <danwent> Salvatore is traveling, so please send any questions to ML
22:18:38 <danwent> I want to try and draft a Quantum Essex roadmap so I could see everything in one place and think about dependencies
22:18:46 <danwent> #link draft Quantum Essex Roadmap: http://wiki.openstack.org/QuantumEssexRoadmap
22:19:13 <danwent> we can definitely add/delete/modify, but I found it helpful to identify the different "chunks" we're working on for Essex.
22:20:04 <danwent> particuarly, I think we need to get people committed to milestones in a couple key areas:
22:20:15 <danwent> 1) nova-parity work for Quantum Manager
22:20:23 <danwent> 2) dashboard work
22:20:26 <danwent> 3) API work
22:20:34 <danwent> 4) functional / integration test
22:20:53 <danwent> so I was thinking of trying to setup phone calls or meetings to make sure we get stuff nailed down.
22:21:32 <danwent> Ram and I already chatted on doing a whiteboard session for #1 to get his team more familiar with the QuantumManager stuff that Brad and I have been doing
22:21:40 <danwent> Mark, are you able to drive #2?
22:22:14 <danwent> doesn't seem over eager….
22:22:22 <danwent> or he's not here :)
22:22:40 <markvoelker> Sorry, getting pulled into multitasking =)
22:23:11 <markvoelker> I'm working on resource allocation this week, should have better answers soon.  But I think we'll be able to tackle it.
22:23:15 <danwent> mark: just saying that I'd like to get a plan around dates + who is doing what for the dashboard
22:23:18 <danwent> great
22:23:53 <danwent> one of my goals is to get folks from different teams working on different parts of the code, so it definitely doesn't have to be all your team on the dashboard stuff, I'm just looking for you to drive the planning.
22:23:55 <somik> for dashboard: I received another volunteer willing to help out, I'll send your way once I know more
22:24:13 <markvoelker> somik: great, please do!
22:24:50 <danwent> Salvatore can drive the API stuff, but we're also looking for someone else to participate on that end.  Please speak up if you're interested.  I know Ram mentioned there might be someone on his team interested.
22:25:11 <danwent> And I will be bugging Carl P about the system/functional test.
22:25:25 <danwent> Mark: is there a cisco contact that you want as a driver on the system/functionanl test?
22:25:49 <markvoelker> Hmm... how about CC myself and shwetap?
22:26:00 <danwent> Ok, I will let Carl know.
22:26:35 <danwent> so expect emails from me in the next few days around how we can firm up plans in each of these areas.  Please look over the draft roadmap and give your thoughts.
22:26:51 <danwent> any questions/comments on quantum before we go to open discussion?
22:27:31 <danwent> #topic open discussion
22:27:52 <danwent> jame urquhart had a good write-up on quantum this week: http://t.co/sqauRvpb
22:28:23 <danwent> anything else?
22:28:40 <danwent> #endmeeting