21:02:01 <ttx> #startmeeting
21:02:02 <openstack> Meeting started Tue Oct 11 21:02:01 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:11 <ttx> Welcome everyone... Today's agenda is at:
21:02:17 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:02:29 <ttx> Please all make liberal use of #<command> for a richer meeting summary:
21:02:41 <ttx> link (for links), info, idea (for notes), action (for TODOs), and help (for calls for help)
21:02:55 <mtaylor> #agreed everyone should use #<command> for a richer meeting summary
21:03:02 <mtaylor> #info link (for links), info, idea (for notes), action (for TODOs), and help (for calls for help)
21:03:03 <mtaylor> :)
21:03:14 <ttx> mtaylor: actually, only the chair can use agreed :P
21:03:19 <mtaylor> BAH
21:03:24 <ttx> #topic Design Summit feedback
21:03:25 <Vek> haha :)
21:03:36 <ttx> So, last week we had the Design Summit
21:03:49 <ttx> I hope mostly everyone made it back home now
21:04:00 <comstud> home but still hung over.
21:04:03 <ttx> We didn't have a closing feedback session, mostly due to the start of the Conference
21:04:14 <ttx> While memories are still fresh, do you have any comment ?
21:04:16 <anotherjesse> ttx: I feel that sessions more on "bugs" / issues would be useful - in addition to forward looking blueprints (although that might be an issue of misuse of blueprints?)
21:04:17 * mtaylor thought that the Design Summit was rather productive this time
21:04:30 <mtaylor> anotherjesse: actually, I think that's the RIGHT use of blueprints
21:04:35 <anotherjesse> ttx: the ec2 api session was an example of one that was very tactical
21:05:00 <ttx> anotherjesse: some people propsoed that we have a pre-event that is more backward looking
21:05:03 <patelna> we should create a bluerprint for bugs
21:05:07 <ttx> but still technical
21:05:09 <bcwaldon> anotherjesse: really? It was basically a discussion around why we support EC2 at all. I don't think it hit it's original purpose of the feature gap
21:05:43 <ttx> anotherjesse: something where we would present technical stuff so that most attendees are up to snuff when the design summit starts
21:05:45 <westmaas> I think a session on how to handle a room full of 80 people, where 20 of those people want to talk, may be useful.
21:05:56 <mtaylor> hehe
21:06:12 <ttx> Do you think we should run a SurveyMonkey thing to gather more precise feedback ?
21:06:15 <anotherjesse> ttx: yes, that was another comment - that while core developers know roughly how everything works, outsiders don't have context to join
21:06:35 <mtaylor> I think we're getting to the point where more sessions, in more parallel that are smaller in scope would be helpful (getting closer to uds style)
21:06:48 <westmaas> ttx: survey monkey would be good
21:07:02 <mtaylor> and if we're at the point where there are 8 folks who need to be in all of the sessions, perhaps that's a good incentive for more delegation
21:07:06 <patelna> #idea - survey monkey...good one
21:07:10 <mtaylor> ++
21:07:18 <anotherjesse> bcwaldon: I didn't see it that way - I thought it was about "we use ec2 api, why does it have bugs" - beside the point though
21:07:46 <ttx> #action ttx to set up some survey monkey for summit feedback
21:08:04 <ttx> #idea more sessions, in more parallel that are smaller in scope would be helpful
21:08:20 <ttx> #idea pre-event that is more backward looking
21:08:36 <medberry> +1 on more smaller sessions
21:08:57 <mchow> #idea some context setting session at the begining for newcomers
21:09:00 <ttx> vishy: since you were the critical path, do you think you can handle more parallelization ?
21:09:40 <comstud> we need to work on human cloning?
21:09:48 <vishy> yes
21:09:57 <vishy> i think breaking out the working groups will help
21:09:59 <patelna> hahahaha like that one
21:10:10 <vishy> like block storage, etc.
21:10:10 <ttx> #action ttx to ask powers that be about next design summit location plans
21:10:24 <mtaylor> #idea have a week long design summit without conference co-location
21:10:28 <glenc> I like that y'all created an index of etherpad pages, but it would have been nice to have had that in advance so that people unable to attend could follow along.
21:10:35 <comstud> mtaylor +1
21:10:39 <mtaylor> glenc: +1
21:10:54 <rjh> where is said index?
21:11:03 <ttx> glenc: actually, the wifi was so bad etherpad was a bit difficult
21:11:06 <anotherjesse> #idea internet is important for a tech conference
21:11:08 <KumarKR_HP> #are these sessions recorded?
21:11:23 <mtaylor> also, uds carries an IRC room for each topic on the agenda and has that irc room on one of the projectors in the room so that people can attend rooms remotely as well
21:11:30 <mtaylor> anotherjesse: ++
21:11:47 <ttx> anotherjesse: hopefully next time we can get rid of the conference pairing, which should allow to go to some lab or university, which have generally good coverage
21:11:52 <devcamcar> worst conference wifi ever
21:12:07 <vishy> glenc: we had serious connectivity issues for the conference
21:12:07 <ttx> devcamcar: I had worse.
21:12:09 <mtaylor> not to keep talking about UDS ... but the uds guys apparently ensure that all locations they use have at least a 45 meg connection that they can be handed
21:12:16 <mtaylor> and then they run their own wifi on top of that connection
21:12:29 <ttx> mtaylor: they arrive 10 days before the event to set it up
21:12:35 <ttx> mtaylor: you propose to do that ?
21:12:38 <mtaylor> it might not be a terrible idea to just use hotels that we know uds has been at before, so we can steal their research :)
21:12:39 <anotherjesse> mtaylor: if you like how they do it so much, why don't you go there ...
21:12:41 <bcwaldon> #idea copy uds wifi setup
21:12:41 <anotherjesse> as well ;)
21:13:01 <mtaylor> ttx: sure. being in a place for a week without proper internet is kind of crappy
21:13:13 <ttx> definitely
21:13:13 <mtaylor> anotherjesse: I will!
21:13:17 <medberry> UDS folks tell the hosting venue that each participant will consume 6 wifi connections and to plan accordingly.
21:13:33 <ttx> ok, that's good feedback
21:13:41 <medberry> (and then we bring our own wifi gear as well.)
21:13:42 <pvo> I guess I shouldn't have torrented the whole time
21:13:45 <ttx> will do surveymonkey for more
21:13:46 <mtaylor> medberry: ++
21:13:58 <mtaylor> medberry: you wanna set up our venue for us? :)
21:14:15 <mtaylor> ttx: I know we can't actually co-locate with uds because of timing
21:14:22 <medberry> mtaylor, my mifi isn't going to handle that load either. :^)
21:14:30 <ttx> ready for next topic ?
21:14:31 * medberry was tethered all week though
21:14:46 <mtaylor> ttx: but what if we went to the same venue they were about to go to just a few weeks earlier ... and then figure out if we can share the setup costs for the infrastructure with canonical
21:15:04 <mtaylor> that way the venue would only have to outfitted once
21:15:16 <ttx> mtaylor: they basically set up their own, separate from the hotel.
21:15:17 <mtaylor> it would be like, I don't know - collaboration!
21:15:21 <mtaylor> ttx: I know
21:15:29 <mtaylor> ttx: we could rent it from them or something
21:15:37 <ttx> mtaylor: don't want to be the one that asks elmo to come 3 weeks early.
21:15:45 <mtaylor> ttx: I'll do it :)
21:15:45 <ttx> ok, next topic
21:15:47 <mtaylor> ok
21:15:47 <ttx> #topic EssexReleaseSchedule final discussion
21:15:57 <ttx> Based on the session we had at the Design Summit, I updated the page at:
21:16:02 <ttx> #link http://wiki.openstack.org/EssexReleaseSchedule
21:16:16 <ttx> The main change from Diablo is that we have a "RC at will" period starting after the last milestone...
21:16:32 <ttx> ...where each project produces release candidates until one is deemed good enough for release (and open the next cycle)
21:17:00 <ttx> Compared to the summit chart I adjusted things a bit (only 4 milestones)
21:17:13 <ttx> Please doublecheck and let me know if you're OK with it
21:17:29 <ttx> bcwaldon: I know jaypipes is fine with it, but your input is welcome
21:17:41 <bcwaldon> ttx: thanks :)
21:17:47 <ttx> It's 4 balanced milestones, E4 on March 1st, with 5 weeks at the end for stabilization work and production of Release Candidates
21:18:26 <patelna> that's good...to see stablization work is included now
21:18:29 <anotherjesse> ttx: lgtm
21:18:37 <pvo> I like it
21:18:42 <comstud> +1
21:18:48 <bcwaldon> ttx: yep, works for me. I know glance is planning to release our RC 1 week ahead of time
21:18:49 <ttx> We expect keystone and glance to use the very beginning of that last period, and nova / dashboard to use the late part
21:18:59 <bcwaldon> ttx: not sure if we want to document that somewhere
21:19:14 <ttx> devcamcar, zns, vishy: ack ?
21:19:21 <anotherjesse> vishy said ack
21:19:24 <bcwaldon> ttx: maybe just the milestones listed in launchpad are good enough
21:19:54 <ttx> bcwaldon: one week ahead of nova, actually.
21:20:09 <ttx> which still falls after E4 in the "RC at will" period
21:20:10 <devcamcar> ttx: yes, that's what we're planning on as well
21:20:10 <vishy> aye
21:20:11 <vishy> ack
21:20:37 <markmc> ttx, RBP isn't listed on the schedule? I can't remember whether there was a conclusion about branching vs freezing trunk
21:20:37 <ttx> ok, will make it "official" then
21:21:00 <ttx> markmc: RBP will actually happen when the RC is deemed "good enough"
21:21:09 <ttx> that's when F will open
21:21:14 <markmc> ttx, k, thanks
21:21:25 <ttx> since the PTLs want people to focus on RCs until one is "good enough"
21:21:42 <ttx> OK, let's go to project status, in roughly the dependency order...
21:22:08 <ttx> is zns around ? or anyone else from keystone ?
21:22:20 <anotherjesse> ttx: I will agree for ziad
21:22:38 <ttx> anotherjesse: but can you replace him for Keystone status ?
21:23:07 <ttx> Let's start with Glance and give him a chance to join
21:23:14 <ttx> #topic Glance status
21:23:26 <ttx> bcwaldon: So is a plan coming together for Essex in Glance ?
21:23:53 <ttx> or is it for Glance in Essex ?
21:24:08 <bcwaldon> ttx: definitely
21:24:11 <ttx> (No Swift this week since nobody replaces John, who is in vacation)
21:24:14 * Vek glances at essex
21:24:18 <bcwaldon> Be sure to check out https://bugs.launchpad.net/glance/+milestone/essex-1 for everything we have targeted at the first Essex milestone. Currently we're looking at one blueprint and 23 bugs.
21:24:26 <bcwaldon> Jay also asked me to mention that he sent a summit summary email to the list highlighting what we are going to focus on in Glance during the Essex release. It outlines some major changes planned for the HTTP APIs and how we are going to make Glance more robust. Any questions I cannot answer today regarding anything in that email I will make sure to relay to him.
21:25:27 <ttx> Looks good. Did you start filing blueprints for the remaining stuff mentioned in that email ?
21:25:53 <bcwaldon> ttx: I haven't but I am assuming Jay will
21:26:00 <ttx> ok. Questions on Glance ?
21:26:01 <bcwaldon> ttx: I think some already exist that aren't yet targeted
21:26:23 <ttx> bcwaldon: ideally you set the "Series goal" to Essex
21:26:37 <ttx> and then they all appear in https://blueprints.launchpad.net/glance/essex
21:26:42 <bcwaldon> ttx: ok, I'll leave that up to the *offical* ptl
21:26:48 <ttx> ready to be milestoned to a specific one
21:27:07 <ttx> No other Glance question ?
21:27:22 <ttx> #topic Nova status
21:27:28 <ttx> vishy: o/
21:28:11 <ttx> vishy: How is the Essex plan coming up for Nova ?
21:28:38 <pvo> vishy: you'd mentioned pulling Core together to try to figure out priorities?
21:29:04 <comstud> +1
21:29:25 <vishy> hey
21:29:26 <vishy> sorry
21:29:30 <vishy> bunch of people just showed up in the office
21:29:49 <vishy> so I haven't made a huge amount of progress since friday since I took yesterday off
21:30:58 <vishy> i'm trying to collect all of the plans here: http::etherpad.openstack.org/essex
21:31:06 <vishy> and convert relevent ones into blueprints
21:31:25 <ttx> vishy: fwiw I filed the rootwrapper and targeted to Essex already.
21:31:26 <vishy> so if anyone has items to add, I could use some help
21:31:41 <ttx> feel free to unset the series goal if you don't want it
21:31:50 <patelna> @Vishy - is there a plan to open up a branch for fixes to D4?
21:31:53 <vishy> ttx: yes I was just looking over the existing blueprints filed and trying to map them
21:32:10 <vishy> patelna: no, there is a separate group working on that
21:32:26 <ttx> Daviey: any news on the sru group setup ?
21:32:27 <patelna> pointers to that team???
21:32:31 <PhilDay> I added my two etherpads to the wiki , and was planning to supply blueprints to go with them (VM State Managment and Nova Image Cache Management)
21:32:33 <vishy> i'm not sure where it is going to live yet
21:32:50 <ttx> patelna: they should send an email to ask people to join the group. Probably this week
21:33:04 <patelna> Got it...thanks
21:33:12 <ttx> patelna: group does not exist yet afaik
21:33:37 <ttx> patelna: ping Daviey on IRC during European office hours
21:33:40 <meng-hp> @ttx who is PTL for D4 maintenance group?
21:33:47 <patelna> k...
21:34:00 <vishy> I'd like to organize a meeting for nova-core to prioritize and target blueprints
21:34:04 <ttx> meng-hp: no PTL, a workgroup will equally handle it
21:34:16 <vishy> pvo: any preference for timing for that?
21:34:40 <pvo> not tuesdays. : )
21:34:43 <pvo> other than that, no
21:35:08 <pvo> soonish, obviously
21:35:18 <vishy> Thursday maybe?
21:35:36 <ttx> yes, would be good.
21:35:38 <pvo> definitely maybe
21:35:45 <ttx> <-- not nova-core :)
21:35:48 <pvo> afternoon is clear
21:35:52 <vishy> I will try for thursday at this time.  I will send out a message to the ml today
21:35:58 <pvo> great
21:36:07 <ttx> vishy: anything else ?
21:36:11 <glenc> <-- not nova-core :)
21:36:13 * Vek suggests #action'ing that
21:36:21 <ttx> #action vishy to invite nova-core for a planning discussion
21:36:29 <ttx> Vek: on my way
21:36:37 <markmc> ttx, I'll have a first cut proposal on the stable branch tomorrow
21:36:45 <vishy> meanwhile if anyone has anything to add regarding blueprints add them to the blueprints page above
21:37:03 <ttx> markmc: cool ! I expect Dave to be a bit busy this week.
21:37:13 <ttx> Questions on Nova ?
21:37:54 <ttx> #topic Dashboard status
21:38:00 <ttx> devcamcar: o/
21:38:05 <ttx> Did you change the name, btw ?
21:38:23 <ttx> or rather, did you select a cool code name ?
21:38:27 <devcamcar> ttx: we didn't get to do the lightning talk for the naming ceremony
21:38:33 <devcamcar> we'll be taking it to the list for a final decision this week
21:38:57 <ttx> ack
21:39:04 <devcamcar> we now have a diablo friendly branch available on git
21:39:04 <ttx> #info We are after the Design Summit, so now the first step is to get your feature plan filed as Launchpad blueprints, and set the "Series goal" to Essex
21:39:10 <vishy> #info collecting plans/blueprints for nova on http://etherpad.openstack.org/essex
21:39:10 <vishy> #action vishy to schedule nova blueprint prioritizing meeting for Thursday and send an email to the list
21:39:38 <devcamcar> i'll be adding blueprints from the essex roadmap discussion this week as well
21:39:38 <ttx> devcamcar: In the end that should give you a nice subset of blueprints at:
21:39:45 <ttx> #link https://blueprints.launchpad.net/openstack-dashboard/essex
21:39:55 <devcamcar> ttx: yep
21:40:02 <ttx> (All members of ~dashboard-drivers are able to confirm the series goal)
21:40:15 <ttx> devcamcar: I'll also need you to set the "Maintainer" at https://launchpad.net/openstack-dashboard to ~openstack-admins
21:40:25 <ttx> should avoid having to add extra people to ~dashboard-drivers for admin reasons
21:40:35 <devcamcar> will do
21:40:45 <ttx> #action devcamcar to set "Maintainer" at https://launchpad.net/openstack-dashboard to ~openstack-admins
21:41:26 <ttx> that's all I had. Is it reasonable to try to get an Essex plan to present by next week meeting ?
21:41:36 <devcamcar> yes i'll have it
21:41:51 <ttx> devcamcar: anything else on your mind ?
21:41:57 <ttx> all: Questions on Dashboard ?
21:42:02 <devcamcar> not today! mostly just admin stuff
21:42:38 <ttx> zns: around now ?
21:43:01 <ttx> #topic Incubated project news
21:43:03 <anotherjesse> ttx: I can give a broad summary of the summit stuff if not
21:43:20 <ttx> anotherjesse: ok, will do after that topic. Thanks
21:43:23 <ttx> danwent: news ?
21:43:25 <danwent> hi
21:43:40 <danwent> slides, etherpads, notes from netstack sessions at the summit are at: http://wiki.openstack.org/NetstackEssexSummit
21:43:48 <ttx> danwent: when do you push other projects to join you in incubation ? You're a bit lonely :P
21:44:15 <ttx> #link http://wiki.openstack.org/NetstackEssexSummit
21:44:19 <danwent> #info based on discussions at summit, donabe will no longer be handled within netstack.  debo sent email to list about scheduling separate donabe meetings
21:44:32 <danwent> ttx:  i'll just have to talk with myself :)
21:44:38 <ttx> for some reason the network guys had a working network and could use etherpad.
21:44:51 <danwent> other than that, we had an unconference session to identify priorities, will be writing up blueprints this week.
21:44:51 <Vek> haha :)
21:45:01 <tr3buchet> that's lucky
21:45:02 <danwent> there's no nestack meeting today…. just write blueprints
21:45:11 * medberry guesses network guys had a 3G laptop
21:45:12 <danwent> haha, we bring our networks with us :)
21:45:20 <medberry> or 4g
21:45:21 <danwent> that is all
21:45:34 <danwent> any questions?
21:45:49 <ttx> danwent: nice summary page
21:45:55 <danwent> ttx: thanks
21:46:14 <ttx> danwent: would be great if all track leads had such a page, but that sounds a bit unfair to vishy.
21:46:37 <danwent> yes, i had it pretty easy
21:46:37 <ttx> ok, back to keystone
21:46:43 <ttx> #topic Keystone status
21:46:53 <ttx> anotherjesse: quick design summit summary ?
21:47:35 <anotherjesse> ttx: we had several sessions on the auth protocol - the major open question is whether we do:
21:47:43 <anotherjesse> scoping by more than just a tenant
21:48:05 <anotherjesse> more capabilities into the identity service or not
21:48:45 <anotherjesse> we had good discussions from folks at hp and other locations - we will be talking about scope of keystone in essex on the mailing list
21:49:07 <anotherjesse> but try to nail down the api very early in the cycle
21:49:27 <patelna> that's good Jesse...
21:49:28 <ttx> anotherjesse: so the essex plans are not settled yet, right, still needs a bit more discussion ?
21:49:38 <anotherjesse> ttx: that is correct
21:49:50 <ttx> anotherjesse: yes, I'd like to freeze the APi by E3
21:49:57 <ttx> to avoid any bad surprise
21:50:15 <ttx> even if that means having a keystone RC early and open F for keystone earlyt
21:50:32 <ttx> compared to everyone else
21:51:02 <ttx> anotherjesse: did you have anything else ?
21:51:17 <anotherjesse> ttx: good for now - if there are any questions feel free to ask here or in dev
21:51:55 <ttx> ok then
21:51:58 <ttx> #topic Open discussion
21:52:05 <bcwaldon> question!
21:52:09 <bcwaldon> I mean comment!
21:52:11 <bcwaldon> I wanted to bring to everyone's attention the email I sent to the list proposing the removal of OSAPI v1.0 from Nova. I think it's a really important decision we need to make and I want as many people involved as possible. In favor of not wasting anybody's time here, if anybody does have any comments, please share them on the mailing list.
21:52:44 <ziyadb> I might as well ask what would be a great starting place for a new contributor, myself.
21:53:11 <ttx> bcwaldon: do you think you can reach consensus, or does it look like the sort of discussion we should have had last week ?
21:53:28 * ttx admits not having read the whole thread
21:53:33 <anotherjesse> ziyadb: I think getting everything running and working on low hanging fruit is good for getting started … we hope to be finished with a script that helps with that (devstack) and email the list tomorrow
21:53:52 <bcwaldon> ttx: I'm referring to a second email. The conventions email is a separate discussion
21:53:58 <anotherjesse> ziyadb: and there is a "low hanging fruit" tag in the bug list
21:54:00 <bcwaldon> ttx: we can definitely reach consensus around removal ov v1.0
21:54:32 <medberry> anotherjesse, is devstack.org broken atm?
21:54:48 <bcwaldon> medberry: it's up for me
21:54:49 <anotherjesse> medberry: ask in #dev
21:54:51 <anotherjesse> it is github
21:55:04 <ziyadb> anotherjesse: excellent, I'll start there. Although I must comment, a "getting started" page for new devs, aside from that which includes information regarding joining projects and signing the CLA, would be great.
21:55:33 <bcwaldon> ttx: is that something you or stef can tackle?
21:55:35 <anotherjesse> ziyadb: ahh, that is on the wiki I think - one sec
21:56:06 <westmaas> anotherjesse: #dev?  did you mean a diff channel?
21:56:08 <anotherjesse> ziyadb: the top right corner of  http://wiki.openstack.org/ talks about contributing, ...
21:56:11 <ziyadb> and I'm not sure how the dev ecosystem is, would I for instance be able to work with other individual contributors to contribute a particular feature in an ad-hoc fashion?
21:56:14 <anotherjesse> westmaas: sorry, meant #openstack-dev
21:56:17 <ziyadb> anotherjesse: thanks, I'll have a look.
21:57:00 <ttx> bcwaldon: not sure how we can help, the discussion seems to stay on track. Do you mean it needs outsiders to sum it up and help it making progress ?
21:57:20 <glenc> #action someone needs to update the "How to Contribute" page; it's a bit out of date
21:57:21 <bcwaldon> ttx: sorry, I was referring to ziyadb's request for a jumping off point on the wiki
21:57:26 <bcwaldon> ttx: ignore me ;)
21:57:44 <ttx> glenc: I'll take it
21:58:02 <ttx> #action ttx to update the "How to Contribute" page
21:58:37 <ttx> ok then, I think I filled my bag of TODOs for the week.
21:58:49 <ziyadb> ah, I suppose I'll start with the low hanging fruit and work my way up to triaged bugs.
21:58:51 <ziyadb> thanks for the information.
21:59:09 <ttx> ziyadb: I'll try to update the page -- if you have any doubt, ping me
21:59:10 <anotherjesse> #action add dashboard & keystone to wiki.openstack.org overview
21:59:26 <ttx> the wiki definitely needs some love
21:59:27 <ziyadb> ttx: as I will, thanks.
21:59:31 <anotherjesse> lots of change in essex - probably a lot of things need updated :)
21:59:35 <anotherjesse> err - diablo
21:59:51 <ttx> ok, let's close it and leave the room for the netstack folks
21:59:53 <Vek> well, same will be true of essex, I'm sure.
22:00:01 <ttx> #endmeeting