22:15:25 <danwent> #startmeeting
22:15:26 <openstack> Meeting started Tue Sep 20 22:15:25 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:15:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:15:32 <SumitNaiksatam> thanks Dan for the heads up earlier :-)
22:15:39 <danwent> no worries
22:15:49 <somik> Hi folks
22:15:54 <debo_os> Hi
22:15:58 <carlp> Hello
22:16:01 <troytoman> hello
22:16:13 <danwent> agenda: http://wiki.openstack.org/Network/Meetings
22:16:34 <somik> I guess the keystone stuff will also impact Quantum's keystone integration story
22:16:40 <danwent> any topics for general discussion?
22:16:44 <salv> I shall see it
22:17:05 <danwent> #topic melange status
22:17:06 <somik> Should we also follow suit of merging the keystone integration middleware into keystone?
22:17:22 <danwent> somik: let's add an item in the quantum section for that
22:17:23 <anotherjesse> somik: it is a short term thing
22:17:49 <danwent> troy?
22:18:05 <troytoman> sorry, still suffering keystone fatigue
22:18:09 <anotherjesse> somik: if you are doing a diablo release I'd move it - otherwise there isn't a good reason
22:18:10 <danwent> :)
22:18:21 <troytoman> melange was repropped today
22:18:34 <troytoman> we've broken it down into multiple merges within Nova
22:18:40 <troytoman> this will make reviews easier
22:18:55 <troytoman> should start seeing traction in the next week or two.
22:19:17 <troytoman> that's pretty much the focus at this point
22:19:20 <danwent> great.
22:19:25 <danwent> any questions on melange?
22:19:38 <carlp> yes
22:20:04 <carlp> troytoman: Do you want us to get together with you off-line on how to get the IP discovery stuff working and when?
22:20:13 <carlp> or do we just want to talk about it at the summit?
22:20:21 <troytoman> carlp: probably makes sense - summit sounds like a great plan
22:20:43 <carlp> troytoman: OK, we'll make a time to sync up with you there
22:20:54 <danwent> carlp: probably good to have a bp on this at least
22:21:04 <somik> anotherjesee: we have a diablo release, so we will consider that option.
22:21:08 <danwent> or is it not generally applicable?
22:21:22 <troytoman> carlp: i think there is a blueprint placeholder - perhaps a few more details around the idea
22:21:32 <danwent> great.
22:21:43 <danwent> ok, last call for melange...
22:21:44 <carlp> I'll see if I can find it, and do that
22:22:00 <danwent> #topic donabe status
22:22:10 <danwent> debo?
22:22:13 <debo_os> update 1) WIP on donabe api simplification (nested containers) and demo (link it with quantum) 2) Writing a doc summary for the models  3) We have a donabe session and we need to pick up steam 4) Possible directions for the session - i) Is a simple nested container good enough? ii) use cases for 3 tier apps, services iii) container scheduling
22:22:24 <debo_os> batch update ... :)
22:22:29 <troytoman> carlp: https://blueprints.launchpad.net/nova/+spec/melange-address-discovery
22:22:31 <danwent> :)
22:22:53 <debo_os> Rick was supposed to be here to finalize the meeting for Donabe but didnt he sy Wed same time?
22:22:55 <salv> debo: in my order of preference: 2, 1, 3
22:23:10 <debo_os> 'Also please provide comments on the docs in the repo lp:donabe/docs
22:23:37 <debo_os> salv: there are some sketches in the repo
22:23:47 <danwent> debo: is there still a meeting scheduled for tomorrow?
22:23:49 <debo_os> feedback is *really* appreciated
22:24:07 <debo_os> Rick hasnt said anything to the contrary .... since he was organizing the meeting
22:24:16 <debo_os> so I guess lets still plan for tomorrow
22:24:48 <zykes-> is there meetings on wednesdays as well ?
22:24:48 <danwent> is this going to be an IRC meeting, a phone call, something else?  maybe I missed an email?
22:24:48 <salv> debo_os: can you remind us the time?
22:25:03 <debo_os> 3pm PST 6pm EST
22:25:09 <debo_os> same place
22:25:41 <danwent> zykes:  I believe this is intended to be a one-time sync pre-summit, but debo or dendrobates can clarify
22:26:06 <debo_os> yes thats correct
22:26:17 <debo_os> we could make it into a more regular meet if we need to
22:26:43 <danwent> ok, anything else for donabe?
22:26:54 <debo_os> thats all from me
22:27:05 <debo_os> anyone? comments?
22:27:22 <danwent> #topic quantum status
22:27:24 <debo_os> Thanks Salvatore for the prioritization sequence comment!
22:27:36 <danwent> https://launchpad.net/quantum/+milestone/2011.3
22:27:37 <salv> np
22:27:47 <danwent> goes out on 9/22 (thursday)
22:27:57 <salv> no pre-release drama for us?
22:27:59 <danwent> salv got the API docs proposed.
22:28:05 <danwent> salv: fingers crossed :)
22:28:33 <danwent> I think they need one more review (while they aren't code and can't break anything, it woudl be good to get another set of eyes on it)
22:28:34 <somik> salv: I think we should back out the keystone integration as our middleware will not work with keystone and can be misleading
22:28:43 <Daviey> How is the quabtum docs and examples looking?  Still feels very un-exposed from my PoV
22:28:52 <Daviey> quantum*
22:29:00 <salv> somik: do you want to throw it out of the source code tree?
22:29:18 <danwent> Daviey:  API docs are shaping up nicely.  Admin docs are the next priority… still need a lot of work.
22:29:29 * vishy is jealous
22:29:30 <danwent> This is on my plate… I
22:30:32 <danwent> Daviey, I'd encourage you to ping the netstack list and you can get the privilege of being an early reviewer of the docs if you like :)
22:30:43 <danwent> we'll need lots of eye-balls
22:30:57 <carlp> I'll be happy to look over the docs as well
22:31:17 <salv> carlp: lp:~salvatore-orlando/quantum/quantum-api-doc
22:31:32 <salv> or, more easily, I can send you a preview pdf by email.
22:31:35 <danwent> carlp: thanks. API docs are were to start.   i'm definitely hoping people will take a break from the pre-summit madness to help with docs.
22:31:41 <salv> Or maybe I will circulate it on the Openstack ML
22:31:51 <Daviey> danwent: sounds good.
22:32:05 <danwent> salv: I'm sure that won't open up a can of worms :)
22:32:32 <danwent> but hey, the more eyeballs, the merrier
22:32:47 <salv> danwent: definitely.
22:33:04 <danwent> Ok, somik, I think you wanted to bring up some issues with quantum + the dashboard?
22:33:34 <somik> yup, the issues with quantum and dashboard were partially related to keystone
22:34:06 <somik> but in general, there is a little misalignment in our dashboard's expectations
22:34:36 <somik> Essentially, creating networks in the dashboard doesn't reflect the network in quantum
22:34:54 <somik> whic*nova
22:34:59 <somik> *nova
22:35:31 <salv> I don't get this, I'm sorry. Can you elaborate a bit more?
22:35:32 <somik> So, the user still has to use nova-manage tool with quantum manager to create nova networks that can be used by VMs
22:36:00 <somik> Basically, there is no way to create and nova networks using Dashboard
22:36:05 <danwent> somik: because of IPAM and vNIC ordering?
22:36:32 <somik> danwent: correct and because nova is not notified of quantum networks created through dashboard
22:36:49 <danwent> (i.e., nova networks represent more than just L2 networks, they also handle IPAM, and they determine the number of vNICs a VM gets in Nova)
22:37:26 <danwent> somik: I dont' think its a matter of notification… as nova will query the set of networks a tenant has in quantum.
22:38:00 <somik> I believe we will need to fix this and also create a top level non-nova Quantum UI that directly interacts with Quantum service.
22:38:05 <danwent> IPAM to me seems like the real blocker.
22:38:48 <danwent> are there any plans to expose melange via the dashboard to let the customer define subnets similar to Amazon VPC?
22:38:59 <somik> danwent: currently IPAM and such is done through nova, so we will need dasboard to support nova way of creating networks.
22:39:20 <troytoman> i think that once melange merges into nova, more integration will happen
22:40:05 <troytoman> also, there is no clean way to add NICs/networks to nova outside of nova manage
22:40:09 <salv> So, if I get it right the reason for which networks created in dashboard do not work whereas they work if created with nova-manage is that the dashboard creates only the L2 part of the network and not the L3 part?
22:40:44 <somik> salv: correct and nova network table doesn't have a L2 network entry
22:41:13 <salv> Fine. I don't there's a lot we can do for diablo release
22:41:45 <somik> salv: I think, taking some time to discuss the UI use-cases and workflows during the summit might be helpful to iron out these kinks. but I just wanted to point out the current state of things.
22:42:09 <salv> What would be the impact of disabling quantum network creation in the dashboard?
22:42:37 <danwent> somik:  I agree.  that is part of what I was hoping to do with the nova-parity session, but hadn't been explicitly considering dashboard
22:42:42 <salv> somik: agreed, and probably also something more on nova <-> net_services interfaction
22:42:53 <somik> for Diablo release, we will have to default to nova-manage as the primary network creation mechanism.
22:43:32 <danwent> somik: ok, thanks.  let's move this on to the ML if more discussion is needed.
22:43:49 <danwent> Next topic: keystone issues (follow-up from nova meeting)
22:44:06 <salv> I haven't followed everything in the nova meeting
22:44:15 <salv> anyone can summarize the issue?
22:44:15 <danwent> Do we feel we need to make any diablo changes for this?
22:44:29 <vishy> i can summarize
22:44:33 <somik> for this, I believe the decision was to remove keystone middlewar from project trunks and put it into keystone trunks
22:44:38 <vishy> keystone is not releasing for ~6 weeks
22:44:40 <salv> vishy: thanks!
22:44:57 <vishy> which causes major issues for a full deployment
22:45:09 <vishy> i.e. no dashboard, no public glance server without security issues
22:45:14 <vishy> etc.
22:45:32 <vishy> so we decided to remove all middleware from the official diablo release
22:45:48 <vishy> and when keystone ships it will include the required middleware
22:46:09 <vishy> the issue is keystone implementation is changing rapidly right now
22:46:19 <danwent> ok, so we should remove middleware from quantum?
22:46:21 <salv> vishy: thanks again. I reckon that the best thing we can do is follow the other projects.
22:46:28 <salv> yep, let's get rid of it.
22:46:32 <carlp> +1
22:46:36 <vishy> so it keeps breaking everything else and we can't track it because we need ano official release
22:46:39 <edgarmagana> salv: +1
22:46:51 <vishy> I'm sure if you prop the middleware into the keystone project with the other ones it will be fine
22:46:54 * salv is extremely disappointed about wasted time for doing keystone integration
22:46:57 <danwent> yay, and to think I was worried we wouldn't get a last minute bug for the diablo release :)
22:47:03 <edgarmagana> we had experienced the same issues in our test beds
22:47:04 <vishy> salv: tell me about it
22:47:19 <somik> salv: but we will need to have quantum integration middleware in keystone and have to make sure when keystone releases we have the appropriate support..
22:47:26 <danwent> salv: we'll all buy you a beer at the summit
22:47:32 <salv> visky: you sure wasted more time then me!
22:47:41 <vishy> the hope is in a month or so there will be diablo+keystone
22:47:43 <salv> danwent: that would make up for it
22:47:52 <danwent> somik: ok, can you track this with a bug for essex?
22:47:54 <vishy> otherwise we can't really deploy dashboard
22:48:14 <somik> danwent: sure, I'll file a tracker bug
22:48:27 <edgarmagana> is there any way we can deploy dashboard without keystone?
22:48:46 <salv> somik: I think we need also a quick branch for diablo to revert quantum to pre-keystone status
22:48:52 <edgarmagana> I man a quick fix?
22:48:57 <danwent> #action #somik add bug to remove keystone middleware in diablo, work with keystone folks to make sure their diablo+ release works with quantum
22:49:18 <somik> salv: correct, I'll file a tracker bug for that too
22:49:19 <edgarmagana> mean*
22:49:49 <salv> It should be easy: just take out the two middleware and remove the already commented line in quantum.conf for keystone pipeline
22:50:34 <danwent> edgar: not that I know of, but perhaps others can correct me.
22:50:58 <danwent> Ok, 10 minutes left.  anything left to discuss on this topic?
22:51:13 <danwent> Brad, can you chime in about the github transition?
22:51:14 <edgarmagana> dan and salv: thanks
22:51:35 <bhall> danwent: sure
22:51:53 <bhall> we're transitioned (thanks jeblair) .. we've done a few pushes already and they seem to work
22:52:04 <bhall> there was an issue with not getting emails from gerrit but that has been resolved
22:52:13 <bhall> (if you find you don't get emails just reregister your address in gerrit)
22:52:39 <danwent> bhall: are all of the groups setup appropriately so that core-devs can approve?
22:52:51 <danwent> last I checked I couldn't +2, only +1
22:53:08 <danwent> (gotta love gerrit-speak)
22:53:09 <bhall> I just saw a couple "you've been added" notifications, so I think that is set up now
22:53:18 <danwent> great.
22:53:18 <bhall> lets try it out today but I think we're ok
22:53:50 <bhall> any other questions on the transition?
22:54:01 <danwent> bhall: what's the best way for everyone to get familiar with gerrit reviews?  are there some simple commits people can do to play with it?
22:54:24 <bhall> fix a pylint error or two and submit it to get an idea of the workflow
22:54:25 <danwent> are you able to do reviews for arbitrary branches, or just trunk?
22:54:36 <bhall> both
22:54:58 <danwent> great, that should make playing around with it easy.
22:55:16 <danwent> bhall: great idea :)
22:55:42 <bhall> currently our trunk isn't gated by pylint checks
22:55:44 <bhall> it will be at some point
22:55:48 <danwent> we also have a few branches to carry over right?  like salv'e pylint branch?
22:55:50 <bhall> so if we could fix the ones we've got, that'd be great
22:55:59 <danwent> salv's
22:56:16 <bhall> danwent: yup.. I can help if he needs help with that
22:56:49 <danwent> Ok, any pressing issues to bring up around the design summit?
22:57:03 <danwent> lot's of energy around proposals, which is great.
22:57:04 <bhall> danwent: do you mean wrt github or in general?
22:57:07 <bhall> oh, ok
22:57:09 <bhall> n/m :)
22:57:13 <danwent> bhall: sorry, trying to move quickly :)
22:57:17 <salv> Not any pressing issue, but I would like to start seeing more detailed proposals on the ML
22:57:38 <salv> just to go to summit sessions with a rather precise idea of the things that will be discussed in each session
22:57:41 <danwent> salv: took the words out of my mouth :)
22:57:58 <carlp> The session for CI discussion was approved, so I'm looking forward to see everyone there!
22:57:58 <danwent> this will also be key when we try to organize and order the sessions.
22:58:24 <danwent> remember that you do NOT have to have a session at the summit in order to work on something during essex.
22:58:51 <salv> definitely. This why we should decide to schedule sessions only for items that really deserve discussion
22:59:06 <danwent> sessions are designed when you want input, feel that your changes affect others, want to recruit people, or just improve awareness.
22:59:25 <danwent> but space is limited, so we may have to prioritize
22:59:46 <danwent> discussion on the ML helps us figure out what sessions can be merged as well.
22:59:58 <danwent> (edgar: thanks for sending that draft out!)
23:00:13 <danwent> ok, 4pm… anything else folks need to discuss?
23:00:25 <danwent> #topic open discussion
23:00:30 <salv> also, we will soon know which sessions will be approved, and it might help if we inform the summit drivers about our priorities
23:00:32 <edgarmagana> dan: i hope we can start the discussion on that draft over ML
23:00:58 <salv> edgarmagana: had a quick look at it, will send some comment tomorrow
23:01:17 <danwent> ok, going once…, twice...
23:01:27 <danwent> #endmeeting