21:01:23 <ttx> #startmeeting
21:01:24 <openstack> Meeting started Tue Sep 13 21:01:23 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:35 <ttx> Welcome to our weekly team meeting... Today's agenda is at:
21:01:40 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:02:04 <ttx> #topic Actions from previous meeting
21:02:12 <ttx> * ttx to refurbish aws-api-validation and hyper-v-update as bugs and untarget them: DONE
21:02:20 <ttx> * blamar to discuss openstack-common on the ML
21:02:46 <ttx> That was DONE, with a good reception as always -- now hopefully we'll get some resources working on that :)
21:03:07 <ttx> * annegentle to email the mailing list with new naming possibilities (for API doc)
21:03:23 <ttx> That was done as well AFAICT... Anne ?
21:03:31 * vishy sneaks in late and sits in the back
21:04:12 <ttx> let's parallelize that answer
21:04:20 <ttx> #topic Essex is open, Diablo is in RC (release on Sep 22)
21:04:32 <ttx> Just a quick note to say that Essex development is open in trunk...
21:04:47 <ttx> ...and we continue to backport release-critical bugfixes to the milestone-proposed branches
21:05:01 <ttx> Note that as we get closer to release date we need to be more careful about which bugfixes we accept to backport
21:05:13 <ttx> Final release on Sep 22.
21:05:34 <ttx> Questions on what we need to do those last week(s) ?
21:06:20 <jaypipes> ttx: nope. you want to discuss your thought from yesterday that in Essex, we should abandon the "RBP milestone" for tracking purposes?
21:07:14 <ttx> jaypipes: not really -- we can discuss that when discussing the Essex cycle at the summit
21:07:40 <jaypipes> ttx: ok, no worries.
21:07:56 <ttx> (basically, since -rbp is just a date, not a milestone, it's a bit awkward to target things against it)
21:08:08 <ttx> #topic Swift status
21:08:13 <ttx> notmyname: o/
21:08:17 <notmyname> hi
21:08:29 <ttx> 1.4.3 was released on Monday...
21:08:43 <ttx> notmyname: How is design summit session planning going so far ?
21:08:52 <notmyname> is packaging for 1.4.3 still in the works?
21:09:25 <ttx> notmyname: yes, see https://bugs.launchpad.net/openstack-ci/+bug/848971
21:09:26 <notmyname> I have entered several proposed sessions. yet to be reviewed
21:09:26 <uvirtbot> Launchpad bug 848971 in openstack-ci "Swift fails to build on maverick/lucid in trunk / milestone-proposed / release PPAs" [High,New]
21:09:52 <ttx> mtaylor is on it.
21:10:29 <ttx> notmyname: anything else ?
21:10:40 <notmyname> not unless anyone has questions
21:11:33 <ttx> looks like nobody has...
21:11:36 <ttx> #topic Glance status
21:11:41 <ttx> jaypipes: hey
21:11:46 <jaypipes> ttx: yo.
21:11:49 <ttx> Looking at: https://launchpad.net/glance/+milestone/2011.3
21:12:05 <ttx> On the feature side, I think we are done now -- should we consider changes-since-filter complete ?
21:12:59 <jaypipes> ttx: yes, actually, there's quite a bit going on in Glance right now, but a lot of the attention has unfortunately been going into new Essex features and not bug fixing and stabilization/documentation that we really should be focused on. I take responsibility for not sending emails to focus people away from feature-writing.
21:13:22 <jaypipes> ttx: I will send such an email this afternoon.
21:13:26 <ttx> cool
21:13:47 <ttx> so i can mark changes-filter-since implemented ?
21:14:00 <ttx> changes-since-filter*
21:14:05 <jaypipes> ttx: no, not yet.
21:14:09 <ttx> ok
21:14:18 <jaypipes> ttx: it is in review.
21:14:23 <ttx> jaypipes: On the bugs side, you have 8 targeted bugs so far. Let's do a quick status round
21:14:30 <jaypipes> k
21:14:39 <ttx> to see if they are all fixable in time
21:14:42 <ttx> https://bugs.launchpad.net/bugs/804429 (jaypipes)
21:14:43 <uvirtbot> Launchpad bug 804429 in glance "Cannot stream http image" [Critical,Confirmed]
21:15:02 <jaypipes> ttx: yes, that should still be fixed.
21:15:06 <ttx> https://bugs.launchpad.net/bugs/809663 (mtaylor)
21:15:08 <uvirtbot> Launchpad bug 809663 in glance "Glance milestone and integrated packages should automatically be uploaded to PyPI" [High,Confirmed]
21:15:09 <jaypipes> ttx: and can.
21:15:18 <jaypipes> mtaylor: ?
21:15:30 <mtaylor> yeah. sorry - it keeps falling down on the todo list
21:15:39 <ttx> sounds liek a CI bug more than a Glance bug ?
21:16:23 <jaypipes> ttx: well yes :)
21:16:36 <ttx> #action jaypipes to send a diablo-focus email for Glance devs today
21:16:50 <ttx> jaypipes: shoudl I move it ?
21:17:12 <jaypipes> ttx: up to mtaylor. as long as it gets addresses, I don't care. it's now been pushed a couple milestone releases :(
21:17:22 <jaypipes> addressed
21:17:25 <ttx> https://bugs.launchpad.net/bugs/814981 (jaypipes)
21:17:26 <uvirtbot> Launchpad bug 814981 in openstack-live "glance-api fails on image delivery: AttributeError: context" [Medium,Confirmed]
21:17:49 <jaypipes> ttx: meh, I've been going back and forth on whether that's really a bug.
21:18:10 <ttx> sounds like a good target for... un-RC-targeting
21:18:13 <jaypipes> ttx: it's really all about making sure that upgrades happen more smoothly when config/PasteDeply files change.
21:18:29 <Vek> perhaps the description should be updated?
21:18:35 <jaypipes> ttx: so it might be able to be marked duplicate of bug 779311
21:18:36 <uvirtbot> Launchpad bug 779311 in glance "Glance update for Ubuntu failing" [High,Confirmed] https://launchpad.net/bugs/779311
21:18:50 <jaypipes> Vek: ya, or marked a duplicate...
21:19:08 <ttx> jaypipes: yes, mark it dupe
21:19:14 <ttx> https://bugs.launchpad.net/bugs/817032 (jaypipes)
21:19:16 <uvirtbot> Launchpad bug 817032 in glance "glance-control exits with 0 when glance-<server> script is not found" [Medium,Confirmed]
21:19:35 <jaypipes> ttx: moved.
21:20:23 <ttx> The remaining 4 are unassigned... If they all need to be fixed by release time, a good first step would be to get them all assigned...
21:20:35 <ttx> If they aren't release-critical, then they should be removed from the list...
21:20:55 <ttx> remaining 4 are actually "remaining 2" now
21:21:09 <jaypipes> ttx: yes, the low priority ones I pushed to essex
21:21:12 <ttx> https://bugs.launchpad.net/bugs/779311
21:21:13 <uvirtbot> Launchpad bug 779311 in glance "Glance update for Ubuntu failing" [High,Confirmed]
21:21:17 <ttx> https://bugs.launchpad.net/bugs/794582
21:21:18 <uvirtbot> Launchpad bug 794582 in glance "glance sets image size to 0 for http images -> yields connection reset error on GET" [Medium,Confirmed]
21:22:02 <ttx> any taker ?
21:22:02 <jaypipes> the update for Glance failing one is really kinda weird, and doesn't seem to be reproduceable.. :(
21:22:21 * ttx will try to have a look at that one
21:22:31 <jaypipes> the image size to 0 thing is definitely an issue and should stay targeted to 2011.3.
21:22:56 <ttx> jaypipes: can you find a victim^W assignee for it ?
21:23:16 <jaypipes> ttx: I will mention it in my email to the ML.
21:23:20 <ttx> ok
21:23:29 <ttx> Any other Glance bug that /needs/ to be fixed before we can release Diablo ?
21:23:46 <ttx> jaypipes: Other announcements/comments ?
21:23:48 <jaypipes> ttx: not that I know of, but you never know ;)
21:23:59 <jaypipes> ttx: no other comments/news
21:24:08 <ttx> Raise your hand if you have a question on Glance.
21:24:37 <ttx> #topic Nova status
21:24:41 <ttx> vishy: o/
21:24:47 <ttx> Looking at: https://launchpad.net/nova/+milestone/2011.3
21:25:05 <ttx> Also 8 bugs on the release-critical list:
21:25:13 <ttx> https://bugs.launchpad.net/bugs/833552 (pvo)
21:25:15 <uvirtbot> Launchpad bug 833552 in nova "No easy migration from old auth to keystone" [Critical,In progress]
21:25:34 <ttx> Are we making progress here ?
21:25:37 <vishy> he's upgrading his branch from reviews
21:25:41 <vishy> should be back up soon
21:25:53 <ttx> https://bugs.launchpad.net/bugs/847604 (rcb)
21:25:54 <uvirtbot> Launchpad bug 847604 in nova "Instance rebooting is broken" [Critical,In progress]
21:26:14 <ttx> just approved, I see
21:26:29 <ttx> https://bugs.launchpad.net/bugs/843704 (JordanRinke)
21:26:30 <uvirtbot> Launchpad bug 843704 in nova "Hyper-V needs updates to catch up with Diablo" [High,In progress]
21:26:55 <ttx> branch is a bit behind apparently
21:27:35 <ttx> https://bugs.launchpad.net/bugs/833331 (_0x44)
21:27:36 <uvirtbot> Launchpad bug 833331 in nova "OSAPI v1.1 needs to document config-drive as an extension" [Medium,Confirmed]
21:27:56 <vishy> the instance rebooting doesn't actually apply to diablo
21:28:01 <vishy> taht can e retargetted
21:28:07 <ttx> vishy: oh.
21:28:17 * ttx drops target
21:28:25 <vishy> not sure if jordan's will make it
21:28:37 <vishy> no idea on _0x44 docs
21:28:53 <_0x44> Sorry, I dropped the ball on that
21:29:17 <ttx> _0x44: any chance you can submit something soon for that bug ?
21:29:58 <_0x44> ttx: Can you define soon?
21:30:08 <ttx> hmm... end of week ?
21:30:50 <_0x44> Yes, I should be able to do something by the end of the week.
21:30:55 <ttx> kewl
21:31:01 <ttx> https://bugs.launchpad.net/bugs/827807 (vishy)
21:31:03 <uvirtbot> Launchpad bug 827807 in nova "in multi_host nova-network mode, nova-network doesn't reassociate reassociate the floating ips on reboot" [Medium,Triaged]
21:31:06 * annegentle sneaks in late and sits next to vishy
21:31:19 <vishy> so i haven't looked into that one yet
21:31:26 <vishy> but i think it should be a simple fix
21:31:34 <ttx> Feeling confident, I like that.
21:31:47 <ttx> Remaining 3 are unassigned. We'll have to get them off the list if nobody commits to fixing them...
21:31:55 <ttx> https://bugs.launchpad.net/bugs/834189
21:31:58 <uvirtbot> Launchpad bug 834189 in nova "XenServer and KVM handle local storage differently" [High,Triaged]
21:32:09 <ttx> https://bugs.launchpad.net/bugs/845866
21:32:10 <uvirtbot> Launchpad bug 845866 in nova "exception tracebacks are lost when using raise" [Low,Triaged]
21:32:15 <ttx> https://bugs.launchpad.net/bugs/838386
21:32:16 <uvirtbot> Launchpad bug 838386 in nova "Test suite requires kombu and carrot to be installed" [Low,Triaged]
21:32:29 <ttx> That last on, soren and Daviey were supposed to discuss who takes it
21:32:31 <ttx> one*
21:32:32 <annegentle> _0x44: I have an RST template for extensions doc that might help, I'll send it to you and glenc
21:32:47 <_0x44> annegentle: That would be great, thanks. Do you have my email address?
21:32:56 <vishy> so first one i don't see us getting to
21:33:16 <ttx> vishy: yes, I guess we'll have to live with it
21:33:26 <ttx> vishy: should I untarget ?
21:33:42 <vishy> yes, we'll just have to add it to the release notes and discuss at the summit
21:33:56 <jk0> yeah, that would be a very big change to go in at this point
21:33:58 <vishy> the second is a pretty easy one
21:33:59 <annegentle> _0x44: please dm it to me
21:34:01 <jk0> lots of discussion needed still
21:34:53 <ttx> anyone feels like taking bug 845866 ?
21:34:53 <uvirtbot> Launchpad bug 845866 in nova "exception tracebacks are lost when using raise" [Low,Triaged] https://launchpad.net/bugs/845866
21:34:58 <vishy> the third i don't really think that is a huge deal anyway
21:36:09 <ttx> Also if you know a bug that we should really fix before releasing Diablo, ping me or vishy so that we add it to the list. Bugs with assignees preferred :)
21:36:39 <tr3buchet> i've got a small small one, that i can handle, i'll talk to vishy about it
21:36:54 <vishy> also I have been trying to keep up with fixes that have been going in that need to be backported
21:36:54 <ttx> vishy: Anything else ?
21:36:56 <Vek> I'm aware of a zones bug in the cost scheduler
21:37:15 <Vek> it's not targeted, but it is fixed in base scheduler
21:37:17 <vishy> but I may have missed some, so let me know
21:37:38 <Vek> probably not very important; just means not all the instances you ask for may get created
21:38:10 <vishy> tr3buchet: what ever happened to the bug about overriding the vland in the db
21:38:41 <tr3buchet> ...
21:38:53 <tr3buchet> happen to have the number? i'm drawing a blank
21:39:25 <ttx> https://bugs.launchpad.net/nova/+bug/708278 ?
21:39:25 <uvirtbot> Launchpad bug 708278 in nova "Prevent duplicated VLAN IDs " [Medium,Triaged]
21:40:35 <vishy> tr3buchet: I don't know if it had a bug or not.  It was using the flag to override the vlan device in the database
21:41:43 <tr3buchet> vishy: having vlan on a particular device which can change from host to host?
21:42:29 <vishy> tr3buchet: right.  We talked about changing the flag to override what was in the db
21:42:38 <ttx> hmm, let's take that offline maybe -- so that we can get to the other topics
21:42:52 <tr3buchet> sure sure
21:42:53 <vishy> on non-homogenous hardware
21:42:53 <vishy> sure
21:42:54 <vishy> go...
21:42:55 <ttx> #topic Incubated projects news
21:43:06 <ttx> devcamcar, zsm, danwent: o/
21:43:18 <ttx> News ?
21:43:46 <ttx> I've seen a few Keystone / Dashboard session proposals already, that's good !
21:43:48 <danwent> got the quantum manager integrated into nova
21:44:09 <danwent> other than that, we're frozen for diablo, and are going to be focusing on docs + essex blueprints.
21:44:24 <ttx> danwent: someone suggested to have a "Netstack" track instead of the "Incubated" track -- since we'll only have Quantum in incubation that may make sense
21:44:29 <ttx> (for the summit)
21:44:37 <ttx> Would that work for you ?
21:44:39 <danwent> I'm all for it.
21:45:00 <ttx> #action ttx to rename "Incubation" track to "Netstack" in summit
21:45:07 <ttx> I've seen a few Keystone / Dashboard session proposals already, that's good !
21:45:41 <ttx> devcamcar, danwent: anything else ?
21:46:12 <danwent> nope
21:46:36 <ttx> #topic Documentation updates
21:46:40 <ttx> annegentle: floor is yours
21:46:50 <annegentle> thanks.
21:47:14 <annegentle> Just wanted to report a few things - the Starter Guide now has a handful of pages in the top ten most visits for the docs.openstack.org site.
21:47:53 <annegentle> This past week I moved the API guides for Glance, Keystone, and Swift. This week I plan to create compute-api as a github repo so that API guides live in github.
21:48:23 <annegentle> The Jenkins build jobs now point to github. After all the API guides are out of lp:openstack-manuals I'll move the remaining docs to github.
21:48:59 <annegentle> I'm also listening in on the thread on the mailing list about the naming for that project, and trying to find a good way to ensure extensions get docs. Right now none of the extensions have docs that I can see.
21:49:09 <jaypipes> annegentle: awesome work :)
21:49:32 <annegentle> If you've written an extension, please drop me a line via email so I can send you some templates for extension docs - RST if you like, or DocBook if you like. I'm open.
21:49:43 <annegentle> jaypipes: whew, thanks! More to come!
21:50:28 <ttx> annegentle: wanna introduce the Monday event ?
21:50:29 <annegentle> Also, the Doc Blitz is Monday 9/19 - basically set aside an hour that day to poke the docs, log doc bugs, comment, offer feedback. We'll be listening intently. :) http://www.openstack.org/blog/2011/09/openstack-documentation-blitz/
21:50:33 <ttx> eh
21:50:41 <annegentle> ttx: :)
21:50:58 <jaypipes> annegentle: excellent :)
21:51:12 <annegentle> there are two times you can join in the fun, to try to meet both sides of the globe (while I'm still awake)
21:51:50 <annegentle> I'm still setting up the docs.openstack.org/docblitz site (it's an ugly landing page right now with broken links) but that's where I plan to collect comments on each page.
21:51:59 <annegentle> All of the blitzing will help improve the docs!
21:52:15 <ttx> annegentle: sounds great! anything else ?
21:52:23 <annegentle> That'll do! Thanks.
21:52:30 <ttx> #topic Open discussion
21:52:41 <ttx> The waiting list for the Essex Design Summit is now closed
21:53:02 <ttx> If you are a real dev, somehow lived under a rock for the last two weeks, and missed registration: you can contact me so that I try to get you whitelisted -- but do it today :)
21:53:20 <ttx> Session proposing is in full swing
21:53:30 <ttx> Let me know if you have questions on that
21:53:59 <ttx> or on anything else...
21:55:48 <ttx> I'll take that as a no.
21:56:08 <ttx> anything, anyone, before I close ?
21:56:25 <annegentle> wow quiet at the close
21:56:30 <jaypipes> :)
21:56:40 * Vek feels barely here anyway.
21:56:49 <carlp> You should have been at the CI meeting - it was dead there too
21:56:56 <ttx> heh, let's cut it then
21:57:00 <ttx> #endmeeting