20:07:22 <annegentle> #startmeeting
20:07:23 <openstack> Meeting started Mon Sep 12 20:07:22 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:07:50 <annegentle> #topic St4ck3rntl
20:07:53 <annegentle> er
20:08:04 <annegentle> #topic Action items from the last meeting
20:08:12 <deshantm> what password is that i wonder... ;)
20:08:19 <annegentle> LOL a temp one now!
20:08:29 <deshantm> :)
20:08:39 <annegentle> pervious action item, staging areas for wiki and openstack.org main site.
20:08:54 <annegentle> I have a meeting set up for next week with a Rackspace UI team who would like to improve the wiki UI.
20:08:56 * sandywalsh yells annegentle's password in #openstack-dev
20:09:00 <annegentle> LOL
20:09:18 <annegentle> So, I hope that part of that work involves a staging area for the wiki. As well as CSS improvements.
20:09:35 <annegentle> The second action item is "wiki page to clarify version matrix that works with moving parts of OpenStack"
20:09:45 <annegentle> I took that one but haven't done any action on it yet.
20:09:52 * annegentle could use help on that one
20:10:20 <deshantm> that is a confusing one
20:10:29 <deshantm> could you start an etherpad to brainstorm in
20:10:29 <annegentle> yes.
20:10:34 <annegentle> that's a good idea.
20:10:59 <deshantm> maybe we could then get devs to contribute bits and pieces and then just make it work
20:11:18 <annegentle> could use some clarity - is the idea to say "Image service version, Identity service version, Dashboard version, etc?
20:11:26 <annegentle> or is it about hypervisors and compute?
20:11:51 <annegentle> #link http://etherpad.openstack.org/versionmatrix
20:12:38 <deshantm> I forget for sure, but I think the thing you are referring to is about what versions of the compute API work with what version of the other openstack components
20:12:49 <deshantm> I only have a weak recollection of the conversation
20:12:59 <annegentle> I wonder if the integration testing is in a similar vein?
20:13:12 <deshantm> it could be...
20:13:45 <annegentle> I think that just recording the various version numbers that make up Diablo is a good start.
20:14:04 <deshantm> It is also hard for users to tell what versions of nova work with which version of XenAPI-based hypervisors well too
20:15:20 <annegentle> Ok, that's good too, feel free to add it to the Etherpad
20:15:44 <annegentle> Ok, we'll keep that action item going forward.
20:16:07 <annegentle> #topic General documentation status - github move.
20:16:38 <annegentle> #info This past week I moved the API guides for Glance, Keystone, and Swift.
20:17:22 <annegentle> New github projects are named identity-api, image-api, object-api, so https://github.com/openstack/identity-api, https://github.com/openstack/image-api, https://github.com/openstack/object-api
20:17:35 <annegentle> I also have new Jenkins jobs for each book to be built from those repos. So far, so good.
20:17:46 <annegentle> I hope to move Compute to compute-api this week.
20:18:09 <annegentle> As you may have seen on the mailing list, this move does bring up discussion on the governance of the API itself, not just the docs.
20:18:26 <annegentle> For now, the way we have Gerrit set up, I have the ability to vote +2 on a change in those repos.
20:18:49 <annegentle> That enables quick doc changes to go through, but for wider API changes, we can have core teams review those.
20:19:23 <annegentle> Any questions on the move or governance?
20:19:27 <deshantm> ok, that makes sense
20:20:04 <annegentle> Good, I think it's a good move and I like to be able to build each doc separately.
20:20:19 <annegentle> #topic Doc status on RST docs
20:20:44 <annegentle> We now have man pages for all of the swift services thanks to the Swift team.
20:20:54 <annegentle> That was a pile of work.
20:21:19 <annegentle> There's also the new keystone.openstack.org site.
20:21:32 <annegentle> Not sure if I have any other news from RST-land.
20:21:52 <annegentle> #topic Doc status on openstack-manuals
20:22:10 <annegentle> So after the move of all the API docs to separate repos, I'll move openstack-manuals to git.
20:22:22 <annegentle> That should happen this week after the Compute API docs go to their new home.
20:23:00 <deshantm> by the way, how is the openstack starter guide managed?
20:23:34 <annegentle> Oh, good question. They created a Launchpad repo and the Starter Guide is build from there - it's  a separate Jenkins job pulled from http://launchpad.net/openstack-book.
20:23:48 <annegentle> so any time they make updates, our Jenkins server rebuilds the book.
20:23:58 <deshantm> that's cool
20:24:00 <annegentle> The CSS OSS team is managing the comments that come through on that book as well.
20:24:20 <annegentle> I was actually going to highlight them in open discussion - Looking at web stats - the Starter Guide has pages that have jumped into the top 10 in the past month, good going.
20:24:21 <toddmorey> Is that the same one linked from the community page, Anne?
20:24:37 <deshantm> http://docs.openstack.org/
20:25:01 <annegentle> #link http://docs.openstack.org/cactus/openstack-compute/starter/content/
20:25:05 <annegentle> it's that one ^^
20:25:12 <deshantm> the welcome guide is a shorter doc
20:25:12 <toddmorey> gotcha. thanks.
20:25:48 <annegentle> Last week I sent out 10 tshirts to doc contributors, all of the CSS OSS team plus Razique, who re-wrote all the Volume Management section.
20:25:55 <toddmorey> I really like the content of openstack-starter-guide-cactus.pdf. It's been well received and I point people to it a lot.
20:25:57 <annegentle> Love the contributions.
20:26:08 <annegentle> toddmorey: good to know. The web stats show it too. Popular!
20:26:26 <annegentle> #topic Doc Blitz Day
20:26:47 <annegentle> So this is a new idea we're going to try. It's a Doc Blitz - intense review and test period for the documentation.
20:27:35 <annegentle> It'll be held online for one hour next Monday - collecting doc feedback and doc bugs through IRC in #openstack, through Twitter on #docblitz, and in doc comments on a special site I'll set up at docs.openstack.org/docblitz/
20:28:00 <annegentle> #info Doc Blitz next Monday, collecting doc feedback and doc bugs through IRC in irc://ryder.racklabs.com/#openstack, through Twitter on irc://ryder.racklabs.com/#docblitz, and in doc comments on the docs.openstack.org site
20:28:16 <annegentle> I'm working on a blog post and note to the mailing list.
20:28:25 <deshantm> sounds neat
20:28:25 <annegentle> I think it'll be a fun experiment.
20:28:29 <toddmorey> so that's open to the wider community?
20:28:36 <annegentle> I think I have thick enough skin to take all the doc bugs that'll come in
20:29:08 <annegentle> Yes, we'll run it from 12 noon - 1:00 CST (1:00-2:00 EST), then run a second one for the other half of the world from midnight EST for an hour.
20:29:23 <annegentle> We want all the reviewers we can get.
20:29:39 <annegentle> I'll try to list priorities - based on web stats, I'd say people read the Compute Admin manual through and through.
20:29:56 <toddmorey> agreed!
20:30:04 <annegentle> I was looking for pages with high exit rates, but what's funny is some of the pages with high exit rates are say, the RHEL install instructions where the page tells them to go download something.
20:30:28 <annegentle> So really I'll have to dig in deeper. I think focus areas should be install and networking for the Compute Admin guide.
20:30:42 <annegentle> But I'd love feedback from all over the docs sites - docs.openstack.org, nova.openstack.org, you name it.
20:31:27 <annegentle> #info Doc Blitz times: 12 noon - 1:00 CST (1:00-2:00 EST), plus at midnight EST for an hour.
20:31:49 <annegentle> #topic Doc bugs
20:32:18 <annegentle> I full expect for the Doc Blitz to make this list longer than 12 -  https://bugs.launchpad.net/openstack/+bugs?field.tag=documentation
20:32:23 <annegentle> full/fully
20:32:44 <annegentle> Razique's work on the volume doc did close a bug last week, wahoo.
20:33:13 <annegentle> it'd be great to knock out https://bugs.launchpad.net/nova/+bug/794441 about XenAPI driver doc
20:33:14 <uvirtbot> Launchpad bug 794441 in nova "Poor XenAPI driver documentation" [Wishlist,Confirmed]
20:33:52 <annegentle> #topic Open Discussion
20:33:59 <annegentle> Anything else we can talk about?
20:34:08 <deshantm> I've started some work on the xen documentation
20:34:18 <annegentle> Great!
20:34:24 <deshantm> #link http://etherpad.openstack.org/openstack-xen
20:35:20 <deshantm> It is very much a work in progress
20:35:41 <annegentle> Nice. For XCP mostly, are you thinking?
20:35:48 <deshantm> I have at least another source or two to incorporate
20:36:00 <deshantm> I mention at the beginning about Xen in general
20:36:14 <deshantm> but then shift the focus to XenAPI-based hypervisors
20:36:23 <deshantm> XCP/Project Kronos will be the focus
20:36:30 <annegentle> Okay.
20:36:38 <deshantm> I'll refer to public docs for Citrix XenServer
20:36:45 <deshantm> but a lot overlaps anyway
20:37:30 <annegentle> yeah that's okay I think.
20:37:36 <deshantm> any feedback is appreciated
20:37:46 <deshantm> I'll solicit more when it is more ready
20:37:52 <annegentle> ok, cool.
20:38:02 <annegentle> Well I think that's all we have for today, anything else?
20:38:04 <deshantm> also it would be worthwhile to mention that the docs team is planning to meet up at the summit
20:38:33 <annegentle> oh good, yes. I need to finalize the Summit proposal.
20:40:16 <annegentle> #action Anne to set up doc talk proposal for the Summit
20:40:23 <annegentle> Ok, if that's it we can adjourn.
20:40:44 <deshantm> that's all I have
20:40:45 <deshantm> thanks
20:40:53 <annegentle> Thanks for joining in :)
20:41:00 <annegentle> #endmeeting