22:01:59 <danwent> #startmeeting
22:02:00 <openstack> Meeting started Tue Aug  2 22:01:59 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:14 <danwent> #link Agenda: http://wiki.openstack.org/Network/Meetings
22:02:27 <danwent> #topic netstack updates
22:02:41 <danwent> Several people have been asking about incubation.
22:02:54 <EdgarPerdomo> Hello All
22:02:57 <danwent> now that dashboard and keystone recently joined.
22:03:10 <danwent> we'll be working toward this in the next few weeks.
22:03:20 <danwent> one other thing that I saw that was pretty cool:
22:03:23 <salv> at this stage, my first concern is jenkins integration and the system testing infrastructure.
22:03:34 <zykes-> working towards ?
22:03:52 <danwent> our states on launchpad: quantum has 23 active branches owned by 9 people and 4 teams. There were 135 commits by 16 people in the last month.
22:04:06 <danwent> 135 commits by 16 people in the last month.... very impressive
22:04:09 <danwent> go team :)
22:04:21 * markvoelker cheers
22:04:40 <danwent> salv:  agreed.  I actually think there's a bit of a chicken and egg here
22:05:02 <danwent> being incubated may make it clear that we can use the standard openstack infrastructure.  either way, definitely want to work toward better system test and integration
22:05:04 <somik> salv: I think the incubation gives us access to those resources too
22:05:07 <salv> danwent: should we throw and decide between the chicken and the egg?
22:05:45 <danwent> zykes: I think we'll be working toward a proposal... I'm not sure how quickly such things move though.
22:05:48 * salv remember we talked about setting up our own jenkins infrastructure
22:06:15 <danwent> salv: carlp said he was playing with jenkins, said that having something setup in d-4 timeframe woudl be reasonable
22:06:27 <danwent> anyone want to take on that blueprint?
22:06:56 <danwent> https://blueprints.launchpad.net/quantum/+spec/quantum-system-test
22:07:09 <salv> Is carlp here for an update?
22:07:23 <danwent> he's on the list, not sure if he's listening in
22:07:25 <pvo> danwent: can we talk later about that blueprint?
22:07:32 <danwent> pvo: sounds good.
22:07:35 <pvo> I'm going to be looking at this very soon.
22:07:41 <markvoelker> danwent, pvo: add me to the list please....may have some help there
22:07:51 <pvo> markvoelker: sure thing
22:07:54 <danwent> we'll use the netstack list, definitely
22:08:16 <markvoelker> awesomesauce then.
22:08:24 <danwent> ok, we're going with salvatore's reverse agenda....
22:08:31 <danwent> #topic donabe status
22:08:52 <danwent> anyone here for this?
22:08:59 <danwent> or melange?  I believe troy is out.
22:09:04 <markvoelker> I believe James had to leave town unexpectedly....
22:09:04 <RamD> nothing specific for this week
22:09:13 <danwent> RamD: k, thanks.
22:09:25 <danwent> Ok, we'll just move on to quantum
22:09:29 <danwent> #topic quantum status
22:09:50 <danwent> we're starting to target things for milestones now: https://launchpad.net/quantum/+milestone/diablo-4
22:10:13 <danwent> If you have something major that you expect to land in this window, please try and target it against the milestone so everyone knows it is coming.
22:10:21 <RamD> we will add few more for 802.1bqh and nx-os related bps
22:10:29 <danwent> RamD: fantastic
22:10:56 <danwent> Thanks to those folks doing all the reviews lately, we've been getting a lot of code merged
22:11:05 <danwent> active merge props are here: https://code.launchpad.net/quantum/+activereviews
22:11:10 <heckj> re: CI infrastructure - monty and crew are pretty open to expanding Jenkins as needed for related projects - unless you have some specific hardware needs, it should be pretty doable there, and I'm sure they're willing to help
22:11:25 <salv> danwent: are we adopting the same approach as nova?
22:11:29 <danwent> heckj, thanks.
22:11:43 <salv> All features in D-4, then testing and bug-fixes for diablo-release
22:11:51 <danwent> heckj, can you email me so I can include you on the thread we have on that?
22:12:02 <danwent> salv: yes, I'd like to get any major features into D-4
22:12:26 <danwent> salv: then focus on testing, packaging, and everyone's favorite: documentation :)
22:12:31 <salv> k. So we should add authN/authZ, and I think we should agree in this meeting what we expect to deliver.
22:12:43 <Tv_> salv: i can sub in for carlp (sorry, was checking email)
22:12:51 <markvoelker> salv: +1, I was actually going to bring up Keystone integration
22:13:10 <RamD> On jenkins related requirement ...it would be great to track it in terms what are the requirements e.g. access to physical hw infra if any
22:13:26 <danwent> I think we can target the basic keystone integration for D-4, inline with our previous discussion.
22:13:33 <salv> Tv_: thanks. carlp said he was looking into CI testing for quantum. However pvo suggested to discuss this topic later on the meeting.
22:13:53 <danwent> (i.e., not role-based access control, just basic protections so one tenant can't mess with another tenant's stuff)
22:14:00 <salv> by "basic" we mean authentication only?
22:14:28 <danwent> #action: danwent  start email thread with folks about CI/systemtest
22:14:33 <salv> danwent: sorry I missed your last line
22:14:56 <salv> danwent: agree on the target for authN/authZ in D-4
22:14:58 <danwent> salv:  that seems pretty achievable in the short time period.  we already have a pretty full plate with all of the nova changes.
22:15:02 <danwent> salv: great
22:15:07 <Tv_> salv: all i can really say with certainty is we want to do a *lot* more with openstack, it's just a question of time.. especially we're interested in the non-VLAN deployment model
22:15:32 <mtaylor> yes. quite willing to pull stuff in to CI
22:15:43 <mtaylor> danwent: make sure I'm on that thread :)
22:15:44 <markvoelker> danwent, salv: well, one tenant not messing with another's stuff sort of implies some authz and authn, no?  E.g. you have to authenticate to say who you are and then we have to say "you are not authorized to touch the other guy's stuff"?
22:15:49 <danwent> Ok, Salvatore, want to give a brief update on the API spec work ?
22:16:04 <salv> markvoelker: we'll get to that later...
22:16:04 <danwent> mtaylor: will do (thank god these meetings are archived :P)
22:16:06 <salv> API Spec.
22:16:26 <salv> My goal is to "lock down" the specification by the end of the week, and label it "1.0".
22:16:28 <danwent> mark: agreed, it is just a very simple authorization model
22:17:00 <salv> I would like to know if there's anything you would like to change in the current spec.
22:17:18 <danwent> markvoelker: what about the labels you mentioned?
22:17:39 <salv> I've updated it to make it more compliant with OS API spec, and I'm working on the API code to make sure it faithfully does what the API says.
22:17:41 <danwent> do you think that should be considered with the v1.0 API?
22:17:47 <mtaylor> danwent: (actually, there is absolutely no need for carlp to set up his own jenkins ... we've got a team of us doing the openstack one :) ) (sorry - trolling through scrollback now)
22:17:52 * mtaylor shuts up now
22:18:14 <markvoelker> danwent: I want labels, but I'm thinking we may have bigger fish to fry for Diablo.  Nice to have for D4 in my mind, but I'd rather work on keystone integration first.
22:18:22 <somik> salv: I have some feedback that I'll send it over email.
22:18:29 <danwent> mtaylor: good to know.
22:18:46 <danwent> markvoelker: k, sounds good.
22:18:47 <salv> somik: ok, thanks.
22:19:05 <salv> Do you agree locking down the API spec during this week is a reasonable assumption?
22:19:10 <danwent> +1
22:19:29 <danwent> unless a bigger discussion pops up on the list, I'd like to get this solid
22:19:36 <danwent> it will help us write more and more tests, etc.
22:19:37 <somik> it would be a good thing to look things down soon.
22:19:44 <markvoelker> Sounds good to me.
22:20:02 <markvoelker> Deadline?
22:20:19 <danwent> Let's give a deadline for initial feedback.
22:20:23 <salv> I don't think there will be a lot of discussion on operations, requests and responses
22:20:38 <danwent> but if there's an ongoing discussion, I don't want to kill it just because of a deadline.
22:20:41 <salv> But synchronous vs async behaviour probably needs to be discussed
22:20:43 <RamD> what about sync vs async :-)
22:20:49 <danwent> :)
22:21:08 <salv> Shall we spend some time on this during the open discussion?
22:21:15 <danwent> Ok, how about if there is a topic you'd like to raise, do it by the end of the week on the mailing list
22:21:32 <salv> danwent: +1
22:21:32 <heckj> 0/
22:21:37 <danwent> At least by the end of the week we'll know everything where there is potential disagreement
22:21:52 <salv> (end of the week meaning friday night PST - so I can fix stuff by next tuesday)
22:22:01 <heckj> what's the status of documentation for Quantum, Danube, and Melange? Is there anything in RST or docbook?
22:22:04 <danwent> #info get all feedback on 1.0 API in by end of the week
22:22:28 <salv> heckj: I'm aiming at producing an RST document for quantum API by next tuesday
22:22:28 * heckj hasn't trolled the branches to look
22:23:08 <danwent> heckj:  some wiki pages, but not much.  Definitely part of the final diablo deliverable in my mind.
22:23:52 <danwent> #action danwent create blueprints for docs
22:24:06 <danwent> Ok, anything else on API?
22:24:17 <salv> Summarizin on API spec: deadline for feedback is august 5, spec lock down expect for tue aug 9, api-spec implementation to be totally aligned by aug 25
22:24:33 <danwent> salv: sounds great
22:24:51 <heckj> +1
22:25:03 <danwent> Ok, markvoelker, any update on the GUI work?  Congrats to tyler on getting the client lib work merged.
22:25:11 <salv> (feedback received after Aug 5 will not be ignored, but will target next API version)
22:25:25 <markvoelker> Yes.  First: thanks to everyone for the reviews and getting that client merged.
22:25:54 <markvoelker> GUI-wise: working out a few kinks, but Arvind expects a good reviewable branch to land ~mid next week if not before.
22:26:22 <danwent> mark: great.  I'll target that blueprint for D-4
22:26:28 <markvoelker> Sounds good
22:26:54 <danwent> Ok, on Nova work.
22:27:23 <danwent> As you saw from the list of blueprints, I started creating "shadow" blueprints in quantum for work that is being done in nova that is important to quantum.
22:27:51 <danwent> these blueprints are just links to nova blueprints, but they should increase people's ability to know what of all of the blueprints in nova are critical to quantum, who's working on them, etc.
22:28:43 <danwent> the main chunks of work and people working on them are:  creating a quantum manager (me, brad), exposing vif-ids (ryu, troy), linuxnet-vifplugging (me), and melange integration (troy + team)
22:29:02 <danwent> if you're interested in contributing, please check out the blueprints and contact the authors
22:29:23 <salv> exposing vif-ids, will also allow us to do the cross-service verification for authorizing quantum operations?
22:29:30 <danwent> ttx is STRONGLY encouraging early merges for anything going into nova for D-4
22:30:04 <danwent> salv:  I actually put that in the quantum-manager blueprint, though if you have a different proposal that is fine.
22:30:28 <salv> danwent: I just wanted to make sure we are tracking this
22:30:39 <danwent> salv: cool.
22:30:47 <danwent> anything else on nova?
22:31:10 <danwent> Ok, is Tyler here?
22:31:22 <markvoelker> Not, I think
22:31:29 <danwent> he mentioned that he will be taking a look at packaging for quantum, which is great.
22:31:47 <danwent> https://blueprints.launchpad.net/quantum/+spec/quantum-packaging
22:31:47 <markvoelker> Yes, he has .debs worked up and is working on RPM's.
22:32:02 <markvoelker> (for the client lib)
22:32:03 <danwent> #info contact tyler if you're interested in quantum packaging
22:32:24 <salv> on Nova I forgot to mention that we are starting to move toward ESX support for VIF-plugging. We first need to support multi-nic, and we will be addressing this shortly.
22:32:44 <danwent> salv: cool.  Is there a bp or bug?
22:33:10 <salv> Not yet, we are still internally investigating the work required
22:33:23 <danwent> #topic open discussion
22:33:28 <danwent> salv: k
22:33:46 <markvoelker> Keystone integration: anyone taking point on this?  If not I'll volunteer my team.
22:34:10 <salv> markvoelker: I was looking after it. Happy to work with your team
22:34:16 <danwent> mark: salv and I have talked a bit about it, but I have few dev cycles, so it would be great if you can help
22:34:41 <markvoelker> Excellent.  Salv, can you maybe send out a "where things stand" email so we can figure out how to attack this?
22:35:13 <salv> markvoelker: we can start from the meeting we had a few weeks ago. I think the minutes I sent on the ML list are a good idea of where we are at the moment. (Unfortunately).
22:35:26 <salv> I'd love to have an attack strategy in the next couple of days
22:36:10 <danwent> salv: I will send some quick thoughts to the list, with some thoughts on the "simple" authn/authz
22:36:17 <danwent> ok, anything else folks?
22:36:34 <danwent> #endmeeting