21:02:09 <ttx> #startmeeting
21:02:09 <jmckenty> piston, cloudscaling, citrix, 4p, rPath and Stackops
21:02:10 <openstack> Meeting started Tue Jul 19 21:02:09 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:17 <ttx> Welcome to our weekly team meeting...
21:02:25 <ttx> Today's agenda:
21:02:32 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:03:09 <ttx> hrm, just a sec
21:04:18 * ttx has some connection problems with that page
21:04:34 <ttx> #topic Actions from last week
21:04:50 <ttx> Could someone paste the actions from last week from http://wiki.openstack.org/Meetings/TeamMeeting ?
21:05:07 <Vek> Actions from previous meeting
21:05:07 <notmyname> ttx: http://paste.openstack.org/show/1910/
21:05:08 <Vek> * notmyname and soren get together on Swift packaging needs
21:05:08 <Vek> * jaypipes to update Glance D3/D4 blueprints
21:05:39 <ttx> Thanks. I'm on a crappy wifi that blocks some addresses
21:06:02 <ttx> notmyname: did you sync with soren already ? Or that's still a TODO ?
21:06:30 <notmyname> ttx: soren and gholt talked about this at length. I think this is resolved. soren?
21:06:51 <mtaylor> (soren is on vacation today, no?)
21:06:52 <ttx> soren is in vacation, so we'll assume yes
21:06:58 <notmyname> ok
21:07:14 <ttx> jaypipes: BP updates ?
21:07:24 <jaypipes> ttx: gah, still working on it, sorry :(
21:07:46 <ttx> jaypipes: do you regret your new job already ?
21:07:52 <jaypipes> ttx: heh
21:07:59 <ttx> #topic Swift status
21:08:12 <ttx> notmyname: So for 1.4.2 we should branch on July 25 and release on Jul 27 ?
21:08:15 <notmyname> correct
21:08:24 <ttx> Looking at https://launchpad.net/swift/+milestone/1.4.2 -- the feature plan looks complete
21:08:34 <ttx> notmyname: You also have two 1.4.2-targeted bugs: those should be addressed before release ?
21:09:03 <notmyname> ya, I think one has been done. I'll need to check. I added them this morning and expect them to be done this week
21:09:09 <ttx> cool.
21:09:19 <ttx> notmyname: Other announcements/comments ?
21:09:21 <notmyname> ya, just one outstanding bug
21:09:28 <notmyname> no
21:09:35 <ttx> Questions for the Swift PTL ?
21:09:50 <whitt> I have a stats q: stats was removed from Swift 1.4.2 - what is it's future?
21:10:03 <notmyname> I sent a reply to the mailing list
21:10:14 <notmyname> stats are separate and will no longer be tracked with swift
21:10:31 <notmyname> links and details are on the mailing list reply
21:10:35 <whitt> is there a repo?
21:10:48 <notmyname> https://github.com/notmyname/slogging
21:11:02 <notmyname> and https://github.com/notmyname/slogging-debian
21:11:26 <whitt> thanks - was looking all over for it
21:11:28 <ttx> other questions ?
21:11:58 <ttx> #topic Glance status
21:12:04 <ttx> jaypipes: Hi!
21:12:06 <jaypipes> slow. :)
21:12:13 <ttx> Looking at: https://launchpad.net/glance/+milestone/diablo-3
21:12:20 <ttx> So it's not up to date, IIUC :)
21:12:23 <jaypipes> we've got a bunch of reviews to do.
21:13:36 <ttx> jaypipes: could you update the status by tomorrow ?
21:13:38 <jaypipes> and I've got to get the blueprints updated. the URI bug (https://bugs.launchpad.net/bugs/771849) is a top priority and we have a fix proposed, but it breaks on Python 2.6's urlparse lib. So, I need to get a dev env on 2.6 up and fix that.
21:13:41 <uvirtbot`> Launchpad bug 771849 in glance "Port not parsed correctly in Swift URI" [High,In progress]
21:13:45 <jaypipes> ttx: yes, I will.
21:13:53 * jaypipes hangs head
21:14:02 <ttx> #action jaypipes to update D3/D4 plans for Glance before EOD Jul 20
21:14:35 <ttx> jaypipes: Other announcements, comments ?
21:15:08 <ttx> Note that we'll branch Glance for D3 milestone release at EOD Monday.
21:15:57 <jaypipes> ttx: no.
21:15:59 <ttx> Raise your hand if you have a question for jaypipes on Glance
21:16:05 * Vek does
21:16:13 <ttx> Vek: shoot.
21:16:28 <Vek> just checking that jaypipes saw my email from this morning and that it didn't get lost in the pipes or clutter somewhere.
21:16:40 <jaypipes> Vek: did you see my PM in IRC? ;)
21:16:43 * Vek didn't intend to make a "pipes" pun, but it works...
21:16:58 <Vek> no, 'fraid I didn't; I don't log PMs, either, unfortunately, sorry :/
21:17:06 <jaypipes> Vek: yes, didn't lose it. :)
21:17:13 <Vek> 'k, thanks :)
21:17:15 <jaypipes> Vek: I'll email you about the ideas.
21:17:22 <Vek> 'k, thanks :)
21:17:51 <ttx> #topic Nova status
21:17:57 <ttx> vishy: yo!
21:18:32 <vishy> hai
21:18:50 <ttx> Looking at: https://launchpad.net/nova/+milestone/diablo-3
21:19:03 <ttx> A lot of merges should be proposed this week, so the priority is in getting those reviewed -- keep the review loop tight
21:19:20 <ttx> If you already know you won't be able to propose your code for merging this week, your feature should be deferred to D4
21:19:30 <ttx> So please let me or vishy know if that's the case.
21:19:42 <ttx> Note that we already deferred quite a bit today
21:19:56 <ttx> Also if you have any bug that *needs* to be fixed before diablo-3 release...
21:20:05 <ttx> ...you can set the milestone target to diablo-3 (or ask me to do that for you)
21:20:52 <ttx> we still need someone to be assigned to https://bugs.launchpad.net/bugs/803654
21:20:53 <uvirtbot`> Launchpad bug 803654 in nova "availability zone ignored when creating volume" [High,Confirmed]
21:21:10 <ttx> anyone feeling like fixing this one ?
21:21:21 <ttx> vishy: otherwise we'll have to untarget it from D3
21:21:33 <ttx> no point in listing bugs nobody will fix anyway.
21:21:49 <vishy> it is a nice feature :)
21:22:27 <ttx> heh
21:22:56 <ttx> apparently we didn't trigger mass-interest for that bug
21:23:11 <ttx> or everyone sleeps already.
21:23:14 <ttx> vishy: more comments ?
21:23:45 <vishy> ha-net and block-migration need to get in
21:23:47 <vishy> they are close
21:24:37 <ttx> vishy: is there an issue with the review days lately ? I've seen a bit of stale reviews lately
21:25:37 <ttx> hm, looks like https://code.launchpad.net/~usc-isi/nova/extra_specs_sched/+merge/65980 should just have the approved bit set
21:26:49 <ttx> we shouldn't block on a non-reset "needs fixing" when what needs to be fixed obviously was.
21:27:00 <vishy> reviews have been a bit sparse for the past week or two
21:27:09 <vishy> i think a lot of people are going on vacation and such
21:27:33 <ttx> vishy: what an idea.
21:27:43 <ttx> Questions for Nova PTL ?
21:27:55 <Tushar> I have added one blueprint add-options-network-create-os-apis
21:28:02 <Tushar> URL: https://blueprints.launchpad.net/nova/+spec/add-options-network-create-os-apis
21:28:09 <Tushar> I am waiting for approval from Vishy
21:28:35 <Tushar> This is targeted for D3 milestone
21:28:45 <Tushar> I have already finished implementation and have proposed it for merging (https://code.launchpad.net/~tpatil/nova/add-options-network-create-os-apis/+merge/68292)
21:29:11 <ttx> Tushar: ok
21:29:11 <ttx> Tushar: would that be proposed potentially in time for D3 ?
21:29:21 <vishy> if you already have proposed it i don't know that it needs a blueprint approval
21:29:25 <vishy> they aren't required
21:29:38 <Tushar> Yes, I am working on review comments and will finish that up today
21:29:56 <Tushar> vishy: OK
21:30:17 <jtran> can anyone do reviews?  I haven't done any but would like to start
21:30:19 <ttx> vishy: someone needs to set priority though, but I can do that for late specs.
21:30:57 <ttx> jtran: anyone can. Only core members count towards the 2 approvals. Doing reviews is a good way to become a core member.
21:31:16 <jtran> understood.
21:31:26 <tr3buchet> vishy: can you clarify what you're saying about the blueprints?
21:31:57 <vishy> blueprints aren't required to get a branch merged
21:32:54 <ttx> #topic Open discussion
21:33:08 <tr3buchet> sounds scary
21:33:47 <Vek> question about https://bugs.launchpad.net/nova/+bug/794705 -- Have we decided which of the two competing approaches are going to be used?  There haven't been that many "votes" so far, though there does seem to be a trend...
21:33:48 <uvirtbot`> Launchpad bug 794705 in nova "need a real argparser for the bin/nova-manage commands" [Wishlist,Confirmed]
21:34:41 * ttx looks
21:37:04 * tr3buchet chirp chirp
21:37:38 <Vek> there's a lot of comments on the two merge-props in question :)
21:39:01 <ttx> Vek, vishy: looks like the OptionParser approach gets more votes
21:39:24 <Vek> *nod* that's kinda what I was expecting.  Oh, well...
21:39:35 <vishy> Vek: ttx
21:39:37 <ttx> fwiw I prefer that we don't reinvent an option parser
21:39:39 <vishy> yes
21:39:50 <vishy> i think the explicit approach is best
21:39:51 <Vek> indeed :)
21:40:11 <vishy> but some parts of the other branch could be incorporated after
21:40:27 <ttx> would be good if that would land in D3 and we stop breaking nova-manage-using docs :)
21:40:44 * annegentle seconds that
21:41:02 <Vek> vishy: Which parts did you have in mind?  The subcommand parsing, as opposed to the other argument parsing?
21:42:27 * ttx waits for the final words before closing the meeting
21:42:30 <vishy> Vek: i think kevin had an idea for some stuff he wanted to add
21:42:54 <ttx> vishy: can you comment on both so that the good one gets merged ?
21:42:56 <Vek> vishy: I am Kevin
21:43:08 <ttx> ahah
21:43:08 <blamar> ttx: Late to party, but was pinged on extra_specs_sched... fixing my stale review now
21:43:33 <ttx> blamar: cool
21:43:42 <blamar> also, is there a standard on the copyright header?
21:43:48 <blamar> 2011 <Anyone>?
21:44:10 <blamar> can't it just be OpenStack, LLC or what have you?
21:44:11 <Vek> blamar: I keep c&p'ing the wrong one, but I think it's supposed to be the "Openstack, LLC" one.
21:44:27 <annegentle> it can be OpenStack LLC, yes.
21:44:31 <ttx> I think the default one is the Openstack LLC one, if you have no lawyer.
21:44:40 <annegentle> http://swift.openstack.org/_sources/index.txt
21:44:47 <blamar> ttx: Oh dea, what do lawyers have to do with this
21:44:50 <blamar> oh dear*
21:45:02 <ttx> blamar: they hate copyright assignment ?
21:45:05 <blamar> :0
21:45:07 <Vek> they like to keep themselves employed?
21:45:07 <blamar> :)
21:45:20 <ttx> ok guys, let's close it then
21:45:23 <annegentle> :)
21:45:25 <ttx> #endmeeting