21:00:26 <jaypipes> #startmeeting
21:00:27 <openstack> Meeting started Tue Jul 12 21:00:26 2011 UTC.  The chair is jaypipes. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:29 <glenc> \o
21:00:51 <jaypipes> Thierry is away today; soren and I will fill in this week...
21:00:53 <sandywalsh> o/
21:00:55 <soren> o/
21:00:55 <cynb> o/
21:01:07 * soren adopts a French accent
21:01:14 * jaypipes dons beret
21:01:21 <glenc> oui?
21:01:21 <soren> You've lost me.
21:01:37 <dabo> \o
21:01:57 <jaypipes> OK, let's start, eh?
21:02:03 <sandywalsh> jaypipes will henceforth be known as "Don Beret"
21:02:09 <jaypipes> heh
21:02:18 <jaypipes> #topic Swift status
21:02:26 <jaypipes> notmyname: any updates?
21:02:33 <notmyname> I don't think there are any updates
21:02:43 <Vek> point of order: Is there a link to the agenda?
21:02:47 <jaypipes> k. anything you need assistance on from anyone?
21:02:51 <jaypipes> Vek: one sec
21:03:14 <soren> http://wiki.openstack.org/Meetings/TeamMeeting
21:03:28 <jaypipes> dang, beat me to it...
21:03:31 <notmyname> we saw some packaging updates go through this morning for swift. I assume those a  work in progress?
21:03:36 <notmyname> soren: ^?
21:03:38 <soren> Looks quite boiler plate-y.
21:04:14 <soren> notmyname: Sort of?
21:04:23 <jaypipes> soren: some details, please? :)
21:04:26 <soren> I mean... EVerything is work in progress :)
21:04:57 <notmyname> I think there were some concerns about some of the init scripts. I don't have the details, but we can get those to you
21:05:02 <soren> I expect to start merging the stuff you've done tomorrow.
21:05:12 <vishy> o/
21:05:15 <soren> ..but the stuff that landed today isn't meant to be half-done if that's what you're asking.
21:05:30 <notmyname> soren: ok. then we definitely need to comment ;-)
21:05:57 <jaypipes> notmyname, soren: #action get together on Swift packaging needs
21:06:25 <jaypipes> notmyname, soren: can you two handle that off list? or is it something we should go over here?
21:06:33 <notmyname> not here
21:06:36 <jaypipes> k.
21:06:38 <soren> I have no idea.
21:06:45 <jaypipes> notmyname: any other stuffs?
21:06:53 <soren> (seeing as I seem to be the one who'll be told thing, not telling things)
21:07:08 <notmyname> jaypipes: I don't think so
21:07:21 <jaypipes> any questions for notmyname before we move on?
21:07:48 <jaypipes> #action notmyname and soren get together on Swift packaging needs
21:08:08 <jaypipes> ok, moving on...
21:08:12 <jaypipes> #topic Glance status
21:08:16 <jaypipes> https://launchpad.net/glance/+milestone/diablo-3
21:08:52 <jaypipes> Mostly been handling bugs this week and last couple days of last week. Big one almost finished (just finishing tests on it): https://bugs.launchpad.net/bugs/771849
21:08:53 <uvirtbot> Launchpad bug 771849 in glance "Port not parsed correctly in Swift URI" [High,In progress]
21:09:50 <jaypipes> have a small blocker on getting https://bugs.launchpad.net/bugs/713154 done: waiting to set up an AWS testing account we can put creds on the Jenkins box for...
21:09:51 <uvirtbot> Launchpad bug 713154 in glance "S3 Backend doesn't support POST either." [Medium,In progress]
21:10:10 <jaypipes> Have to get back on track with the Keystone integration as well...
21:10:28 <jaypipes> Still hopeful to hit D3 for that, with shared image groups in D4
21:10:48 <jaypipes> #action Jay to update D3/D4 blueprints
21:11:55 <jaypipes> The recent change in nova to support multiple glance servers threw a wrench in a bunch of people's setups. We should try to avoid such situations better in the future... the config files changed (from glance_host/port to glance_api_servers FLAG and things weren't upgrade cleanly)
21:11:58 <glenc> jaypipes - we are looking at Keystone integation, too
21:12:28 <jaypipes> glenc: resource-wise, do you have a specific allotment for someone to work on that?
21:12:46 <jaypipes> glenc: I know you, westmaas and maybe pvo needed to chat about that?
21:12:48 <glenc> we could - we were hoping to start it next sprint (Monday)
21:13:00 <jaypipes> glenc: k, I'll offline it with you.
21:13:02 <glenc> we should sync - don't want to duplicate work
21:13:05 <jaypipes> yup.
21:13:11 <jaypipes> that's about it from me. any questions on Glance stuff?
21:13:30 <jaypipes> in related news, JordanRinke has Glance working on Windows now.. w00t.
21:13:50 <sandywalsh> nice
21:14:05 <jaypipes> ok, moving on...
21:14:06 <heckj> jaypipes: is there a walk-through anywhere for loading in images into Glance? I've been looking, haven't spotted one.
21:14:21 <heckj> (sorry)
21:14:45 <jaypipes> heckj: there's a variety of ways to do so. Here is a good starting point:http://glance.openstack.org/glance.html#the-add-command
21:15:12 <heckj> jaypipes: thanks
21:15:21 <jaypipes> heckj: if you're using the eucatools, you can check out the glance-upload tool, too.
21:15:42 <jaypipes> ok, moving on...
21:15:49 <jaypipes> #topic Nova status
21:15:53 <jaypipes> vishy: you're on.
21:18:08 <soren> *crickets*
21:18:09 <jaypipes> OK, ttx wanted me to ask mtaylor and soren about your blueprints targeted for D3 Nova: https://launchpad.net/nova/+milestone/diablo-3
21:18:37 <jaypipes> soren: https://blueprints.launchpad.net/nova/+spec/ec2-id-compatibilty I assume is held up on the ML discussion on EC2 UUIDs?
21:18:48 <soren> jaypipes: Sounds like a fair summary.
21:19:01 <soren> jaypipes: I also have a ton of packaging things to do and some holiday and OSCON and and and..
21:19:15 <jaypipes> mtaylor: your 2 testing-related bluprints for Nova's D3? Any updates?
21:19:16 <soren> If someone else wants it, feel free to jump on it.
21:19:26 <vishy> wow
21:19:32 <vishy> sorry got disconnected :)
21:19:45 <jaypipes> soren: I think based on the discussion on the ML that one might need to get pushed back...
21:19:50 <jaypipes> vishy: no worries, mate :)
21:20:03 <jaypipes> vishy: have at it.
21:21:12 <vishy> i missed some scrollback unfortunatley
21:21:18 <vishy> *ely
21:21:28 <jaypipes> vishy: just asked soren and mtaylor about their Not Started blueprints for D2
21:21:31 <jaypipes> sorry, D3
21:21:45 <jaypipes> vishy: you also have a Not Started blueprint for separating services...
21:22:01 <vishy> I'm thinking of cancelling that one
21:22:17 <vishy> our next sprint is to spend some time updating and fixing the volume service
21:22:28 <vishy> which may provide some results along those lines
21:22:42 <vishy> but it is probably best to just cancel that blueprint and make a new one
21:22:44 <jaypipes> vishy: any particular blueprints or bugs that you need extra attention on? any particular merge proposals that really need reviews?
21:22:50 <vishy> yes
21:23:06 <vishy> I would love some feedback on the ha-networking branch that I proposed
21:23:32 <vishy> also, since lunr has moved to the driver level, we are going to need some more focus on the volume service
21:23:41 <vishy> there will be a few new blueprints around that showing up
21:23:46 <jaypipes> vishy: I'll send out a "important stuff" mailing list post like ttx usually does.
21:23:51 <vishy> and we might need some help
21:24:21 <vishy> i'm a little concerned about full keystone integration making it in
21:24:36 <jaypipes> vishy: how does the lunr thing work now? have we given up on the idea of elastic block storage at the API level?
21:24:46 <vishy> the main sticking point that no one has tackled is making ec2 api work properly
21:25:03 <vishy> jaypipes: volume already does ebs
21:25:06 <jaypipes> vishy: keystone and EC2?
21:25:25 <vishy> they have just decided to implement lunr as a driver and keep the existing nova code in place
21:25:40 <jaypipes> vishy: right, but it's a subset of the compute API now, correct? no plans to sepaarate that out as its own service?
21:25:55 <creiht> jaypipes: If you would have read the email, I stated that we were scaling back the focus of lunr to the driver level
21:25:56 <vishy> jaypipes: it depends on how you define service
21:26:21 <vishy> jaypipes: there is already a nova-volume service
21:26:34 <vishy> whether it ever graduates into a separate project is unknown
21:26:40 <jaypipes> creiht: sure, but I didn't understand that, really, since nova already contained driver-level code for volumes...
21:27:50 <creiht> jaypipes: oh really? :P
21:28:16 <jaypipes> creiht: yes.
21:28:27 <creiht> I guess that will work then, my job is done
21:28:32 <jaypipes> creiht: there are drivers for AoE, iSCSi, HP LeftHand, etc
21:28:45 <vishy> jaypipes: on the keystone ec2 stuff, if we depend on keystone completely for users and tenants, we don't really have a good place for generating/storing/checking ec2 access and secret keys
21:28:51 <jaypipes> creiht: are you saying that you guys will be adding  additional drivers only?
21:29:02 <creiht> jaypipes: that is correct
21:29:07 <jaypipes> creiht: k, thx
21:29:27 <vishy> jaypipes: this either needs to be a keystone plugin or move into an ec2 only compatibility layer
21:29:36 <jaypipes> vishy: k, understood. do we have a gameplan for that? /me crosses fingers...
21:29:47 <vladimir3p> on volume-service stuff: there are multiple things that might be required... starting from scheduling and reporting capabilities a-la compute
21:29:57 <vishy> since nova will ultimately lose its concept of user and project
21:30:00 <creiht> jaypipes: and helping push nova volume in feature and other areas where it lacks
21:30:25 <creiht> vladimir3p: yeah, I'm working on blueprints right now for some of those areas
21:30:31 <jaypipes> creiht: coolio. good to know. I re-read the ML post. thx.
21:30:34 <vishy> vladimir3p: exactly.  nova-volume got a little bit abandoned over the last few weeks and it needs to be brought up to speed
21:30:39 <vladimir3p> Folks, we have 2 blueprints on our plate: VSA & adminVM. Both are "low priority", but quite important for us. We plan to submit VSA up to the end of this week, but AdminVM is stuck for ~1.5 months without any valuable feedback. The VSA blueprint touches volume service & scheduling and we could try to integrate them better...
21:31:10 <vladimir3p> our VSA code has multiple changes related to scheduling, etc
21:31:26 <vishy> vladimir3p: I thought there was some useful feedback on that proposal
21:31:31 <vladimir3p> will be nice to find the common ground
21:31:51 <creiht> jaypipes: thank you for your undivided attention
21:31:57 <vishy> i think the majority of the feedback was to simplify it to arbitrary network plugging + metadata
21:31:57 <vladimir3p> frankly, have not seen any feedback on VSA yet ...
21:32:08 <jaypipes> creiht: thank you for your undivided sarcasm. ;)
21:32:08 <vishy> maybe I'm thinking of a different proposal
21:32:48 <jaypipes> vishy, vladimir3p: shall I add the AdminVM to thierry's post of important things for reviewers? sounds like I should?
21:33:00 <vishy> jaypipes: yes please
21:33:05 <jaypipes> k, will do.
21:33:17 <vladimir3p> thanks
21:33:21 <jaypipes> no pros.
21:33:27 <jaypipes> no prob even...
21:33:44 <jaypipes> alright, vishy, any other stuff to add to the important list?
21:34:12 <vishy> i think that is good for now
21:34:26 <jaypipes> any more questions for vishy?
21:35:01 <jaypipes> alrighty... thx everyone. same bat-time, same bat-channel next week.
21:35:04 <jaypipes> #endmeeting