19:02:12 <mtaylor> #startmeeting
19:02:13 <openstack> Meeting started Tue Jun 21 19:02:12 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:40 <mtaylor> #topic Meeting Overview
19:02:42 <mtaylor> http://wiki.openstack.org/Meetings/CITeamMeeting
19:02:46 <mtaylor> bah
19:02:51 <mtaylor> #link http://wiki.openstack.org/Meetings/CITeamMeeting
19:02:58 <mtaylor> morning jaypipes
19:03:07 <jaypipes> mtaylor: afternoon :)
19:03:13 <mtaylor> jaypipes: just pasted in http://wiki.openstack.org/Meetings/CITeamMeeting which has today's agenda
19:03:31 <mtaylor> and I figure we can vamp for a moment or two and see who shows up
19:03:34 <jaypipes> mtaylor: I'm casually listening in...
19:04:00 * mtaylor doesn't believe that jaypipes does _anything_ casually
19:04:08 <jaypipes> mtaylor: heh, sure I do :)
19:05:41 <mtaylor> hey dprince
19:05:44 <jaypipes> dprince: afternoon
19:05:44 <dprince> hi
19:05:51 <msinhore> hello all
19:06:02 <mtaylor> hi msinhore
19:06:05 <msinhore> I'm from Brazil from globo.com
19:06:12 <mtaylor> oh sweet! welcome!
19:06:19 <msinhore> we will help with the development
19:06:24 <mtaylor> or should I say bom bia
19:06:26 <mtaylor> or should I say bom dia
19:06:29 <mtaylor> (I can't type)
19:06:40 <msinhore> and this is my first meeting with you all
19:07:00 <mtaylor> happy to have you.
19:07:08 <msinhore> nice, but now is afternoomn :)
19:07:13 <mtaylor> :)
19:07:15 <msinhore> bom dia is good morning
19:07:19 <msinhore> only to ajust it :)
19:07:28 <msinhore> now is boa tarde
19:07:38 <mtaylor> gah. I really need to get my Portuguese up to speed...
19:08:01 <mtaylor> so - with that - let's get this puppy going
19:08:07 <mtaylor> #topic Actions from last meeting
19:08:30 <mtaylor> dprince: any luck with/time to work on a smokestack job for the openstack jenkins?
19:08:46 <dprince> mtaylor: haven't got to it yet.
19:09:04 <mtaylor> cool.
19:09:07 <dprince> mtaylor: on that front I'd like to sync up w/ you offline about the Jenkins box. Who has access. etc.
19:09:18 <mtaylor> cool. happy to chat about that
19:09:47 <msinhore> do you have some stuff now about the dashboard?
19:09:50 <dprince> mtaylor: Actually copying it over is probably easy enough for me but I'd like to have at least a couple people in the know on how it is configured.
19:10:01 <mtaylor> dprince: ++
19:10:02 <dprince> mytaylor: can you skype or chat tomorrow in the AM?
19:10:17 <mtaylor> dprince: I have a dentist appointment at 10am Pacific, other than that, I'm free
19:10:21 <dprince> mtaylor: ^^
19:10:36 <dprince> didn't mean to imply I owned you (mytaylor).
19:10:44 <mtaylor> hehe
19:10:45 <dprince> must of been thinking of me guitar.
19:11:03 <mtaylor> you wanna do 9am PDT?
19:11:24 <dprince> mtaylor: sure.
19:11:52 <mtaylor> cool. done
19:12:03 <mtaylor> I'm gonna put you down again for the same thing
19:12:10 <mtaylor> #action dprince smokestack jenkins job
19:12:17 <mtaylor> just so as that we can keep track of it
19:13:01 <mtaylor> next thing from last time was me getting the pxe booting of the bare hardware integrated with jenkins
19:13:45 <mtaylor> which is also not finished - have been fighting a little bit with some odd ILO systems on the boxes- but we're nearly done with having all of the pxe stuff happy - at which point the jenkins job is a cinch
19:13:46 <mtaylor> SO
19:13:55 <heckj> mtaylor: I missed the last meeting - what are we driving from PXYE with jenkins?
19:13:57 <mtaylor> I should have that done by friday at the latest (going to the datacenter on friday)
19:14:07 <mtaylor> heckj: ah - so...
19:14:28 <mtaylor> we have a set of 10 real machines that we are going to use to test full installs of openstack
19:14:53 <mtaylor> the generalized idea is "reinstall machines - install openstack - run tests"
19:15:06 <mtaylor> and of course, to have that triggered from/integrated with jenkins
19:15:20 <heckj> mtaylor: ah, excellent, thank you
19:16:02 <mtaylor> but - as I did _not_ finish my task from last week - I will re-action myself as well
19:16:18 <mtaylor> #action mtaylor jenkins job for the PXE boot goodness
19:16:56 <mtaylor> and the last thing from last week was that I was going to verify what termie said regarding roundabout triggering jenkins jobs, and yes, he was in fact right
19:17:14 <mtaylor> so that's good to know
19:17:28 <_0x44> What did termie say about roundabout triggering jenkins jobs?
19:17:33 <mtaylor> that it did
19:18:22 <mtaylor> which is lovely, and definitely an improvement over how tarmac does it
19:18:30 <_0x44> Why was that in question? I thought we discused that at the summit?
19:18:39 * _0x44 was unaware of these meetings.
19:18:41 <mtaylor> purely brainfart
19:19:03 <_0x44> Ah ok, was confused :)
19:19:37 <_0x44> I'll pipe down now
19:20:02 <termie> _0x44: you should stay, you can have my spot
19:20:21 <_0x44> termie: I'm sticking around
19:20:28 <mtaylor> so - moving merrily along...
19:20:38 <mtaylor> #topic Addition of rpm/yum building to Jenkins
19:21:17 <mtaylor> we're currently building debs with every push and with releases ... as much as I'd love it if all the world was on debian/ubuntu, that's obviously not the case
19:21:32 <mtaylor> so to be good citizens, we should probalby be making rpms as well, yeah?
19:21:57 <mtaylor> as I understand it, there's somebody with spec files out there somewhere
19:22:17 <heckj> mtaylor: grid dynamics folks have it
19:22:20 <mtaylor> and also the guys from Novell/MSFT Interop Lab (I need a shorter name for that)
19:22:24 <mtaylor> heckj: yes! that's them
19:22:45 <dprince> https://github.com/griddynamics/openstack-rhel
19:22:45 <heckj> mtaylor: They're periodically populating a YUM repo at http://yum.griddynamics.net/
19:22:55 <mtaylor> the NMIL guys were suggesting using the OpenSuSE Build Service in a similar manner to how we use PPAs for debs
19:23:02 <mtaylor> #link https://github.com/griddynamics/openstack-rhel
19:23:07 <mtaylor> #link http://yum.griddynamics.net/
19:23:09 <heckj> looks like they have a jenkins build doing that already
19:23:39 <mtaylor> great. well - I'd like to get that integrated in to our process so that we can produce some that come from a reasonably expected place
19:23:49 <mtaylor> and perhaps make a yum.openstack.org
19:24:23 <mtaylor> unless there are huge amounts of dissent or angst
19:24:45 <heckj> I think it would be an excellent central resource
19:24:54 <mtaylor> sweet
19:25:12 <heckj> maybe fork their repo into openstack/openstack-rhel for the pieces and go from there?
19:25:27 <mtaylor> certainly not a bad idea
19:25:36 <nati> central resource++
19:25:40 <msinhore> nice port the openstack to rpm package.
19:25:59 <mtaylor> #action mtaylor fork griddynamics/openstack-rhel into openstack/openstack-rhel
19:26:11 <msinhore> it will works only with opensuse or with rhel and centos?
19:26:12 <mtaylor> hrm. that should imply actually doing something with it
19:26:14 <mtaylor> oh well
19:26:32 <mtaylor> well... that brings us back to OBS - does anyone have any feelings about the OpenSuSE Build Service?
19:26:54 <heckj> msinhore: from the notes from GridDynamics, I think it's focused on RHEL first, probably CentOS - no idea about OpenSuSE
19:26:55 <mtaylor> I believe we have a person at Novell who is happy to get us set up with a job building rpms for all their distros there
19:28:05 <mtaylor> or - let me re-phrase - is there anyone who would be opposed to having the novell guy get that set up and having our jenkins trigger that as well?
19:28:48 <mtaylor> sweet. everyone is so agreeable!
19:29:07 <heckj> i guess...
19:29:09 <heckj> :-)
19:29:12 <mtaylor> #action talk with Novel/MSFT Interop guys about an OBS build profile run from our jenkins
19:29:13 <nati> I agreed :)
19:29:26 <mtaylor> hrm. I can't type - that should be an action for me ...
19:29:43 <mtaylor> #topic rPath integration
19:30:30 <mtaylor> The fine folks at rPath are building OpenStack images and are internally testing them by driving a cobbler set up to install those images on to bare metal from jenkins
19:31:24 <mtaylor> so we had a chat about putting an rPath builder on our cobbler box and adding a jenkins job to deploy/test against those as well  - which would get us some decent coverage for RH stuff in addition to our ubuntu-based stuff
19:31:29 <heckj> nice - are they aiming to provide openstack virtual appliance images with rPath then?
19:31:33 <mtaylor> yes
19:31:58 <nati> cool
19:32:24 <mtaylor> not really a crapton of action here- just really wanted to get it in people's head that this is available and on the list of stuff we're hoping to test
19:32:34 <heckj> It would be really nice to have a nova-all-in-one and swift-all-in-one preconfigured image for people to play with
19:32:40 <mtaylor> ++
19:33:09 <heckj> who from rPath is doing the work? (i.e. our contact)?
19:33:32 <mtaylor> Mihai
19:33:51 <mtaylor> and I've got a todo list item for this week to chat with him again about coordinating how he can do that work
19:34:27 <msinhore> #topic
19:34:30 <mtaylor> #action mtaylor coordinate with Mihai from rPath to get him what he needs for getting the rPath builder up and going
19:34:56 <mtaylor> one more thing ... then we'll be at open discussion (we're making much better time than last week!)
19:35:05 <mtaylor> #topic Integration of HyperV Lab machines
19:35:45 <mtaylor> in addition to us doing Ubuntu installs and rPath doing rPath installs (and somewhere in there making sure that we test both xen and kvm)
19:36:20 <mtaylor> we've got an offer from the Novel/MSFT guys of a lab of HyperV machines
19:37:17 <mtaylor> so basically the idea is to have them give access to a single machine that can be the jenkins slave - and then on that machine they can put the stuff in place to deploy openstack builds on to their machines and test them
19:38:02 <mtaylor> as I know zilch about deploying/using anything surrounding hyperv, that's going to be squarely on them - but I'm pretty stoked that we can potentially get some builders up and running and making sure stuff works there
19:38:30 <heckj> mtaylor: +1 - the more active testing the better
19:38:32 <johnpur> those guys are really good sysadmins, i know they can do this
19:38:55 <mtaylor> #action mtaylor coordinate HyperV lab builders with Peter Pouliot from Novell/MSFT Interop Lab
19:38:57 <mtaylor> yup.
19:39:21 <mtaylor> I'm sort of hoping they do their deploys with baracus - if for no other reason than that I think it would fun to see that up and running
19:39:26 <mtaylor> but totally their call
19:39:45 <johnpur> are any of those guys in this meeting?
19:39:53 <mtaylor> doesn't seem like it
19:40:00 <mtaylor> primeministerp is Peter
19:40:06 <johnpur> if not, we should ping priministerp and let him know about it
19:40:27 <mtaylor> yeah - we chatted about last week's meeting but he couldn't make it
19:40:53 <mtaylor> and with that...
19:40:57 <mtaylor> #topic Open Discussion
19:41:14 <mtaylor> anybody got anything they want to bring up - and/or punch me in the face about :)
19:41:40 <_0x44> mtaylor: You and termie mentioned at one point in time needing modifications to roundabout, any updates on that?
19:41:51 <_0x44> Maybe s/and termie//...
19:42:21 <mtaylor> _0x44: well, the one we would/might need would be pending discussions with the github folks regarding pull request state
19:42:30 <johnpur> mtaylor: any discussion or volunteers to help test the other hypervisors? particularly the vmware and lxc variants...
19:43:01 <johnpur> it would be cool to have full coverage :)
19:43:20 <heckj> I might have some needs to spin up LXC nodes with nova components in them - not entirely clear yet
19:43:36 <_0x44> mtaylor: That would be firing merges on state transition instead of text lgtm?
19:43:42 <mtaylor> _0x44: although I still want the logic/mechanism that you did for roundabout as a jenkins plugin rather than an external program - but that's sort of a slightly different discussion
19:43:44 <mtaylor> _0x44: yes
19:43:48 <heckj> How do we want to set up for expansion: jenkins slaves running at different locations?
19:44:07 <mtaylor> _0x44: I can't imagine that will be a hard change to make on your side :)
19:44:11 <johnpur> for esx and vsphere maybe we can talk to citrix/ewanmellor...
19:44:38 <mtaylor> johnpur: I havne't heard anything specific from anyone
19:44:45 <mtaylor> heckj: not sure I fully follow the question?
19:45:17 <_0x44> mtaylor: Having more states would actually speed up roundabout considerably (since it currently has to grab all the messages for each pull-request to determine if they're approved)...
19:45:31 <johnpur> mtaylor: maybe an action item?
19:45:35 <mtaylor> _0x44: yes... I think it'll be win all the way around
19:45:55 <mtaylor> johnpur: to reach out to ewanmellor at the least for esx/vsphere?
19:46:06 <heckj> mtaylor: as we add components, distros, other hypervisors with different ways of doing things, are we planning on expanding to have a master jenkins instance and slaves running those various builds/tests?
19:46:19 <mtaylor> heckj: ah. YES
19:46:28 <mtaylor> definitely adding more slaves
19:46:53 <mtaylor> and then where appropriate/where we can adding dynamic cloud-server slaves for parallelism
19:47:16 <mtaylor> obviously - for things like "test deploying this across a bunch of bare metal" we will be limited by actual existence of bare metal
19:47:52 <johnpur> mtaylor: yes. and to solicit help from the community on getting lxc hooked into the CI mesh. might need to add this to the rackspace pile, if no-one else steps up?
19:47:58 <mtaylor> but, as a for instance, soren just set up some chroots to start running unittests in - eventually those can be replaced with cloud servers and we can have more than one go at a time
19:48:04 <mtaylor> johnpur: ++
19:48:22 <mtaylor> #action mtaylor ping ewanmellor about testing esx and vsphere
19:48:34 <mtaylor> #action mtaylor ping community at large about lxc testing
19:49:24 <mtaylor> msinhore: is there anything specific globo.com wants or is looking at in terms of CI and testing?
19:49:57 <mtaylor> msinhore: or, (more importantly to me personally) any specific thing you care about enough that you want to put people working on :)
19:51:33 <johnpur> mtaylor: btw, the reddwarf project at Rackspace is using openvz containers... might be worth a reach out to them regarding openvz/lxc testing.
19:52:06 <mtaylor> ooh. and they're rax too
19:52:22 <mtaylor> #action mtaylor ping reddwarf team about openvx/lxc testing
19:54:31 <mtaylor> anything else from folks?
19:55:07 <heckj> all good here
19:55:12 <mtaylor> great. thanks everybody!
19:55:19 <mtaylor> #endmeeting