21:03:08 <ttx> #startmeeting
21:03:09 <openstack> Meeting started Tue Jun  7 21:03:08 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:19 <ttx> Welcome to the OpenStack team meeting...
21:03:24 <ttx> The agenda for today lives at:
21:03:28 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:03:41 <ttx> #topic Actions from previous meeting
21:03:45 <ttx> * ttx to create webnumbrs for Swift/Glance
21:03:52 <ttx> That was done at:
21:03:58 <ttx> #link http://wiki.openstack.org/releasestatus/swift.html
21:04:01 <ttx> #link http://wiki.openstack.org/releasestatus/glance.html
21:04:09 <ttx> not enough data to make it interesting yet
21:04:34 <ttx> * dabo to make progress towards merging the nova python client library projects
21:04:53 <ttx> dabo: wanna talk about the status ?
21:05:13 <dabo> still in discussion with jacobian about adding committers from OpenStack to his project on GitHub
21:05:26 <jesse_andrews> dabo: what is the general though?
21:05:36 <dabo> he's all for combining
21:05:47 <jesse_andrews> dabo: as for which is the basis?
21:05:56 <ttx> jesse_andrews: his project
21:06:05 <dabo> we thought keeping it external would be a good check on the APIs
21:06:23 <dabo> but allow for OpenStack committers so that he's not a bottleneck
21:06:25 <ttx> dabo: cool
21:06:37 <dabo> he was +1 for that
21:06:49 <jesse_andrews> dabo: cool - our team has been working on making his project exensible (to make it easy to make client api extensions to make server extensions)
21:07:04 <jesse_andrews> to *MATCH* server extensions
21:07:15 <ttx> * mtaylor to set up a "functional testing" meeting to coordinate efforts
21:07:25 <ttx> mtaylor: around ?
21:07:30 <dabo> I only asked for sandy, jk0 and myself to be added. Let me know whatever github names you will also need as committers
21:07:45 <ttx> That was done, meeting will be Tuesdays at 1900 UTC
21:07:46 <devcamcar> dabo: i'd like to be added as well
21:07:57 <bcwaldon> dabo: same here
21:08:10 <dabo> ok - send me your github names and I'll pass 'em along
21:08:21 <ttx> #topic Swift status
21:08:22 <devcamcar> dabo: it's ... wait for it ............ devcamcar
21:08:29 <jk0> dabo: jk0 :)
21:08:30 <devcamcar> :)
21:08:32 <dabo> whoda thunk it?
21:08:33 <ttx> notmyname: hi! Any updated plans for 1.4.1 ?
21:09:04 <notmyname> ttx: no updates yet. We're still working on the same stuff from last week. I hope to have a better idea of date for 1.4.1 by next week
21:09:12 <ttx> ack
21:09:18 <jesse_andrews> we don't need everyone to be added since we can just send pull requests right?
21:09:34 <ttx> We also need to decide in which PPA to put 1.4.0...
21:09:42 <pvo> jesse_andrews: the bottleneck was him incorporating those reqs. iirc.
21:09:46 <devcamcar> jesse_andrews: don't be a code blocker
21:09:47 <notmyname> ttx: indeed
21:09:50 <ttx> I think we need a PPA tracking the last Swift milestone/release, and one PPA tracking the last OpenStack coordinated release
21:10:01 <ttx> For Swift we already have a "Release PPA" with 1.3.0... That means two solutions:
21:10:02 <jesse_andrews> pvo: right - i'm just saying a few added people is good
21:10:13 * pvo nods.
21:10:16 <ttx> 1/ reuse the "Release PPA" for 1.4.0, and create a "OpenStack release PPA" with 1.3.0
21:10:27 <ttx> 2/ create a "Milestone PPA" for 1.4.0 and leave the Release PPA as-is.
21:10:28 <dabo> jesse_andrews: pvo: yeah, as long as one of the stackers can merge into the project
21:10:34 <ttx> notmyname: Any preference ?
21:10:43 <notmyname> ttx: I prefer the first since our milestones are stable releases
21:10:51 <ttx> Right, I think (2) would confuse people around what is a Swift release
21:10:54 <jesse_andrews> dabo: did we setup a launchpad project to pull from the githubs?
21:11:00 <jesse_andrews> dabo: for ppa
21:11:08 <ttx> For (1) we would probably set up a common "OpenStack release PPA" containing all core projects
21:11:16 <dabo> jesse_andrews: not that I know of
21:11:16 <notmyname> yes
21:11:53 <ttx> #action ttx to push update of Swift release PPA to 1.4.0 and creation of a common OpenStack release PPA
21:12:06 <ttx> notmyname: Another question I had -- should we mark the fixed-in-1.4.0 bugs "FixReleased" ? Or wait for the common OpenStack release ?
21:12:22 <notmyname> they should be marked fixed released
21:12:35 <ttx> notmyname: ok, will make that happen, expectr bugnoise.
21:12:55 <ttx> notmyname: Other announcements or comments ?
21:13:04 <notmyname> nothing yet
21:13:06 <ttx> Questions for the Swift team ?
21:13:32 <ttx> jaypipes: around ?
21:13:36 <jaypipes> ttx: yes sir!
21:13:41 <ttx> #topic Glance status
21:13:49 <ttx> jaypipes: hi! So same question for you...
21:13:49 <Vek> (of course he's round, he's a pipe!)
21:13:53 * Vek ducks quickly
21:14:05 <ttx> Do you think we should mark the fixed-in-diablo-1 bugs "FixReleased" ? Or leave them "FixCommitted" until the final release ?
21:14:14 <ttx> For Nova/Glance the latter probably makes more sense...
21:14:37 <jaypipes> bcwaldon and myself had a good chat today splitting up D2 tasks. I'm going to be focusing on auth (keystone integration) and brian's focusing on refactoring the WSGI stuff to pull in some goodies from the latest nova code, plus some XML-ification of the API
21:14:51 <jaypipes> ttx: fix committed is fine for now.
21:15:08 <johnpur> is keystone integration complete in d2 for glance?
21:15:09 <ttx> jaypipes: Plan at https://launchpad.net/glance/+milestone/diablo-2 looks good to me
21:15:18 <jaypipes> I've been working pretty hard on understanding Keystone and have been logging issues like crazy over on github...
21:15:30 <ttx> jaypipes: I assume status is up-to-date, i.e. most things are not started ?
21:15:41 <ttx> (still in investigation phase)
21:15:45 <jaypipes> the spec and API are changing quite rapidly, which makes things challenging, but making progress nonetheless
21:15:52 <jaypipes> ttx: exactly.
21:15:59 <devcamcar> folks on swift team, what is your timeframe for keystone support?
21:16:10 <ttx> jaypipes: Do you agree we should switch to milestone-proposed one day earlier, to give ~2 days for testing/fixes ?
21:16:22 <notmyname> devcamcar: diablo release, I believe
21:16:24 <jaypipes> ttx: expect bcwaldon and me to put some of those bps into a started status tomorrow through friday
21:16:32 <jaypipes> ttx: that's fine, sure
21:16:40 <jesse_andrews> notmyname: is gholt around? he has said he would be able to do a middleware pretty easy
21:16:42 <ttx> That means features for Glance diablo-2 must get merged before EOD June 27... Mark your calendars.
21:16:49 <jesse_andrews> notmyname: that does lazy provisioning
21:16:58 <jaypipes> ttx: yes, that is correct
21:17:02 <devcamcar> notmyname: know which milestone by chance? its a dependency for swift support in dashboard
21:17:17 <notmyname> devcamcar: jesse_andrews: I'll check with gholt
21:17:26 <devcamcar> thx
21:17:30 <jaypipes> ttx: that's it from me.
21:17:40 <jesse_andrews> devcamcar: at the summit gholt thought it should just take less than a day to knock it out, since it is very similar to what already exists
21:17:48 <ttx> Any question about Glance ?
21:18:02 <jesse_andrews> jaypipes: the thought by D2 to have private image support?
21:18:06 <ttx> jesse_andrews: was that before or after beer oclock ?
21:18:11 <jesse_andrews> ttx: before
21:18:42 <jaypipes> jesse_andrews: no. I pushed the shared-image-groups blueprint out to D3 because I've had to spend a lot of time logging issues in Keystone and weriting unit tests... taking longer than I'd planned.
21:18:53 <jaypipes> jesse_andrews: but I think very doable for D3.
21:19:13 <ttx> other Glance questions before we move on to Nova ?
21:19:27 <jaypipes> jesse_andrews: to be clear: authn and basic integration with keystone will be done in D2. but not the shared-image-groups middleware/extension piece.
21:19:40 <jesse_andrews> jaypipes: cooleo
21:20:04 <ttx> #topic Nova status
21:20:35 <ttx> unless vishy makes a surprise entry, I'll talk for him
21:20:53 <johnpur> vishy is turining japanese!
21:21:00 <ttx> The plan is also to branch Nova milestone-proposed 2+ days before release, so features for Nova diablo-2 should land before the end of Monday, June 27.
21:21:07 <pvo> johnpur: you really think so?
21:21:09 <pvo> ;p
21:21:20 <ttx> I've been busy sanitizing the diablo-2 plan, trying to see what should be reasonably done by then, and checking out assignees
21:21:34 <ttx> A bit scary with like 27 blueprints targeted
21:21:40 <ttx> See plan @ https://launchpad.net/nova/+milestone/diablo-2
21:21:50 <ttx> I'm still missing some input, the plan should be finalized in the next days.
21:22:04 <jaypipes> ttx: markwash told me he'd pick up 10 or 12 blueprints.
21:22:07 <ttx> If you're assigned something on this plan and you know you won't deliver by June 27, please let me or vishy know.
21:22:12 * jaypipes runs and hides...
21:22:40 <pvo> ttx: I'll make sure I get our plans to you soon.
21:22:42 <ttx> Questions ?
21:22:51 <jesse_andrews> ttx: my assumption was the "low" ones were icing on the cake
21:23:30 <ttx> jesse_andrews: yes -- we could actually keep them untargeted and target them retrospectively when they land
21:23:48 <tr3buchet> seems cleaner that way
21:24:12 <jesse_andrews> pvo / ozone folks - how risky is multi-nic landing?
21:24:20 <ttx> jesse_andrews: I'll give that a thought. They were originally targeted by Vish, will talk to him
21:24:36 <pvo> jesse_andrews: I know the tests are being cleaned up now.
21:24:43 <jesse_andrews> pvo: nice :)
21:24:47 <tr3buchet> jesse_andrews: as to multi-nic it depends on review respoonse
21:25:03 <ttx> #action ttx to consider untargeting/retrotarget Low specs to decrease noise
21:26:18 <ttx> also, congrats to nova-core for decreasing the review queue to 12 open reviews
21:26:31 <ttx> anything else on Nova ?
21:26:53 <ttx> ah! down to 10 now.
21:27:06 <annegentle> wow, nice job team
21:27:07 <tr3buchet> which means i surely need to merge trunk again
21:27:11 <tr3buchet> ;)
21:27:15 <devcamcar> hah, yea
21:27:19 <jaypipes> hehe
21:27:25 <ttx> #topic Doc status
21:27:32 <ttx> annegentle: floor is yours.
21:27:35 <annegentle> Thanks. We held our first doc/web meeting last night, and went through goals for the meeting and team.
21:27:44 <annegentle> I have a fresh perspective on and respect for the talents inherent in running meetings on IRC. :)
21:27:50 <annegentle> A couple of items of interest to the larger team:
21:27:55 <ttx> heh
21:28:21 <annegentle> toddmorey is working on tracking website bugs and issues through Launchpad, so we'll create an openstack-website project so you can log bugs against http://openstack.org. ttx, Todd'll probably get in touch with you for assistance if needed.
21:28:32 <johnpur> annegentle: no doubt you are awesome!
21:28:39 <annegentle> toddmorey has also implemented the site in Silverstripe which should enable more contributors
21:28:48 <ttx> annegentle: coolio
21:28:53 <annegentle> The http://docs.openstack.org site now includes selected blog entries from kpepple, thanks to Ken releasing those with Creative Commons licensing.
21:29:08 <annegentle> It's an experiment in collaborative docs where I'm contacting authors with CC-licensed content to see if they want to put their content on http://docs.openstack.org.
21:29:21 <annegentle> The next set of CC-licensed contributions are from CSS Corp Open Source Services, hoping to get those in next week.
21:30:08 <annegentle> Lastly, doc builds are now happening automatically when merge props are reviewed/accepted.
21:30:38 <jkoelker> inetrY6o
21:30:40 <annegentle> I'll probably move the time to North America daytime, but we'll continue to meet monthly.
21:31:01 <ttx> annegentle: ok
21:31:06 <annegentle> Any doc/website questions?
21:31:09 <bcwaldon> jkoelker: it showed up as all *'s to me
21:31:25 <tr3buchet> :)
21:31:32 <jkoelker> rigggghhht
21:31:40 <jkoelker> focus follows mouse is bad
21:31:56 <Vek> now there's a religious war!
21:32:01 * tr3buchet puts on his wizard hat and robe
21:32:01 <ttx> annegentle: apparently not. Thanks for that update
21:32:20 <ttx> #topic Open discussion
21:32:26 <johnpur> jkoelker: lol, no-one can access all your bank accounts now!
21:32:35 <spectorclan_> Design Summit (looking like Oct 3-5) & Conference (looking like Oct 6-7) ; both events (marketed separately at Boston Sheraton Hotel next to Hynes Convention Center. Contracts not signed but in review
21:32:48 <ttx> johnpur: especially since he uses SecurID
21:33:14 <johnpur> spectorclan: how firm is this location?
21:33:19 <carlp> quick question: is that 1900UTC meeting on Tuesdays for the larger distributed automated testing environment using jenkins?
21:33:20 <ttx> spectorclan: oh, that's very new
21:33:38 <spectorclan_> Pretty firm - not many places available and this is a popular spot; hotel was just redone and great location
21:34:02 <Vek> and right on the green line
21:34:21 <notmyname> devcamcar: jesse_andrews: https://github.com/rackspace/keystone/blob/master/docs/swift-quick-start.txt
21:34:24 * ttx looks it up
21:34:35 <notmyname> see the bottom of that page for keystone/swift integration notes
21:34:40 <johnpur> spectorclan: can we open the floor to suggestions about 'e' names for the next release?
21:34:41 <eday> spectorclan_: are those dates+boston firm for sure? (even if hotel changes)
21:34:47 <jesse_andrews> notmyname: NICE
21:34:50 <spectorclan_> Yes, dates are firm
21:34:55 <notmyname> jesse_andrews: all gholt :-)
21:35:05 <spectorclan_> ttx: those are the dates you gave me, correct?
21:35:06 <jesse_andrews> go gholt, it is your birthday!
21:35:19 * ttx doublechecks
21:35:29 <devcamcar> notmyname, gholt: word
21:35:56 <ttx> spectorclan: yes!
21:36:26 <ttx> johnpur: let's keep that for the next meeting
21:36:40 <spectorclan_> Any questions on the CLA process I started today?
21:36:47 <ttx> though suggestions are ok :)
21:37:07 <johnpur> ttx: ok, i am just excited about what the next name will be!
21:37:21 <notmyname> ttx: johnpur: https://secure.wikimedia.org/wikipedia/en/wiki/List_of_cities_in_Texas#E
21:37:28 <eday> http://massachusetts.hometownlocator.com/cities/listcitiesalpha,alpha,e.cfm  if we want a 'E' name near boston :)
21:37:37 <creiht> Evil
21:37:40 <johnpur> spectorclan: the cla process looks good to me.
21:37:41 <spectorclan_> ttx: I thought E comes from Massachusetts and not Texas?
21:37:52 <ttx> notmyname: we need to pik somewhere in MA, preferably in Boston area
21:38:04 <carlp> All I can think of is Easton
21:38:18 <Vek> everett?  (doubt I have the right spelling)
21:38:31 <johnpur> i bet we have a lot of folks in the NE that can help with naming!
21:38:38 <jesse_andrews> Edgeworth
21:38:49 <spectorclan_> Essex
21:38:49 <Vek> there's one I never heard of.
21:39:15 <johnpur> primeministerp: around?
21:39:28 <spectorclan_> There is a Mount Everett
21:39:36 <pvo> heh. Egypt.
21:39:39 <ttx> "Everett"
21:40:00 <spectorclan_> Eagle Hill River
21:40:13 <creiht> of course if we use the Texas form of the word close, you could include several states in the search :)
21:40:20 <ttx> spectorclan: multiple words are not ok
21:40:24 <Vek> haha :)
21:40:24 <alandman> johnpur: primeminsterp's not around
21:40:24 <johnpur> ttx: as a Seattle native... Everett is west coast
21:40:40 <ttx> johnpur: http://en.wikipedia.org/wiki/Everett,_Massachusetts
21:40:44 <ttx> not that one ^
21:41:01 <ttx> Can be a city or a county
21:41:11 <ttx> see http://wiki.openstack.org/ReleaseNaming
21:41:13 <johnpur> alandman: have opinion on 'e' names close to Boston?
21:41:47 <ttx> MA is small, that won't leave so many options
21:41:54 <spectorclan_> Essex is the only county
21:42:00 <ttx> spectorclan: yep
21:42:35 <notmyname> Eliot is a Boston suburb
21:43:02 <ttx> that could work.
21:43:03 <alandman> notmyname: Where is Eliot
21:43:11 <creiht> There is an Eden, Vermont
21:43:13 <notmyname> alandman: http://massachusetts.hometownlocator.com/ma/middlesex/eliot.cfm
21:43:21 <notmyname> creiht: and eden texas :-)
21:43:27 <creiht> indeed
21:44:06 <Vek> hmmm...
21:44:12 <tr3buchet> Edinburgh, UK
21:44:13 <alandman> notmyname: Noone I know that lives here would ever use that name for that area
21:44:34 <Vek> Eastham, Easthampton, Easton, Edgartown, Egremont, Erving, Essex, and Everett are all the single-word E names for Massachusetts.
21:44:39 <notmyname> alandman: "suburb of Boston"? just looks close on the map to me
21:45:00 <Vek> (municipality names)
21:45:08 <alandman> notmyname: People would call that area Netwon, from the town
21:45:43 <ttx> feel free to edit the wiki with your preferred candidates
21:45:45 <Vek> there used to be an Enfield, MA...
21:45:50 <ttx> #endmeeting