02:01:30 <annegentle> #startmeeting
02:01:31 <openstack> Meeting started Tue Jun  7 02:01:30 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
02:01:47 <annegentle> #Goal-setting for this meeting
02:02:45 <annegentle> I basically wanted to get doc/web aficionados together regularly to talk about what's going on with docs and the website
02:03:21 <annegentle> especially now that we're looking for ways to open up the openstack.org site for more people to work on it
02:03:36 <annegentle> I think it's good to review doc bugs, too.
02:03:43 <annegentle> Plus, try to coordinate doc tasks.
02:04:02 <spectorclan_> annegentle: can you clarify your open up the openstack.org site for others to work on
02:04:03 <annegentle> Any other goals you want to bring up? Have for this meeting? I'm open to suggestions and agenda items
02:04:34 <kd9261> I think it would be beneficial to standardize a layout for tutorial wiki pages. i.e. installation guides
02:04:34 <annegentle> sure, toddmorey has been working on ways to get a core group of reviewers for the openstack.org site just like we do code reviews
02:05:01 <spectorclan_> annegentle: that makes sense, ok. had not heard that before
02:05:29 <annegentle> kd9261: honestly, I think my hope is to consolidate installation information to just a few pages
02:06:08 <annegentle> kd9261: I like wiki templates and all, but MoinMoin (our wiki engine) just isn't robust enough for end-user docs really, it's better suited for project docs
02:06:08 <kd9261> annegentle: That's a good idea, there are just some specifics b/w different distributions/OS
02:06:52 <annegentle> kd9261: yes, I'd love to start a separate installation guide in fact in DocBook in the openstack-manuals project, but possibly the instructions are quite ready for that? Any thoughts?
02:07:31 <annegentle> kd9261: I appreciate the wiki edits if you're the one who worked on 'em today by the way :)
02:08:00 <annegentle> Vish asked me to consolidate install information this release, so it's certainly a good doc task
02:08:06 <kd9261> annegentle: I am a strong believer of readbility. Especially when new Open Stack users come along (I am one)
02:08:08 <j1mc> annegentle: did you mean that the installation instructions "aren't" quite ready for that?
02:08:32 <annegentle> j1mc: more like, are the installations on distros equivalent yet?
02:08:49 <annegentle> j1mc: oh yes, "are/aren't" thanks :)
02:08:51 <j1mc> ah, ok - thanks for clarifying
02:09:18 <kd9261> annegentle: From my [little] experience, they are different enough to justify having separate pages, the landing page is very clear though
02:09:29 <annegentle> one additional goal for this meeting is to get input on doc priorities
02:09:43 <annegentle> kd9261: ok, good to know
02:09:53 <annegentle> kd9261: and I think your instinct is correct
02:10:43 <annegentle> I think for installation instructions for each distribution, we need a pre-req of a nice page for downloads. Todd and I have talked about this being on openstack.org, any thoughts?
02:11:14 <annegentle> we like this as a model, anyone else have good examples? http://www.postgresql.org/download/
02:11:28 <spectorclan_> So, have a listing of distros on the product download page which has different instructions?
02:12:00 <annegentle> spectorclan_: yes, or at least installation instructions can consistently point to the correct place
02:12:16 <spectorclan_> ok, just saw the link. It makes sense and works easily. I like very much
02:12:16 <annegentle> need to redo the topic, hang on
02:12:20 * j1mc looks at a couple of 'installation doc' examples that come to mind...
02:12:24 <annegentle> #topic Goal-setting for this meeting
02:12:47 <kd9261> something like this is very appealing: http://www.ubuntu.com/download
02:13:03 <kd9261> the postgres is more "professional" looking
02:13:23 <spectorclan_> kd9261: I think it just depends on the look/feel of the existing site
02:13:46 <kd9261> #agree
02:13:49 <annegentle> kd9261: yeah, to me, ubuntu appeals to any end-user, we need to appeal to cloud/server admins
02:14:20 <deshantm> annegentle: agree that audience matters, I was just going to make a similar comment
02:14:21 <annegentle> spectorclan_: true, we already have an established look and feel to openstack.org. Right now our "downloads" are somewhat hosted on the wiki. Should they stay there?
02:14:40 <spectorclan_> No, they need to move to openstack.org; I agree with your thinking
02:14:47 <annegentle> kd9261: but simple is good too :)
02:15:00 <toddmorey> the problems occur when instructions 'branch' to account for variances across installs. So it's good to have some sort of tool to get your target platform, etc, so that the instructions / links can be very clear and very specific
02:15:00 <medberry> I see no dependencies on the Postgresql page. Is that your intent.
02:15:03 <j1mc> http://docs.fedoraproject.org/en-US/Fedora/14/html/Installation_Guide/
02:15:21 <kd9261> medberry: those should be in the specific distro page
02:15:53 <j1mc> annegentle: i know that the ubuntu folks are also working on ensemble and cloud documentation. it is in the early stages, but it might be worthwhile to see where you can work together around infrastructure or general topics.,
02:15:54 <alandman> I think there needs to be something more clearly organized then the wiki since finding the content on it can be far from easy
02:15:57 <annegentle> medberry: ah good point, but yeah they change based on OS, right?
02:16:10 <medberry> annegentle, kd9261: nod.
02:16:29 <spectorclan_> annegentle: I assume we mean the released versions and not daily production? Relased go on main site and daily development off wiki
02:16:45 <annegentle> j1mc: ok, I'll reach out, Jim Campbell was at the Open Help conference with me this weekend and we talked some about Ubuntu's server doc - they do like our webhelp output example
02:17:09 <annegentle> spectorclan_: yes, released, tested, from 3rd party sources, that sort of category
02:17:37 <spectorclan_> 3rd party? Hmm, would we then post a release from StackOps?
02:17:38 <j1mc> yes! the lead of the server group liked it a lot! kudos to the anne and the others (??) who worked on getting the current openstack docs set up.
02:17:48 <annegentle> j1mc: yes that's a great install guide, guess it might be time to separate out to a new install guide
02:18:03 <annegentle> j1mc: awesome, thanks to toddmorey and dcramer_
02:18:27 <annegentle> ok, I think we're okay with goal-setting, on to next (thanks for the input on install as well)
02:18:43 <j1mc> annegentle: that fedora docs setup is done in docbook, and it all output through fedora/redhat's publican
02:18:45 <annegentle> oh and should I do some actions for install doc and download page? Anyone?
02:19:05 <annegentle> j1mc: yes I learned a bit about publican this weekend at Open Help as well :)
02:19:53 <annegentle> #topic General documentation status - RST on each project
02:20:12 <kd9261> annegentle: I have 3 months to dedicate to wiki install doc editing
02:20:48 <kd9261> my group is very active on an Open Stack trunk
02:20:53 <annegentle> kd9261: you hooked on wiki? :) Can we talk more about an install book in docbook or you like wiki better?
02:21:16 <kd9261> annegentle: I am not up to speed on terminlogy, sorry
02:21:39 <annegentle> kd9261: ok, no worries :)
02:21:45 <kd9261> I like the install book a lot, however it would have to gaurantuee complete accuracy otherwise lessons learned by one user don't propogate as well
02:21:46 <annegentle> #link http://wiki.openstack.org/Documentation/HowTo
02:21:55 <annegentle> that page describes the areas where doc lives, wiki is just a small part
02:22:19 <annegentle> accuracy is a huge part of Vish's request, answering the same questions over and over is no fun
02:22:41 <annegentle> so I completely agree
02:23:17 <annegentle> So the swift.openstack.org site is built from RST housed in the Swift source code, and it was updated with their 1.4 release
02:23:42 <annegentle> Other than the swift RST docs, that is the only activity so to speak that I know of.
02:24:05 <kd9261> annegentle: from a new user perspective, it is nice to have lots of documentation but confusing when it is duplicated in multiple places
02:24:26 <kd9261> its unclear which is most accurate, despite that install book looks much mre polished
02:24:29 <annegentle> kd9261: agreed.
02:24:54 <annegentle> kd9261: the install docs are the top priority there
02:25:02 <annegentle> kd9261: as far as removing duplicates
02:25:35 <annegentle> ideally, the RST pages host the dev information and the automated doc from doc strings, the "polished" guides are built from docbook in the lp:openstack-manuals project
02:25:59 <annegentle> kd9261: so that gives the high-level overview of what goes where and also hints at why duplication occurs - both audiences need to know some information
02:26:35 <deshantm> it's an audience thing again. devs vs. sysadmins right?
02:26:42 <annegentle> #topic General documentation status - DocBook docs in openstack-manuals project
02:27:18 <kd9261> annegentle: agreed. Being a new developer and user I can appreciate both views. Development hinges on being able to successful install first.
02:27:21 <annegentle> deshantm: yes, and it's further segmented as Python devs should be the audience for RST sites, web devs using the APIs are also audience for docbook
02:27:59 <annegentle> kd9261: yes, absolutely. I find the sysadmins can install no problem but configuration confounds them.
02:28:50 <annegentle> The status of the DocBook docs - I have merged all requests in and I busily update it about daily.
02:28:53 <kd9261> annegentle: this is exactly the case.
02:28:58 <deshantm> kd9261: agreed.. there is actually a different problem with some of the XenServer docs in that dev docs exists, but the story for sysadmins is not that good yet
02:29:24 <annegentle> I'm working on incorporating CC licensed content in the DocBook content from bloggers whom I've contacted, such as kpepple
02:29:26 * deshantm is working to fix that one
02:30:44 <annegentle> I learned alot about DocBook and translations over this past weekend and would also like to take steps towards doc translations (though maybe organizing the English base is a higher priority)
02:30:53 <kd9261> There is very little in the way of Dashboard as well. I am working alongside a colleague who has come to this realization
02:31:31 <annegentle> there are maybe 3 code branches in the lp:openstack-manuals project that have no merge request, but I've talked with all the authors to get the status.
02:31:46 <j1mc> annegentle: I just emailed you the contact info for the Ubuntu translations coordinator in case it might be helpful.
02:31:54 <annegentle> j1mc: thanks a bunch :)
02:32:22 <annegentle> today I added a short chapter about hypervisors
02:33:01 <annegentle> and we now have automated builds that automatically copy the trunk docs to docs.openstack.org/trunk, but there is no landing page with CSS yet
02:33:15 <annegentle> #link http://docs.openstack.org/trunk/
02:33:34 <annegentle> (yep, ugly, but automated is good)
02:33:53 <kd9261> #agreed
02:34:18 <annegentle> I'll work on the CSS this week, should it just be a simple listing, or should I add a "trunk" option to the docs.openstack.org page?
02:34:40 <toddmorey> that's what I was wondering...
02:35:09 <deshantm> maybe better to have the trunk look different
02:35:17 <toddmorey> Maybe on docs.openstack, but visually separated just a bit
02:35:34 <toddmorey> and below the other options, I would think
02:35:35 <deshantm> so that users don't think it is official by mistake when it is still in progress
02:35:48 <annegentle> also, the automated builds do not activate comments, my ideal is to keep comments with a release and have people log bugs against trunk rather than commenting
02:35:57 <annegentle> deshantm: good point
02:35:58 <spectorclan_> would a user really want to see the trunk docs version?
02:36:04 <toddmorey> I like the idea of some sort of "trunk" banner at the top of those pages… just in case you stumble into one via google search
02:36:25 <deshantm> spectorclan_: OpenStack users probably will
02:36:35 <annegentle> spectorclan_: I think so, one example of a Diablo thing you can do that you can't do in Cactus (silly example) is that you can get the version number easily
02:36:43 <toddmorey> shoot, we could even tell google not to spider trunk… not sure how people feel about that
02:36:51 <deshantm> annegentle: agree with that
02:36:59 <spectorclan_> ok, just checking. As long as we clarify what each section is, we should be fine
02:37:05 <annegentle> spectorclan_: but for the most part, it's best for people to read the Cactus docs as they are still being constantly updated as if they are trunk
02:37:12 <dcramer_> We've added support for a banner to the webhelp format recently.
02:37:15 <annegentle> deshantm: yes I like the idea of a banner
02:37:59 <annegentle> #link http://docs.openstack.org/cactus/openstack-compute/developer/openstack-compute-api-1.1/content/index.html
02:38:13 <annegentle> shows the - DRAFT - banner on the API 1.1 document
02:38:35 <spectorclan_> cool
02:38:43 <annegentle> toddmorey: I like telling Google not to search trunk, it only adds to the "duplication" I scream in my head :)
02:39:27 <annegentle> oh one other status update for the lp:openstack-manuals project, we can now get Site Search analytics and the top search within the docs.openstack.org site is... wait for it...
02:39:29 <annegentle> billing!
02:39:49 <deshantm> annegentle re: Google ...yeah, clouds, you can't trust them ;)
02:39:58 <annegentle> deshantm: hee
02:40:15 <toddmorey> billing?
02:40:27 <j1mc> annegentle: neat idea in telling google to not search trunk
02:40:51 <annegentle> my guess is, they want to know if you get plug-n-play billing when you get OpenStack running
02:40:58 <deshantm> toddmorey: yeah, service providers just want to make money off of our work :)
02:41:13 <spectorclan_> hey stop being a socialist Todd, Money makes the world go around!
02:41:20 <spectorclan_> :)
02:41:34 <toddmorey> ah… yes indeed. and here I thought altruism powered the world
02:41:35 <annegentle> soon, I hope we'll also be tracking searches on individual books though none have come through the system yet so we probably need to troubleshoot that
02:42:00 <annegentle> toddmorey: do you mind talking some about the openstack.org project's status?
02:42:12 <annegentle> #topic General status for openstack.org project
02:42:15 <toddmorey> I get it now. I was thinking from a user perspective, and wondering who had CC statements with OpenStack, LCC on them. :)
02:42:30 <toddmorey> Sure thing!
02:42:42 <annegentle> toddmorey: heh, right. This is the words being input on docs.openstack.org in the Google Custom Search Engine
02:42:48 <annegentle> thanks
02:43:34 <toddmorey> We recently launched an update to openstack.org that brought the site into a CMS. The idea was to prepare it for having more folks collaborate on the project. I'm documenting how to get involved with that piece as we speak.
02:44:20 <deshantm> toddmorey: which CMS did you guys go with?
02:44:25 <toddmorey> First priority is setting up a launchpad project for the website. The big beni there is having a place to track bugs / issues.
02:44:59 <spectorclan_> does this replace the existing launchpad tracking?
02:45:11 <toddmorey> The CMS is called Silverstripe. It's an open source PHP framework… the closest thing in PHP to django.
02:45:56 <toddmorey> The site now has versioned content and consumes other data via RSS or JSON, depending on the source
02:46:49 <toddmorey> that's how we pull things like the latest commits from launchpad or photos from flickr. If anyone has more ideas for data sources, I'd love to start adding more. General theme is hilighting the activity of the community.
02:47:44 <spectorclan_> we need to bring in slideshare as well as vimeo - people love videos
02:48:03 <toddmorey> spectorclan_: I mean a project to show up here: https://bugs.launchpad.net/openstack/+filebug
02:48:40 <j1mc> toddmorey: intersting. i'd certainly like to know when you get the documentation in place. where is the documentation at now? is it available somewhere?
02:49:07 <annegentle> #link http://wiki.openstack.org/Website
02:49:37 <toddmorey> j1mc: it will be in the wiki. Anne's got the right place, I have a lot more to add that I've written. I just wanted to proofread it first. :)
02:49:48 <spectorclan_> toddmorey: sorry, still confused. Are you saying we need a documentation bug project on the Project list?
02:50:56 <toddmorey> no, sorry… I mean the website itself should be a (minor) openstack project, the way manuals currently is. Make sense?
02:50:57 <annegentle> I'm thinking more like we need a project for openstack-web (or something) so bugs can be listed like https://bugs.launchpad.net/openstack-manuals
02:51:09 <spectorclan_> toddmorey: yep, get it
02:51:11 <toddmorey> what Anne said. :)
02:51:59 <toddmorey> bugs and to have ammo for these meetings to prioritize the next projects for the site
02:52:13 <deshantm> oh i found a bug the participating companies is different on the home page and community page
02:52:22 * j1mc nods
02:52:24 <deshantm> 76 vs. 65
02:52:28 <toddmorey> for example, one of the big priorities in my mind is listing all the openstack projects on the site, not just the core ones. That's one thing I'm working on now.
02:52:30 <annegentle> deshantm: good catch
02:53:04 <spectorclan_> deshantm:  we add about 2 or 3 partners a day - very busy getting legal processing completed;
02:53:12 <toddmorey> that is a good catch. I only made one auto-update. I need to fix the other so it increments, too.
02:53:35 <spectorclan_> deshantm: also working with Todd on idea for a Solution Search Catalog instead of just a partner listing
02:53:38 <j1mc> i'm afraid that i'm a bit on the sleepy side for now. if the meeting minutes / log will be posted somewhere, i will be sure to read through them, though.
02:53:52 <annegentle> ok, do we name the project openstack-web, openstack-website?
02:54:05 <spectorclan_> openstack-website sounds better to me
02:54:07 <deshantm> better do website
02:54:07 <annegentle> j1mc: yeah we'll put the notes up
02:54:20 <deshantm> web might be a admin panel someone write
02:54:31 <annegentle> true, who knows it might be taken
02:54:59 <toddmorey> openstack-website: very clear
02:55:04 <annegentle> #action toddmorey and annegentle to work with ttx on making openstack-website project
02:55:09 <j1mc> thanks... it sounds like you're off to a good start. i'll catch up with you all later.
02:55:16 <annegentle> j1mc: thanks Jim
02:55:22 <toddmorey> thanks, j1mc!
02:55:29 <j1mc> yw :)  good night!
02:55:32 <annegentle> ok, last topic, bugs
02:55:33 <spectorclan_> toddmorey: we need to put translations onto our long term list so we can have multiple languages
02:55:51 <annegentle> #topic Doc bugs
02:56:03 <annegentle> For example, see https://bugs.launchpad.net/nova/+bugs?field.tag=documentation
02:56:08 <toddmorey> spectorclan_: translation support is ready when we are!
02:56:23 <annegentle> We are currently tracking doc bugs per project and also within the lp:openstack-manuals project
02:56:28 <spectorclan_> toddmorey: ok, let's talk offline as I have people ready to help us now
02:56:45 <annegentle> The bug lists are managed by ttx and myself mostly, we move them between projects as needed also
02:57:28 <annegentle> Bugs are a great starting point for trying out your DocBook and RST skills, and learning the project landscapes as well.
02:57:40 * annegentle sells people on starting with doc bugs when just getting going!
02:57:59 <annegentle> and I will wrap up in 3 minutes, with the last topic
02:58:04 <annegentle> #topic Open discussion
02:58:27 <toddmorey> annegentle: good sell!
02:58:29 <medberry> tx annegentle
02:58:36 <spectorclan_> awesome!
02:58:38 <medberry> thanks all.
02:58:41 <annegentle> medberry: thanks for the comments on the doc site, keep 'em coming :)
02:58:43 <deshantm> annegentle: is there RSS subcribe for bugs?
02:59:10 <annegentle> deshantm: hm, good question, there's a link on the page to subscribe by email but dunno about RSS
02:59:25 <annegentle> #action annegentle to ask ttx about RSS and subscribing to doc bug feeds
02:59:48 <spectorclan_> i only see bug email
03:00:00 <deshantm> I have a lot of emails that I filter so I might miss the bugs in email
03:00:27 <deshantm> I would rather have a way to make sure I get all xen-related documentation things
03:00:27 <annegentle> deshantm: yeah and I'm realizing I'd like to flag doc bugs in my email so it's a good question
03:00:50 <deshantm> I follow the XenServer wiki page via email, so that is OK
03:01:16 <medberry> you can probably use a 3rd party RSS-izer...
03:01:16 <deshantm> but I don't like launchpad bug mail since it tends to be noisy and hard to filter
03:01:26 <annegentle> OK, good. Well thanks everyone for coming.
03:01:50 <toddmorey> thanks, annegentle! this is a good step forward.
03:01:53 <annegentle> I'll post notes to the wiki page linked from http://wiki.openstack.org/Meetings/DocTeamMeeting
03:01:56 <spectorclan_> exit
03:01:58 <spectorclan_> oops
03:01:58 <annegentle> #endmeeting