21:02:11 <ttx> #startmeeting
21:02:12 <openstack> Meeting started Tue May 31 21:02:11 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:22 <ttx> Welcome to our weekly OpenStack team meeting...
21:02:32 <ttx> New URL for the agenda, due to proliferation of meetings:
21:02:37 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:02:45 <sandywalsh> o/
21:02:48 <devcamcar> o/
21:02:52 <ttx> #topic Actions from previous meeting
21:03:02 <ttx> * ttx to create webnumbrs for all core projects: NOT DONE
21:03:10 <ttx> Been a bit busy setting up the milestone release process, so deferred
21:03:19 <ttx> #action ttx to create webnumbrs for Swift/Glance
21:03:31 <ttx> * dabo to bridge the gap with jacobian and work towards a common client
21:03:31 <jaypipes> o/
21:03:37 <ttx> jaypipes: welcome !
21:03:44 <jaypipes> heya
21:03:49 <ttx> dabo: I saw the email for this, and Jacob just answered very positively.
21:04:31 <ttx> dabo: I suspect you'll answer and progress towards merging the two projects ?
21:04:43 <ttx> * jaypipes to confirm the nobottle unblocking
21:05:30 <ttx> jaypipes: did you confirm that mysteriously-named action ?
21:05:33 <jaypipes> ttx: that is done.
21:05:39 <ttx> * jaypipes to create removal of local image service blueprint
21:05:57 * vishy grabs a bottle to help unblock...
21:06:34 <ttx> jaypipes: still TODO ?
21:07:04 <jaypipes> ttx: hmm, I *thought* I made a bug report about that... still looking for it.
21:07:14 <ttx> #action dabo to make progress towards merging the nova python client library projects
21:07:32 <dabo> ttx: I'll follow up with him
21:07:36 <ttx> dabo: cool
21:07:47 <ttx> let's move on
21:07:53 <ttx> #topic General release status
21:08:04 <ttx> Soren and I worked on the milestone release process...
21:08:16 <dabo> ttx: wait - you got a response? I didn't see it
21:08:17 <ttx> in particular the Jenkins automation around release branches ("milestone-proposed")
21:08:25 <ttx> dabo: verry recent.
21:08:28 <dabo> ah
21:08:31 <jaypipes> ttx: https://bugs.launchpad.net/nova/+bug/723947 dprince marked it Invalid.
21:08:32 <uvirtbot> Launchpad bug 723947 in nova "Remove the local image service (nova/image/local.py)" [Undecided,Invalid]
21:09:28 <ttx> jaypipes: it was not valid by that time but becomes more valid now.
21:09:38 <ttx> jaypipes: feel free to reopen it rather than make your own
21:09:44 <jaypipes> ttx: k
21:09:52 <ttx> This automation was applied to Swift and will be applied to Nova/Glance tomorrow.
21:10:00 <ttx> #topic Swift status
21:10:09 <notmyname> 1.4.0 released today
21:10:15 <ttx> #link https://launchpad.net/swift/diablo/1.4.0
21:10:25 <ttx> There are also Ubuntu packages here:
21:10:33 <ttx> #link https://launchpad.net/~swift-core/+archive/milestone-proposed
21:10:44 <ttx> We'll set up a specific "last milestone" PPA soon to hold pure "1.4.0" packages.
21:10:57 <ttx> notmyname: how is 1.4.1 looking so far ? Any feature planned, or proposed date ?
21:11:16 <notmyname> no date yet. I hope to have one soon (within a week or so)
21:11:27 <ttx> cool.
21:11:33 <ttx> notmyname: Other announcements or comments ?
21:11:36 <notmyname> as for new features, I'm currently working on the existing blueprints
21:11:47 <notmyname> swauth and stats/logging stuff will be removed
21:11:55 <notmyname> to their own respective projects
21:12:20 <ttx> notmyname: will there be doc pointers in core swift to find them ?
21:12:31 <notmyname> I certainly hope so :-)
21:12:35 <ttx> ok :)
21:12:44 <ttx> Questions for the Swift team ?
21:12:59 <notmyname> I know there will be other things in 1.4.1, but I don't have anything else targeted yet
21:13:24 <devcamcar> notmyname: what is timeframe for removing swauth/keystone support?
21:13:47 <notmyname> the goal is to not have an auth system in swift
21:14:05 <notmyname> swauth will be removed in 1.4.1 (likely in about 6 weeks)
21:14:14 * ttx likes negative goals
21:14:14 <devcamcar> notmyname: excellent, thanks
21:14:32 <ttx> no other question ? moving on then
21:14:33 <notmyname> I don't know if keystone will be in 1.4.1
21:14:38 <notmyname> that is,
21:14:45 <notmyname> it won't be part of the project
21:14:55 <notmyname> but I don't know if pointers, etc will be there
21:15:02 <notmyname> (or if keystone will be ready then)
21:15:16 <notmyname> it's a matter of docs, mostly
21:15:26 <ttx> #topic Glance status
21:15:36 <ttx> jaypipes: hi! Looking at https://launchpad.net/glance/+milestone/diablo-1
21:15:50 <ttx> All targeted features are in. You have one open targeted bug left...
21:16:06 <jaypipes> ttx: yes, I've been waiting for dprince to do a final check on that.
21:16:09 <ttx> Note that if this one doesn't get in today (and doesn't get retargeted) we'll have to push it to the release branch *and* to trunk, tomorrow.
21:16:24 <jaypipes> ttx: yes, understood.
21:16:29 <ttx> jaypipes: Other announcements, comments ?
21:16:33 <jaypipes> ttx: nope.
21:16:41 <jaypipes> ttx: I'll do a release announcement on thursday.
21:16:53 <ttx> Any Glance question, raise your hand
21:16:57 <jaypipes> ttx: been working on fixing myriad Keystone unit test issues today.
21:17:30 <primeministerp1> yes
21:17:34 <primeministerp1> whoops
21:17:42 <ttx> primeministerp1: a Glance question ?
21:17:54 <primeministerp1> nope, stuff to add to misc
21:18:07 <ttx> ok, wait for open discussion then
21:18:08 <primeministerp1> sorry slip of the sausage hands
21:18:14 <ttx> #topic Nova status
21:18:24 <ttx> vishy: yo! Looking at https://launchpad.net/nova/+milestone/diablo-1
21:18:38 <ttx> A few planned features are still missing -- let's see what can still make it and what should be deferred:
21:18:47 <ttx> * integrate-nova-authn: no code linked
21:19:09 <ttx> Been trying to get updated status from westmaas, apparently this was between Titan and RCB
21:19:22 <vishy> there is code in keystone for integration
21:19:28 <vishy> that works - ec2 api
21:19:39 <vishy> minus the ec2 api that is
21:19:54 <devcamcar> vishy: no ec2 api with keystone?
21:19:57 <vishy> the spec included a middleware for ec2 that is not done
21:19:58 <ttx> so this should be retargeted to diablo-2 ?
21:20:02 <vishy> so yes
21:20:05 <ttx> ok will do
21:20:16 <ttx> * xs-ovs: branch proposed, no review yet
21:20:27 <ttx> Looks like time is running short for this one
21:20:41 <jaypipes> vishy: that's interesting, considering I can get virtually no tests to pass in keystone...
21:20:44 <ttx> oh, it got one approved recently
21:20:54 <jaypipes> vishy: remove the stubs and it falls apart...
21:21:01 <vishy> rick reviewed it needs another +1.  I've looked at it
21:21:13 <vishy> jaypipes: hmm, we are using it successfully
21:21:40 <ttx> * provider-firewall: branch proposed, one review missing
21:21:45 <jaypipes> vishy: simple little things like you can create a user with no password, then try it again and the server dies.
21:22:06 <vishy> it is very hard for anyone to test the ovs branch, but apparently it has gone through qa inside of rs
21:22:22 <vishy> i think provider will make it in
21:22:40 <ttx> ok, let's keep both targeted atm
21:22:51 <ttx> * administrative-vms: not proposed yet
21:23:02 <vladimir3p> still working on it
21:23:20 <vladimir3p> just changed its target to diablo-2
21:23:31 <ttx> vladimir3p: makes sense, thanks
21:23:36 <vishy> the testing one titan said they need a couple more days
21:24:06 <vishy> it doesn't really affect any production code so we can merge it if it makes it
21:24:21 <vishy> it is essentially just docs
21:24:21 <ttx> sure.
21:24:37 <ttx> and reference-architectures doesn't land in code, so we can keep it in
21:24:54 <ttx> On the bugs side, we have no bugs targeted to diablo-1 yet. Any candidate ?
21:25:09 <ttx> any critical regression we missed ?
21:25:46 <ttx> vishy: anything else you wanted to mention ?
21:26:12 <ttx> Questions for the Nova PTL ?
21:26:17 <vishy> I would love help tomorrow with testing
21:26:42 <soren> I'll certainly help test.
21:26:46 <vishy> if everyone could just try to install and run the trunk code to pick up any last minute issues before we cut milestone 1 that would be great
21:27:03 <ttx> vishy: I'll try to throw some spare cycles at basic testing, been some time since I last refreshed my install.
21:27:47 <ttx> ok, moving on in 10 seconds if nobody raises their hand.
21:27:49 <primeministerp1> question
21:27:53 <primeministerp1> on the nova side
21:27:57 <ttx> primeministerp1: yes ?
21:28:02 <primeministerp1> how's about hyperv bits
21:28:28 <ttx> primeministerp1: you mean, do they work ? As far as we know, yes, but that doesn't mean much.
21:28:34 <primeministerp1> i'm trying to understand how it fits in
21:28:51 <primeministerp1> and how we can help
21:29:01 <ttx> vishy: you take this one ?
21:29:04 <primeministerp1> to bring everyone here up to speed
21:29:06 <primeministerp1> if i may
21:29:36 <primeministerp1> we have an 8 node hyperv compute cloud running on 4xnehialm(sp?) machines
21:29:48 <dabo> b
21:29:52 <primeministerp1> we would like to make sure
21:29:54 <dabo> oops - wrong window
21:30:03 <primeministerp1> we are testing all the latest stuff
21:30:10 <ttx> primeministerp1: did you get the contacts that were promised to you ?
21:30:13 <primeministerp1> to help w/ the advancement of hyperv/openstack
21:30:14 <primeministerp1> o yes
21:30:27 <primeministerp1> i did
21:30:32 <mtaylor> primeministerp1: I was actually _just_ in the middle of writing some email about that :)
21:30:41 <primeministerp1> however i would like to invite others to our cause
21:31:04 <ttx> primeministerp1: integrate the testing sounds like the best way to achieve that
21:31:09 <mtaylor> ++
21:31:12 <primeministerp1> exactly
21:31:22 <ttx> maybe we can come back on that at the end of the meeting, time permitting
21:31:30 <primeministerp1> is there anyone out there currently who has done anything w/ hyperv/nova
21:31:35 <ttx> we have a few more topics to cover.
21:31:38 <primeministerp1> fair enough
21:31:45 <ttx> and this is an open-ended question :)
21:31:50 <primeministerp1> hehe
21:31:52 <ttx> #topic Nova review backlog
21:31:52 <primeministerp1> i love thos
21:31:53 <primeministerp1> e
21:32:08 <ttx> I wanted to quickly discuss what we can do to reduce the Nova review backlog (again).
21:32:22 <ttx> I'm under the impression that since ReviewDays were set up, we have less opportunistic reviews than we used to...
21:32:32 <ttx> Does that mean we should move to two core reviewers per day ?
21:32:45 <ttx> There are 23 members. At this point that means one review day every month.
21:32:56 <ttx> Sounds like two review days per month wouldn't be too much.
21:32:58 <devcamcar> i prefer the idea of assigning areas to people
21:33:04 <bcwaldon> c:q
21:33:12 <devcamcar> making people responsible for specific reviews and not specific days
21:33:13 <jk0> assigning areas++
21:33:21 <ttx> devcamcar: that hasn't really been working well so far
21:33:33 <devcamcar> ttx: i wasn't aware we were even formally doing that
21:33:39 <devcamcar> maybe thats the problem?
21:33:45 <jk0> there is just too much that particular core members may not be able to fully test
21:34:53 <ttx> vishy, soren: opinions ?
21:35:37 <soren> When we first started this, the reviewer of the day didn't have to actually do all the reviews.
21:36:09 <soren> They were supposed to do reviews, click the approve button, and/or poke more appropriate people to review.
21:36:24 <ttx> soren: I haven't seen that happening so far.
21:36:42 <ttx> (the poke more appropriate people to review part)
21:36:43 <soren> I think we still need review duty. Otherwise things will inevitable fall through the cracks between people's designated areas of expertise.
21:36:55 <Vek> I've had a merge prop languishing for a week since last review/update
21:36:58 <soren> ttx: Nor have I. I've not even done it myself. :)
21:37:08 <ttx> soren: the question is, should we double the number of reviews per day ?
21:37:22 <soren> ttx: follow-on question is: should this be permanent?
21:37:26 <ttx> i.e. review duty once or twice per month ?
21:38:08 <ttx> soren: I think it would. If the number of pending reviews goes sown, the duty becomes lighter
21:38:20 <ttx> down*
21:38:34 <soren> I'm fine with two review days a month.
21:38:39 <ttx> others ?
21:38:54 <ttx> vishy: ?
21:39:04 <bcwaldon> definitely agree, but we should also consider removing some from the rotation
21:39:15 <vishy> I'm ok with it although I think the problem is really scheduling
21:39:16 <bcwaldon> people that may not be as active in the project as they used to be
21:39:18 <soren> I can adjust the e-mail that gets sent out to be clearer that merely poking other, more appropriate people to do reviews is perfectly fine.
21:39:21 <ttx> bcwaldon: names ! names !
21:39:24 <soren> vishy: How so?
21:39:27 <bcwaldon> I will not be that guy
21:40:40 <vishy> soren: most of the people working on the project have a lot of other responsibilities
21:41:02 <vishy> soren: our solution seems to be trade with someone else if there is a conflict...
21:41:30 <vishy> soren: although we don't necessarily have a good way of doing that...
21:41:43 <soren> vishy: No?
21:42:15 <vishy> soren: any way to get your automatic emailer to send out google calendar hits :)
21:42:34 <devcamcar> i never receive emails for review days
21:42:39 <soren> vishy: Per-person ical feed?
21:42:57 <vishy> I've had twice now where i've lost track of my day and suddenly gotten the email on a morning when i have 4 meetings :)
21:43:01 * jaypipes already remove himself...
21:43:05 <soren> devcamcar: devin.carlen@gmail.com is you, right?
21:43:12 <devcamcar> soren: yes
21:43:18 <devcamcar> it worked once
21:43:32 <devcamcar> but hasn't lately for some reason
21:43:33 <vishy> soren: in any case, this is a side issue
21:43:41 <vishy> soren: two times a month is fine
21:43:42 <ttx> devcamcar: then you worktime optimizer filter decided to spam it :)
21:44:08 <ttx> ok, time is running out, we need to go to the last topic
21:44:22 <ttx> soren: can you take the action of doubling the duty ?
21:44:35 <soren> ttx: Doing so right now.
21:44:40 <ttx> thx
21:44:46 <ttx> #topic Functional testing
21:44:57 <ttx> so several people raised the issue of lack of progress on the functional testing side
21:45:07 <ttx> separate groups are involved in designing/implementing parallel efforts
21:45:25 <ttx> I was wondering how we could optimize that, reduce duplication of effort and get something usable asap :)
21:45:34 <westmaas> vek has a good branch out that a decision should be made on
21:45:39 <ttx> Looks like setting up a regular "functional testing" meeting to coordinate could help.
21:45:39 <Vek> um...get my merge prop in?  :)
21:45:47 <ttx> mtaylor: ?
21:45:50 <mtaylor> ttx: I heard mention of perhaps setting up a team/group ... yes. what you just said
21:45:52 <Vek> https://code.launchpad.net/~klmitch/nova/os_int_tests/+merge/61474
21:46:04 <ttx> mtaylor: may I action you on that ?
21:46:20 <mtaylor> ttx: yes. I will take care of that... and will send a mail to the list about it
21:46:28 <ttx> #action mtaylor to set up a "functional testing" meeting to coordinate efforts
21:46:32 <bcwaldon> Vek: Have you seen the comments on that prop?
21:46:52 <Vek> bcwaldon: and replied, addressed, etc.
21:46:54 <mtaylor> ttx: also, I'm writing up some notes on what's going on so far to go out to the list - I'll tie that in with the group thing
21:47:02 <Vek> I'm not aware of any outstanding unaddressed comment.
21:47:16 <bcwaldon> Vek: check one more time for me. There are two comments at the bottom
21:47:28 <ttx> #topic Open discussion
21:47:37 <ttx> For those interested, two iCal feeds:
21:47:42 <primeministerp1> yes
21:47:45 <ttx> iCal for OpenStack milestones and releases:
21:47:49 <ttx> #link http://tinyurl.com/openstack-releases
21:47:54 <ttx> iCal for OpenStack meetings:
21:48:00 <ttx> #link http://tinyurl.com/openstack-meetings
21:48:04 <ttx> ping me for any change
21:48:04 <Vek> bcwaldon: the one from dietz was in response to the one from blamar, and made at my request to look at it.
21:48:49 <bcwaldon> Vek: gotcha
21:49:13 <ttx> Vek: if you addressed the reviewers comments, they should finally approve it
21:49:24 <ttx> Vek: if they don't, hunt them down
21:49:28 <Vek> You'd think :)
21:49:29 <blamar> ttx: Or disapprove if it's not something that should go in?
21:49:35 <bcwaldon> seconded
21:49:35 <ttx> blamar: of course :)
21:49:48 <Vek> I haven't heard anything from termie since I addressed his concerns after the summit
21:50:04 <Vek> and I haven't heard anything from vishy since I addressed *his* concerns last week.
21:50:14 <Vek> *poke* *poke*
21:50:23 <vishy> ow
21:50:34 <bcwaldon> inappropriate behavior
21:51:18 <ttx> primeministerp1: back on the Hyper-V question. What are you expecting exactly ?
21:51:54 <ttx> primeministerp1: I think the key is to get the setup integrated so that we can actually test trunk on Hyper-V.
21:52:05 <ttx> primeministerp1: not sure there is much more to it ?
21:52:10 <mtaylor> ttx: ++ ^^
21:52:46 <ttx> <primeministerp1> however i would like to invite others to our cause
21:53:10 <mtaylor> so, the idea there is to make sure we have a story for deploying in general that we can apply to the machines we have now or to machines we get access to from primeministerp1
21:53:13 <primeministerp1> o yes
21:53:14 <ttx> I think you won't gather momentum until that first rthing is done
21:53:15 <mtaylor> or from anyone else
21:53:15 <primeministerp1> i'm in
21:53:48 <primeministerp1> i can prob offer up some linux(xen/kvm) nodes as well
21:53:56 <primeministerp1> to assist in the total cause
21:53:59 <mtaylor> then the thing that's in parallel to that is ensuring we have dev resources also provided so that if a dev hits a snag on a branch going in due to hyperv - that there is somewhere they can go to look at it
21:54:07 <ttx> primeministerp1: so watch for mtaylor's announcement of that functional testing group
21:54:12 <primeministerp1> so i have a full class c
21:54:17 <primeministerp1> that's currently unused
21:54:25 <primeministerp1> if we coordinate
21:54:32 <primeministerp1> i can make this thing fully public
21:54:42 <ttx> primeministerp1: looks like you should be part of that group :)
21:54:54 <primeministerp1> does that mean i get a new email addr?
21:54:56 <primeministerp1> ;)
21:55:12 <mtaylor> ha. no email address for you!
21:55:16 <ttx> no, but you may get a bumper sticker
21:55:16 <primeministerp1> :(
21:55:20 <primeministerp1> fair enough
21:55:29 <primeministerp1> I'll work on the email addr
21:55:30 <ttx> "if you can read this you should be doing QA instead"
21:55:35 <primeministerp1> haha
21:55:48 * Vek has too many email addresses as it is...hard to keep track of them all
21:55:57 <primeministerp1> i love shockwaves
21:55:58 <ttx> anything else before I close this meeting ?
21:56:33 <primeministerp1> any new discussion of location for the upcoming summit
21:56:48 <ttx> primeministerp1: last I heard it would be east coast.
21:56:58 <jk0> sounded like it was between Boston and NYC
21:57:04 <ttx> primeministerp1: potentially very close to you.
21:57:11 <primeministerp1> i'm up for lobbying for boston
21:57:17 <jatsrt> ++ Boston
21:57:22 * Vek would be too, actually...
21:57:32 <jk0> NYC
21:57:37 <westmaas> blacksburg, va
21:57:39 <primeministerp1> haha
21:57:42 <bcwaldon> seconded
21:57:53 <ttx> ok, that's a sign this meeting came to an end.
21:58:01 <ttx> #endmeeting