21:01:37 <ttx> #startmeeting
21:01:38 <openstack> Meeting started Tue May 24 21:01:37 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:44 <ttx> Welcome to our weekly OpenStack meeting...
21:01:50 <ttx> Today's agenda lives at:
21:01:54 <ttx> #link http://wiki.openstack.org/Meetings
21:02:04 <ttx> #topic Actions from previous meeting
21:02:11 <ttx> * jaypipes to confirm the nobottle unblocking
21:02:27 <ttx> jaypipes: nothing like getting actions assigned to you while you're not here :)
21:02:39 <jaypipes> ttx: heh
21:02:49 <jaypipes> ttx: sorry, have not checked that one.
21:03:14 <ttx> jaypipes: ok, just wanted to make sure that was unblocked, please reraise it if it's not
21:03:25 <ttx> * ttx to crosspost assignee search to ML: done
21:03:27 <jaypipes> ttx: I'll check into it.
21:03:37 <ttx> * soren to raise a thread on the python-openstack.compute jacobian situation
21:03:45 <ttx> This was done, but the thread died...
21:03:51 <soren> Oh, did I?
21:03:56 <soren> Oh, right, I did!
21:04:00 <ttx> I think the conclusion was, since the current client needs to evolve in parallel to exhibit new Nova features...
21:04:02 <soren> phew
21:04:12 <ttx> ...it's difficult to have it live outside our direct and timely control
21:04:26 <ttx> That said it still sucks to have two nearly-identical confusing projects.
21:04:49 <ttx> Could the two projects be merged and both sides be committers ?
21:05:19 <mtaylor> ++ - and just add support for new features to the library before they are added to the server code
21:05:26 <ttx> Who knows Jacobian better and could help in bridging the gap ?
21:05:28 <dabo> I think they should be separated. The jacobian part would work with the public API only, and we would maintain a separate library for inter-zone communication
21:05:53 <dabo> I know Jacob, and could talk with him
21:06:22 <ttx> dabo: we still need to make quick updates to the client to exhibit new features
21:06:58 <dabo> ttx: true, but that could be something we coordinate with the jacobian version.
21:07:19 <dabo> I don't think he would object to having the utility kept up-to-date
21:07:22 <ttx> dabo: could you take the action of starting to bridge the gap ?
21:07:30 <dabo> Sure.
21:08:07 <ttx> #action dabo to bridge the gap with jacobian and work towards a common client
21:08:17 <ttx> ok, moving on
21:08:24 <ttx> #topic General release status
21:08:39 <ttx> The release status page is now milestone-oriented, represents our always-evolving plan of record:
21:08:43 <ttx> #link http://wiki.openstack.org/releasestatus/
21:08:57 <ttx> If you have any remark or correction, please talk to me or corresponding PTL.
21:09:15 <ttx> I also created a few webnumbrs for Nova, to track open bugs, untriaged bugs and bugfixes committed:
21:09:21 <ttx> #link http://wiki.openstack.org/releasestatus/nova.html
21:09:33 <ttx> Should get more interesting with a bit more data collected.
21:09:45 <vishy> ttx: nice!
21:09:56 <ttx> Questions before we move to per-project status ?
21:10:26 <johnpur> ttx: can we get standardized reports for all the projects?
21:10:52 <ttx> johnpur: we could. It was more pressing for nova, given the recent bug inflation that I'm trying to flight
21:10:55 <ttx> fight, even
21:11:03 <johnpur> agree on the priority
21:11:14 <ttx> but I can have the same webnumbr set up for the others, sure
21:11:20 <johnpur> thx
21:11:27 <ttx> #action ttx to create webnumbrs for all core projects
21:11:35 <ttx> #topic Nova status
21:11:43 <ttx> The first milestone is diablo-1, scheduled for Thursday, June 2nd.
21:11:58 <ttx> The plan is to cut a milestone release branch early Wednesday morning, which means that diablo-1 features should get in before Tuesday EOD.
21:12:13 <ttx> Looking at the milestone status it appears we are still quite far from the objective:
21:12:17 <ttx> https://launchpad.net/nova/+milestone/diablo-1
21:12:32 <ttx> The only feature that was proposed for merging so far is snapshot-volume, but it is missing reviews...
21:12:41 <ttx> So please give some love to: https://code.launchpad.net/~morita-kazutaka/nova/snapshot-volume/+merge/61071
21:13:13 <ttx> i see Vish looked into it very recently :)
21:13:19 <ttx> clone-volume is ready but needs snapshot-volume to land first.
21:13:31 <vishy> yes...
21:13:37 <ttx> xs-multi-nic, xs-ovs, administrative-vms, nova-virtual-storage-array, integrate-nova-authn and unittest-examples are all planned to be proposed very soon
21:13:53 <ttx> reference-architectures is a design/documentation effort, should be completed it time
21:14:03 <vishy> yes, tr3buchet says multinic won't make it
21:14:09 <ttx> kvm-pause-suspend is blocked on legal issues, might still make it
21:14:11 <vishy> but should be in early in diablo-2
21:14:17 <markwash> :-(
21:14:27 <ttx> vishy: ok, please move milestone if you haven't already
21:14:31 <vishy> i did
21:14:47 * ttx refreshes
21:14:48 <vishy> might be best that way, so we have time to fix the stuff that it breaks
21:15:01 <ttx> vishy: makes sense indeed.
21:15:07 <ttx> xtoddx: how is provider-firewall doing ?
21:15:09 <vishy> i asked him to propose it asap so that we can all start helping
21:15:25 <xtoddx> ttx, vishy: there is a patch to move libvirt into a directory
21:15:40 <xtoddx> is that going to land first, or should mine?  we're going to have to work around each other somehow
21:15:58 <vishy> xtoddx: do you have a link?
21:16:06 <vishy> just propose and we'll see who wins! :)
21:16:08 <xtoddx> finding
21:16:08 <blamar_> xtoddx: Doesn't matter to me :) It's my change
21:16:21 <blamar_> https://code.launchpad.net/~rackspace-titan/nova/libvirt-firewall-breakout
21:17:34 <ttx> propose early, propose often :)
21:17:41 <vishy> blamar_: why hasn't that merged yet?
21:17:52 <ttx> so yours is ready, or almost ready ?
21:17:57 <ttx> xtoddx: ^
21:17:58 <vishy> blamar_: it is well past monday :)
21:18:02 <blamar_> vishy: I'd like to get a core member to approve that isn't on my team :)
21:18:08 <vishy> o
21:18:09 <markwash> lol
21:18:20 <bcwaldon> but, jaypipes matters!
21:18:20 <xtoddx> mine is ready, though i haven't merged trunk recently
21:18:27 <jaypipes> :(
21:18:33 <bcwaldon> jaypipes: you do, I swear!
21:18:52 <jaypipes> lol
21:19:02 <ttx> vishy: I'll probably tweak the scoring on http://wiki.openstack.org/reviewslist/ so that it prioritizes the features that are targeted to the next milestone
21:19:05 <xtoddx> i'll make sure mine is ready and propose, and we'll let the chips fall how they may
21:19:08 <ttx> If anyone still uses that ;)
21:19:27 <bcwaldon> ttx: I do!
21:19:34 <xtoddx> ttx: link from http://wiki.openstack.org/Nova/ReviewDays
21:19:37 <xtoddx> and i'll use it
21:19:42 <ttx> bcwaldon: cool !
21:19:46 <ttx> xtoddx: good point
21:19:57 <ttx> vishy: lots of stuff targeted to diablo-2 now
21:20:11 <ttx> vishy: once diablo-1 is out we'll have an early look at diablo-2 and make sure the plan is doable (and people know what they are assigned to), and push back to diablo-3 what needs to be
21:20:20 <vishy> ttx: yes, we will probably have to move some of the dependent stuff
21:20:34 <ttx> Questions for the Nova PTL ?
21:20:48 <jaypipes> vishy: hey, when is local image service going bye bye?
21:21:13 <markwash> and when that happens, can we ditch the base class too?
21:21:17 <vishy> blamar_: seems fine, I'm still annoyed by virt not using import_object but whatev
21:21:26 <vishy> jaypipes: is it going away?
21:21:36 <vishy> jaypipes: are we just going to default to glance?
21:21:40 <jaypipes> vishy: well, Glance already has a local image service ;)
21:21:49 <jaypipes> vishy: it's Filesystem backend...
21:22:07 <blamar_> vishy: lots of good changes for libvirt coming once I can get some code separation
21:22:09 <xtoddx> i think the issue would be ec2 compatibilty layer only being half-way complete then
21:22:27 <vishy> xtoddx: no it works fine with glance
21:22:41 <jaypipes> vishy: and the filesystem backend is Glance's default storage, so switching from local to glance by default would essentially be the same as we have now (only requiring the dependency on glance I guess)
21:23:02 <vishy> jaypipes: i'm just a little worried about having to configure glance to get it working, but as it is relatively easy I don't mind
21:23:24 <jaypipes> vishy: no configuration besides the existin glance_host and glance_port.
21:23:24 <vishy> jaypipes: it messes up venv install i think
21:23:33 <ttx> soren: we need to track that, since Ubuntu will want to default on Glance too
21:23:51 <jaypipes> vishy: ok, we can take it offline. sounds like something we can work towards at a low priority.
21:23:51 <soren> *nod*
21:23:53 <ttx> jaypipes, vishy: do we need/want a blueprint for that migration ?
21:23:57 <vishy> jaypipes: cool
21:24:03 <jaypipes> ttx: good idea, yes
21:24:07 <ttx> could help for downstream to track when it lands
21:24:22 <ttx> jaypipes: you create it ?
21:24:34 <jaypipes> ttx: sure
21:24:45 <jaypipes> #action jaypipes to create removal of local image service blueprint
21:24:46 <markwash> vishy: the venv is for unit testing though, right?
21:24:54 <markwash> vishy: so we shouldn't need a real image service anyway
21:25:15 <ttx> can we move to Glance and Swift ?
21:25:23 <markwash> ttx: sorry, sure
21:25:33 * ttx thiks he should reorder the topics
21:25:39 <ttx> #topic Glance status
21:25:42 <jaypipes> https://launchpad.net/glance/+milestone/diablo-1
21:25:49 <ttx> (since glance and swift usually don't generate so much discussion)
21:25:56 <ttx> Your first milestone (diablo-1, also June 2nd) looks in good shape: 2 merged, 1 proposed.
21:26:06 <jaypipes> we're on target to cut diablo-1 with the currently targeted features and bug fixes.
21:26:18 <ttx> indeed
21:26:30 <jaypipes> hammering out a couple remaining issues around results pagination, but I don't foresee too many issues in meeting June 2nd deadline
21:26:37 <bcwaldon> seconded
21:26:52 <jaypipes> I'll be focusing entirely on bug fixes this coming week while bcwaldon finishes the little work left on pagination.
21:27:06 <ttx> jaypipes: do you want a release branch cut on Wednesday morning ?
21:27:16 <jaypipes> there's a couple outstanding SQLalchemy migrate bugs that are annoying, as always.
21:27:23 <jaypipes> ttx: yes please
21:27:30 <ttx> ok
21:27:42 <ttx> Anything else on/for Glance ?
21:28:15 <jaypipes> other than that, diablo-2 is all about integration with keystone. waiting to see how termie and vishy's work around nova integration with keystone works out. we'll use what we can there to save time and give us more time to work on shared image groups (http://etherpad.openstack.org/GlanceSharedImageGroups)
21:28:36 <markwash> jaypipes: did you see my email about pagination this afternoon?
21:28:45 <jaypipes> markwash: yeppers. I'll ping you in a bit.
21:28:52 <markwash> jaypipes: gotcha, thanks
21:28:55 <jaypipes> np
21:28:59 <jaypipes> ttx: that's it for us.
21:29:09 <jaypipes> anybody have any questions for us?
21:29:29 <ttx> #topic Swift status
21:29:30 <blamar_> jaypipes: Given that Keystone isn't an official OpenStack project, is integration premature?
21:29:38 <ttx> ah!
21:29:41 <jaypipes> blamar_: it's integration around the API, so no... :)
21:30:06 <blamar_> jaypipes: Good thing the API is stable and decided? :)
21:30:24 <blamar_> ttx: apologies
21:30:30 <jaypipes> blamar_: heh, well, you know what I mean...
21:30:30 <ttx> no problem :)
21:30:44 <jaypipes> blamar_: we focus on the spec versus the implementation.
21:30:49 <ttx> notmyname: Hi! So the first milestone for Swift is 1.4.0, on May 31.
21:30:57 <johnpur> anotherj1sse: what is the progress on pushing the keystone project foward
21:31:00 <notmyname> yes it is
21:31:14 <ttx> johnpur: please raise in open discussion
21:31:16 <ttx> 6 blueprints targeted: 5 merged and 1 proposed, looks good
21:31:23 <notmyname> we are currently doign QA work for 1.4.0. It should be ready
21:31:31 <notmyname> the one that hasn't merged yet will be removed
21:31:35 <ttx> notmyname: so next Tuesday you'll bump the version number to 1.4.0, and then bump it again to 1.4.1-dev, so that we get one build versioned "1.4.0" ?
21:31:35 <notmyname> and not be in 1.4.0
21:32:09 <ttx> oh, ok
21:32:11 <notmyname> yes. we will bump the version to only have one 1.4.0
21:32:23 <ttx> cool.
21:32:29 <ttx> notmyname: any other announcements or comments ?
21:32:38 <notmyname> future plans:
21:32:46 <notmyname> probably in this next milestone:
21:33:01 <notmyname> to remove swauth and the stats/loggin stuff currently in swift to be in separate projects
21:33:22 <jaypipes> notmyname: can we get swift to make toast yet?
21:33:53 <notmyname> this will allow for independent release cycles and further show that they are good examples, not always recommended for every production use
21:34:22 <creiht> jaypipes: for certain selections of server chassis, yes :)
21:34:25 <ttx> Other questions for the Swift team ?
21:34:27 <jaypipes> :)
21:34:48 <ttx> Then raise you hand before I switch to next topic :)
21:35:04 <ttx> #topic Open discussion
21:35:11 <ttx> <johnpur> anotherj1sse: what is the progress on pushing the keystone project foward
21:35:16 * jaypipes would like to hear from mtaylor about CI
21:35:46 <johnpur> or any of the keystone folks
21:35:56 <ttx> johnpur: from where I stand there is a first nova integration step targeted to diablo-1, assigned to Titan team
21:36:17 <johnpur> ttx: the reason i ask is the point that was brought up earlier
21:36:28 <johnpur> there is assumptions on integration
21:36:42 <ttx> jaypipes: the magic QA setup that tests everything and ensures nothing ever breaks was targeted to diablo-1, but won't make it
21:36:47 <johnpur> however, we need to get keystone recognized as a project
21:37:03 <ttx> jaypipes: for more detail, see mtaylor :)
21:37:13 <jaypipes> johnpur: I think that is outside the scope of this meeting, to be fair.
21:37:15 <johnpur> nova, swift, and glance should be integrated near the second miletsone
21:37:16 <blamar_> johnpur: Isn't that just a vote somewhere?
21:37:28 <johnpur> jaypipes: ok
21:37:32 <jaypipes> blamar_: bit more involved than that :)
21:37:47 <johnpur> i just get too excited, i guess :)
21:37:51 <jaypipes> johnpur: :)
21:38:36 <ttx> any other topic / question ?
21:39:03 <jaypipes> antonym: how's the racker setup testing going? comstud and soren seemed to have fixed the eventlet issues?
21:39:23 <jaypipes> antonym: have we run into more concurrency issues?
21:39:30 <pvo> still seeing some issues, not sure if they're eventlet or not.
21:39:36 <ttx> notmyname, vishy, jaypipes: do you agree to reorder the topics at the next meeting as [ 'swift', 'glance', 'nova'] ? Looks like the questions and nova and open discussion could better blend.
21:39:37 <jaypipes> pvo: k
21:39:50 <notmyname> ttx: good with me
21:39:51 <jaypipes> ttx: no probs with me.
21:39:52 <antonym> jaypipes: working on it right now, about to get some scale tests going again once i get past some hiccups with builds
21:39:52 <vishy> sure
21:40:01 * vishy makes a note to show up at 2:30
21:40:04 <vishy> :p
21:40:14 <jaypipes> antonym: cool, good to know.
21:40:16 <notmyname> vishy: like I do now? ;-)
21:40:19 <mtaylor> jaypipes: aroo?
21:40:31 <jaypipes> mtaylor: just wondering on progress with the smoketesting stuff
21:40:35 <westmaas> ttx: do dev teams have any special responsibilities around milestone releases outside of getting things in before tuesday EOD?
21:40:44 <ttx> westmaas: no
21:41:01 <westmaas> ttx: cool, thanks
21:41:06 <ttx> westmaas: work on targeted bugs... but we haven't so many of them in the first milestone
21:41:11 <mtaylor> jaypipes: first step "works" on jenkins... second step needs to clean up the first step (which is what I'm on right now)
21:41:32 <ttx> westmaas: and usually part of the milestone-targeting process is to ensure you have someone committed to fixing the bug
21:41:35 <jaypipes> mtaylor: k. what about the hardware that you and letterj were working on?
21:41:40 <mtaylor> jaypipes: then I need to get some jenkins goo sorted out so that results of this can be properly integrated in to what we're doing with tarmac
21:42:00 <ttx> westmaas: otherwise it's like pissing in a violin, like we say in france.
21:42:02 * jaypipes away last week so trying to catch up with folks..
21:42:14 <mtaylor> jaypipes: deferring on the hardware at this instant - getting the functional smoketests in a vm working properly before we sort out launching it all on actual hardware
21:42:18 <westmaas> ttx: is that a bad thing?
21:42:20 <mtaylor> jaypipes: (starting small and getting bigger)
21:42:29 <ttx> westmaas: it's surprisingly ineffective.
21:42:29 <jaypipes> mtaylor: k. good to know. thx for the update.
21:42:34 <vishy> mtaylor: if you can get some of us access to the servers where the tests are actually running, we might be able to help debug why smoketests are failing
21:42:54 <soren> ttx: lol
21:43:09 <mtaylor> vishy: I can stop the script from deleting the cloud servers when it's done
21:43:30 <vishy> mtaylor: cool, i think it is probably just a couple of config changes
21:43:33 <mtaylor> vishy: and then give you access to that
21:44:01 <vishy> is the stuff that provisions the cloud server and installs nova checked in somewhere?
21:44:06 <mtaylor> vishy: sweet - I was also going to start working through the chef recipies to see what they are doing that I'm not doing
21:44:06 <vishy> in case we need to edit it?
21:44:12 <mtaylor> vishy: no, it's just in jenkins right now
21:44:22 <mtaylor> vishy: it's all in the jenkins config page
21:44:32 <vishy> mtaylor: ok
21:44:47 <vishy> mtaylor: is that visible publicly? or do i need a login?
21:45:15 <mtaylor> vishy: http://jenkins.openstack.org/job/nova-smoketests/configure
21:45:33 <mtaylor> vishy: you need jenkins login to see it most likely - although you know - I _REALLY_ should figure out a good way to version control the contents of that
21:45:44 * mtaylor mutters about data on web forms..
21:45:56 <jaypipes> mtaylor: I heard github can store code for you in a version control system.
21:46:16 * jaypipes runs and hides
21:46:17 <ttx> jaypipes: sounds cool
21:46:24 <soren> jaypipes: I see what you did there.
21:46:31 <markwash> I'm really excited about the things we can do after multinic. . what's the progress there? anything we can help with?
21:46:32 <jaypipes> hehe
21:46:36 <mtaylor> jaypipes: sure it can - but can it store the sub chunk of an xml config file?
21:46:41 <jaypipes> tr3buchet: ^^
21:47:06 <mtaylor> jaypipes: in a way that's sensible for the jenkins interface (/me may need to have to write yet-another jenkins plugin)
21:47:10 <ttx> mtaylor strickes back jaypiipes using XML
21:47:22 <ttx> oo, that went bad.
21:47:35 * jaypipes lashes out with JSON fireball.
21:47:58 <jaypipes> alright, this is getting out of control. :)
21:48:12 * ttx uses a shield of YAML.
21:48:30 * mtaylor just pukes on people
21:48:31 <jaypipes> do we have any more pressing business? I think the Network (quantum) folks may have a meeting next here?
21:48:34 <_0x44> Did someone order this pile of CSV?
21:49:09 <ttx> ok, let's leave the room to the network dudes
21:49:18 <jaypipes> ack
21:49:25 <ttx> and continue discussion on #openstack
21:49:26 <ttx> #endmeeting