19:12:33 <jbryce> #startmeeting
19:12:34 <openstack> Meeting started Thu May 12 19:12:33 2011 UTC.  The chair is jbryce. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:12:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:12:50 <jbryce> #topic Action items from last week
19:13:42 <jbryce> I had 2 items from last week. Publish the project designations and getting community asset managers to publish processes for use
19:14:09 <anotherjesse> 2 minutes
19:14:41 <jbryce> The project designations will be up today, and I'll hit the mailing list with them. I was hoping to have them published before the meeting, but my travel back from Interop was screwed up by Dallas weather.
19:15:17 <eday> I had one item with ttx, not gotten to it yet since ttx is at UDS and I've been busy with burrow things and taking care of a sick wife. should have it for next week.
19:15:42 <jbryce> Still working with the community asset managers to get a full list of who has access to what. I'm hoping to have progress on it by early next week.
19:15:51 <vishy> o/
19:16:17 <vishy> i was answering from mah phone
19:16:50 <eday> you need to get irc on your phone :)
19:16:55 <vishy> apparently
19:17:35 <jbryce> vishy: how'd the ptl meeting go?
19:18:27 <vishy> ok
19:18:32 <vishy> we made some progress
19:18:33 <vishy> :)
19:19:26 <jbryce> progress is good
19:19:47 <jbryce> any particular next step for it? just continue discussions?
19:19:54 <johnpur> if it is *forward* progress...
19:20:33 <vishy> jbryce: i posted an email to the mailing list
19:20:38 <vishy> (openstack)
19:20:49 <vishy> with the action items that we took
19:20:55 <jbryce> ok. i'm a couple days behind.
19:21:29 <jbryce> will read that
19:22:39 <jbryce> #topic communication channels
19:22:43 <jbryce> we had one thing left over from last week's marathon meeting that we didn't get to
19:22:56 <jbryce> johnpur: do you want discuss this one?
19:23:24 <johnpur> ahhh, remind me what the topic is?
19:23:34 <jbryce> http://wiki.openstack.org/Governance/PPB
19:23:42 <jbryce> Define communication channels (IRC channels, StackExchange, LP Answers, Forums). Is it time to start specializing; targeting to dev, devops/sysadmins, users? (johnpur)
19:23:50 <johnpur> OK
19:24:11 <johnpur> last week we gave the go ahead for user support forums
19:24:52 <johnpur> i just pinged the url and nothing has been set up
19:25:44 <johnpur> the open questions are a) do we want to consider moving away from LP Answers to a Q&A style for dev/devops issues?
19:25:56 <johnpur> who would own this, etc.?
19:26:21 <vishy> a) Yes!
19:26:40 <johnpur> the last issue was the setting up of additional irc channels... we setup #openstack-dev... it has almost 0 traffic to date
19:26:41 <vishy> I have answered the same questions in Q&A a whole bunch of times
19:27:19 <johnpur> starting from the top
19:28:02 <johnpur> for the forums site, do we want to nudge jordan/chad to get going after they made such an issue on the ml, or just let it lie?
19:28:29 <jbryce> i'll shoot jordan an email just to see what's going on
19:28:44 <jbryce> i don't want it to be confusing for people in the community who are expecting something to happen
19:28:51 <johnpur> agree
19:29:04 <jbryce> #action jbryce to ping jordan on openstack forums
19:29:10 <johnpur> second
19:29:28 <vishy> johnpur: i think he was going to make a poll to decide on software
19:29:45 <johnpur> anyone besides vishy want to weigh in on Answers vs Q&A?
19:30:12 <jbryce> seems like there was pretty broad agreement on a stack style q&a setup
19:30:47 <johnpur> if we go to a Q&A i am an advocate of using an open source project, to emphasize our commitment to being open
19:30:49 <eday> mp strong opinions either way here, but certainly not opposed. my main concern is who would own/moderate it
19:31:21 <notmyname> eday: ditto
19:31:38 <johnpur> i think i can find someone to do the setup/sysadmin... we need to discuss moderation
19:32:05 <johnpur> perhaps a call to the community?
19:33:01 <jbryce> will there be additional moderation beyond what already happens in launchpad answers?
19:33:48 <johnpur> idk, is there a need to clean spam, off-topic, etc.?
19:34:53 <johnpur> would this be a good task for a technical community manager to own?
19:35:02 <jbryce> probably some, but i'd imagine it would be pretty similar to how the answers process is working currently.
19:35:03 <jbryce> sounds like it
19:35:09 <johnpur> i am looking to find one now
19:35:45 <johnpur> ok, for now leave this on my plate... but we agree that we want to move off of Answers?
19:36:12 <jbryce> johnpur: i'd send an email to the list just to make sure everyone (thierry, josh, rick) can all way in as well
19:36:13 <vishy> the great point of QA sites is that most of the moderation is done by users
19:36:46 <johnpur> jbryce: can you set an action to get feedback from the other ppb members?
19:37:11 <jbryce> #action johnpur to verify QnA approach as replacement for Launchpad Answers
19:37:45 <johnpur> lastly, the question of additional IRC channels
19:38:20 <johnpur> i'm wondering if we need to contract, not expand?
19:38:32 <johnpur> *-dev isn't being used
19:38:44 <eday> johnpur: I'd say lets see how dev works out for a bit
19:39:17 <johnpur> eday: ok by me
19:39:59 <johnpur> done on this topic
19:40:03 <jbryce> ok
19:40:07 <jbryce> thanks
19:40:15 <jbryce> #topic other discussion
19:40:24 <jbryce> anyone have anything else they wanted to cover?
19:40:30 <johnpur> yes
19:40:46 <johnpur> question regarding non-core projects
19:41:23 <jbryce> ok
19:41:36 <johnpur> should we have a specified meeting where the non-core projects can discuss progress, issues, etc. like we do in the release meeting for core?
19:42:16 <jbryce> are you thinking weekly in terms of frequency?
19:42:18 <johnpur> i am a little concerned that there is no visibility to naas, lunr, redwarf, keystone, burrow, etc.
19:42:31 <johnpur> just throwing it out there
19:42:37 <jbryce> right...i think the idea makes sense
19:43:09 <notmyname> but since they aren't officially openstack projects, should we be the ones to establish that process for them?
19:43:31 <notmyname> or is this to see where they are to see when they will be ready to become part of the official project?
19:43:33 <johnpur> notmyname: good point. how should we handle?
19:43:55 <eday> I think we should encourage more frequent mailing list updates or something (somehting I've been meaning to do for burrow)
19:44:22 <johnpur> since the DS there has been little to no discussion on IRC or the ML on these projects
19:44:24 <notmyname> since we know they are interested in being part of openstack (although we should have them apply--what happend to that?), they should keep us all up to date on how things are going
19:44:40 <notmyname> not an oversight thing, just a "how's it going" thing
19:46:01 <johnpur> so, is this outside the purview of the PPB?
19:46:38 <notmyname> IMO, yes. but we are interested in general status
19:47:21 <jbryce> like eday said we can encourage them to provide more information
19:47:30 <jbryce> i think we've almost got the steps published on how to apply to incubate
19:47:42 <jbryce> and then we could have an official regular update time for incubated projects
19:47:43 <johnpur> notmyname: the danger is that some of these are tightly coupled (such as naas) and key to the objectives of the overall project (federation).
19:47:45 <eday> more open they are along the process, easier it will be to approve them later one, that ca be the PPB's position
19:48:06 <notmyname> I like what eday says
19:48:35 <eday> we don't want to approve things that are thrown over the wall, we want demonstration that projects are community driven
19:49:04 * notmyname will now let eday speak for him because he agrees with everything eday is saying
19:49:17 <eday> :)
19:49:18 <anotherjesse> ++
19:49:27 <johnpur> OK, for the more strategic projects i think we should be more actively involved to ensure alignment with the overall project goals. Outside the scope of the PPB, but within the scope of being senior leaders and PTL's.
19:50:57 <johnpur> I know anotherjesse agrees with this as he is mentoring the keystone project :)
19:51:16 <anotherjesse> keystone is reaching out the the PTLs
19:51:34 <anotherjesse> since we need them to adopt keystone as an auth mechnism
19:53:13 <johnpur> anotherjesse: exactly. we need to ensure that projects such as naas understand how to engage the community and other projects.
19:54:35 <johnpur> and *why* they should
19:56:34 <jbryce> i think it makes sense, but should just be informal until the incubation process gets rolling
19:57:55 <notmyname> so do we have other things to talk about?
19:58:09 <johnpur> jbryce: ok. we don't want to wait too long to get the ball rolling, i would suggest that the diablo midpoint should be a drop dead date
19:58:45 <jbryce> johnpur: that is fine with me
19:58:54 <jbryce> anyone have anything else?
20:00:25 <jbryce> all right
20:00:34 <jbryce> talk to you guys later
20:00:38 <jbryce> #endmeeting