21:01:08 <ttx> #startmeeting
21:01:09 <openstack> Meeting started Tue Mar 15 21:01:08 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:18 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:25 <ttx> Today's agenda:
21:01:29 <ttx> #link http://wiki.openstack.org/Meetings
21:01:42 <ttx> #topic Actions from previous meeting
21:01:54 <ttx> * ttx and spectorclan_ to look at providing weekly focus ML post
21:02:02 <ttx> I sent the first version on Monday, let me know how useful you think it is.
21:02:09 <jaypipes> ttx: extremely.
21:02:16 <soren> ttx: It seems to have worked wonders.
21:02:31 <ttx> ok, i'll do it again.. and again.. and again..
21:02:41 * soren replaces ttx with a cron job
21:02:46 <ttx> * jaypipes to raise a ML thread about review focus for nova-core
21:02:57 * jaypipes failed.
21:03:08 <ttx> jaypipes: I might beat you to it though with my BMPFreeze focus email on Thu
21:03:21 <ttx> Hrm. I mean Friday
21:03:36 <ttx> * ttx to update status on cynb's deferred spec list if nobody beats him to it: DONE
21:03:42 <ttx> * ttx to sync with Tushar on cactus-flatmanager-ipv6-support status: DONE
21:03:54 <eday> speaking of review emails, we should probably email about review days schedule. someone pinged me today it was my day, I didn't know we had started
21:04:23 <ttx> #action jaypipes to try to send review focus email before ttx sends the BMPFreeze focus email on Friday
21:04:30 <jaypipes> ttx: will try.
21:04:43 <ttx> jaypipes: if not, I'll cover it then
21:05:05 <ttx> eday: i thought soren's magic autosent emails ?
21:05:32 <soren> It's meant to.
21:05:51 <soren> eday: You didn't get an e-mail from me?
21:05:59 <_0x44> I didn't either.
21:06:05 <ttx> #info Review days have started, in case you haven't noticed yet.
21:06:15 <ttx> (for the minutes)
21:06:18 <devcamcar> soren: me neither, though i had put it on my cal :)
21:06:28 * jk0 didn't either
21:06:44 <ttx> soren: fail?
21:06:45 <eday> soren: only a q if I wanted to participate, not that it was starting w/ schedule
21:06:53 <soren> eday: Weird.
21:06:57 * soren looks into that.
21:07:05 <soren> It's meant to send an e-mail to the reviewer of the day.
21:07:10 <ttx> #action soren to fix his review day reminder
21:07:12 <soren> ..and if it fails, it's meant to e-mail me.
21:07:22 <ttx> Moving on...
21:07:29 <ttx> #topic Current release stage: Development
21:07:35 <eday> might want to email the entire list too once in a while so folks know who to bug
21:07:47 <soren> eday: It's on the wiki.
21:07:48 <ttx> We are 2 days from BranchMergeProposalFreeze, which will happen late on March 17.
21:08:00 <ttx> All your feature branches should be proposed by then.
21:08:04 <soren> eday: http://wiki.openstack.org/Nova/ReviewDays
21:08:07 * soren shuts up now
21:08:13 <eday> soren: I saw, wasn't easy to find though :)
21:08:18 <ttx> Be ready to answer any question the reviewers may have on your proposed branches, so that we can get them all merged in one week.
21:08:39 <soren> eday: I include the link in the e-mail :)
21:08:42 <ttx> #info Feature branches that are not proposed in time should be kept for the next merge window (Diablo, opening April 14), or follow the BMPFreeze exception process to try to sneak in Cactus.
21:08:50 <ttx> See exception process at:
21:08:57 <ttx> #link http://wiki.openstack.org/BranchMergeProposalFreeze
21:09:13 <ttx> The core teams should concentrate their review efforts on the feature branches that were proposed before the freeze.
21:09:38 <jaypipes> Gold Team, focus your fire on the review droids.
21:09:40 <ttx> Questions on that stage ?
21:10:07 <eday> comment: if you're not on that list, don't be disappointed. 30 active + 20wip reviews will not happen in one week
21:10:40 <ttx> That brings us to:
21:10:41 <ttx> #topic Cactus Release status
21:10:52 <ttx> Check out:
21:10:55 <ttx> #link http://wiki.openstack.org/releasestatus/
21:11:06 <ttx> I'm always complaining loudly when we suck, so let's cheer up for a bit
21:11:20 <ttx> We've actually been doing a good job at early merging in Cactus, compared to Bexar.
21:11:30 <ttx> Lots of specs are already "Implemented".
21:11:47 <ttx> Review effort should go in priority on the planned feature branches:
21:11:53 <ttx> https://code.launchpad.net/~ntt-pf-lab/nova/flatmanager-ipv6/+merge/53064
21:11:57 <ttx> https://code.launchpad.net/~sandy-walsh/nova/zones3/+merge/52565
21:12:02 <ttx> https://code.launchpad.net/~zulcss/nova/nova-lxc/+merge/51469
21:12:05 <ttx> https://code.launchpad.net/~citrix-openstack/nova/vmware-vsphere-support/+merge/53060
21:12:10 <ttx> https://code.launchpad.net/~citrix-openstack/nova/xenapi-netinject-prop/+merge/49798
21:12:14 <ttx> https://code.launchpad.net/~tr3buchet/nova/xs_multi_nic/+merge/53458
21:12:20 <ttx> https://code.launchpad.net/~rackspace-titan/nova/openstack-api-version-split/+merge/53510
21:12:43 <ttx> Once we clear those, it's free game.
21:13:05 <ttx> On the completion rate, based on the current data:
21:13:11 <ttx> Essential specs:
21:13:15 <ttx> Glance: 3 completed, 1 proposed
21:13:19 <ttx> Nova: 1 proposed
21:13:23 <ttx> High specs:
21:13:27 <ttx> Glance: 1 completed, 1 deferred
21:13:31 <ttx> Nova: 4 completed, 2 in progress, 1 in jeopardy and 2 deferred
21:13:36 <ttx> Other specs:
21:13:41 <ttx> 16 implemented, 5 proposed, 6 in progress, 8 not started and 3 deferred
21:13:49 <jaypipes> ttx: all essential Glance specs will be done... final one waiting on a fix on sqlalchemy-migrate... coming soon.
21:13:56 <ttx> Does anyone know of any spec in that list that will not get done ?
21:14:15 <ttx> I'm seeing a lot of "Non started" specs in particular...
21:14:41 <ttx> I guess those should be deferred, please mark them as such if you know they can't make it
21:14:49 <_0x44> jaypipes: When that spec is ready for merge, can you ping me? I'm avail to review it
21:15:25 <ttx> Anything in jeopardy that might not make it ?
21:16:10 <ttx> Did I just lose everyone with boring stats ?
21:16:15 <jaypipes> _0x44: sure. it's already up though: https://code.launchpad.net/~jaypipes/glance/checksum/+merge/52569
21:16:27 <_0x44> jaypipes: Oh, I can't read... you know that.
21:16:56 <jaypipes> ttx: auth and ssl MAY be in jeopardy for glance, about a 30% chance they won't hit if I can't push through this crap with migrate by EOD tomorrow.
21:17:43 <ttx> jaypipes: ok, we'll wait for EOD tomorrow then :)
21:18:14 <ttx> I guess I'll chase down the other "not started" owners and update their status
21:18:20 <ttx> On the Nova stabilization effort:
21:18:23 <ttx> Last week we had 16 bugs opened and 10 fixes committed
21:18:28 <ttx> This week we had 35 bugs opened and 29 fixes committed
21:18:36 <ttx> So we are back to normal rates :)
21:19:06 <ttx> Last minute comments, before we switch to another topic ?
21:20:08 <ttx> ok
21:20:13 <ttx> #topic Election & Nomination Process
21:20:19 <ttx> spectorclan: hello
21:20:22 <spectorclan_> hello
21:20:38 <spectorclan_> I just want to check and see if anyone has any questions with the process that I posed today?
21:20:42 <pvo> I have one.
21:20:45 <spectorclan_> yup
21:20:48 <pvo> Can you explain this a bit more "The online election tool we are using allows for restricted access
21:20:49 <pvo> voting based on a secure link but limits access via that link by IP
21:20:49 <pvo> address."
21:21:08 <spectorclan_> Sure, it only allows 1 voter per IP address if I don
21:21:11 <spectorclan_> 'hold on
21:21:24 <spectorclan_> it only allows 1 vote per IP address if I don't give it a specific email address
21:21:35 <spectorclan_> thus, using the mail to all button will not allow everyone to vote
21:21:52 <spectorclan_> That is how I understood it. perhaps ttx can provide more info
21:21:55 <pvo> ok, so all of us coming from a natted ip will not have any issues?
21:21:58 <jlmjlm> So, you only need special link from you if multiple of us are behind one NAT?
21:22:00 <ttx> pvo: CIVS has two types of polls. Public ones were anyone with a link to the poll can vote...
21:22:01 <pvo> those that got emails?
21:22:14 <ttx> and the other one that works from a list of emails and sends everyone a unique link
21:22:30 <spectorclan_> we are using the private system that ttx mentions so I need emails
21:22:32 <ttx> Our election uses the latter, obviously
21:22:54 <ttx> and you can't get emails from launchpad that easily
21:23:01 <spectorclan_> I am running a test of the system Thursday if you want to be on it, just let me know via email
21:23:20 <ttx> lots of people mark their address proivate, hence the recent email Stephen sent to grab emails to use for the PPB poll.
21:23:40 <spectorclan_> So far, I have 20 responses which is pretty good start
21:24:03 <spectorclan_> For the other 3 election I already have the emails
21:24:09 <ttx> pvo: agree that sentence is confusing. Just ignore it.
21:24:43 <spectorclan_> other issues?
21:24:45 <ttx> pvo: does the explanation make sense ?
21:24:51 <pvo> I think so
21:25:03 <pvo> I'll ping if not... I'm double booked in 2 meetings at the moment. :/
21:25:47 <ttx> pvo: see http://www.cs.cornell.edu/w8/~andru/civs/ for a better explanation
21:26:12 <pvo> ttx: thanks!
21:26:13 <ttx> of the differences between private and public polls.
21:27:14 <ttx> spectorclan: you done ?
21:27:18 <spectorclan_> yup
21:27:21 <ttx> #topic Open discussion
21:27:30 <ttx> anything, anyone ?
21:27:37 <spectorclan_> Remember that OpenStack Design Summit Registration is open
21:27:57 <pvo> when is the call for summit talks?
21:28:12 <spectorclan_> Summit content will be based on Blueprints, etc.
21:28:33 <pvo> spectorclan_: are you planning the summit?
21:28:34 <ttx> pvo: It's already open... but i'll send an email about the process soon
21:28:48 <spectorclan_> Yes
21:28:57 <ttx> pvo: see http://wiki.openstack.org/Summit
21:29:11 <spectorclan_> ttx and I are doing the Design Summit content with ttx and soon to be voted in PTL leading content for Design Summit
21:29:30 <spectorclan_> Conference part handled separately - Day 1 and Day 2
21:29:35 <pvo> ttx: got it. thanks.
21:29:46 <soren> With my last couple of branches merged, trunk can now actually withstand my test suite for extended periods of time.
21:29:55 <soren> ...so I'll be running it against trunk from now on.
21:30:15 <pvo> soren: integration tests?
21:30:19 <soren> Whenever there are new packages in the PPA, they get installed, and the tests just run in a tight loop until there's another update.
21:30:32 <westmaas> soren: nice
21:30:34 <soren> pvo: Yup. They're not very extensive, though. At all.
21:30:42 <westmaas> where are those tests?
21:30:54 <soren> pvo: I've been fixing a lot of small things along the way to make this stable.
21:31:20 <pvo> soren: sweet. looking forward to checking those out
21:31:25 <soren> pvo: I didn't want to branch out until it was stable. Otherwise it'd be hard to tell regressions from existing instability.
21:31:45 <soren> westmaas: They are runnign on my own hardware, if that's what you mean.
21:31:58 <westmaas> soren: I just wanted to take a look at the tests
21:32:01 * soren got fed up waiting for hardware from someone else
21:32:20 <westmaas> wasn't sure if they were in the nova code base or somewhere separate
21:32:23 <soren> westmaas: LEt me find the url.
21:32:30 <westmaas> soren: awesome :)
21:32:45 <soren> westmaas: lp:~linux2go/nova/jenkins-config
21:33:13 <soren> westmaas: It's not pretty, but it works pretty well. I'll probably convert it to python unittests, or maybe just switch to the smoketests altogether.
21:33:15 <jaypipes> are any anso folks here?
21:33:32 <ttx> I heard devcamcar.
21:33:42 <westmaas> soren: sounds good, we have some people looking at that as well, I will probably chat with you so we don't duplicate efforts
21:33:42 <devcamcar> hi!
21:33:54 <kpepple> soren: can you also publish your setup (not just code) ... it would be good for people to start running similar / same tests against RHEL, Xen, etc.
21:33:54 <soren> westmaas: Again, this started out very, very small. Then I fixed all the problems I found, added a bit, fixed a bunch of things, added some more, etc.
21:34:15 <soren> westmaas: The existing smoke tests did way too much stuff. I didn't know where to start on fixing things.
21:34:21 <jaypipes> devcamcar: hi! hey, so there's been a number of bad bugs break trunk recently that could have been prevented with having Anso's smoketests linked to Hudson... any chance we can get those soon?
21:34:30 <pvo> soren: westmaas: we have some integration tests we're working on too...
21:34:35 <pvo> lets talk about it soon
21:34:36 <soren> kpepple: What sort of stuff are you missing?
21:34:39 <westmaas> pvo: haha yes please
21:34:49 <jaypipes> devcamcar: note, I'm not at all blaming Anso for the bugs! just itching for those smoketests to be intergrated :)
21:35:03 <devcamcar> jaypipes: what do you mean "get those"?  they are in the repo, unless there is something specific you are looking for?
21:35:04 <soren> jaypipes: I'll integrate them into my jenkins setup tomorrow.
21:35:20 <jaypipes> devcamcar: the ones here: http://ansolabs.no-ip.org:9000/
21:35:57 <jaypipes> devcamcar: can we hook those jobs into our Tarmac pit so that if the smoketests fail, we can prevent a merge?
21:36:10 <devcamcar> jaypipes: ahh yes, should be just whats in trunk, just needs integration magic and sounds like soren is on it
21:36:20 <jaypipes> devcamcar, soren: k, cool :)
21:36:33 <kpepple> soren: sorry, just looking at code. got it.
21:36:34 <soren> I'm not sure they'll be able to prevent a merge.
21:36:37 <soren> That'll be tricky.
21:36:53 <soren> ..but we'll know very quickly if something breaks.
21:36:59 <soren> It's better than what we have now, at least.
21:37:30 <ttx> anything else before we close the bar ?
21:37:51 <pvo> last call?
21:38:38 <ttx> I'll be giving an Openstack presentation next week at UKUUG Spring Conference in Leeds, for those in the area
21:38:53 <spectorclan_> ttx: be sure to send the slides to me for posting and take pictures
21:39:14 <ttx> spectorclan: will do my best
21:39:24 <ttx> If I don't get sick like last time.
21:39:35 <ttx> ok, time to end it
21:39:36 <spectorclan_> start taking C vitamins
21:39:40 <ttx> #endmeeting