21:01:39 <ttx> #startmeeting
21:01:40 <openstack> Meeting started Tue Dec 14 21:01:39 2010 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:40 * vishvananda has a big head
21:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:45 <ttx> Welcome to our weekly OpenStack team meeting...
21:01:55 <ttx> Today's agenda is at: http://wiki.openstack.org/Meetings
21:02:01 * ttx quickly rechecks
21:02:13 <ttx> Looks like nobody added any topics.
21:02:33 <ttx> #topic Actions from previous meeting
21:02:42 <ttx> * ttx to clarify with spectorclan / dendrobates the future of the "other" MLs
21:02:44 <soren> o/
21:02:53 <ttx> Looking at http://wiki.openstack.org/MailingLists it's now been simplified.
21:02:57 <chmouel> o/
21:03:09 <ttx> We have the main development ML (openstack@lists.launchpad.net), the annoucement one (openstack-announce@lists.openstack.org)...
21:03:24 <ttx> Two additional ones have apparently been kept: a users ML (openstack-operators@lists.openstack.org)...
21:03:34 <ttx> and a partner one (openstack-partner@lists.openstack.org)
21:03:48 <ttx> those last two should both be monitored by spectorclan.
21:03:51 <jaypipes> cool. good to consolidate those.
21:04:00 <eday> we need to remove openstack-discuss as well, that still works (LP list)
21:04:03 <spectorclan> ttx: yes, I am monitoring the other two lists
21:04:25 <ttx> eday: I'll try to look into that
21:04:38 <ttx> #action ttx to remove openstack-discuss if he can find it
21:04:43 <eday> was mistakenly posted to this week
21:04:47 <soren> ttx: mtaylor owns the team. He can take it down.
21:04:50 <ttx> * jaypipes and mtaylor to help Tushar set up his i18n efforts
21:05:02 <ttx> jaypipes is now assigned the i18n spec and the branches look almost done ?
21:05:16 <eday> ttx: https://launchpad.net/~openstack-discuss
21:05:34 <ttx> sore,eday: ok
21:05:40 <jaypipes> ttx: yup. still need a couple automation things, but Nova is now i18n'd.
21:05:51 <ttx> #action mtaylor to bring down the openstack-discuss group
21:06:27 <ttx> About LP groups, for those that are lost, I wrote http://wiki.openstack.org/LaunchpadGroups
21:06:30 <jaypipes> vishvananda: welcome back.
21:06:49 <ttx> If you know of any group like openstack-discuss that is not in that drawing, let me know
21:07:00 <ttx> * ttx to investigate calendar options
21:07:12 <ttx> Looks like there wasn't strong momentum behind that idea...
21:07:28 <ttx> Subgroups are free to implement whatever they feel can help them, but at this point we won't have a common OpenStack calendar.
21:07:54 <ttx> Questions ?
21:08:23 <ttx> ... ok, moving on
21:08:28 <ttx> #topic Current release stage: Implementation
21:08:40 <ttx> We are three weeks and 2 days away from the BranchMergeProposalFreeze (Jan 6).
21:08:55 <ttx> Remember: the sooner your branches get proposed for merging, the better: it helps spreading the branch review work.
21:09:13 <ttx> #topic Release status
21:09:27 <ttx> I almost finished targeting Nova blueprints to Bexar, so we now have a list we can work from.
21:09:47 <ttx> We have a total of 40 specs tracked currently (3 for glance, 3 for swift, 31 for nova, 3 others)
21:10:00 <ttx> Looks a bit ambitious, but that's what you told me you could deliver :)
21:10:20 <ttx> Thanks to the new Launchpad API around blueprints, I'm working on a release status page that lists all blueprints in OpenStack Bexar, whatever the project, and gives extra info:
21:10:25 <ttx> #link http://wiki.openstack.org/releasestatus/
21:10:45 <ttx> also shows graphically where we are in the cycle
21:11:07 <ttx> (the green in the gauge is the implementation phase of the release cycle)
21:11:35 <ttx> That's the first version, I'll work on making that list more useful.
21:11:52 <ttx> Quick review of the essential specs:
21:12:01 <ttx> * glance/teller-api (jaypipes): good progress ?
21:12:16 <jaypipes> ttx: yes.
21:12:28 <ttx> * swift/bexar-client-side-chunking (gholt): branch review in progress
21:12:42 <jaypipes> ttx: working with sirp on a few architectural/API changes for Glance that have been a delay, but still on track.
21:13:03 <ttx> jaypipes: ok, thanks
21:13:07 <ttx> * nova/admin-only-api (sandywalsh): implemented
21:13:27 <ttx> * nova/xs-snapshots (sirp): started
21:13:44 <ttx> sirp is not around, will sync with him offline
21:14:00 <ttx> High prio specs: 15% implemented, 23% needs branch review, 46% good progress, 15% other
21:14:14 <jaypipes> :w
21:14:18 <jaypipes> oops..
21:14:19 <jaypipes> sorry.
21:14:45 <ttx> Highlights:
21:14:53 <ttx> * nova/raw-disk-images (dendrobates): blocking xenapi-raw-disk-images
21:15:04 <ttx> dendrobates told me he would work on it this week...
21:15:15 <ttx> but that was before he get poisoned by Californians
21:15:24 <soren> I'm pretty much done with it.
21:15:28 <alekibango> poisoned?
21:15:32 <creiht> That darned poisoned veggies
21:15:34 <soren> I'm doing my last bit of testing right now.
21:15:43 <ttx> alekibango: follow twitter :)
21:16:05 <creiht> alekibango: food poisoning
21:16:23 <ttx> anyone else being blocked ?
21:16:48 <alekibango> i hope he will get good soon
21:16:49 <ttx> anyone else wanting to report progress on their spec ?
21:17:25 <ttx> If the status on the releasestatus page is not accurate, please update it.
21:18:05 <ttx> ok, moving on then
21:18:12 <ttx> #topic Open discussion
21:18:16 * ttx opens the bar
21:18:31 <annegentle> ttx: do you plan to bring blueprints from https://blueprints.launchpad.net/openstack-devel/ into the umbrella openstack project?
21:18:39 <annegentle> (there're only 2)
21:18:56 <spectorclan> ttx: Is glance ever going to be a project on the level of Swift or Nova?
21:19:36 <ttx> annegentle: they appear in http://wiki.openstack.org/releasestatus/
21:19:49 <ttx> spectorclan: I think it already is
21:19:53 <alekibango> yes it is
21:20:38 <spectorclan> does that mean that we need to change our website at openstack.org and list Glance as well as Swift and Nova?
21:20:41 <devcamcar> fyi nasa allocated resources this month to release our django based ui as part of openstack
21:20:42 <ttx> annegentle: i could target doc-enhancements to bexar. i'l ldiscuss that with you offline
21:20:59 <annegentle> ttx: great, thanks
21:21:04 <ttx> devcamcar: cool
21:21:05 <soren> devcamcar: Whoo! \o/
21:21:22 <creiht> woot
21:21:36 <alekibango> devcamcar: when might that come out?
21:21:53 <devcamcar> our goal is to have our first code drop in about 3 weeks
21:22:04 <alekibango> thanks, tell me if you will want testers
21:22:17 <devcamcar> great, will do
21:22:18 <ttx> devcamcar: that means it could make bexar
21:22:22 <jaypipes> spectorclan: after Bexar release is a good time to put Glance on there... not until then. major API changes are afoot...
21:22:30 <devcamcar> ttx: that is our goal
21:22:48 <spectorclan> jaypipes: OK, I will make sure that is part of our launch plan for the website. Thanks.
21:22:54 <jaypipes> spectorclan: cheers
21:23:38 <ttx> devcamcar: great, keep me posted. If that progresses well, we'll probably create a blueprint after the fact to track it
21:24:37 <vishvananda> I will be clearing the rest of the stuff off of my plate today so I can spend the rest of the week on my bps. So expect progress on those by next meeting.
21:24:52 <devcamcar> ttx: there is one in nova for that currently
21:24:54 <devcamcar> ttx: https://blueprints.launchpad.net/nova/+spec/bexar-django-nova-ui
21:25:01 <devcamcar> not sure where it should really live though
21:25:07 <ttx> vishvananda: cool. who is working on web-based-serial-console ?
21:25:36 <ttx> devcamcar: what do you mean by "live" ?
21:25:38 <vishvananda> Anthony. He has time set aside in this sprint as well.
21:26:04 <ttx> vishvananda: ok, I'll update the assignee then
21:26:13 <devcamcar> ttx: which project bucket the blueprint should be in
21:26:31 <vishvananda> ttx: His lp I'd is sleepsonthefloor
21:26:44 <ttx> devcamcar: the django UI covers more than just nova ?
21:27:02 <devcamcar> ttx: eventually we will add swift support to it as well
21:27:37 <ttx> devcamcar: at this point it's probably ok as a nova spec (one more)
21:28:01 <ttx> devcamcar: then maybe in openstack-common, or as its own project
21:29:21 <ttx> ok, anything else before we close ?
21:30:20 <ttx> then...
21:30:22 <ttx> #endmeeting