21:00:15 <soren> #startmeeting
21:00:16 <openstack> Meeting started Tue Oct  5 21:00:15 2010 UTC.  The chair is soren. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:00:33 <soren> Rick had to deal with a family emergency, so I'm filling in.
21:00:43 <soren> http://wiki.openstack.org/Meetings should have the agenda for today.
21:00:45 <soren> ...but doesn't.
21:00:51 <soren> It's the one from last week, so we'll have to play it by ear.
21:01:15 <soren> I'd like to talk about Feature Freeze a little bit.
21:01:20 <soren> Who else has stuff for the agenda?
21:01:33 <chmouel> testing?
21:01:43 <chmouel> or i guess it's part of feature freeze?
21:02:02 <soren> If you don't feel it gets covered under feature freeze, we'll take i separately.
21:02:08 <soren> Anyone else?
21:02:10 <ewanmellor> Glance -- status, where it's going to be for Austin.
21:02:17 <soren> Alright.
21:02:20 <soren> Oh, and blueprint status.
21:02:24 <soren> Ok, so:
21:02:27 <soren> * Feature Freeze
21:02:28 <soren> * TEsting
21:02:36 <soren> * Glance status
21:02:39 <soren> * Blueprint status
21:02:42 <soren> Sound good?
21:02:50 <alekibango> i would like to stress that there is a need for nova usage/admin  documentation --  few pages of docs could bring much more users (testers) in. That is  very important now, so we can get more response from people in time, before the release.
21:03:11 <chmouel> soren: all good to me
21:03:22 <soren> alekibango: I'll add that after Testing.
21:03:30 <alekibango> :)
21:03:38 <soren> Alright then.
21:03:43 <soren> #topic Feature Freeze
21:03:52 <soren> Ok, so feature freeze kicked in slightly delayed on Friday.
21:04:03 <soren> I blame French crappy internet.
21:04:23 <chmouel> soren: ah ah (i'm french btw)
21:04:32 <soren> I put up some guidelines here: http://wiki.openstack.org/FeatureFreeze
21:04:50 <soren> One thing that is not clear yet is how to deal with exceptions to the feature freze.
21:04:53 <soren> freeze, even.
21:05:21 <soren> So, for instance: https://bugs.launchpad.net/nova/+bug/655152
21:05:21 <ewanmellor> Did you have any particular exception in mind?  ;-)
21:05:29 <soren> Not really, just an example. Really. :)
21:06:01 <soren> The idea of providing rationale and regression potential is well-tested and sound.
21:06:15 <alekibango> another example: https://bugs.launchpad.net/nova/+bug/654843
21:06:18 <soren> However, the approval process for stuff like this is undefined.
21:06:41 <soren> In Ubuntu, we have a release team. They evaluate these things and approve or decline them.
21:06:52 <soren> a) We don't have a release team (yet?).
21:06:59 <soren> b) We may not need it for this.
21:07:16 <soren> What to do?
21:07:30 <alekibango> about releases - some people (me included) would like to see releases daily, weekly, monthly.
21:07:34 <xtoddx> this just just a "technology preview", right?  so i don't think we need to be too strict
21:07:44 <soren> Maybe branches that "fix" bugs like that need extra approval? Like 3  up-votes and no down-votes?
21:07:56 <ewanmellor> Have we formally chosen a version number for the Austin release?
21:08:00 <soren> no
21:08:12 <chmouel> people fetching apt daily ppa package should be release early enough ?
21:08:14 <soren> Our fearless leader has said: Not 1.0.
21:08:26 <xtoddx> i'm okay with a consensus strategy for approving changes after freeze
21:08:27 <soren> Other than that, it's up in the air.
21:08:38 <ewanmellor> soren: OK, that counts as choosing a version number!  Anything that's not 1.0 is fine.
21:08:57 <soren> It also has to be > 0.9.0, since we already sort of released that.
21:09:15 <soren> (We made a tarball)
21:09:16 <creiht> swift will likely be 1.1
21:09:21 <alekibango> soren: btw who has right to approve ?   imho i didnt see that button in lp
21:09:34 <soren> alekibango: Members of ~nova-core.
21:09:38 <creiht> or something like that
21:09:51 <soren> alekibango: And ~swift-core, obviously, for swift.
21:09:57 <alekibango> ty
21:10:02 <soren> (It's defined by the default reviewer for the target branch)
21:10:07 <ewanmellor> I'm happy with you merging the xen branch. We can be more strict about what Feature Freeze means when we reach 1.0.
21:10:54 <alekibango> ewanmellor: +1
21:10:55 <soren> I think it's important, even though (or perhaps especially since) this is our first public release, that we focus on QA for the rest of the cycle and not new features.
21:11:22 <alekibango> even docs, not only qa
21:11:29 <chmouel> soren: +1
21:11:32 <ewanmellor> soren: Agreed.  We bolt the door immediately after your horse has bolted.
21:11:34 <soren> alekibango: Certainly, that too.
21:11:42 <soren> ewanmellor: Well, that horse and one more :)
21:11:50 <ewanmellor> ?
21:11:50 <soren> (EC2 security groups)
21:12:02 <alekibango> but i would say your rule (3 up and no down votes) looks nice for me
21:12:05 <soren> Ok, so how about this:
21:12:34 <ewanmellor> That one is less clear to me -- I can't even begin to understand the networking code at the moment.  Is it really ready for security groups to go in?
21:12:42 <ewanmellor> It certainly won't work on XenAPI.
21:12:43 <soren> Bugs that require a feature freeze exception should say either "Feature Freeze Exception" or "FFe" in the subject. That way, they're easy to spot on the merge proposal page.
21:12:51 <soren> ...and to approve one, there must be 3 +1's.
21:12:55 <soren> and no -1's.
21:12:57 <soren> Sound good?
21:13:07 <sirp1> #agreed
21:13:11 <alekibango> #agreed
21:13:16 <ewanmellor> #agreed
21:13:18 <chmouel> #agreed
21:13:32 <xtoddx> #Agreed
21:14:03 <soren> Lazy consensus kicks in in 5
21:14:05 <soren> 4
21:14:07 <soren> 3
21:14:08 <soren> 2
21:14:10 <soren> 1
21:14:13 <soren> 0
21:14:16 <soren> #agreed Bugs that require a feature freeze exception should say either "Feature Freeze Exception" or "FFe" in the subject (to be easier to spot). To approve one, it must have 3 +1's and no -1's.
21:14:21 <soren> Wicked.
21:14:26 <soren> Alright, testing.
21:14:34 * alekibango goes to edit bug title :)
21:14:36 <soren> Who added that?
21:14:51 <chmouel> i did
21:14:53 <soren> chmouel: That was you.
21:14:54 <soren> :)
21:15:16 <chmouel> yes so aside of the unit testing what kind of real world testing stuff we have ?
21:15:22 <ewanmellor> #topic Testing
21:15:27 <soren> #topic Testing
21:15:38 <soren> ewanmellor: Thanks, I usually have people for this :)
21:15:41 <chmouel> i would not mind working on it i have plenty of resources for that in rs uk
21:16:08 <ewanmellor> Citrix is ramping up testing, but it won't be very useful for Austin.
21:16:14 <soren> Perhaps someone at Rackspace can speak up?
21:16:28 <alekibango> soren: maybe we could use FFE as a TAG
21:16:32 <creiht> soren: you work at rackspace :)
21:16:33 <soren> ewanmellor: Ok. Won't be ready or are you testing different things?
21:16:56 <soren> creiht: Indeed )
21:16:58 <soren> :)
21:17:09 <soren> Ok, maybe someone *physically* at Rackspace can speak up?
21:17:09 <creiht> hehe
21:17:15 <soren> I don't command much hardware for testing.
21:17:29 <chmouel> soren: i can have resources for hw from rs (EMEA at least)
21:17:50 <soren> Once I feel the packages are in good shape, I'll try throwing them on a bunch of cloud servers and use UML for testing.
21:18:26 <alekibango> soren: what about FFe as a TAG? would that be good ?
21:18:27 <soren> I don't know how different the NASA Nebula code is, but I'm hoping they'll converge very, very shortly, so that should give us some real-worl testing, too.
21:18:34 <soren> alekibango: Nah.
21:18:52 <soren> alekibango: I want it to be easy to spot from the merge proposal page (which just shows the bug title).
21:18:53 <ewanmellor> soren: There won't be much ready.  We'll be testing end-to-end properly with a new team by the end of the year.  For now it will be seat-of-the-pants.
21:19:03 <soren> ewanmellor: Alright.
21:19:07 <mtaylor> soren: _almost_ done with the hudson module to spin up cloud servers for us (the drizzle beta sapped some of my strength)
21:19:10 <soren> ewanmellor: No worries, I was just curious.
21:19:33 <soren> mtaylor: Awesome.
21:19:38 <mtaylor> hopefully should help support bigger testing
21:19:43 <soren> Yup.
21:19:51 <ewanmellor> soren: This will be a great topic for the summit of course.  Jay was also interested.
21:19:59 <soren> chmouel: Anything else you want to cover?
21:20:03 <soren> ewanmellor: Indeed.
21:20:14 <soren> Where is Jay, by the way?
21:20:25 <chmouel> soren: that's cool i probably going to get myself some testing over here and will cover the results somwehre on the wiki
21:20:47 <soren> chmouel: And file bugs! Lots of them! :)
21:20:54 <alekibango> i cant find how to change title  of my bug... in LP :)
21:21:07 <ewanmellor> soren: Jay's probably trawling down our merge requests one by one writing "Unit test please!" on the end of each one.
21:21:08 <soren> alekibango: Right next to the title, there's a pencil sort of thing.
21:21:52 <soren> Alright, next topic.
21:21:59 <soren> #topic Documentation
21:22:35 <chmouel> it would be nice to have a wiki page always updated like the swift 'all in one' for nova
21:22:41 <alekibango> chmouel: do you know how you can administer nova installation?
21:22:56 <alekibango> or how your users will do?
21:22:57 * soren pokes alekibango
21:23:01 <chmouel> alekibango: no not yet
21:23:10 <alekibango> we have no such documentation for nova
21:23:11 <soren> Ah, whoops :)
21:23:22 <alekibango> we cant expect annegentle to write it
21:23:31 <alekibango> i cant write it well -- and i am here for a month
21:23:38 <chmouel> i would not mind writing it
21:23:46 <chmouel> as long i get things working which i hope soon
21:23:50 <alekibango> i too, but i feel *very* uncertain
21:24:06 <alekibango> so, i would like to ask for some examples - how to install nova on 4 servers?
21:24:23 <chmouel> like deployement wise?
21:24:23 <alekibango> how to administer it? add hardware? add cluster?
21:24:40 <alekibango> how to add web console for endusers?
21:24:54 <soren> One problem with docs is that we've spent so much time on core features, we're only just now starting to get deployment sorted out.
21:24:57 <alekibango> how will endusers use the nova?
21:24:59 <xtoddx> should we make bugs for documentation?
21:25:01 <creiht> as an fyi, there is a push for documentation for an end user that might help with this
21:25:10 <soren> I expect the deployment side of things to change quite a bit over the next couple of weeks.
21:25:25 <chmouel> yeah it's kind of hard to have any deployment at this time
21:25:25 <creiht> I'm supposed to meet with bpiatt this evening about it
21:25:33 <alekibango> soren: even few lines would be very nice to have....
21:25:39 <chmouel> deployement guide even
21:25:41 <soren> ...since right now, there's lots of stuff that needs to be done manually and whatnot. I hope that changes now that things are settling.
21:25:42 <alekibango> yes
21:25:45 <alekibango> deployment guide
21:25:48 <alekibango> thats the word
21:25:53 <soren> Volunteers?
21:26:03 <alekibango> me+chmouel - but we need help
21:26:07 <soren> Sure.
21:26:13 <xtoddx> alekibango: ping me for help
21:26:13 <chmouel> yeah for sure
21:26:20 <soren> I'm happy to help any way I can.
21:26:21 <creiht> soren: I would ping jim curry, and brett
21:26:26 <creiht> also on this
21:26:33 <chmouel> i'll ping soren since he's more on my timezone :)
21:26:34 <alekibango> :)  i have 4 servers now - and i am not sure how to install nova on it - and what will i do when i will have another 4
21:26:37 <creiht> since there is a big need for docs for an end user
21:27:02 <alekibango> i can provide few servers for testing for few weeks if thats needed
21:27:08 <soren> creiht: _Would_ you or _will_ you? :)
21:27:16 <creiht> well I will be for swift :)
21:27:41 <creiht> not sure if they are talking to someone on the nova side yet
21:27:56 <alekibango> chmouel: i am in EU too
21:27:56 <creiht> just saying that it would be a good idea for someone over there to ping them to coordinate
21:28:34 <xtoddx> i'll work on docs from the nova side, if needed
21:28:35 <creiht> I'll ping them about it as well when I talk to them
21:28:36 <chmouel> i think there is two type of documentation needed one for end-user/deployment stuff and one for devs to get kick started
21:28:52 <alekibango> xtoddx: yes, its very needed - maybe if you can start with structure
21:28:54 <creiht> the part I am talking about is mainly for deployment
21:29:01 <alekibango> we wil try to add content as we will learn it
21:29:09 <soren> creiht: Great.
21:29:26 <alekibango> imho good docs are essential for adoption -- and release is near
21:29:27 <soren> I think deployment is our number 1 focues. Without deployments, we won't have end users anyway.
21:29:29 <creiht> soren: but it wouldn't hurt for someone on your side to ping them as well :)
21:29:30 <xtoddx> sure, once we settle down from our release later this week i'll start looking very seriously at sphinx docs
21:29:59 <soren> xtoddx: Excellent.
21:30:12 <soren> Anyone else want to say stuff on the subject of Documentation?
21:30:17 <alekibango> xtoddx: sphinx docs -- there are some. but there is no deployment docs
21:30:36 <michaeldreamhost> an organizational chart might be useful as well. for developers that are looking to get involved
21:30:50 <alekibango> soren: i might take that deployment docs as my goal for next week
21:30:51 <soren> michaeldreamhost: Yeah. There is some, but I fear it's somewhat out-dated.
21:31:01 <soren> alekibango: Sounds excellent.
21:31:05 <soren> Alright, moving on.
21:31:14 <creiht> soren: we probably should add a task for anne to coordinate the docs so that we don't duplicate effort
21:31:14 <soren> #topic Glance status
21:31:19 <sirp1> #info Glance (both teller and parallax) are functional; tested their
21:31:19 <sirp1> interaction using curl.
21:31:19 <sirp1> #info jaypipes is working on grafting GlanceImageService into Nova. He has merged in work
21:31:19 <sirp1> that exposes Parallax through the API.
21:31:19 <sirp1> #info Still remaining is adding in the _fetch_teller_image adapter and changing
21:31:20 <sirp1> use_s3 to something like FLAGS.image_service [ 'local', 's3', 'teller' ]. I
21:31:20 <sirp1> have an experiemental branch which does this.
21:31:23 <jc_smith> I know there are a lot of pieces in flight with the code in nova, but I'd love to see a reference architecture diagram that shows how a small production deployment would look, with different services logically split apart across different servers, its one thing to get the dev env working, but I find it challenging to take it to the next step
21:31:33 <soren> creiht: That's a good point.
21:31:52 <soren> creiht: Do you have her e-mail handy?
21:32:05 <creiht> soren: just sec
21:32:17 <ewanmellor> So is it planned for Glance to be fully working with Nova for austin?
21:32:27 <creiht> soren: anne@openstack.org
21:33:01 <alekibango> jc_smith: yes. thats what i am talking about :)
21:33:07 <sirp1> ewanmellor:  good question, i don't think we have much to do to have it working end to end, so i'd personally like to get it in
21:33:09 <soren> #info Anyone working on documentation, shoot anne@openstack.org an e-mail letting her know. She's our technical writer, so she'll be the best to keep track of everyone's efforts so we avoid duplication.
21:33:18 <sirp1> im curious what jaypipes opinion on this is
21:33:56 <soren> Alas, he is absent.
21:34:02 <ewanmellor> So does GlanceImageService not count as a "feature"?  It looks like one to me.
21:34:10 <soren> It certainly does to me.
21:34:13 <creiht> jc_smith: fyi on the swift side, we are working on setting up a reference implementation, but it may still be a bit down the road before we can get that all set up
21:35:11 <ewanmellor> I don't want to block it, so if it's ready to go in, then that's for nova-core to decide.  However, bear in mind that the later it lands, the less chance there is of it working with XenAPI in time.
21:35:48 <jc_smith> having setup both a swift cluster and nova one, I can say swift had way more documentation, all the conf properties were explained, detailed info on the rings, etc. Not so much on nova
21:35:52 <soren> I'd also be hesitant to merge it at this point, to be honest.
21:36:08 <gundlach> GlanceImageService is required for the OpenStack API's /images endpoint to work
21:36:09 <soren> jc_smith, creiht: We've moved on. Can you guys take this to #openstack, perhaps?
21:36:15 <gundlach> (unless we want to store images on the API servers themselves)
21:36:27 <gundlach> jpipes!  hi.
21:36:30 <sirp1> understood, i'd say if we did merge it, it should be clear that it is experimental and you flip the flags to glance at your own risk
21:36:31 <soren> jpipes: Greeting!
21:36:33 <soren> s
21:36:45 <jpipes> gundlach: heh, sorry :) had to take a neighbour's kid to doctor...
21:37:05 <ewanmellor> Why, what did you do to him?
21:37:13 <jpipes> ewanmellor: :)
21:37:17 <soren> jpipes: Opinions on Glance for Austin?
21:37:19 <alekibango> imho - glance is such important goal that we might rather move the release date a bit than miss that one
21:37:44 <jpipes> soren: I believe we should target Glance for post-Austin.
21:37:54 <soren> jpipes: Ok.
21:37:58 <alekibango> that looks like one down vote
21:38:07 <jpipes> soren: the skeleton is in there now...but there's still ways to go before it's usable..
21:38:15 <soren> I have to say that's my inclination, too, but I may be slightly biased.
21:38:46 <jpipes> sirp1, _0x44 and myself have made some good progress, but not enough to say "Glance is in Austin"
21:39:24 <soren> (If anyone cares: Glance is too late for Ubuntu 10.10, and I'd like at least the set of components and thus basic architecture of the packages in Ubuntu to match what we have in Austin (now that we couldn't actually get the final release in there)
21:39:50 <alekibango> why is release planned every 6 months? why not every week?
21:39:54 <soren> ..but I don't want that to be /the/ deciding factor.
21:40:05 <jpipes> alekibango: packaging.
21:40:10 <soren> alekibango: Sanity.
21:40:14 <soren> Mine.
21:40:19 <jpipes> lol
21:40:39 <alekibango> agile methodologies done right are able to deliver :)
21:40:46 <alekibango> maybe
21:40:46 <soren> We have daily built packages. That's enough release-early-release-often for me.
21:41:02 <jpipes> alekibango: you are talking about the trunk series, not a release...
21:41:03 <alekibango> soren: i understand that sanity bit.... :)
21:41:11 <soren> A proper release every three months seems good to me. So far, at least.
21:41:17 <jpipes> alekibango: a release is a packaged, stable set of components.
21:41:19 <alekibango> jpipes: yes, but big release monthly or bimonthly   could be nice :)
21:41:27 <jpipes> alekibango: yup, agreed.
21:41:37 <jpipes> alekibango: I think we'll get there eventually...
21:41:39 <soren> We're drifting..
21:41:43 <jpipes> indeed. sorry.
21:41:47 <soren> Are we done with Glance status?
21:41:54 <sirp1> done
21:41:58 <soren> \o/
21:42:03 <soren> #topic Blueprints
21:42:10 <soren> #topic Blueprint status, even.
21:42:16 <soren> So..
21:42:38 <soren> I'm an idiot. In the midst of the whole ORM refactor ordeal, I forgot to file a merge proposal for my Xen branch.
21:42:49 <soren> I've kept claiming it was done, but I lied.
21:42:53 <jpipes> ++ on being an idiot.
21:42:55 <jpipes> :P
21:42:56 <soren> (Inadvertently)
21:43:00 <creiht> #agreed
21:43:01 <creiht> :)
21:43:06 <soren> Hey!
21:43:09 <soren> :)
21:43:30 <soren> So, at least austin-xen is not done, but there's an FFE filed for it.
21:44:04 <soren> I'll be filing an FFe for security groups, too. It's been reviewed some and it's in production (I believe) at NASA, so it should be reasonably solid.
21:44:26 * soren double checks that he hasn't got more outstanding stuff.
21:44:29 <alekibango> soren: btw i cant edit my bug title  -> maybe because its triaged now
21:44:40 <soren> alekibango: Which one?
21:44:50 <alekibango> https://bugs.launchpad.net/nova/+bug/654843
21:44:51 * jpipes is focusing on bugs until release. will be pinging various parties about statuses and trying to get the undecided/new bug count down.
21:44:57 <creiht> the stats blueprint for swift hasn't been approved yet, as we are still reviewing it
21:45:04 <creiht> but will be done for austin
21:45:09 <soren> O_o
21:45:24 <soren> The bluprint isn't even done, and you still expect it to land?
21:45:28 <jpipes> alekibango: sure you can.  little yellow edit button next to the title of the bug
21:45:31 <ewanmellor> So, all these blueprints with austin- in the name that aren't merged.  What's happening with those?
21:45:45 <soren> ewanmellor: Retarget for austin+1.
21:45:56 <ewanmellor> Named bezar, right?
21:46:05 <creiht> soren: it is done, we are still reviewing (it is a large chunk of code and things have been busy over here)
21:46:07 <soren> bexar.
21:46:09 <jpipes> ewanmellor: some retargeted, some need a status update from Anso guys.
21:46:11 <alekibango> jpipes: wanna see screenshot? its not there...
21:46:20 <creiht> it is based on production code, so I'm not too worried about it
21:46:24 <soren> creiht: Ok, so the blueprints should be approved, but not the merge proposal, right?
21:46:27 <jpipes> alekibango: :( ok, I can edit for you I guess!
21:46:30 <creiht> soren: correct
21:46:32 <soren> alekibango: In #openstack, please.
21:46:33 <jpipes> alekibango: private message me
21:46:34 <alekibango> You are not the bug assignee nor the maintainer of OpenStack Compute (nova), and therefore cannot edit this bug's status
21:46:36 <soren> creiht: Phew :)
21:46:39 <creiht> hah
21:46:39 <alekibango> ok sorry soren
21:46:46 <ewanmellor> So who's responsible for renaming austin-foo to bexar-foo?  The blueprint owner, or the release manager?
21:46:52 <jpipes> ewanmellor: dendrobates
21:46:53 <soren> ewanmellor: Rick.
21:47:06 <creiht> yeah that is the only way he gets karma ;)
21:47:11 <jpipes> ewanmellor: I don't think anyone else has the permissions to do it for Nova blueprints..
21:47:21 <soren> jpipes: I do, but I don't want to :)
21:47:21 * jpipes doesn't
21:47:39 <soren> jpipes: I think it's just Rick and myself right now.
21:47:48 <soren> But Rick said he'd do it, so there.
21:48:12 <vishy> catching up on scrollback: security groups work, we've had to patch a few things which i will get to you soon soren, and we are having an issue with libvirt hanging which may be related to them
21:48:13 <soren> Does anyone else have anything interesting to say/ask about blueprints?
21:48:28 <ewanmellor> So are we expecting that all these are definitely not in austin:
21:48:34 <ewanmellor> austin-scheduler
21:48:40 <vishy> scheduler is in
21:48:44 <soren> vishy: Great, wanted to talk to you about this in #openstack earlier. Let's do that in a minute.
21:48:50 <soren> ewanmellor: scheduler is in.
21:48:50 <vishy> soren: ok
21:49:00 <ewanmellor> It's marked "Review" and "Started"
21:49:00 <soren> ewanmellor: Has been for... a while. At least a week.
21:49:02 <soren> Ancient history.
21:49:23 <ewanmellor> austin-nwfilter?
21:49:32 <ewanmellor> austin-microsoft-hyper-v-support?
21:49:39 <soren> Superseded by ec2-security-groups.
21:49:53 <soren> austin-microsoft-hyper-v-support: no news.
21:50:01 <soren> So not going to land for sure.
21:50:11 <jpipes> ewanmellor: yes, I brought that scheduler one up last week's meeting...unfortunately I cannot edit the status on it (dendrobates!)
21:50:20 <soren> jpipes: I'll do it.
21:50:23 <jpipes> soren: thx
21:50:34 <soren> Done.
21:50:39 <ewanmellor> And what about boot-whole-images?  That got wrapped up with Glance.
21:50:53 <soren> How are they related?
21:50:54 <alekibango> yes yes i love whole images
21:51:23 <ewanmellor> Justin's raw-disk-images branch is linked from the austin-image-stores blueprint.
21:51:26 <jpipes> ewanmellor: will have to ask sirp.  I do not know the status of that (but I would say pretty certainly it will NOT be in Austin)
21:51:29 <ewanmellor> I never understood why, precisely.
21:51:46 <soren> Sounds like a mistake?
21:51:55 <jpipes> soren: perhaps, I really don't know.
21:52:25 <ewanmellor> I'm a big fan of whole-disk-images.  It suits our usecases much better.
21:52:45 <vishy> raw-disk-images should be a simple addition, just no one actually merged justins patch, and now it is heavily bitrotted
21:53:34 <soren> Sounds like a target for Bexar.
21:53:46 <jpipes> #agreed
21:53:48 * soren senses we're about done.
21:54:03 <soren> Anyone else got anything for Blueprint status?
21:54:09 <soren> Going once.
21:54:13 <soren> Going twice.
21:54:24 <soren> #topic Any other business
21:54:47 <soren> Noone?
21:54:56 <ewanmellor> What's the austin release date?
21:54:57 <soren> Going once.
21:55:03 <alekibango> 21th
21:55:13 <soren> October.
21:55:16 <soren> 21st.
21:55:19 <soren> http://wiki.openstack.org/Release
21:55:40 <soren> Anyone else?
21:55:40 <ewanmellor> How much time do we need for packaging before then?
21:55:47 <ewanmellor> So, when's the last bugfix go in?
21:56:02 <alekibango> final freeze is in a week
21:56:15 <soren> ewanmellor: Ideally, Oct 14th.
21:56:18 * jpipes thinks dendrobates or soren should send an email to ML answering ewanmellor's ?s
21:56:32 <soren> ewanmellor: In reality, probably Oct 20th.
21:56:40 <soren> jpipes: Will do tomorrow.
21:56:55 <soren> Erk, I need to run for a minute.
21:56:55 <jpipes> soren: cool, thx
21:57:04 <jpipes> alright, end meeting?
21:57:33 <ewanmellor> I'm done.
21:57:42 <chmouel> done for me
21:57:48 <soren> back
21:57:56 <jpipes> soren: think we're done
21:57:59 <soren> Yay.
21:58:01 <soren> #endmeeting