20:00:39 <johnsom> #startmeeting Octavia
20:00:40 <openstack> Meeting started Wed Jun  1 20:00:39 2016 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:43 <xgerman> o/
20:00:44 <openstack> The meeting name has been set to 'octavia'
20:00:44 <fnaval> o/
20:00:44 <Frito> o/
20:00:45 <ajmiller_> Hi
20:00:49 <bana_k> Hi
20:00:50 <johnsom> Hi folks
20:00:54 <sg> Hi
20:00:56 <sbalukoff> Howdy folks!
20:00:57 <eranra> Hi
20:01:04 <johnsom> Welcome to another fine week in the land of LBaaS/Octavia
20:01:18 <evgenyf> o/
20:01:23 <sbalukoff> Yay!
20:01:26 <johnsom> #topic Announcements
20:01:35 <johnsom> Newton-1 was last week
20:01:54 <johnsom> Just as an FYI, we are starting the N-2 window
20:02:11 <johnsom> Along those lines there was discussion on the mailing list about:
20:02:14 <johnsom> Changing release model for *-aas services
20:02:21 <johnsom> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/096281.html
20:02:56 <xgerman> yep, the iron fist
20:02:59 <johnsom> Where it was proposed that *aas should go to release intermediate as opposed to with-milestones
20:03:13 <sbalukoff> What does that actually mean for neutron-lbaas and octavia?
20:03:25 <johnsom> However I think there was a realization that there may be bad side effects to that, so I think it's dead
20:03:33 <sbalukoff> Ok.
20:03:51 <sbalukoff> So, we get to continue to be a thorn in the side of Neutron folks. Yay!
20:03:59 <johnsom> It means nothing for Octavia.  For *aas it means they would not be making milestone releases on N1,N2,N3 etc.
20:04:11 <sbalukoff> Ok.
20:05:00 <johnsom> My last announcement is Flask broke Octavia (and other projects) recently
20:05:02 <rm_mobile> o/
20:05:07 <sbalukoff> Joy.
20:05:20 <johnsom> The requirements change is trickling out to exclude that release.
20:05:29 <sbalukoff> *nod*
20:05:56 <johnsom> Any other announcements before we move on to progress reports/bugs needing attention?
20:05:57 <TrevorV_> o/
20:06:00 <TrevorV_> sorry, was late
20:06:15 <rm_mobile> I'm in Cuba
20:06:27 * johnsom Hands those two a tardy slip
20:06:27 <rm_mobile> ... Cuba NM
20:06:28 <eezhova> there is also a fix would make Octavia work for Flask  0.10.1 and 0.11 https://review.openstack.org/#/c/323869/
20:06:28 <sbalukoff> rm_mobile: ...like ya do, eh?
20:06:47 <sbalukoff> eezhova: Great!
20:07:09 <johnsom> eezhova Yeah, that is great to have.
20:07:31 <johnsom> #topic Brief progress reports / bugs needing review
20:07:31 <rm_mobile> FYI I'm on PTO for travel this whole week so I haven't been and won't really be around
20:07:39 <johnsom> Ok, I will open the flood gate....
20:07:47 <eezhova> shall we need to backport this to mitaka and liberty?
20:08:11 <fnaval> #link https://review.openstack.org/#/c/308718/
20:08:11 <fnaval> #link https://review.openstack.org/#/c/310326/
20:08:11 <fnaval> #link https://review.openstack.org/#/c/317692/
20:08:16 <sbalukoff> Cool. I've been working on reviewing Octavia patches mostly. Am happy to review N-LBaaS patches if there are urgent ones there waiting on attention.
20:08:18 <johnsom> We probably should.  I know the exclusion is going into those, but it would be nice to have fixed
20:08:24 <xgerman> +1
20:08:28 <fnaval> workng on internal stuff this week but I still have some reviews up
20:08:29 <evgenyf> #link https://review.openstack.org/#/c/321413/2
20:08:41 <eezhova> #link https://review.openstack.org/#/q/status:open+branch:master+topic:bug/1585116
20:09:20 <sbalukoff> Ok, I'll try to have a look at all the patches linked here in the next few days.
20:09:38 <evgenyf> I have also cuople of changes in vendor code, unit test addition and a fix backport
20:09:40 <evgenyf> #link https://review.openstack.org/#/c/323188/1
20:09:47 <evgenyf> #link https://review.openstack.org/#/c/318153
20:10:08 <sbalukoff> evgenyf: Do those mostly concern Radware drivers? (ie. we can assume you've tested them?)
20:10:39 <a2hill> o/
20:10:54 <TrevorV_> #link https://review.openstack.org/#/c/257201/
20:11:00 <evgenyf> sbalukoff: there are unit test and a bug fix backport that merged master
20:11:12 <sbalukoff> evgenyf: Ok.
20:11:13 <TrevorV_> I need someone with +2 in Neutron LBaaS to seriously sit down and review the single-create
20:11:19 <TrevorV_> its been too long with all greens to not go in
20:11:29 * blogan stumbles in really late
20:11:33 <sbalukoff> Speaking of which: Did the governance changes go through yet?
20:11:46 <eezhova> #link https://review.openstack.org/#/c/310490/
20:11:58 <johnsom> dougwig had that action.  I have not gone and looked yet
20:12:16 <evgenyf> #link https://review.openstack.org/#/c/318513/5
20:12:33 <johnsom> sbalukoff No
20:12:38 <sbalukoff> D'oh!
20:12:45 <evgenyf> And this one is for neutron flavors plugin: #link https://review.openstack.org/#/c/318153
20:12:53 <sbalukoff> Well, we know that dougwig hates us.
20:12:55 <TrevorV_> #link https://review.openstack.org/#/c/318153
20:12:59 <dougwig> i do
20:13:07 * sbalukoff cries
20:13:07 <TrevorV_> The #link command has to be on its own line, otherwise the bot doesn't get it, I don't think
20:13:24 <xgerman> dougwig why?
20:13:30 <johnsom> Well, maybe just some of us
20:13:42 <sbalukoff> And by 'some of us' johnsom means me.
20:13:52 <dougwig> groups fixed
20:13:55 <johnsom> You said it, I didn't
20:13:56 <sbalukoff> Woot!
20:14:11 <dougwig> don't merge a neutron api change unless it has an approved rfe or blueprint for newton.
20:14:24 <sbalukoff> Ok.
20:14:29 <TrevorV_> dougwig what if the RFE went into an earlier release?
20:14:45 <sbalukoff> TrevorV_: That would be an 'approved rfe' then.
20:14:50 <xgerman> sure, was hoping I could finally add the things I always wanted
20:14:56 <sbalukoff> Haha!
20:14:58 <johnsom> Single create should be good with it's RFE
20:15:04 <TrevorV_> Sweetness
20:15:14 <TrevorV_> Then I definitely want some +A goodness on that
20:15:17 <johnsom> It was approved
20:15:44 <johnsom> #topic Octavia / Neutron-LBaaS mid-cycle
20:16:01 <johnsom> Ok, I am going to switch the agenda order slightly as I think the next topic will take more time
20:16:08 <johnsom> So, mid-cycle
20:16:10 <sbalukoff> Yep.
20:16:14 <sbalukoff> June is probably out at this point.
20:16:21 <sbalukoff> Neutron's is in August... and in Irelane.
20:16:21 <johnsom> When/Where/etc.
20:16:25 <sbalukoff> Ireland.
20:16:34 <xgerman> Cincinatti
20:16:47 <sbalukoff> I'm thinking August for ours as well...  no idea where.
20:16:55 <rm_mobile> Ah FYI I moved to Washington state so I'm good with having the midcycle up north :P
20:17:07 <johnsom> #link https://etherpad.openstack.org/p/lbaas-octavia-newton-midcycle
20:17:07 <rm_mobile> Though I'll be in Texas in August...
20:17:21 <sbalukoff> rm_mobile: Wait, what?
20:17:27 <rm_mobile> ... moved -> moving
20:17:36 <dougwig> latter half of august, pretty please.
20:17:51 * xgerman will look tm_work up when in Seattle
20:17:57 <rm_mobile> Driving through NM currently almost to UT
20:18:13 <sbalukoff> dougwig: Week of the 22nd of August?
20:18:35 <sbalukoff> rm_mobile: I love the roads there. :)
20:18:43 <sbalukoff> They're fun on a bike.
20:18:48 <xgerman> lol
20:18:49 <rm_mobile> Yeah it's crazy nice out right now and I'm in a convertible :P
20:19:16 <blogan> rm_mobile: get off your phone while driving
20:19:20 <TrevorV_> Depending on when in August, I may not be able to attend
20:19:46 <blogan> august-december is a no go for me
20:20:23 <rm_mobile> I'm on my off shift for driving
20:20:33 <rm_mobile> Surprised internet connection is holding up...
20:20:35 <sbalukoff> blogan: Any time in August?
20:20:42 <dougwig> sbalukoff: i suppose that could work, though i'll be flying from ireland to the lbaas one.
20:20:43 <dougwig> :)
20:20:51 <blogan> sbalukoff: babies could come anytime in august
20:20:57 <sbalukoff> blogan: right.
20:21:07 * johnsom think dougwig will be in charge of the beer....
20:21:09 <xgerman> blogan: congrats
20:21:10 <rm_mobile> Too early in August could be problematic for me
20:21:25 <sbalukoff> July is crappy for me.
20:21:30 <sbalukoff> But I can do any time in August.
20:21:31 <dougwig> late june?
20:21:38 <blogan> dougwig: thought you couldn't make the ireland one
20:21:39 <rm_mobile> Oh yeah July is 100% out for me
20:21:42 <sbalukoff> dougwig: So... like 3 weeks from now?
20:21:54 <dougwig> week of the 20th?
20:22:03 <dougwig> blogan: it got moved, so i can.
20:22:05 <blogan> don't make the date insane on account of me
20:22:11 <dougwig> week of june 20th, i mean?
20:22:16 <blogan> dougwig: didn't think thsoe 2 days would make a difference
20:22:20 <rm_mobile> I could do late June if it's up north I think
20:22:52 <sbalukoff> I could potentially do the week of June 20. I was hoping to give the folks working on active-active more time, though.
20:23:13 <sbalukoff> (Not that they're asking me for it, or anything... I don't actually know their state of readiness.)
20:23:16 <blogan> thats probably too soon for most folks
20:23:25 <johnsom> I may be busy the week of June 20th, though it's not clear whether I will be able to travel
20:23:35 <sg> sbalukoff: quite low..
20:23:40 <dougwig> so it's latter half of june (to give us 14 day on tickets), or way out there?
20:23:58 <sbalukoff> sg: Oh, cool! Are you one of the ones working on it? (Sorry, don't recognize the IRC handle)
20:24:18 <sbalukoff> dougwig: Sounds like it. And way out there will exclude blogan.
20:24:31 <sbalukoff> dougwig: but would probably be better for the active-active work.
20:24:34 <xgerman> unless Texas?
20:24:38 <TrevorV_> Don't forget, blogan is Neutron, not LBaaS for the most part.
20:24:41 <dougwig> sbalukoff: there could be two.
20:24:42 <TrevorV_> Just to clear up that necessity
20:24:46 <blogan> i'm all the things
20:24:55 <blogan> bad at all the things
20:25:01 <sbalukoff> xgerman: I'm willing to do Texas in August. I hear they have air conditioning technology.
20:25:04 <johnsom> Haha
20:25:35 * TrevorV_ hates Texas with the same burning passion pavement has on my feet during the summer
20:25:46 <sg> sbalukoff: ahm... I'm close to the team
20:26:24 <sg> (name's "Sergey")
20:26:26 <sbalukoff> sg: Cool. What's your name?
20:26:27 <sbalukoff> Oh!
20:26:29 <sbalukoff> Ok.
20:26:41 <dougwig> texas is good by me.
20:26:56 <TrevorV_> We just hosted.  Someone else's turn, remember?
20:27:04 <TrevorV_> Texas in the winter, elsewhere in the summer?
20:27:06 <TrevorV_> We talked aboutt his.
20:27:09 <TrevorV_> about this***
20:27:46 <sbalukoff> How many of you, seriously, would go to Boise during the weeks of June 22 or June 27?
20:27:53 <TrevorV_> o/
20:28:02 <rm_mobile> I could
20:28:15 <TrevorV_> sbalukoff that's a joke... I don't think we can be approved that fast.
20:28:19 <TrevorV_> We'd have to talk to our manager
20:28:40 <rm_mobile> I'd road trip with sbalukoff
20:28:47 <sbalukoff> Haha!
20:29:37 <dougwig> i'd go!  :)
20:29:59 <sbalukoff> I'd offer to host in Seattle, but Blue Box's offices are crowded as hell right now because they keep hiring and the move-in date for the new digs has been pushed back to next January.
20:30:05 <dougwig> depending on how many, we can either use our conference room, or i'll book one of the ballrooms downstairs.
20:30:36 <TrevorV_> sbalukoff I thought your family had a house or something that hosts like 10000 people
20:30:45 <sbalukoff> Ok, being serious again: Is June 22 or June 27 too soon to be feasible (for getting approval) for RAX folks? If y'all hosted it in San Antonio, would that make a difference?
20:31:16 <TrevorV_> sbalukoff maybe.
20:31:19 <sbalukoff> TrevorV_: Yep, assuming they're cool with having a bunch of nerds there during the day for a week, they've got more than enough room to host us.
20:31:35 <rm_mobile> I wouldn't want to do SAT in June honestly <_<
20:31:36 <TrevorV_> Since we've always rotated it I didn't start that conversation for us hosting.
20:31:38 <TrevorV_> I can ask.
20:31:42 <rm_mobile> But maybe
20:32:12 <TrevorV_> I will say this, with me "asking", we might not be sure until next week, which would push the date again, so I'd say its probably best to say August
20:32:16 <rm_mobile> I'm literally right now in the process of escaping Texas for the northwest
20:32:24 <johnsom> Ok, in light of time for other topics, please vote on the etherpad
20:32:41 <rm_mobile> Yeah probably a written vote would be best
20:32:44 <johnsom> The PNW is really nice right now (as long as you don't have grass alergies)
20:32:52 <johnsom> #link https://etherpad.openstack.org/p/lbaas-octavia-newton-midcycle
20:33:05 <johnsom> #topic Active-active topology stuff
20:33:07 <sbalukoff> I'm honestly not sure what we'd have to review by the end of June though. I mean-- we could just work through outstanding patches and bug reports...  but again, I'd kinda like to see us merging active-active code then, assuming it's in ready-enough state.
20:33:16 <johnsom> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/096393.html
20:33:32 <johnsom> #link https://review.openstack.org/#/c/234639/
20:33:45 <johnsom> Someone added this, please have the floor....
20:33:50 <sbalukoff> That was me.
20:34:03 <sg> yes, I was hoping to "buy a cheap ticket" for the virtual d'tor with that one
20:34:05 <sbalukoff> However, sg or eranra, would you like to have the floor instead of me?
20:34:18 <sg> it would be great to hear more people's say
20:34:38 <sg> I'm going to respond to sbalukoff email on the thread later though
20:35:12 <sbalukoff> Ok, on that front, I wanted to say: I feel like IBM is throwing enough resources at the active-active feature to make it a reality in Newton. However, just like with the L7 stuff, it's going to take others reviewing stuff to make it a reality.
20:35:34 <sbalukoff> I apologize I've not done much on the reviews there myself (until this week, actually)...
20:35:35 <johnsom> Wow, throwing down the gauntlet...
20:35:39 <sbalukoff> Haha!
20:35:51 <sbalukoff> But my thought here wasn't to accuse or anything...
20:35:57 <sbalukoff> It's just to raise awareness...
20:36:06 <johnsom> Well, this is a huge change, I REALLY don't want this to be a up to the minute thing
20:36:34 <eranra> We need to get the blueprints reviewed
20:36:38 <sbalukoff> That there are going to be a lot of medium-to-large patches to make this stuff happen. And if we want to get this in for Newton, we need to give ourselves enough time to work through the problems we're inevitably going to encounter.
20:36:44 <johnsom> This means docs too as I think there is going to be some additional setup required
20:36:49 <sbalukoff> johnsom: Agreed!
20:37:14 <sbalukoff> There's already some code up for people to have a look at. And I think the blueprint is pretty close to being ready for merge.
20:37:39 <sbalukoff> (Added a bunch of notes today to it, but they're all pretty minor--  I think active-active N+1 is designed well enough now in that document to merge.)
20:37:42 <johnsom> sbalukoff Have you +#'d the spec?
20:37:55 <sbalukoff> johnsom: I -1'ed it today.
20:38:02 <johnsom> Ok
20:38:09 <sbalukoff> But I expect my minor concerns will be addressed quickly
20:38:51 <johnsom> Things have been a bit challenging in my world recently, but I will make sure it is at the top of my list
20:39:00 <sbalukoff> So yeah--  by all means if you've not had a look at the blueprint in a while, please have a look!
20:39:03 <sbalukoff> Thanks!
20:39:07 <johnsom> Especially as we have code starting to go up for review
20:39:11 <sbalukoff> Yep!
20:39:34 <sbalukoff> That was my thought too. And I totally understand having other concerns vying for your time as well.
20:40:39 <sbalukoff> So... yeah.
20:40:57 <johnsom> Ok.  Any other comments/questions?
20:41:07 <sbalukoff> I think that's all I had to say about active-active at this time. But you can probably expect to see me bugging people for reviews and stuff on it. :)
20:41:14 <eranra> Containers plans?
20:41:17 <johnsom> Yes, good plan.
20:41:19 <TrevorV_> I just want to recap something on the front of "can we review this" that I want to see single-create in before something like ACTIVE-ACTIVE goes in, especially since its literally waiting on a second +2
20:41:23 <johnsom> Ok, next topic
20:41:30 <johnsom> #topic Open Discussion
20:41:33 <sbalukoff> TrevorV_: +1
20:41:40 <sbalukoff> TrevorV_: I think we can absolutely make that happen.
20:41:45 <TrevorV_> I'm really hoping so ha ha
20:41:51 <johnsom> Yeah, getting single create/single delete wrapped up is a priority as well.
20:42:09 <johnsom> I am worried about the client patches getting rejected in favor of OSC work
20:42:25 <sbalukoff> TrevorV_: It's already there in Octavia, eh. And Neutron-LBaaS isn't getting active-active (since topology stuff is behind-the-scenes for N-LBaaS)
20:43:00 <sbalukoff> johnsom: If the API lands, I think we have time to figure out the CLI stuff.
20:43:10 <sbalukoff> And again, that work should be orthogonal to the active-active work.
20:43:46 <johnsom> Yes, there is a client patch already.  There are comments on it about blocking it in favor of openstack client...  I want to head that off
20:43:57 <sbalukoff> johnsom: Ok!
20:44:16 <johnsom> So, once the api is cook, client is quick
20:44:29 <sbalukoff> Yep.
20:44:47 <johnsom> Ok, I think eranra asked about containers.
20:45:06 <johnsom> Yes, please, containers would be great!  girn
20:45:20 <johnsom> Some work started on that.  I'm not sure the current state.
20:45:24 <sbalukoff> So my thought was that magnum isn't great, because it ignores our use case: The whole point of containers for us is speed and footprint. And that means not running your containers inside of a VM. :P
20:45:37 <sbalukoff> But... isn't there another project that doesn't do that that recently started to gain momentum?
20:45:56 <blogan> nova lxc?
20:46:14 <johnsom> Yeah, there are some nova extensions.
20:46:21 <sbalukoff> Ergh... there was an internal e-mail thread I had with some other IBMers about it recently. Trying to remember the project name.
20:46:23 <blogan> and using magnum would help some if we just spun up one VM before the tests
20:46:47 <johnsom> I haven't kept up with kuryr to see how far they have come with the networking issues
20:46:58 <sbalukoff> Oh! Higgins!
20:47:26 <sbalukoff> blogan: I'm certainly not vetoing working with Magnum if people want to do that.
20:47:29 <eranra> Also lower footprint when n+1 will start working. So
20:47:31 <rm_mobile> Kubernetes
20:47:32 <johnsom> A reference to Magnum PI?
20:47:36 <rm_mobile> ? :P
20:47:56 <johnsom> #link https://wiki.openstack.org/wiki/Higgins
20:48:02 <sg> has anyone tested the KVM overhead impact on haproxy by any chance?
20:48:03 <dougwig> sbalukoff: are you referring to the canonical nova-compute-lxd driver?
20:48:05 <sbalukoff> johnsom: Yep, that's it.
20:48:14 <sbalukoff> dougwig: No, I was talking about Higgins.
20:48:31 <fnaval> lol i remember that
20:48:40 <rm_mobile> Nah Magnum is kinda dumb...
20:48:51 <dougwig> so that is going to fulfill the use case of "lightweight VM" that nova and everyone else is ignoring?
20:49:09 <sbalukoff> Higgins sounds like a better fit for our use case. I can start poking around to see if I can find out how close they are to having something usable.
20:49:25 <johnsom> Higgins seems very new-ish.  Started meetings last month it looks like
20:49:36 <sbalukoff> dougwig: That's the idea. Also, manage containers like other openstack resources, instead of managing a container management framework like Magnum does.
20:49:57 <xgerman> well, most container people swear on kubernetes
20:50:03 <rm_mobile> I still don't understand why anyone would want what Magnum provides... ever...
20:50:08 <johnsom> swear at or on?
20:50:14 <sbalukoff> Haha!
20:50:19 <Frito> lol
20:50:32 <xgerman> rm_mobile a vm you can have on OpenStack, amazon, etc. increases portability
20:50:37 <sg> I suspect containers might not be perfect for haproxy, as it spends a lot of time in kernel
20:50:49 <sbalukoff> I'll plan on lurking in a couple Higgins meetings in the next week or two to start feeling out the waters there.
20:50:52 <sg> and that requires kernel fine tuning
20:50:55 <xgerman> then there is that
20:51:20 <rm_mobile> Well, deployers can make dedicated cells for container hosts that have the necessary tweaks
20:51:28 <rm_mobile> That was our plan
20:51:29 <sbalukoff> Yep.
20:51:37 <sg> I see
20:51:45 <johnsom> Cool, I would like to hear an update on Higgins, so maybe sbalukoff can have an agenda item next week
20:52:02 <sbalukoff> Ok!
20:52:23 <blogan> waht about the migration from nlbaas to octavia/
20:52:25 <blogan> ?
20:52:28 <blogan> well the gap filling
20:52:42 <blogan> tahts a big chunk of work to do
20:52:44 <sbalukoff> blogan: Yep, we need to do that, too. :P
20:52:59 <johnsom> Ah yes.  The other chunk of stuff we need to at least make good progress on for Newton
20:53:01 <blogan> dougwig: thoughts, any news?
20:53:21 <blogan> dougwig: we were supposed to spend a day hammering out your driver
20:53:25 <sbalukoff> It would be nice to have a prioritized list of stuff to work off of... especially as we recruit new people to work on stuff, to know how they can be most effective for the project.
20:53:28 <dougwig> sorry, i've been buried. i will update the spec tomorrow.
20:53:37 <dougwig> blogan: can we put some time on the calendar for that?
20:53:39 <sbalukoff> johnsom: Would you mind putting together an etherpad on that?
20:53:40 <dougwig> (the driver)
20:53:42 <TrevorV_> I'll be working on those bits as soon as "life" calms down for me.
20:53:46 <blogan> dougwig: yes, what calendar?
20:53:55 <sbalukoff> johnsom: Like a "stuff that's on the radar, prioritized" or something?
20:54:13 <dougwig> didn't blogan have a spec for the details of what to do in octavia?
20:54:34 <johnsom> #link https://etherpad.openstack.org/p/lbaas-octavia-newton-priorities
20:54:53 <sbalukoff> johnsom: I can take a stab at an initial version of that if you want, but I feel like you've got a better over-arching view of Octavia + Neutron-LBaaS :)
20:54:58 <sbalukoff> Oh, nice!
20:55:15 <johnsom> sbalukoff If you could please take a start I will help as I can
20:55:22 <sbalukoff> johnsom: Will do!
20:55:31 <johnsom> sbalukoff Thanks!
20:55:37 <sbalukoff> #action sbalukoff to creep up on Higgins people and check them out
20:55:55 <sbalukoff> #action sbalukoff to take initial stab at prioritized list of Octavia Newton priorities.
20:55:55 <dougwig> phrasing.
20:56:11 <TrevorV_> Best phrasing
20:56:15 <sbalukoff> :D
20:56:17 <sg> lol
20:56:47 <blogan> sbalukoff: i do have a spec out in the wild with the list of things to be done
20:57:01 <sbalukoff> blogan: Yay!
20:57:03 <blogan> and its grouped by MUST and OPTIONAL
20:57:08 <sbalukoff> blogan: Link again, please?
20:57:18 <rm_mobile> https://imgur.com/3wOVnEV <- taken about 60 seconds ago
20:57:22 <blogan> #link https://review.openstack.org/#/c/310667/
20:57:22 <TrevorV_> #link https://review.openstack.org/#/c/310667/
20:57:26 <TrevorV_> DAMMIT
20:57:27 <blogan> first!
20:57:29 <TrevorV_> he BARELY beat me
20:57:53 <blogan> no one pastes me links of my links to myself but myself
20:57:58 <johnsom> I see where rm_mobile's priorities are...
20:58:07 <sbalukoff> blogan: Do you think this might be something better kept in an etherpad?
20:58:13 <sbalukoff> Or...  meh?
20:58:17 <blogan> rm_mobile: i could have used not seeing your face today
20:58:28 <fnaval> heh
20:58:37 <TrevorV_> sbalukoff we can have the spec, but then have the actual progress tracked in the etherpad, right?
20:58:42 <Frito> blogan: what you don't realize is it's now your desktop background!
20:58:43 <sbalukoff> Oh!
20:58:47 <blogan> sbalukoff: i think its good as a spec so we can all agree on it, then we cna transfer to etherpad to start checking the items off
20:58:52 <sbalukoff> Wait, that spec covers just the gaps.
20:59:01 <TrevorV_> sbalukoff that's for parity, yeah
20:59:03 <sbalukoff> Ok, so that will be something that goes into a list of 'all the shit we're working on'
20:59:07 <blogan> Frito: nooo
20:59:18 <xgerman> T-1
20:59:24 <Frito> coming up on time
20:59:26 <Frito> ha
20:59:29 <sbalukoff> blogan: Ok, I'll link to your spec on the etherpad.
20:59:39 <rm_mobile> Later all, disconnecting :P
20:59:43 <blogan> sbalukoff: read through it too and see if you see anything wrong or missing
20:59:44 <sbalukoff> I have a hard stop at 2:00, so I'll get on that later this afternoon / evening.
20:59:47 <rm_mobile> Soon: Utah
20:59:50 <sbalukoff> blogan: will do!
20:59:56 <sbalukoff> Ok, out of time.
20:59:58 <sbalukoff> thanks folks!
20:59:59 <xgerman> no Internet in Utah?
21:00:00 <fnaval> thanks!
21:00:08 <sg> thanks)
21:00:09 <xgerman> o/
21:00:16 <TrevorV_> \o
21:00:18 <Frito> later all
21:00:21 <eranra> Night
21:00:44 <johnsom> #endmeeting