20:01:11 <johnsom> #startmeeting Octavia
20:01:12 <openstack> Meeting started Wed Mar 16 20:01:11 2016 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:16 <openstack> The meeting name has been set to 'octavia'
20:01:17 <sbalukoff> Howdy, howdy!
20:01:25 <markvan> o/
20:01:36 <johnsom> #topic Announcements
20:01:47 <johnsom> Octavia 0.8.0 released!
20:01:55 <sbalukoff> Woot!
20:02:15 <xgerman> Yeah!
20:02:18 <johnsom> #link http://lists.openstack.org/pipermail/openstack-announce/2016-March/001014.html
20:02:34 <johnsom> So, that is excellent!
20:02:34 <ajmiller> Very cool!
20:02:48 <sbalukoff> Yep, yep!
20:03:04 <bharathm> o/
20:03:10 <johnsom> The LBaaSv2 dashboard will be released after this meeting.  We had to wait for a governance patch to merge, so that got delayed.
20:03:34 <xgerman> awesome
20:03:35 <sbalukoff> And the governance patch just merged this morning.
20:03:37 <johnsom> Anyway, thank you to the whole team for your effort in getting 0.8 out the door for Mitaka
20:03:46 <johnsom> Yep
20:03:48 <sbalukoff> This puts the UI on the same release schedule as Octavia, right?
20:04:08 <johnsom> Well, um, yes.  That topic is coming up next....
20:04:14 <sbalukoff> Heh! Ok.
20:04:25 <johnsom> Any questions about the release?
20:04:49 <johnsom> #topic Governance issues
20:05:22 <johnsom> So, my comment yesterday "We aren't part of Mitaka?????" based on the e-mail I got back from the release team:
20:05:29 <johnsom> "Because octavia uses the release:independent project, we don't want you to say it is "part of the mitaka release series""
20:05:47 <sbalukoff> So, as usual, we are the red-headed stepchild.
20:06:47 <johnsom> Apparently back in January we got moved out of the release because we didn't do an M-1:
20:06:48 <TrevorV|Home> As is tradition
20:06:50 <johnsom> #link https://review.openstack.org/#/c/272696/
20:07:05 <sbalukoff> *sigh*
20:07:11 <xgerman> sneaky
20:07:15 <johnsom> I think it's a bit evil that no Octavia PTLs were included in that review.
20:07:35 <sbalukoff> Awesome that they communicate these decisions in such an apropos and timely manner.
20:07:42 <johnsom> So, we have a decision to make.
20:07:52 <johnsom> #link http://governance.openstack.org/reference/tags/index.html#release-management-tags
20:08:41 <johnsom> The release tags are of interest.  After learning of this I read through them and I think we were working under the "release:cycle-with-intermediary" ideals
20:09:06 <johnsom> Meaning we would be releasing on the OpenStack six month cycle.
20:09:49 <johnsom> So, the decision we need to make is do we stay release:independent and "not be part of the release" or do we switch to release:cycle-with-intermediary?
20:10:26 <johnsom> We could go back to milestones too.  We decided to not cut M1 as it wouldn't have been that exciting.
20:10:41 <johnsom> Thoughts?
20:10:43 <sbalukoff> Will (how) this affect anyone from using the software? Anyone who has been contributing, mostly?
20:11:37 <xgerman> probably not but we are cutting releases every 6 months so...
20:11:44 <johnsom> Well, it's about alignment IMO.  We need to line up with neutron-lbaas and the client to some degree.
20:11:57 <johnsom> I also worry about the impact with the packagers.
20:12:05 <sbalukoff> Until / unless we become completely independent. Yes.
20:12:16 <sbalukoff> Right.
20:12:22 <xgerman> yes, as a packager it would be convenient to have them released at the same time
20:12:30 <TrevorV|Home> Actually, I think we should have another conversation in this one's place, that will also answer this question
20:12:52 <sbalukoff> If we change, I suspect it would make things awkward for Octavia to be the reference implementation at that point?
20:12:54 <johnsom> Ok
20:13:05 <TrevorV|Home> At the last midcycle, we discussed "what we need" to get octavia to replace neutron LBaaS, I think we should revisit this in our list of priorities
20:13:21 <sbalukoff> TrevorV: For the Newton cycle, certainly.
20:13:29 <neelashah> yes, sbalukoff - I had the same question - if octavia is the reference impl, it makes sense for it to be part of the release
20:13:31 <johnsom> Well, it's awkward now as Octavia is independent, neutron-lbaas is not
20:13:35 <sbalukoff> Is there an immediate decision that needs to be made?
20:14:00 <sbalukoff> johnsom: Right.
20:14:01 <TrevorV|Home> I'm not trying to say we should make a decision per-say, but we should definitely have that as a shorter term goal than just "when we get to it"
20:14:02 <sbalukoff> So...
20:14:13 <TrevorV|Home> If we intend to do it, I mean
20:14:48 <johnsom> If we want to switch to release:cycle-with-intermediary we probably need to do that close to the start of the cycle
20:15:00 <xgerman> and the repos just opened
20:15:05 <sbalukoff> what I'm hearing here is that we have been trying to be part of the release, we are surprised that once again we were cut out of the decision on this in ways one could construe as being mean to fly under the radar, and that we really should be releasing on the same schedule as neutron-lbaas. At least for now.
20:15:06 <johnsom> I didn't ask for specific timelines on that.
20:15:54 <sbalukoff> So, I think we want to be on the same cycle as the release. Others thoughts?
20:16:04 <neelashah> +1
20:16:14 <TrevorV|Home> Yeah, are we not intending to replace neutron lbaas anymore?
20:16:19 <johnsom> I think we still need to make this decision even if we plan to pull neutron-lbaas out of neutron in Newton.  We still need to decide if we want to be on the six month OpenStack cycle
20:16:38 <sbalukoff> TrevorV: Regardless of whether we do that, we probably still need to be on the standard OpenStack release cycle.
20:17:05 <johnsom> I feel the same.  I think it is in our best interests to be on release:cycle-with-intermediary
20:17:06 <TrevorV|Home> sbalukoff, I was taking it the other route, if we intend to replace it, we definitely need to be on the openstack release cycle, otherwise it doesn't really matter
20:17:26 <xgerman> johnsom +!
20:17:28 <sbalukoff> The 6-month cycle can be a serious pain (as we all know), but it does mean we at least have hard deadlines, and this can help to get stuff done faster.
20:17:47 <johnsom> sbalukoff +100
20:18:08 <TrevorV|Home> Alright, so I'm not hearing any "don't do that" for the 6-month cycle
20:18:15 <TrevorV|Home> I'm okay with it as well
20:18:17 <sbalukoff> For example, I'm pretty sure I wouldn't have been able to beg, please, and threaten my way into getting y'all to review L7 if it weren't for the deadline. ;)
20:18:28 <johnsom> Should we vote?  (though it's lost that Doug isn't here)
20:18:29 <sbalukoff> plead
20:18:31 <TrevorV|Home> Right, ha ha, same for single-create in octavia
20:18:56 <sbalukoff> I don't hear any dissenting voices, so I'm not sure a vote is necessary.
20:19:09 <sbalukoff> Let's just note the decision and move on, eh?
20:19:21 <johnsom> #startvote Should we move to release:cycle-with-intermediary? Yes, No, eh
20:19:21 <openstack> Begin voting on: Should we move to release:cycle-with-intermediary? Valid vote options are Yes, No, eh.
20:19:22 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:19:28 <sbalukoff> #vote Yes
20:19:29 <TrevorV|Home> #vote Yes
20:19:34 <bharathm> #vote Yes
20:19:37 <madhu_ak> Yes
20:19:38 <johnsom> #vote Yes
20:19:40 <ajmiller> #vote Yes
20:19:41 <minwang2> #vote YES
20:19:46 <johnsom> Make it all official and such
20:19:48 <neelashah> #vote yes
20:19:49 <madhu_ak> #vote Yes
20:19:50 <sbalukoff> Haha
20:19:51 <xgerman> #vote Yes
20:19:54 <bharathm> Unanimous it is
20:20:26 <johnsom> Going once...  No blogan rm_work today?
20:20:41 <sbalukoff> yeah, that's odd. Maybe the change in meeting time threw them off?
20:20:43 <TrevorV|Home> johnsom, they're "joining" now methinks... at least rm_work is
20:20:50 <johnsom> ptoohill?
20:20:50 <TrevorV|Home> We're REALLY busy with internal stuff
20:20:50 <sbalukoff> Or rather, the change in daylight savings.
20:20:54 <TrevorV|Home> ptoohill, is off this week
20:20:57 <TrevorV|Home> Spring break and all
20:21:03 <sbalukoff> Cool.
20:21:15 <johnsom> Ok, well, not waiting.
20:21:17 <johnsom> #endvote
20:21:18 <openstack> Voted on "Should we move to release:cycle-with-intermediary?" Results are
20:21:19 <openstack> Yes (8): xgerman, johnsom, neelashah, bharathm, madhu_ak, TrevorV|Home, ajmiller, sbalukoff
20:21:47 <johnsom> Next topic along those lines....
20:21:54 <johnsom> stable:follows-policy tag
20:22:14 <johnsom> The current "has stable branch" tag, which Octavia has, is going away.
20:22:29 <johnsom> You have to "apply" to get the new one.
20:22:37 <johnsom> #link https://bugs.launchpad.net/bandit/+bug/1557697
20:22:38 <openstack> Launchpad bug 1557697 in Bandit "bandit-baseline doesn't work on a detached head state" [Undecided,New]
20:22:47 <johnsom> This went out in a small e-mail on the 7th.
20:22:54 <johnsom> Opps, wrong link
20:22:55 <xgerman> wrong link?
20:23:02 <johnsom> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088592.html
20:23:35 <johnsom> Do we want to apply for this?
20:23:43 <xgerman> why not?
20:23:59 <sbalukoff> I think it sounds like a good idea.
20:24:00 <xgerman> is there a downside?
20:24:02 <johnsom> From what I can see, we follow the policy they define.  It's just work to get blessed...
20:24:05 <sbalukoff> What are the implications of this tag?
20:24:14 <sbalukoff> Aah.
20:24:15 <sbalukoff> Ok.
20:24:21 <johnsom> #link http://governance.openstack.org/reference/tags/stable_follows-policy.html
20:24:25 <sbalukoff> Another hoop to jump through.
20:25:20 <johnsom> Personally, I think this is another way to be friendly to packagers, so I support it.
20:25:21 <TrevorV|Home> Doesn't sound like a super difficult one though sbalukoff
20:25:24 <sbalukoff> Ok, I think the "upside" is that we're considered "more legitimate" as a project if we have that.
20:25:36 <sbalukoff> So yes, let's do it.
20:25:40 <johnsom> I am a bit annoyed at the process here, but will do the foot work if we decide we want it.
20:25:44 <xgerman> +1
20:26:17 <johnsom> #vote Should we apply for the stable:follows-policy tag? Yes, No, eh
20:26:23 <sbalukoff> Thanks for taking on the yak-shaving on that, johnsom.
20:26:27 <sbalukoff> #vote Yes
20:26:31 <johnsom> #startvote Should we apply for the stable:follows-policy tag? Yes, No, eh
20:26:31 <xgerman> startvote johnsom
20:26:31 <sbalukoff> Er...
20:26:32 <openstack> Begin voting on: Should we apply for the stable:follows-policy tag? Valid vote options are Yes, No, eh.
20:26:33 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
20:26:41 <xgerman> #vote Yes
20:26:46 <ajmiller> #vote Yes
20:26:48 <TrevorV|Home> #vote Yes
20:26:49 <bharathm> #vote Yes
20:26:51 <minwang2> #vote Yes
20:26:52 <johnsom> #vote Yes
20:26:52 <sbalukoff> #vote Yes
20:26:54 <madhu_ak> #vote Yes
20:27:03 <neelashah> #vote yes
20:27:55 <johnsom> Okey-dokey
20:28:02 <johnsom> #endvote
20:28:03 <openstack> Voted on "Should we apply for the stable:follows-policy tag?" Results are
20:28:04 <openstack> Yes (9): xgerman, johnsom, sbalukoff, minwang2, bharathm, madhu_ak, TrevorV|Home, ajmiller, neelashah
20:28:18 <johnsom> So, I will start the governance fun.
20:28:37 <sbalukoff> Yey!
20:28:37 <johnsom> #topic Update on Bandit gate
20:28:39 <xgerman> thanks for doing that
20:29:24 <johnsom> Our new experimental gate for Bandit (security check) is failing.  I guess our code is checked out in detached head state, which bandit doesn't like.
20:29:36 <johnsom> They have a bug and are going to work on it:
20:29:42 <johnsom> #link https://bugs.launchpad.net/bandit/+bug/1557697
20:29:43 <openstack> Launchpad bug 1557697 in Bandit "bandit-baseline doesn't work on a detached head state" [Undecided,New]
20:29:51 <johnsom> So, WIP...
20:29:57 <sbalukoff> Ok.
20:29:58 <johnsom> Just wanted to give an update
20:30:04 <sbalukoff> It'll be nice to have that once it's ready, eh.
20:30:28 <johnsom> #topic Brief progress reports / patches needing reviews
20:30:44 <minwang2> The following 3 patches need code review #link https://review.openstack.org/#/c/285596/
20:30:44 <minwang2> #link https://review.openstack.org/#/c/285596/
20:30:45 <minwang2> #link https://review.openstack.org/#/c/289595/
20:31:04 <johnsom> I plan to look at the file permission one and the config one today, after I get the dashboard released.
20:31:20 <minwang2> cool, thanks!
20:31:23 <johnsom> I have opened the Newton series on launchpad so we can start planning work
20:31:43 <sbalukoff> I plan to work on an L7 scenario test, though it sounds like documentation might be more urgent, so I may do that first.
20:31:52 <sbalukoff> When would be a good time to talk about docs?
20:32:17 <johnsom> Oh yeah, I will try to pull the deleted docs into our repo.  Resurrect if you will.
20:32:25 <sbalukoff> Sweet!
20:32:30 <madhu_ak> Anyone aware of the latest gate failure: http://paste.openstack.org/show/qnohA0SkT8DbdWUG1xH0/
20:32:31 <madhu_ak> ?
20:32:59 <johnsom> You have to look in the devstack log to see the error
20:33:32 <bharathm> It's the "add-apt-repository" cmd missing error
20:33:35 <madhu_ak> Okay, will check.
20:33:37 <johnsom> I noticed an odd one on minwang2's patch.  Something like the apt tool was missing
20:33:53 <madhu_ak> Its ailing in all the patches though. So curious..
20:33:56 <madhu_ak> failing*
20:34:02 <johnsom> Yeah, haven't looked into that yet
20:34:04 <bharathm> I noticed all gates were failing because of that on minwang2 and banak patches
20:34:18 <xgerman> mmh
20:34:20 <johnsom> Joy
20:34:39 <johnsom> Well, if anyone has time, feel free to chase it
20:34:46 <minwang2> i am checking the log now, this morning it passed the gate though
20:35:01 <madhu_ak> we have a TLS(with intermediates) scenario tests working and need reviews for #link: https://review.openstack.org/#/c/164828/
20:35:08 <sbalukoff> It would be good to know whether it's "our" problem or one that affects multiple projects.
20:35:21 <sbalukoff> Nice!
20:35:44 <madhu_ak> #link https://review.openstack.org/#/c/164828/ - Need to reuse methods though, but that will be in a separate commit
20:36:05 <sbalukoff> *nod*
20:36:22 <johnsom> #topic Open Discussion
20:36:31 <sbalukoff> Ooh--
20:36:33 <johnsom> sbalukoff You had a docs topic?
20:36:37 <sbalukoff> Yep.
20:36:55 <sbalukoff> So, I had a meeting with IBM docs people yesterday.
20:37:18 <sbalukoff> They're happy to help refine the language and organization we do on our docs, but of course the bulk of the content needs to be provided by us.
20:37:30 <sbalukoff> I have this etherpad defining docs we could use:
20:37:32 <sbalukoff> #link https://etherpad.openstack.org/p/lbaas-octavia-docs-needed
20:37:43 <johnsom> Yes, good stuff
20:37:52 <xgerman> +1
20:38:02 <sbalukoff> Also, I understand from dougwig that neutron leadership wants / needs us to put together some devref documentation for features added in mitaka to be considered complete.
20:38:11 <sbalukoff> I would like to divide and conquer on this if we can.
20:38:36 <sbalukoff> I'm happy to work on L7 stuff, and resurrect that old patchset which is a 'getting started' guide for getting stuff installed.
20:38:59 <sbalukoff> Someone needs to move the neutron-lbaas API ref from the wiki page it's currently on into the neutron-lbaas project, docs directory.
20:39:08 <johnsom> Ok cool.  Should we put these into RFE bugs that people can grab?
20:39:17 <xgerman> +1
20:39:18 <sbalukoff> And, as johnsom said, we should try to recover the docs from the main manual that were deleted and get them into our repo.
20:39:27 <sbalukoff> johnsom: Yes!
20:39:35 <sbalukoff> johnsom: Want me to handle that?
20:39:42 <johnsom> Sure!
20:39:46 <sbalukoff> Ok!
20:39:54 <johnsom> Just tag them with RFE
20:40:02 <sbalukoff> #action sbalukoff to open bugs listing docs needed (RFE bugs)
20:40:28 <sbalukoff> Ok, any questions about docs?
20:40:38 <johnsom> I hope they come out in small enough chunks that it is easy to grab one and get it done quickly.
20:40:53 <sbalukoff> I hope so too. I'll open lots of bugs. :)
20:41:07 <johnsom> Sounds good
20:41:13 <rm_work> sorry blogan and ptoohill both PTO today, and i am insanely distracted by everything here, just got on
20:41:40 <xgerman> it was a day of two votes
20:41:47 <johnsom> rm_work You missed the governance votes.  check the log.
20:41:50 <sbalukoff> rm_work: You've got quite the back-log.
20:42:01 <xgerman> also neither blogan nor ptoohill should be allowed to take PTO on Mwefnesday
20:42:05 <johnsom> Ok, any other topics?
20:42:05 <rm_work> yeah trying to read
20:42:26 <sbalukoff> Where are we at on the tempest test stuff?
20:42:39 <rm_work> uhh, fnaval is PTO today <_<
20:42:42 <sbalukoff> HAHA!
20:42:43 <johnsom> Good question.  I think we need to do some reviews there.
20:42:43 <rm_work> ot sure
20:42:45 <rm_work> *not sure
20:42:47 <sbalukoff> RAX is totally AWOL today.
20:42:54 <madhu_ak> we have working octavia scenario tests
20:43:03 <xgerman> yep, the castle is empty
20:43:04 <sbalukoff> Yay!
20:43:25 <madhu_ak> fnaval asked for some ideas #link: https://review.openstack.org/#/c/172199/
20:43:27 <johnsom> I will try to take a look at those tomorrow.  I plan to work on a scenario test for failover
20:43:34 <sbalukoff> Cool.
20:44:13 <xgerman> +1
20:44:24 <madhu_ak> Also, note we are not maintaining tempest tests in lbaas repo
20:44:38 <madhu_ak> tempest libraries*
20:44:42 <sbalukoff> madhu_ak: Oh!
20:44:45 <sbalukoff> I was going to say...
20:44:55 <johnsom> Yeah, that needs to get fixed too
20:45:21 <madhu_ak> it is already merged I guess: #link: https://review.openstack.org/#/c/273817/
20:45:53 <johnsom> Oh, nice!  I missed that it got merged.
20:46:06 <sbalukoff> Rad!
20:46:19 <johnsom> That reminds me.  What do we want to do about the session persistence issues?
20:46:40 <johnsom> I'm getting to the point that we should disable that test until we can resolve it's issues.
20:46:44 <sbalukoff> Are we still no closer in figuring out why they fail?
20:47:04 <sbalukoff> I haven't looked closely into them in over a week, so I'm not sure.
20:47:11 <johnsom> sbalukoff You and I have both put attempts out there, but it is still failing
20:47:11 <madhu_ak> I had the same thought of skipping the test, ut when I do recheck again and again, it passes and the other one fails..
20:47:22 <sbalukoff> Though the session persistence patches of mine merged, so hopefully that's less to troubleshoot.
20:47:46 <sbalukoff> madhu_ak: Do you think it's a timing issue?
20:47:54 <sbalukoff> As in, the test overall just takes too long to run?
20:47:55 <johnsom> This one is still up for review: https://review.openstack.org/#/c/278874/ but doesn't fully solve the issue
20:48:02 <sbalukoff> And if so, would it help to split it up?
20:48:22 <johnsom> It might
20:48:44 <madhu_ak> many factors sbalukoff: timing, cookie is not being worked properly, http 503 error (ike johnsom linked the above link)..
20:49:19 <johnsom> I will clean up that patch and try to drive to get it in.  Like I said, I don't think it will fix it, but might help
20:49:48 <madhu_ak> yeah, I ran full tests this morning, able to succeed them
20:50:14 <johnsom> Yeah, last time I worked on this, it passes fine on my local system
20:50:17 <sbalukoff> Does anyone here want to volunteer to split that test into smaller tests?
20:50:30 <sbalukoff> Right-- I've never been able to get it to fail locally.
20:50:35 <johnsom> I will not have time this week, sorry
20:50:41 <sbalukoff> I won't either.
20:50:43 <sbalukoff> In fact...
20:50:56 <xgerman> internal stuff is keeping me busy
20:50:57 <sbalukoff> I would say, nobody should, because if you have cycles, you should be working on docs. ;)
20:51:21 <xgerman> but if you get writers block?
20:51:22 <johnsom> Well, we need to get our scenario gate working again.
20:51:23 <sbalukoff> And yes--  it's looking very likely that internal stuff is going to eat a lot of my time over the next month.
20:51:24 <madhu_ak> internal stufffffff..
20:51:44 <minwang2> i will be out of town tomorrow…
20:51:56 <johnsom> Ok, let's put it on our todo lists, if you get time great.
20:52:04 <johnsom> Otherwise I will bring it up again next week
20:52:05 <sbalukoff> Ok.
20:52:10 <xgerman> k
20:52:21 <johnsom> Anything else?
20:53:04 <johnsom> Ok, thanks again for the work on Octavia 0.8.0!
20:53:08 <johnsom> #endmeeting