20:00:07 <johnsom> #startmeeting Octavia
20:00:13 <openstack> Meeting started Wed Dec 16 20:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is johnsom. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:17 <openstack> The meeting name has been set to 'octavia'
20:00:27 <johnsom> Hi folks
20:00:44 <johnsom> #topic Announcements
20:01:18 <johnsom> LBaaS/Octavia/FWaaS mid-cycle Jan 12-15th in San Antonio
20:01:28 <johnsom> #link https://etherpad.openstack.org/p/lbaas-mitaka-midcycle
20:01:53 <eranra> hello
20:01:54 <johnsom> GSLB/Kosmos mid-cycle Jan 20-22 in Seattle
20:02:04 <johnsom> #link https://etherpad.openstack.org/p/kosmos_2016_winter_midcycle_meetup
20:02:14 <johnsom> Hi eranra, welcome
20:02:18 <kobis> hi
20:03:02 <johnsom> We will be taking a break for this meeting.  We will resume January 6th.
20:03:10 <johnsom> Any other announcements?
20:03:17 <ajmiller> Hi
20:03:38 <johnsom> #topic Brief progress reports
20:04:36 <johnsom> I have been working on testing/bug fixes for the active/standby fail over flow.  Deleting the LB now works correctly.  I hope to wrap that up today.  I have one more bug to look into.
20:05:19 <johnsom> I also found that our health monitoring had a problem.  We were failing over deleted amphora.   I have a couple of patches in progress for that too.
20:05:40 <johnsom> Any other progress reports?
20:05:59 <johnsom> #topic Bug review
20:06:26 <johnsom> Ok, I wanted to bring some visibility to the bugs we have in launchpad for Octavia.
20:06:53 <johnsom> We will see how this goes.  This week might not be the best week to start as we have a low turnout
20:06:55 <dougwig> i'm hoping one of them is whatever is making the lbaas gate semi-random.
20:07:29 <johnsom> I am starting with the open critical bugs.
20:07:52 <johnsom> dougwig I don't think we have an open bug for the one I have seen related to test order.
20:08:08 <johnsom> #action johnsom to open bug for test order bug
20:08:27 <johnsom> First up: #1490033 Devstack scripts need to enable lb-network controller IP
20:08:58 <johnsom> This one is about not having an interface on the lb-mgmt-subnet available for the controller when running under devstack
20:09:24 <johnsom> It needs somebody that knows how to plumb in the interface under devstack.
20:09:54 <johnsom> #1491560 Deleting a non-existing member deletes the actual member
20:10:17 <johnsom> Next is a member issue.  Has anyone tried this out recently?  I haven't had a chance.
20:11:03 <johnsom> I'll take that as a no.
20:11:13 <johnsom> #1509706 Failover fails when instance is deleted
20:11:35 <johnsom> This one needs some discussion.  Again, might need to bring up again when folks are back.
20:11:43 <dougwig> i think everyone is drunk on egg nog or something.
20:12:10 <johnsom> The issue here is the fail over flow expects the amphora to be present in nova to gather information from it.
20:12:41 <johnsom> If, for whatever reason, the amphora is no longer in nova fail over fails.
20:13:33 <johnsom> I think this is a bug, but it could be an RFE type thing.
20:13:49 <johnsom> Any comments?
20:14:01 <eranra> johnsonm, any specific one,  to pick? i need to practice bug fixing
20:14:47 <johnsom> eranra Great!  I would recommend investigating the 1491560 or the next one 1514510 as starters
20:15:01 <eranra> will do.
20:15:03 <johnsom> #1514510 Delete of last member does not remove it from haproxy config
20:15:21 <johnsom> Again this is one that probably needs to be re-tested and confirm it is still an issue.
20:16:11 <johnsom> So, those are the currently open critical bugs.  Please feel inspired to take one on!
20:16:47 <johnsom> #topic Holiday meeting schedule
20:17:09 <johnsom> As I mentioned earlier, we will pick up these meetings on January 6th.
20:17:19 <johnsom> #topic Open Discussion
20:17:25 <johnsom> Any other topics?
20:17:54 <dougwig> fastest lbaas meeting ever.
20:17:57 <dougwig> move to adjourn.
20:18:00 <johnsom> grin
20:18:09 <johnsom> Ok, have a great break folks!
20:18:15 <johnsom> #endmeeting