20:00:51 <xgerman> #startmeeting Octavia
20:00:51 <openstack> Meeting started Wed Sep 30 20:00:51 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:52 <rm_work> that is a lot of arms
20:00:52 <blallau> Hi
20:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:55 <rm_work> o/
20:00:56 <openstack> The meeting name has been set to 'octavia'
20:00:57 <TrevorV> o/
20:00:58 <johnsom> o/
20:00:59 <xgerman> #chair blogan
20:01:00 <openstack> Current chairs: blogan xgerman
20:01:00 <sbalukoff> Howdy, folks!
20:01:01 <minwang2> o/
20:01:10 <bharathm> o/
20:01:17 <johnsom> Someone ate their wheaties this morning
20:01:18 <xgerman> #topic Announcements
20:01:28 <crc32> o=/
20:01:31 <ajmiller> hi
20:01:33 <blogan> chemically infused wheaties
20:01:35 <crc32> hello
20:01:38 <xgerman> Mitaka design summit topics  #link  https://etherpad.openstack.org/p/neutron-mitaka-designsummit
20:02:10 <xgerman> please add, +1, etc. if something is interesting to you
20:02:28 <sbalukoff> Sweet.
20:02:46 <bana_k> hi
20:02:52 <xgerman> oh, and for those under a rock: amax is the new Neutron PTL
20:02:56 <xgerman> armax
20:03:12 <blogan> all hail our new overlord
20:03:15 <armax> aye
20:03:18 <rm_work> heh
20:03:19 <xgerman> not sure if dougwig can cling on to be a lt in the new regime
20:03:20 <sbalukoff> Haha! Welcome!
20:03:21 <TrevorV> Thanks... us rock people have trouble getting those updates
20:03:28 <rm_work> I did miss the official results, but cool
20:03:38 <dougwig> xgerman is my biggest fan.
20:03:54 <xgerman> if that’s all it took a lot of people would be lt.
20:04:11 <johnsom> He is already helping us out with the Octavia release
20:04:16 <armax> I am dougwig’s proxy
20:04:22 <armax> he’s the one really pulling the strings
20:04:41 <xgerman> welcome - all bow
20:04:45 <xgerman> \me bows
20:04:50 <johnsom> armax I am so sorry.  He really does like to make people dance....
20:04:58 * TrevorV laughs at xgerman and his failed bowings
20:05:00 <sbalukoff> You're Bush to dougwig's Cheney? ;)
20:05:07 <armax> johnsom: no need, that was the plan all along :)
20:05:16 <xgerman> sbalukoff lol
20:05:20 <TrevorV> We've fallen right into their trap!
20:05:38 * dougwig cries in the corner.
20:05:44 * blogan watches
20:05:45 <sbalukoff> Seriously though-- great to have you on board, and thanks for attending this meeting today, eh!
20:05:57 <johnsom> +1
20:05:59 <sballe> o/
20:06:00 <xgerman> +!
20:06:02 <xgerman> +1
20:06:07 <crc32> o/=
20:06:19 <blogan> yes thanks for attending this meeting and the countless others
20:06:55 <xgerman> #topic Tagging our release + packaging
20:07:18 <johnsom> So we ran into some trouble getting the octavia release up on pypi
20:07:20 <xgerman> johnsom was working with mestery on getting us into pypi
20:07:40 <xgerman> trouble?
20:07:44 <johnsom> Evidently the octavia repository wasn't quite setup right (no stares in any direction)
20:08:02 * rm_work has no idea how pypi really works internally
20:08:11 <johnsom> But, we got some help from infra this morning and I have patches up to fix those.
20:08:15 * TrevorV shares rm_work 's lack of knowledge here
20:08:20 <xgerman> rm_work magic?
20:08:20 <blogan> johnsom: patches in infra?
20:08:31 <johnsom> We are just waiting on the infra patch to go in
20:08:39 <johnsom> #link https://review.openstack.org/#/c/229518/
20:08:39 <sbalukoff> Cool.
20:08:47 <xgerman> link? so we can all +1 to show our support and gartitude
20:08:51 <xgerman> gratitude
20:09:02 <johnsom> Octavia is up on pypi now, but it is just the initial push I did when setting it up.
20:09:32 <xgerman> well, does this mean we are still sort in a code freeze?
20:10:17 <johnsom> In theory yes, as I expect there will need to be another tag added to the repo to get it through the OpenStack release process
20:10:51 <sbalukoff> johnsom: Can you broadcast loudly in channel when that tag happens?
20:10:59 <johnsom> Sure can.
20:11:04 <sbalukoff> Danke!
20:11:10 <xgerman> also once we have Octavia in pypi who will test that it actually works?
20:11:12 <xgerman> fnaval?
20:11:17 <johnsom> mestery or armax will actually push the button, but I am trying to follow along
20:11:37 * xgerman thinks johnsom would make a great release manager
20:11:49 <johnsom> Oye
20:11:54 <sbalukoff> Let's vote on it! ;)
20:11:59 <sballe> +1
20:12:01 <blogan> the customary vote
20:12:10 <sbalukoff> +1
20:12:13 <minwang2> +1
20:12:15 <johnsom> Just for dougwig
20:12:24 <sbalukoff> That's 4 of us. Congratulations, johnsom.
20:12:25 * rm_work wonders what johnsom votes
20:12:56 <johnsom> Is that even a role?
20:13:00 <TrevorV> Is now
20:13:04 <blogan> sounds official
20:13:23 <xgerman> doesn’t neutron has a release team?
20:13:35 <crc32> yea its called blogan upstream
20:13:39 <sbalukoff> Haha
20:13:46 * johnsom bows
20:14:12 * blogan is lost
20:14:21 * sballe congratulates johnsom in his new role
20:14:28 <dougwig> this meeting is a tad wandering.
20:14:30 <xgerman> #topic Brief progress reports
20:14:32 <blogan> yes it has
20:14:34 <johnsom> So, as release manager, what is going to be in next weeks release?  hmmm???
20:14:59 <blogan> has rc2 been cut?
20:15:04 <blogan> or deadline past for that?
20:15:35 <johnsom> Release stuff above and any little bug fixes we have needed for liberty.  I also put up google docs to get us started on our Tokyo presentations.
20:15:52 <sbalukoff> I have a first draft of the blueprint the IBM research team wants to use to add active+active and auto-scale to Octavia, hopefully in Mitaka. I want to do a small revision of it before putting it in front of the group, and that team is on vacation right now anyway... so expect to see it around mid next-week.
20:15:52 <blogan> i think this one is worth getting into liberty
20:15:55 <blogan> https://review.openstack.org/#/c/210968
20:15:59 <xgerman> yeah!! we have an extra Tokyo topic
20:16:06 <blogan> ajmiller: i added tests for it ^ hope you dont mind
20:16:16 <sbalukoff> And yes, I'll add that to the list for the design session.
20:16:18 <ajmiller> blogan: not at all!
20:16:20 <bana_k> heat hooks BP is up but still wip, needs to cross check some parameter with the api doc.
20:16:42 <xgerman> great bana_k
20:16:46 <johnsom> blogan I tagged that as an RC candidate.  I agree it would be good to get in
20:16:51 <sbalukoff> bana_k: Awesome!
20:16:51 <blogan> johnsom: oh great
20:17:06 <bana_k> api doc is not entirely correct so reviewing it n raising bugs.
20:17:15 <xgerman> thanks
20:17:20 <bana_k> thanks :)
20:17:47 <sbalukoff> Apologies it's taking me so long to get the stupid docs updated. And yes, johnsom, if it's not in gerrit it doesn't exist. I'll try to correct that this week.
20:18:20 <johnsom> Grin
20:18:32 <xgerman> I need to fix https://review.openstack.org/#/c/227912/ — maybe paying some voodoo master
20:19:02 <sbalukoff> Otherwise, I'm just waiting for the go-ahead on release tagging to start guilting you into reviewing the Neutron-LBaaS shared pool code and L7 stuff that Evgeny has been working on. ;)
20:19:27 <xgerman> yeah, we want L7 in Mitaka
20:19:39 <xgerman> I think blogan and I need to do some work in LP for milestones, etc.
20:19:50 <blogan> xgerman: sure
20:19:52 <sbalukoff> Cool beans!
20:20:03 <johnsom> Also, I put a global requirements change in to exclude coverage 4.0 as it breaks our unit tests in bad/strange ways.
20:20:13 <johnsom> #link https://review.openstack.org/#/c/228581/
20:20:16 <blogan> also noop driver fixes that we might use for some tests, but even if we dont at least this allow them to work: https://review.openstack.org/#/c/229262/
20:20:30 <xgerman> NICE
20:21:14 <xgerman> should we aim to get that in Octavia RC2 (are we doing an RC?)
20:21:16 <johnsom> Upstream bug against coverage is here:
20:21:23 <johnsom> #link https://bitbucket.org/ned/coveragepy/issues/416/coverage-40-is-causing-existing-unit-tests
20:22:07 <minwang2> i still have one unit test for cert rotation #link https://review.openstack.org/#/c/215359/
20:22:25 <blogan> xgerman: that one's isn't too important, so i wouldn't fight for it
20:22:29 <blogan> if its easy enough, then sure
20:22:42 <xgerman> well, we are still cutting so...
20:23:28 <xgerman> any other progress?
20:23:32 <minwang2> also need to address some update for octavia doc patches #link https://review.openstack.org/#/c/226599/  #link https://review.openstack.org/#/c/224929/
20:23:47 <xgerman> yes, docs are real important — please review
20:23:54 <sbalukoff> +1
20:24:04 <xgerman> #action review #link https://review.openstack.org/#/c/224929/
20:24:26 <TrevorV> minwang2, links need to be on separate lines for the bot to pick them up
20:24:33 <TrevorV> #link https://review.openstack.org/#/c/226599/
20:24:38 <TrevorV> #link https://review.openstack.org/#/c/224929/
20:24:43 <TrevorV> I gotchu though :)
20:24:48 <minwang2> Trevor thanks!
20:24:49 <xgerman> dougwig wonder if there is some more step—by-step guide w need to write
20:25:05 <xgerman> also sbalukoff you said you were working on that
20:25:08 <crc32> #link https://review.openstack.org/#/c/218735/
20:25:15 <crc32> ^^ can I get a review too?
20:25:19 <xgerman> sure
20:25:31 <sbalukoff> xgerman: If I need to, I'll make my patch dependent on Min's.
20:25:32 <xgerman> #action review #link https://review.openstack.org/#/c/218735/
20:25:59 <xgerman> sbalukoff I saw Min’s docs but I also got asked in IRC for a more like deployment guide
20:26:10 <sbalukoff> xgerman: Yep, that's what I'm working on.
20:26:28 <xgerman> awesome
20:27:18 <xgerman> ok, any other progress?
20:27:38 <sbalukoff> Sounds like a "nope" to me. :)
20:27:39 <xgerman> #topic Octavia talk
20:27:42 <TrevorV> I can't add here, honestly... Been doing internal stuffs :(
20:27:55 <sbalukoff> TrevorV: I hear you.
20:27:57 <xgerman> so we are still looking for a sponsor for the USB drive ...
20:28:02 <TrevorV> Also I won't be able to go to Tokyo... so enjoy it without me guys :'(
20:28:25 <xgerman> too bad… they should have just chartered a plane
20:28:26 <sbalukoff> Oh! I suppose it's worth mentioning that I'm in the stages of making sure the legal paperwork is right with the OpenStack Foundation to assign the 'Octavia' trademark to them. So... yay!
20:28:44 <blogan> sbalukoff: thats great news!
20:28:50 <xgerman> +1
20:28:52 <sbalukoff> So, sometime in 2017, the USPTO will likely have finished reviewing that same paperwork and the trademark will officially transfer! ;)
20:29:08 <xgerman> you used the IBM lawyers?
20:29:11 <TrevorV> ha ha ha ha
20:29:14 <sbalukoff> xgerman: Yep.
20:29:35 <xgerman> Nice
20:29:37 <rm_work> heh
20:29:41 <johnsom> Doc for the hands on lab:
20:29:44 <johnsom> #link https://docs.google.com/document/d/12x6Xc6ktopg9mhxz7yqp_VsFTTqVRxJ_PtZlvzb0xPU/edit?usp=sharing
20:29:50 <sbalukoff> xgerman: Didn't have a choice. This would have been easier had the USPTO moved faster than IBM's acquisition team (ie. if this were still only under Blue Box), but... such is life.
20:30:08 <xgerman> yeah, but glad it’;s happening...
20:30:15 <sbalukoff> Yep, me too!
20:30:23 <johnsom> Slides for the presentation:
20:30:25 <johnsom> #link https://docs.google.com/presentation/d/1PYBLtNrkyg__FjyZ2ywynNv-22FW88hDz5j9q8W1ZOQ/edit?usp=sharing
20:30:30 <xgerman> so USB sticks? We can also put up a donation box at the session...
20:30:36 <johnsom> Not much progress on either yet.
20:30:37 <crc32> sbalukoff: Or the project gets renamed.
20:30:57 <xgerman> hah
20:31:01 <rm_work> heh how much do those cost
20:31:06 <rm_work> for however many we need
20:31:14 <rm_work> did we figure out what size we'd need minimum?
20:31:20 <crc32> and how big do they need to be?
20:31:29 <sbalukoff> crc32: That's what I had to demonstrate to the IBM lawyers in exquisite detail and my usual... er... coloful language.
20:31:33 <sbalukoff> ;)
20:31:34 <johnsom> I think we can fit in 8GB
20:31:35 <rm_work> johnsom: we need a new road image
20:31:54 <crc32> cool. Ho many usb sticks?
20:31:58 <xgerman> 8GB are $7 at staples
20:31:59 <johnsom> Let me know if you want edit rights.
20:32:17 <johnsom> rm_work accepting suggestions
20:32:22 <rm_work> xgerman: yeah but I assume we can get a bulk discount :P
20:32:26 <rm_work> johnsom: something with less clouds
20:32:34 <rm_work> johnsom: it looks like a stormy road ahead
20:32:45 <rm_work> that sends a scary message :P
20:32:48 <xgerman> I was hoping some corporate marketing department would see that as a good use for their money
20:32:50 <johnsom> rm_work hahahaha, I was thinking links....
20:33:10 <rm_work> xgerman: how many do we need tho?
20:33:13 <johnsom> These images pre-date me
20:33:15 <sbalukoff> xgerman: I checked with my team. I think they're willing, but worried about the timeline to get it through red tape.
20:33:32 <crc32> 28 dollars for 10 Gigs
20:33:32 <sbalukoff> Nobody here has any idea how many we need, right? :P
20:33:45 <crc32> 28 dollars for 10  8Gig sticks
20:34:12 <xgerman> I think the web page knows
20:34:16 <rm_work> johnsom: http://www.ewallpapers.eu/w_show/open-road-1920-1080-5092.jpg
20:34:17 <johnsom> I don't know how many we need.  I can look and see how many people have already signed up, but that doesn't tell us the limit
20:34:33 <sbalukoff> Do we know how many seats the room will have?
20:34:41 <rm_work> right
20:34:43 <sbalukoff> I mean, maybe we'll pack the place, maybe we won't.
20:34:47 <minwang2> rm_work nice pic
20:34:48 <rm_work> like how many could it possibly be
20:34:49 <sbalukoff> But it seems silly to bring more than that.
20:34:49 <rm_work> 100?
20:35:15 <rm_work> johnsom: that seems more "laxidaisical" to me
20:35:18 <xgerman> it says limited
20:35:19 <rm_work> or however you spell that
20:35:38 <xgerman> so far we have 10 signed up
20:35:46 <rm_work> johnsom: maybe http://alphatravelblog.com/wp-content/uploads/2013/07/French-Roadtrip-Open-Road.jpg
20:35:56 <johnsom> We have 11 signed up right now
20:36:02 <sbalukoff> Well... as long as we have the image available for download someplace, I don't feel guilty about not having enough USB sticks. If you really want to check out Octavia you can download a friggen image.
20:36:25 <blogan> yeah that sounds like the default solution, and usb stick is a backp
20:36:25 <rm_work> johnsom: did we get the actual rights to the last one or was it just google-image-search?
20:36:26 <blogan> backup
20:36:41 <rm_work> well, the internet AT the conference will not be great, it never is
20:36:42 <johnsom> rm_work again, pre-dates me
20:36:57 <rm_work> but just a couple to pass around would be fine for that
20:37:03 <blogan> just post the link to the image on a keynote slide, let everyone at the summit download it all at once
20:37:13 <johnsom> Yeah, that is my worry.  I don't want to count on good internet.
20:37:25 <rm_work> actually, maybe it Tokyo it won't be too bad
20:37:32 <rm_work> like everyone there has gigabit i think
20:37:40 <sbalukoff> Right, so $28 for 10 of these sticks... and we're covered, eh?  (Also, who doesn't have the ability to download this stuff? Are we expecting to hand a bunch of these out to Chinese citizens?)
20:37:47 <xgerman> as long as we put ti in a JP data center
20:38:14 <rm_work> closest we can get is like... Hong Kong
20:38:40 <crc32> I'm ordering 3 sets of 10. 22$ each
20:38:42 <blogan> alright plan needs some work it sounds like, but a direction in place
20:38:55 <johnsom> Our CDN has a pop in Japan.  I will load the image there
20:39:07 <xgerman> awesome — so we have it all covered
20:39:13 <sbalukoff> crc32: Thanks, eh!
20:39:22 <rm_work> crc32: erk, k -- hopefully they reimburse you
20:39:23 <sbalukoff> Sweet!
20:39:24 <xgerman> I can’t really see how we can’t expense that...
20:39:26 <crc32> is 30 enough?
20:39:43 <crc32> cause thats all I can afford now.
20:39:46 <rm_work> and/or I wonder if RAX has a vendor where we could get them cheaper and with RAX logo on them :P
20:39:55 <sbalukoff> crc32: It sounds like it probably will be, yes.
20:40:07 <xgerman> yeah, let’s work the corporations again
20:40:11 <rm_work> crc32: i might wait just a moment at least and ask someone at RAX
20:40:17 <xgerman> +1
20:40:21 <sbalukoff> +1
20:40:24 <crc32> When they arrive I'll hand them to rm_work since I lose things. :(
20:40:28 <rm_work> lol
20:40:41 <sbalukoff> Heh!
20:40:42 <crc32> you ask rm_work. its only 68$
20:40:42 <johnsom> We need to get the image on them too
20:40:50 <rm_work> hopefully data rate from HK to JP is not far :P
20:40:58 <crc32> yea but you said you would load them in Tokyo.
20:40:59 <rm_work> err, hopefully data rate is good
20:41:00 <crc32> I thought
20:41:09 <crc32> or we can load them here.
20:41:18 <rm_work> yeah we'd want to pre-image them
20:41:23 <crc32> I'm guessing were going to load them at the last second though.
20:41:26 <rm_work> pretty easy to do en-mass
20:41:31 <johnsom> It's a long plane flight, so whoever has them could image on the way....  grin
20:41:32 <sbalukoff> crc32: +1
20:41:42 <TrevorV> I think rm_work would do that.
20:41:45 <crc32> incase some last second patches make it in.
20:41:46 <TrevorV> He can't sleep regularly anyway
20:41:55 <rm_work> I am so going to be taking ambien on the plane >_>
20:42:12 <xgerman> ok, I think we are all set
20:42:29 <xgerman> #topic Open Discussion
20:42:40 <dougwig> what part of this meeting hasn't been open discussion?  :)
20:42:52 <xgerman> lol
20:43:00 <johnsom> Two or three minutes...
20:43:17 <xgerman> so moving the meeting time didn’t garner much support on the ML...
20:43:53 <sbalukoff> dougwig: We are always on topic. The topic just likes to shift without a general notice to everyone. No our fault, eh.
20:44:07 <johnsom> If anyone knows Matt Riedemann at IBM you can ping him to remove his -1 from the global requirements update.  He didn't ready the commit message.
20:44:07 <crc32> rm_work are you gonna ask rax or do I just order them. I'm like ready to click shit to address.
20:44:19 <TrevorV> dougwig, you just upset that we young peeps keep up with the conversational flow and you have trouble with it :P
20:44:36 <sbalukoff> johnsom: I've no idea who that is... :/
20:44:57 <xgerman> TrevorV dougwig - that’s how we roll
20:45:01 <blogan> doesn't this seem like an important patch to get into rc2?
20:45:03 <blogan> https://review.openstack.org/#/c/220654
20:45:21 <xgerman> yep
20:45:22 <TrevorV> #link https://review.openstack.org/#/c/220654
20:45:28 <sbalukoff> Yeah.
20:45:53 <blogan> does it need a bug report in lp to get into rc2?
20:46:04 <johnsom> Could be.  Do you all want me to tag it?  That means we have to get on the reviews and get it merged.....
20:46:08 <johnsom> Yes
20:46:20 <dougwig> TrevorV: get off my lawn.
20:46:45 <crc32> forget this order then. Deliver estimate Oct 27 - Nov 13
20:47:08 <xgerman> yeah, it might be the JP CDN
20:47:17 <TrevorV> dougwig, I found a snipe, and I followed it under your porch, but this snipe had a long tail, and looked more like a large mouse.
20:48:41 <rm_work> crc32: ah lol such slow
20:48:43 <blogan> back to octavia stuff, some of us discussed having a lot of the long running tests run the noop drivers so the tests run faster
20:48:57 <xgerman> yeah, we said API tests
20:49:01 <blogan> since they sometimes hit the timeout
20:49:06 <johnsom> Ah yes....
20:49:36 <johnsom> The new lower and variable timeout no less
20:49:40 <blogan> so is there an easy way to change what drivers the gate tests use?
20:49:44 <blogan> indeed
20:49:53 <blogan> easy = i can do it in octavia
20:49:57 <blogan> or does it require a change in infra
20:50:05 <johnsom> It goes in neutron-lbaas
20:50:11 <blogan> yeah tahts what i mean
20:50:12 <blogan> sorry
20:50:13 <xgerman> well, can’t we change the octavia.con easily?
20:50:16 <rm_work> it's possible to do with iniset in the gate-hook script
20:50:18 <xgerman> octavia.conf
20:50:20 <blogan> in gate_hook?
20:50:24 <blogan> yeah tahts what i thought
20:50:25 <xgerman> rm_work +1
20:50:28 <johnsom> yep
20:50:33 <blogan> so that'll be ab it more involved that i hoped but i'll start on it
20:50:47 <johnsom> It's really not that bad.
20:50:53 <blogan> me + bash = bad
20:51:05 <blogan> but i gotta get better at it
20:51:06 <xgerman> ask rm_work to mentor you :-)
20:51:07 <johnsom> I can do it if you would prefer
20:51:18 <blogan> no, ill do it, im just complaining :)
20:51:35 <xgerman> ok, settled
20:51:44 <xgerman> meeting time?
20:51:50 <blogan> ending time?
20:51:51 <xgerman> I think we keep the slot...
20:51:56 <blogan> ohhh
20:52:06 <blogan> well i guess i dont see a lot of people wanting the change in time
20:52:10 <blogan> which is why i asked
20:52:11 <blogan> in the thread
20:52:12 <xgerman> yep
20:52:42 <xgerman> but it’s probably good to check once in a while...
20:52:43 <blogan> what originally brought it up?
20:52:58 <xgerman> sbalukoff and his EMEA IBM people + Evgeny wanted it earlier
20:53:00 <sbalukoff> xgerman: Yep, keep the slot for now.
20:53:29 <sbalukoff> xgerman: I will poke the IBM research team again on this, and I can get them motivated to start attending these meetings (as they should), we can revisit the meeting time again then.
20:53:38 <blogan> ah okay well if we hit a larger amount of contributors we can do the split one that neutron does
20:54:00 <xgerman> or we do an ASCTIVE-ACTIVE spin-off
20:54:13 <rm_work> yeah though discussing meeting time during a meeting that people can't attend due to the time... is lulz
20:54:13 <sbalukoff> blogan: I'm hoping we can find a time in the morning that works well for most... and doesn't make me want to gouge out my eyes. ;)
20:54:19 <rm_work> but i guess if no one responded on the ML <_<
20:54:27 <blogan> sbalukoff: 7am est
20:54:28 <sbalukoff> rm_work: Yep, but nobody much has said much on the ML abou tit.
20:54:33 <sbalukoff> blogan: I will destroy you.
20:54:44 <rm_work> sbalukoff: +2
20:54:46 <johnsom> blogan Enjoy talking to yourself....
20:54:46 <blogan> sbalukoff: no need, that time will do that for you
20:54:51 <rm_work> I am core on "destroying blogan"
20:54:52 <sbalukoff> Haha!
20:55:11 <xgerman> anything else (serious)?
20:55:21 <blogan> nope
20:55:23 <xgerman> #endmeeting