20:00:03 <xgerman> #startmeeting Octavia
20:00:04 <openstack> Meeting started Wed Aug 26 20:00:03 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:08 <openstack> The meeting name has been set to 'octavia'
20:00:13 <TrevorV> o/
20:00:17 <xgerman> #chair blogan
20:00:18 <minwang2> o/
20:00:19 <abdelwas> o/
20:00:19 <madhu_ak> hi
20:00:23 <openstack> Current chairs: blogan xgerman
20:00:23 <ajmiller> xgerman you were three seconds late
20:00:24 <bana_k> hi
20:00:25 <evgenyf> hi
20:00:37 <blogan_> hello
20:00:44 <sbalukoff> Howdy, howdy!
20:00:45 <xgerman> #topic Announcements
20:00:47 <bharathm> o/
20:01:05 <crc32> o/
20:01:07 <xgerman> Accepted Summit talks
20:01:08 <xgerman> Load Balancing as a Service, Liberty and Beyond
20:01:08 <xgerman> Hands on Lab: Install and Configure OpenStack Octavia
20:01:32 <blogan_> how many people are signed up for the lab?
20:01:54 <xgerman> it’s huge — now we need to see who actually gets funded to go
20:01:54 <sbalukoff> I'd be happy to help out with that.
20:02:04 <sbalukoff> I'm about 95% certain I'm going.
20:02:22 <xgerman> #action german add sbalukoff to lab talk
20:02:28 <rm_work> I ... don't think they are planning to send me at the moment
20:02:36 <rm_work> i don't know if i adequately expressed that they SHOULD be
20:02:36 <xgerman> you have a talk...
20:02:39 <crc32> I'm funding my self. Due to health concerns
20:02:41 <rm_work> we'll see
20:02:59 <rm_work> we honestly weren't sure if they would send anyone
20:02:59 <TrevorV> I'm not sure if anyone from rax is going on company dime
20:03:05 <TrevorV> I'll have to talk to our guy.
20:03:08 <TrevorV> Cuz I'd love to
20:03:25 <sbalukoff> Wow, that sucks, eh.
20:03:40 <sbalukoff> Have I mentioned that IBM is sending a whole bunch of people? Also, we're hiring. XD
20:03:41 <crc32> maby we'll get funded due to the intel boost.
20:03:59 <sbalukoff> Hopefully!
20:04:09 <TrevorV> Tis possible, we'll see I guess :D
20:04:19 <xgerman> #link https://www.openstack.org/summit/tokyo-2015/schedule/main-conference
20:04:24 <xgerman> ^^ blogan
20:04:34 <blogan_> first day as always
20:05:05 <xgerman> yeah, 8 people are in the lab
20:05:23 <xgerman> or we have 8 presenters
20:05:26 <blogan_> thats a big meatball
20:05:44 <dougwig> i think blogan should do all of the lbaas talk. it's his favorite thing.
20:05:50 <sbalukoff> HAHA!
20:06:08 <sbalukoff> Seriously though-- I'm happy to help out with whatever there, eh.
20:06:18 <xgerman> awesome
20:06:29 <blogan_> ill be sure to fake a cold
20:06:30 <dougwig> i'll be there, also happy to help.  equally happy to let people that need to be speakers to attend be the speakers.
20:06:59 <blogan_> being a speaker isn't as powerful as it was for the paris summit, in regards to rax sending us
20:07:05 <blogan_> low on the totem poll now
20:07:12 <blogan_> so if someone else needs to speak...
20:07:16 <xgerman> what about keynote speaker?
20:07:18 * blogan_ feels a cold coming on
20:07:32 <sbalukoff> dougwig: +1 as well (same sentiment)
20:07:33 <rm_work> o/
20:07:35 <blogan_> well ill be doing that for sure
20:07:41 <crc32> openstack on shingled magnetic recordings?
20:07:46 <crc32> ???
20:07:46 <sbalukoff> Since I'm going regardless of whether I'm speaking at anything.
20:07:48 <xgerman> #chair blogan_
20:07:49 <openstack> Current chairs: blogan blogan_ xgerman
20:07:58 <blogan_> 2 blogans > 1 xgerman
20:08:10 <xgerman> k, so next is GSLB
20:08:14 <xgerman> johnsom?
20:09:17 <xgerman> I think they had a short meeting and nothing of substance got decided ;-)
20:09:23 <xgerman> there he is
20:09:29 <johnsom_> Sorry.
20:09:51 <dougwig> i did show this cool pic of why i wasn't there: http://i.imgur.com/HTp5Wlu.jpg
20:09:53 <johnsom_> GSLB Short meeting, we are reviewing updated diagrams that are going into gerrit
20:10:29 <evgenyf> xgerman: I would like to discuss L7 tasks if there is time
20:10:37 <xgerman> yes it’s on the agenda
20:10:39 <dougwig> evgenyf: there's an agenda item for it
20:11:13 <xgerman> next, L3 deadline — dougwig is release master since mestery is on vacation
20:11:25 <sbalukoff> dougwig: Fun!
20:11:32 <blogan_> dougwig changed that to armax
20:11:33 <dougwig> actually it's armax.  myself and carl_baldwin are the backups.
20:11:50 <xgerman> smart!!
20:12:21 <xgerman> so deadline is still 8/31
20:12:34 <xgerman> does this mean code complete by then?
20:13:16 <dougwig> in gerrit by then, yes.
20:13:24 <xgerman> ok, cool
20:13:48 <xgerman> other announcements?
20:14:07 <xgerman> #topic Brief progress reports
20:14:10 <johnsom_> Are we going into depth on that last point about what needs to be in gerrit?
20:14:20 <dougwig> can we do liberty first?
20:14:27 <dougwig> i have to bail at 2:30 for dentist.
20:14:36 <blogan_> i have a dentist appt too!
20:14:41 <xgerman> k, let’s do L7 and then Liberty
20:14:51 <xgerman> #topic L7
20:15:04 <dougwig> xgerman clearly didn't hit refresh on the agenda.  :)
20:15:19 <dougwig> what's left to get l7 in?  do we have people on all the pieces?
20:15:28 <xgerman> #topic Liberty deadline stuff
20:15:32 * xgerman hit refresh
20:15:35 <blogan_> lol
20:15:35 <sbalukoff> Let's talk about Liberfy
20:15:40 <sbalukoff> Liberty
20:15:46 <blogan_> liberfinity
20:15:51 <sbalukoff> eew.
20:15:56 <dougwig> we have 3 liberty features.  l7, horizon, octavia as ref.
20:16:01 <dougwig> pick one to start.
20:16:01 <sbalukoff> Seriously, you just made me shudder.
20:16:14 <sbalukoff> Octavia as ref is most important.
20:16:24 <dougwig> octavia as ref, where are we?
20:16:45 <blogan_> heartbeats, failover are coming
20:16:54 <blogan_> seems like its close
20:16:59 <xgerman> +!
20:17:02 <xgerman> +1
20:17:02 <TrevorV> I think I may have just finished failover.
20:17:06 <blogan_> need to get scenario tests working with the octavia driver
20:17:19 <xgerman> gate is in but fails
20:17:31 <johnsom_> heartbeats is done, just updating unit tests.
20:17:39 <dougwig> if we fire it up in devstack, does it work better than the current ref?  is it performant at all?
20:17:51 <blogan_> ptoohill: tls?
20:18:16 <blogan_> dougwig: its performant if you're got enough space for nova instances
20:18:32 <xgerman> +1
20:18:45 <xgerman> yeah, if you use a small machine it will be slower
20:18:51 <TrevorV> Has anyone done any kind of load testing or anything?  Not scale, but load?
20:18:59 <abdelwas> +1
20:18:59 <blogan_> and nova scheduler will fail
20:19:00 <xgerman> TrevorV no
20:19:09 <blogan_> if not much capacity
20:19:11 <dougwig> do we have any docs or deployment guides?
20:19:25 <xgerman> not yet — we decided we can deliver them after L3
20:19:27 <rm_work> johnsom_: did you commit the main part of your udp changes yet?
20:19:27 <blogan_> that was set up to be done after deadline
20:19:29 <sbalukoff> I didn't think load testing (or really, any kind of significant performance numbers) were a part of it?
20:19:48 <xgerman> they were but we skirted
20:19:58 <rm_work> i don't think they need to be, but we should get them done at some point
20:20:02 <johnsom_> rm_work main part yes, unit test update part we talked about earlier, no, just about donw.
20:20:11 <dougwig> are we ready for the octavia api to be partial baked into stone?
20:20:15 <rm_work> johnsom_: not sure if you actually did a review?
20:20:44 <blogan_> dougwig: hmm there was the goal to make octavia api exactly like neutron-lbaas, its not there
20:20:47 <xgerman> dougwig — do we really need to bake in stone since we use LBaaS V2?
20:20:52 <blogan_> does that need to be baked in stone though?
20:20:54 <rm_work> dougwig: i think there's a couple of changes that need to be ported by blogan_ about the tls containers
20:21:06 <rm_work> but yeah, octavia isn't used by end-users yet, just the driver
20:21:11 <rm_work> so as long as we update the driver...
20:21:28 <dougwig> well, i said partially.  once we release the service, we'll likely need to be careful about breaking api changes.  especially to the operator api, right?
20:21:29 <sbalukoff> The tentant-facing API for both Octavia and Neutron LBaaS v2 should be the same.
20:21:50 <blogan_> dougwig: really only a user api at this point, though its noauth
20:21:56 <sbalukoff> dougwig: There is no operator API right now.
20:22:00 <xgerman> +1
20:22:02 <blogan_> dougwig: no operator style commands
20:22:11 <blogan_> well you knwo what i mean
20:22:24 <sbalukoff> We will be adding one, but it wasn't seen as necessary in order to replace the current refrence implementation.
20:22:25 <dougwig> maintenance is via nova commands, then?
20:22:41 <blogan_> can be
20:22:52 <sbalukoff> dougwig: When the system isn't self-correcting, sure.
20:22:52 <blogan_> its something we can add in later
20:22:53 <crc32> ls -alF
20:22:56 <crc32> danmit
20:22:57 <sbalukoff> Right.
20:23:07 <dougwig> ok, this sounds doable, then. does anyone think it's not?
20:23:09 <blogan_> but its not something the current ref impl has anyway
20:23:20 <sbalukoff> I think it's totally doable.
20:23:23 <xgerman> `1
20:23:31 <xgerman> +1
20:23:35 <johnsom_> +1
20:23:38 <xgerman> though still experimental
20:23:48 <blogan_> dougwig: i am concerned a bit by me not being able to create more than one load balancer at the moment in devstack bc nova fills up fast with that one
20:24:04 <xgerman> we can create more than one
20:24:09 <blogan_> if hte ref impl is experimental does that mean neutorn lbaas v2 remains in experimental?
20:24:16 <dougwig> blogan_: one per nova, you mean?
20:24:33 <rm_work> well, is neutron-lbaas not still experimental?
20:24:39 <xgerman> we can create like 4 before our 8 GB VMware devstack dies
20:24:51 <sbalukoff> I thought neutron-lbaas v2 API was still experimental.
20:25:05 <dougwig> it is, at least until we get horizon support (later in the agenda)
20:25:08 <xgerman> yeah, but we like it to be stable so we can deprecate bass v1
20:25:12 <rm_work> k then no worries yet
20:25:14 <blogan_> dougwig: yes, but im sure its a local issue though
20:25:18 <sbalukoff> Right.
20:25:21 <dougwig> well, for devstack, they can still enable the old driver if needed.
20:25:49 <xgerman> agreed
20:26:25 <dougwig> what's the minimum VM size, btw?
20:26:42 <sbalukoff> Yes...  so, the namespace driver becomes deprecated, Octavia becomes recommended, and then in "M" release, namespace driver goes away (hopefully).
20:27:09 <TrevorV> dougwig, I think ptoohill saw performance degradation under 1GB...
20:27:14 <blogan_> sounds like a plan to me
20:27:23 <xgerman> +1
20:27:43 <johnsom_> dougwig I run tests on m1.small
20:28:34 <blogan_> johnsom_: int that 1 GB?
20:28:36 <blogan_> isnt
20:29:09 <dougwig> i can see how multiple LB's per amphora would be a useful optimization later.
20:29:26 <dougwig> ok, let's get this on the L-3 docket unless anyone objects?
20:29:33 <blogan_> or we can make a compute driver that just spins up a process on the controller worker in a namepsace!
20:29:35 <sbalukoff> dougwig: Yep!  But first things first.
20:29:38 <blogan_> we could call it the namespace compute driver
20:29:47 <xgerman> lol
20:29:58 <sbalukoff> Haha
20:29:59 <dougwig> let's move on to L7/liberty (rushing, have to leave shortly)
20:30:11 <TrevorV> dougwig, problem with multiple lb's per amphora (in my eyes) is bad neighbor effect
20:30:18 <blogan_> so is L7 useful at all without being able to point to another pool?
20:30:21 <sbalukoff> evgenyf: You wanted to say something ablut L7, right?
20:30:21 <dougwig> TrevorV: same tenant though, no problem.
20:30:35 <sbalukoff> blogan_: Yes--  you can set a rule to block.
20:30:40 <TrevorV> Maybe, still one LB could tank another, tenant causes own problem, still "bad neighbor" right?
20:30:53 <blogan_> sbalukoff: so only useful for one rule?
20:31:06 <sbalukoff> Sorry, I meant policy type.
20:31:07 <evgenyf> or redirest to URL
20:31:09 <sbalukoff> but yes.
20:31:10 <johnsom_> BTW, L7 has not been added to Octavia yet either
20:31:16 <sbalukoff> Two policy types.
20:31:20 <sbalukoff> That's correct.
20:31:37 <xgerman> well, I think it’s doable but...
20:31:39 <sbalukoff> I think we're likely to miss the L3 deadline because of too many missing "support stuff" to make L7 more useful.
20:31:40 <sbalukoff> But!
20:31:54 <sbalukoff> The work evgeny has done does expand the API in useful ways...
20:32:04 <xgerman> dougwig was talking extension
20:32:05 <sbalukoff> And in ways that won't need changing later on, right?
20:32:19 <dougwig> how many weeks away are we?
20:32:29 <evgenyf> There are 3 patches for review for L7, extension, CLI and ref.implementation, tempest is missing
20:32:30 <sbalukoff> Probably 3.
20:32:36 <blogan_> but if there's no driver using it, it shouldn't go in
20:32:58 <blogan_> i mean if the ref impl isn't, and if octavia bcomes the ref impl then that'll be odd
20:33:04 <sbalukoff> We're also missing functionality to create / manipulate pools without being associated with a listener (essential for redirect_to_pool L7 policies)
20:33:09 <blogan_> ref impl doesn't support it, but deprecated driver does
20:33:17 <evgenyf> sbalukoff: how many work is there for ref.implementation you think?
20:33:18 <sbalukoff> I think we're probably going to miss the deadline for this this time.
20:33:42 <sbalukoff> evgenyf: I'm pretty close on the namespace driver. It's mostly fleshing out tests that I needed to do.
20:34:04 <dougwig> i'm wondering if it's kosher to merge the extension and then not publish the feature, to enable iteration or decomp'ed drivers to use it (which includes the ref in M.)
20:34:13 <dougwig> and then publish in M.
20:34:25 <sbalukoff> But again, the wind is really stolen from our sails here if we can't do redirect_to_pool rules, since that's what like 95% of our customers use in production with L7 stuff.
20:34:32 <blogan_> it'd be nice to have api versioning for this
20:34:41 <sbalukoff> Right.
20:34:45 <sbalukoff> I personally don
20:34:55 <sbalukoff> 't think it's the end of the world if we miss this deadline.
20:35:13 <sbalukoff> I'd rather we make sure that Octavia is a solid replacement for the ref. impl....
20:35:14 <xgerman> well, Sam *really* wants this
20:35:16 <dougwig> blogan_: that work is in the main service plugin, right?
20:35:17 <blogan_> well what has neutron-lbaas accomplished for L?
20:35:19 <sbalukoff> Because if it's not, our project loses credibility.
20:35:33 <blogan_> dougwig: independent pools?
20:35:41 <dougwig> blogan_: yes
20:36:00 <blogan_> dougwig: yeah but maybe some work with the backends as well
20:36:05 <xgerman> one more driver
20:36:06 <blogan_> drivers i mean
20:36:17 <xgerman> yeah, it might be too rushed
20:36:22 <blogan_> but i think every driver probably allows independent pools
20:36:32 <blogan_> except octavia at this point
20:36:39 <blogan_> but that'd be worked on in parallel
20:36:44 <sbalukoff> Right.
20:37:02 <xgerman> well, we also need to finish all the other work
20:37:10 <dougwig> sbalukoff/evgenyf - can you guys make a list of what's left and an expected timeline, and then we can circle with the L-3 folks?
20:37:11 <blogan_> but exposing to API is just service plugin work
20:37:47 <sbalukoff> If we merge evgeny's patch (which is honestly pretty much ready to be merged), then in order to deliver this for Liberty we need to solve the independent pools problem for Neutron LBaaS and Octavia, do the L7 stuff for Octavia, and also do it for the namespace driver for good measure (which, again, is mostly done)
20:37:52 <blogan_> oh and db work
20:37:59 <sbalukoff> right.
20:38:11 <evgenyf> dougwig: sure, how abiut to have it on the ML
20:38:17 <dougwig> sbalukoff: ha, i didn't mean right now.  :)
20:38:18 <xgerman> sounds good
20:38:21 <johnsom_> And tempest test
20:38:23 <sbalukoff> So...  it's a lot of medium-to-small work kind of stuff.
20:38:28 <sbalukoff> Oh yes, tempest test.
20:38:33 <dougwig> let's get an etherpad going with a plan, then we can ML that.
20:38:37 <sbalukoff> Which I have no idea how difficult is to do.
20:38:38 <xgerman> +1
20:38:42 <sbalukoff> Ok.
20:38:45 <blogan_> i personally dont see it making it in
20:38:55 <sbalukoff> evgenyf: Do you want to do that etherpad, or shall I?
20:39:02 <sbalukoff> blogan_: +1
20:39:04 <dougwig> that depends on how motivated evgenyf is. i'm willing to give him a shot.
20:39:10 <sbalukoff> Ok!
20:39:28 <blogan_> if independent pools is a must, which seems like it is, its too much work for too little time
20:39:28 * xgerman shipd redbull to evgenyf_
20:39:44 <evgenyf> sbalukoff. I will
20:39:48 <dougwig> priority is likely octavia first, l7 second.
20:39:55 <blogan_> horizon?
20:39:55 <dougwig> can we do horizon quick now?
20:39:55 <evgenyf> sbalukoff: I will
20:40:07 <dougwig> we've got the repo and initial code. has there been any activity since then?
20:40:19 <xgerman> haven’t heard from vivek_ebay in a while so
20:40:26 <blogan_> i dont even know who's working on it, i havent even tested it out bc im a horrible dev
20:40:33 <sbalukoff> blogan_: I'd be willing to call the independent pools problem a "bug" which affects the ability to utilize some features of the new L7 patch... but I realize that might be stretching the truth a bit. ;)
20:40:52 <xgerman> probably safe to move horizon to M
20:41:10 <sbalukoff> #action evgenyf to do etherpad, start ML discussion of remaining L7 tasks.
20:41:14 <blogan_> i think its more like a cockroach that has been mutated by radiation
20:41:16 <dougwig> can all of the neutron-lbaas cores take a look at the horizon patch (and anyone else, of course.)  but neutron-lbaas cores are also cores in that repo.
20:41:20 <sbalukoff> (I don't know if I can add action items, eh.)
20:41:50 <xgerman> #action evgenyf to do etherpad, start ML discussion of remaining L7 tasks.
20:41:57 <xgerman> for good measure
20:42:21 <sbalukoff> dougwig: +1
20:42:22 <ajmiller> dougwig will look
20:42:24 <evgenyf> I tried vivek's horizon patch, merged it, restarted, the new section did not show up, left it there
20:42:28 <xgerman> thanks ajmiller
20:42:40 <xgerman> evgenyf good to know
20:43:02 <blogan_> evgenyf: how does that get loaded into horizon?
20:43:27 <dougwig> it might be a new panel that needs to get added to /etc/openstack_dashboard, but i haven't looked
20:43:30 * dougwig runs off to dentist.
20:43:41 <evgenyf> I merged the code into horizon dashboard like vivek said
20:44:20 <evgenyf> bunch of new files and new import, that;s it
20:44:49 <blogan_> okay
20:44:50 <blogan_> hmm
20:45:02 <xgerman> mmh, let’s try and update on the ML
20:45:04 <blogan_> ive gotta head to the dentist soon as well
20:45:14 <rm_work> airport soon for me
20:45:27 <xgerman> blogan_ you and dougwig use the same dentist?
20:45:32 <xgerman> same teeth?
20:45:33 <sbalukoff> So, I was in a meeting yesterday with IBM bluemix people giving me a demo of the GUI work they did around neutron LBaaS v1...  it was prettty good. I think I also made a really strong case for them moving to v2 as soon as possible. If there's interest, I can ping them about the possibility of getting engineering talent on an upstream LBaaS v2 horizon UI. :/
20:45:35 <evgenyf> xgerman: will do
20:45:45 <sbalukoff> Haha!
20:45:59 <xgerman> sbalukoff the more the merrier
20:46:05 <blogan_> yeah i'm seeing dougwig's dentist, he's doing a remote root canal
20:46:07 <blogan_> on me
20:46:09 <sbalukoff> xgerman: Okeedokee!
20:46:12 <blogan_> with a robotic arm
20:46:16 <sbalukoff> Haha!
20:46:20 <crc32> I hope they hit a nerve
20:46:23 <xgerman> dougwig is probably driving that
20:47:00 <xgerman> #topic Brief progress reports
20:47:10 <xgerman> really brief
20:47:17 <blogan_> so for the neutorn lbaas talk for Liberty, if horizon and L7 dont get in, we only have one thing accomplished, octavia as ref impl
20:47:31 <xgerman> yep, and that is huge!!
20:47:39 <johnsom_> health manager is fully functional (DB is updated for status and stats).  Working on finishing up updating unit tests
20:47:45 <blogan_> its huge but takes up like 1 minute of talk time
20:47:46 <rm_work> yeah but ... not sure it will be perceived as quite as momentus as we see it :)
20:47:56 <sbalukoff> Heh!
20:48:06 <xgerman> rm_work we also have active-passive
20:48:12 <sbalukoff> That's true.
20:48:14 <xgerman> huge as I said
20:48:17 <rm_work> yeah that is true
20:48:30 <rm_work> and ... TLS?
20:48:31 <blogan_> thats a huge review to merge before the deadline
20:48:38 <rm_work> TLS is in actually, and wasn't, right?
20:48:40 <blogan_> and its not a requirement for ref impl
20:48:45 <blogan_> it was in
20:48:50 <sbalukoff> And it's not the only one that would need to be reviewed / merged.
20:48:57 <rm_work> TLS was enabled in lbaas in K?
20:48:58 <xgerman> I will try to strongram dougwig for an extension
20:49:02 <blogan_> yes
20:49:06 <rm_work> T_T k
20:49:08 <blogan_> just found out there were no docs about it
20:49:10 <blogan_> but it was there
20:49:15 <xgerman> yep
20:49:16 <TrevorV> I need some eyes again on https://review.openstack.org/#/c/202336/
20:49:18 <rm_work> no idea how it would have worked
20:49:19 <TrevorV> #link https://review.openstack.org/#/c/202336/
20:49:23 <xgerman> johnsom demoed it on stage
20:49:25 <rm_work> since we JUST managed to merge the final commits to make it work
20:49:26 <rm_work> lol
20:49:30 <sbalukoff> I'll work hard on getting my stuff updated and stable. I apologize I've not gotten y'all an updated patch yet.
20:49:30 <TrevorV> I think its ready for merging in its most basic failover form
20:49:32 <TrevorV> I just tested it.
20:50:00 <johnsom_> Cool
20:50:10 <xgerman> grande
20:50:18 <blogan_> ok dentist time
20:50:21 <blogan_> talk to yall later
20:50:26 <johnsom_> Enjoy
20:50:27 <madhu_ak> for TLS tests, looks like adam is working on setting up barbican with devstack and that test can be tested
20:50:29 <xgerman> good luck
20:50:33 <TrevorV> johnsom_, captures the routes, adds the haproxy config, and I tested with a LB with a listener, pool, member, and health monitor.
20:50:57 <TrevorV> I also tested failing over a failed-over amphora
20:51:03 <rm_work> madhu_ak: yeah, soon barbican will support the new plugin method so we can actually use it correctly in our devstack gates
20:51:05 <TrevorV> To make sure it couldn't only fail over once :D
20:51:15 <johnsom_> Nice
20:51:24 <bana_k> testing and will continue
20:51:25 <xgerman> rm-work nice
20:51:26 <rm_work> which involves me fiddling with THEIR gate right before freeze <_<
20:51:32 <madhu_ak> nice ram_work
20:51:33 <xgerman> thanks bana_k
20:51:36 <madhu_ak> rm_Work
20:52:18 <xgerman> I like ram_work
20:52:23 <rm_work> heh
20:52:24 <madhu_ak> heh
20:52:37 <sbalukoff> HAHA
20:52:37 <madhu_ak> time to change his nick
20:52:41 <xgerman> ok, I guess we can move to
20:52:42 <rm_work> T_T
20:52:53 <xgerman> #topic Open Discussion
20:52:56 <rm_work> time to head to the airport, maybe i'll wave at the Seattle HP people on Friday
20:53:16 <xgerman> yeah, stop by I am sure they can hook you up with red bull and stuff
20:53:18 <ajmiller> rm_work ping us if you have a chance...
20:53:21 <rm_work> heh
20:53:33 <madhu_ak> if there is any open task needs to be done, I can try to work on it
20:53:38 <bana_k> any other tasks to be done ?
20:53:44 <rm_work> i'll prolly be occupied most of the day, but i can wave in passing at least :P
20:53:45 <rm_work> we'll see
20:53:58 <rm_work> the convention center will be BONKERS, so have fun with that
20:54:10 <xgerman> well, In saw a potential L7 tempest test made_ak
20:54:13 <xgerman> mshu_ak
20:54:15 <rm_work> ridiculous number of people will be there
20:54:17 <madhu_ak> madhu_Ak
20:54:21 <xgerman> yep
20:54:35 <madhu_ak> sure, can take a look into it. best person to reach?
20:54:50 <xgerman> sync with sbalukoff and evgeny
20:54:51 <sbalukoff> bana_k: I don't think anyone has started on the L7 work for Octavia directly yet. I can give you pointers on that if you'd like.
20:54:59 <xgerman> +1
20:55:12 <madhu_ak> awesome, I can sync with them
20:55:21 <johnsom_> +1
20:55:24 <xgerman> also there was an ask for performance tests
20:55:40 <bana_k> sbalukoff, that do be great.
20:55:44 <TrevorV> xgerman, who asked that?
20:55:45 <sbalukoff> Sweet!
20:55:48 <xgerman> dougwig
20:55:51 <sbalukoff> dougwig was asking earlier
20:55:55 <TrevorV> kk
20:55:58 <TrevorV> just curious
20:55:58 <xgerman> TrevorV you guys have a lb?
20:56:00 <sbalukoff> However, I would consider a performance problem to be a "bug"
20:56:01 <xgerman> lab?
20:56:18 <sbalukoff> So... work on it after this week. In the short term, let's get that Octavia as a reference driver done.
20:56:26 <xgerman> +1000
20:56:32 <sbalukoff> So any review work that needs to be done to make that happen... let's get that done!
20:56:34 <madhu_ak> yep.. please let me know how I can seek more details on performance tests. Any pointers is appreciated
20:56:39 <TrevorV> xgerman, we have lab space we've been testing our implementation and such, if blogan were still here he'd have more info.  ptoohill anything to add here?
20:57:09 <xgerman> cool, yeah, I will have numbers next year ;-)
20:57:20 <sbalukoff> Heh!
20:57:42 <xgerman> yep, we are still kilo in HP land
20:58:21 <xgerman> anyway, we probably need to get dougwig to file extensions
20:58:31 <xgerman> will work on that...
20:58:44 <xgerman> #endmeeting