20:00:04 <xgerman> #startmeeting Octavia
20:00:06 <openstack> Meeting started Wed Jul  1 20:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:09 <openstack> The meeting name has been set to 'octavia'
20:00:15 <rm_work> o/
20:00:16 <ajmiller_> o/
20:00:17 <madhu_ak> hi
20:00:20 <Aish> o/
20:00:21 <xgerman> #topic Announcements
20:00:40 <xgerman> CfP Tokyo Summit
20:00:50 <xgerman> #link https://www.openstack.org/summit/tokyo-2015/call-for-speakers/manage/3647/summary
20:01:03 <xgerman> #link https://etherpad.openstack.org/p/Octavia-Tokyo-Talks
20:01:23 <xgerman> Ok, I think only two weeks left so if you have a talk make sure to submit :-)
20:01:59 <madhu_ak> yes, fnaval and myself proposed for a talk and it is added in the etherpad..so checking whether the community is okay with it
20:02:21 <fnaval> o/
20:02:22 <xgerman> yep, "Hands on Lab: Learn how to exercise and create tempest tests for OpenStack Neutron LBaaS V2"
20:02:45 <xgerman> even if we like it doesn’t mean it gets accepted + you can submit talks we don’t like, too
20:03:02 <xgerman> #chair blogan
20:03:03 <openstack> Current chairs: blogan xgerman
20:03:19 <madhu_ak> okay, sounds good. will submit them maybe on monday
20:03:29 <blogan> hello!
20:03:34 <mwang2> hi
20:03:35 <xgerman> hi
20:03:48 <xgerman> blogan + dougwig what’s your take on talk proposals
20:03:50 <xgerman> ?
20:04:01 <xgerman> just submit and see if it sticks?
20:04:31 <TrevorV> o/
20:04:33 <TrevorV> late hiya
20:04:38 <blogan> xgerman: works for me, i'd like to get at least one lbaas talk accepted and thats usually the and beyond talk
20:04:42 <dougwig> i wouldn't oversubmit, or the voters won't know what's up. and to some degree, the TC and PTLs will make sure the projects have good coverage.
20:05:18 <blogan> or just name it buzzword bingo
20:05:43 <xgerman> that’s close to promising everybody who shows up $100
20:05:58 <dougwig> or call it "docker NFV chaining"
20:06:29 <xgerman> lol
20:06:44 <xgerman> also Midcycle is close:
20:06:49 <xgerman> #link https://etherpad.openstack.org/p/LBaaS-FWaaS-VPNaaS_Summer_Midcycle_meetup
20:07:00 <xgerman> we have a good crowed
20:07:04 <xgerman> crowd
20:07:27 <xgerman> also get your hotels rather sooner then later :-)
20:07:45 <blogan> holy crap that exploded since i last looked at it
20:08:10 <xgerman> yep… I asked for a bigger room :-)
20:08:23 <blogan> we're gonna need a bigger boat
20:09:15 <xgerman> #topic Brief progress reports
20:09:16 <sballe> I am happy about all the participation
20:09:20 <xgerman> +1
20:09:57 <TrevorV> I have a WIP review up, so nothing needed there
20:09:59 <dougwig> neutron driver, i'm thinking we merge that, and let folks iterate?  it's been sitting in WIP for awhile now. alternately, we can move it to octavia and put a shim in neutron-lbaas, so the driver can be modified in lockstep with octavia features?
20:10:06 <TrevorV> But the last delete fix thing needs reviews: https://review.openstack.org/#/c/192359/
20:10:08 <TrevorV> #link https://review.openstack.org/#/c/192359/
20:10:28 <blogan> dougwig: you mean octavia driver?
20:10:36 <dougwig> blogan: yes
20:11:04 <xgerman> since we are destined to become the reference implementation we *should* have all the features in Octavia
20:11:04 <blogan> well i'd like it to delete correctly
20:11:28 <xgerman> so I think it can stay in neutron-lbaas
20:11:32 <xgerman> blogan +1
20:11:53 <dougwig> ok
20:12:09 <dougwig> it needs a unit test, too, but i was hating on requests-mock last week.
20:12:47 <xgerman> you go ask them for responses :-)
20:12:50 <xgerman> \me hides
20:12:58 <blogan> \me /mes
20:13:01 <TrevorV> Really dougwig ?  That's the easy stuff.  Just make response say "I WORKED!" and done
20:13:19 <xgerman> TrevorV don’t ask for responses
20:13:22 <rm_work> TrevorV: can you rebase that just for funsies? lots of stuff has merged in the past two weeks
20:13:32 <TrevorV> The health monitor review?  Yeah
20:13:35 <rm_work> thanks
20:13:43 <rm_work> would just like to make sure i'm reading all the changes in the new context
20:13:50 <TrevorV> Yep
20:13:55 <xgerman> also #link https://review.openstack.org/#/c/171172/ — I have a +2 demo rm_work...
20:14:01 <TrevorV> Done
20:14:09 <xgerman> probably needs rebasing, too
20:14:16 <dougwig> TrevorV: eh, it's mostly me hating on how verbose and crappy unittest and mock make tests look.  why have a few dozen lines of logic when you can mix 1000 lines of boilerplate into it?
20:14:36 <TrevorV> Hah, yeah, well... wut?
20:16:26 <xgerman> ok, moving on...
20:16:35 <xgerman> #topic Should Octavia install the Neutron LBaaS Octavia plugin?
20:16:44 <xgerman> #link https://review.openstack.org/#/c/196265/
20:17:02 <xgerman> there is some history in the comments
20:17:02 <rm_work> that's a weird one
20:17:20 <xgerman> yeah, I felt we should discuss it with a wider audience
20:17:52 <dougwig> hmm, interesting.
20:17:57 <blogan> i wouldnt say its installing, octavia would just be modifying the neutron_lbaas.conf's service_provider, but there's already a way to have devstack override that value
20:18:18 <dougwig> how does it work when you install, say, ODL via devstack?
20:18:19 <xgerman> ok, what blogan said...
20:18:31 <blogan> dougwig: you tell me neutron core
20:18:56 <dougwig> standby
20:19:11 * blogan waits for dougwig to do his bidding
20:19:13 <xgerman> you want to screen share while you try it out?
20:19:47 <dougwig> from networking-odl's devstack plugin:
20:19:49 <dougwig> https://www.irccloud.com/pastebin/QlA8s66x/
20:20:02 <dougwig> so i'd say it's ok to configure the portion of the config files to enable yourself.
20:20:49 <xgerman> yeah, I think with flavors that should become even less controversial
20:21:09 <blogan> sounds fine to me then
20:21:12 <xgerman> since you are not disabling anyone else
20:21:13 <rm_work> alright, if there's precedent, then whatevs
20:21:21 <xgerman> ok, that was quick
20:21:22 <rm_work> also -- it's devstack
20:21:25 <rm_work> lol
20:21:39 <TrevorV> rm_work, stop it.
20:21:54 <TrevorV> rm_work, if this change breaks my devstack like everything else that updates in it does, then I'll be upset.
20:21:58 <xgerman> #decision Octavia can enable itself in neutron_lbaas.conf in devstack
20:22:01 <TrevorV> I am the guinea pig for rando crap goin wrong.
20:22:23 <dougwig> breaking TrevorV is just icing on the cake.
20:22:24 <xgerman> just get a teflon suit...
20:22:44 <xgerman> #topic Open Discussion
20:22:50 * TrevorV sent weeping into a corner
20:23:05 <blogan> breaking TrevorV is like breaking egg shells to scramble eggs, its going to happen
20:23:35 <rm_work> giving ajmiller a second to change his review to +1 before we workflow :P
20:23:55 <ajmiller> rm_work just a sec
20:24:22 <rm_work> i'll let xgerman workflow it
20:24:35 <xgerman> neat
20:24:35 <ajmiller> done
20:25:04 <xgerman> done = done
20:25:14 <TrevorV> Is it done or done done?
20:25:21 <xgerman> done + done
20:25:25 <xgerman> hit +A
20:25:51 <madhu_ak> do we need to setup a new jenkins job for running scenario tests?
20:26:11 <xgerman> to run LBaaS tests or Octavia as part of LBaas
20:26:55 <xgerman> I assume you are asking LBaaS?
20:26:59 <madhu_ak> yep
20:27:11 <madhu_ak> its for neutrl lbaas
20:27:15 <madhu_ak> neutron*
20:27:26 <xgerman> yes, we should but dougwig has a better idea what the CI system can ebar
20:27:31 <xgerman> bear
20:28:03 <dougwig> we should setup a new job, because the api job is already too long.
20:28:18 <dougwig> and yet another for octavia, when its ready for an end-to-end CI job.  is it?
20:28:50 <rm_work> dougwig: can we add py34 as a gate-test for octavia?
20:28:51 <xgerman> mmh, I haven’t tested that yet
20:29:00 <rm_work> the tox job and most of the corrections merged
20:29:02 <madhu_ak> sure, I have marked WIP for this https://review.openstack.org/#/c/196238/ until we set cenario test job for lbaas
20:29:36 <rm_work> now it's a keep-up game, because there's no gate-check for py34 so people are starting to commit more stuff that violates it
20:29:48 <TrevorV> You violate it.
20:29:55 <rm_work> TrevorV: I most certainly do not
20:30:04 <rm_work> unless that's because I'm not a python interpreter
20:30:08 <TrevorV> I just pictured you doing something like "egads"
20:30:32 <madhu_ak> on the other hand, for this one: https://review.openstack.org/#/c/158904/, its currently in zuul, how the jenkins is testing them?
20:32:04 <xgerman> so we want to do a lot of stuff so do we have names of people doing it?
20:32:19 <xgerman> who is adding the py34 job?
20:32:50 <xgerman> blogan do you have the power to violin-tell?
20:32:56 <xgerman> volun-tell?
20:33:50 <rm_work> technically we should make the decision as a project that we WANT py34 to be a gate check
20:33:59 <rm_work> I certainly am for it
20:34:09 <rm_work> but I don't know how many openstack projects do py3 compat yet
20:34:17 <rm_work> some of them, but it isn't yet a requirement
20:34:18 <xgerman> I am in favor
20:34:26 <rm_work> I just like being ahead of the curve
20:34:58 <TrevorV> By that he means he like to lose weight
20:34:58 <rm_work> blogan / dougwig?
20:35:01 <xgerman> #vote Should we do y34? Yes, No
20:35:11 <rm_work> TrevorV: i do like to lose weight as well ;P
20:35:18 <rm_work> votebot off?
20:35:25 <rm_work> anyway no one is responding
20:35:33 <xgerman> yeah
20:35:42 <dougwig> neutron is doing py3 now
20:35:46 <xgerman> votebot didn’t do it since I did the syntax wrong
20:35:47 <rm_work> dougwig: ah ok
20:35:50 <dougwig> so i don't see why we couldn't
20:35:53 <rm_work> so that seems like a good plan then
20:36:11 <TrevorV> Alrighty rm_work get on that my man.
20:36:14 <TrevorV> o_0
20:36:15 <xgerman> #action rmwork enable py34 gate for Octavia
20:36:15 <rm_work> there's only one or two violations that have made it in since i did the major overhaul
20:36:19 <rm_work> kk
20:36:26 <rm_work> err, where do i do that? :P
20:36:34 <rm_work> which project is it
20:36:38 <xgerman> probably an infra path?
20:36:45 <xgerman> infra patch
20:36:57 <rm_work> project-config ?
20:37:29 <xgerman> I think so — but dougwig basically lives there
20:37:53 <xgerman> ok, next action: scenario job
20:37:58 <rm_work> there's no octavia for project-config/jenkins/jobs :/
20:38:29 <xgerman> mmh
20:39:12 <xgerman> https://review.openstack.org/#/c/182439/
20:40:04 <rm_work> thx
20:40:15 <xgerman> well, thank Google :-)
20:40:26 <xgerman> anyhow, next action the scenario job
20:40:38 <xgerman> madhu_ak you want to tackle that?
20:40:51 <madhu_ak> yeah, I can volunteer for that
20:41:23 <xgerman> #action madhu_ak add scenario job to Neutron LBaaS
20:41:43 <madhu_ak> sure
20:42:18 <xgerman> lastly, we wanted to run LBaaS tempest tests against Octavia and report back
20:42:41 <xgerman> volunteers for that?
20:43:06 * xgerman thinks tough crowd today
20:43:10 <dougwig> actually, we should set that up as a job.
20:43:21 <mwang2> i can try that
20:43:23 <xgerman> ok, non-voting
20:43:26 <madhu_ak> I can pick that unless there is no takers
20:43:31 <dougwig> experimental, actually.
20:43:38 <xgerman> yep
20:44:13 <xgerman> #action mwang2 set up experimental job to run LBaaS V2 tempest tests against Octavia
20:44:21 <mwang2> ok
20:44:27 <xgerman> mwang2 you can probably get ajmiller to help you ;-)
20:44:35 <mwang2> sure!
20:44:45 <ajmiller> Yes, I would be happy to help
20:44:54 <mwang2> thank you !
20:45:10 <xgerman> he had some collaboration with the jenkins people in his devstack adventures
20:45:42 <xgerman> so other things we should discuss?
20:46:15 <xgerman> I am still hoping BlueBox/IBM is sponsoring an evening at the mid cycle...
20:46:16 <madhu_ak> yeah, dougwig was telling we need to trim some tests..so checking whether there was debate about that
20:46:42 <dougwig> maybe a smoke tag
20:46:58 <xgerman> +1
20:47:02 <madhu_ak> I guess so
20:47:34 <madhu_ak> wondering if that is already being implemented or yet to start them
20:48:17 <TrevorV> Alright, so the WIP review I mentioned earlier is review-able
20:48:26 <xgerman> link?
20:48:31 <TrevorV> Just tested successfully with blogan's approval and everything
20:48:42 <TrevorV> #link https://review.openstack.org/#/c/197717/
20:48:44 <TrevorV> There yar
20:48:53 <dougwig> madhu_ak: not yet, feel free
20:49:25 <madhu_ak> sure, will take a look on that after setting up experimental job for scenario in lbaas
20:49:41 <xgerman> cool
20:49:52 <rm_work> https://review.openstack.org/#/c/197732/
20:50:06 <rm_work> from what I can tell, that job name is somehow automagic
20:50:17 <rm_work> don't see them defined anywhere
20:50:21 <TrevorV> #link https://review.openstack.org/#/c/197732/
20:51:08 <xgerman> well, the neutron review has python3-jobs
20:51:20 <dougwig> they are defined in macros.yml
20:51:37 <dougwig> i think that's where python*-jobs live.
20:52:02 <xgerman> yeah, so I think we need python3-jobs?
20:52:07 <xgerman> frm_work
20:52:10 <xgerman> rm_work
20:52:40 <xgerman> also 8 minutes - but it seems we can also take what we are doing to the labs channel
20:53:43 <xgerman> #endmeeting