16:32:33 <tjones> #startmeeting NovaBugScrub
16:32:34 <openstack> Meeting started Wed Feb 26 16:32:33 2014 UTC and is due to finish in 60 minutes.  The chair is tjones. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:32:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:32:35 <tjones> trying anyway
16:32:38 <openstack> The meeting name has been set to 'novabugscrub'
16:32:38 <dansmith> heh
16:32:41 <tjones> hee hee
16:32:43 * dansmith eats his words
16:33:03 <tjones> lets have a quick hello around the room.  to see who is here.  hi dansmith
16:33:08 <jog0> o/
16:33:31 <wendar> o/
16:34:01 <dorin-paslaru> o/
16:34:01 <gdebreczeni> o/
16:34:10 <claudiub> \o
16:34:10 <lpetrut> o/
16:34:11 <zsoltdudas> o/
16:34:12 <cnesa> o/
16:34:26 <claudiub> \o/
16:34:40 <avladu> o/
16:34:40 * johnthetubaguy is sorry he is a bit late
16:35:02 <tjones> excellent - we have a good bunch.  lets get started.  I've only blocked 1/2 hour for this meeting - which i hope is sufficient.   we ave a ton to do.
16:35:29 <tjones> digging right in to untriaged bugs - which is what we will focus on until the queue gets down to a decent #
16:35:39 <tjones> #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_bran
16:35:44 <tjones> ugh - sorry about that
16:36:01 <johnthetubaguy> is it worth thinking about just tagging untagged ones first?
16:36:22 <tjones> we could start that way - we have 137 untriaged.  let me grab the untagged
16:36:39 <tjones> 32
16:37:07 <tjones> here comes another big link (i'll do tiny url next time)
16:37:08 <tjones> https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
16:37:33 <tjones> #link https://bugs.launchpad.net/nova/+bug/1285209
16:38:05 <johnthetubaguy> list of tags, if thats helpful:https://wiki.openstack.org/wiki/Nova/BugTriage
16:38:07 <tjones> bot does look broken
16:39:11 <tjones> ok lets just go through each one then and tag them
16:39:15 <dansmith> tjones: I think it's working
16:39:21 <johnthetubaguy> link is normally just an agenda entry though, not sure the bug bot is in here
16:39:28 <tjones> ah ok
16:39:36 <johnthetubaguy> bug 1285209
16:39:43 <johnthetubaguy> hmm, oh well
16:40:37 <tjones> ok if people can take a look at each bug and chime in on the tag (cause i won't know until i get better at this) we can tab them
16:40:44 <tjones> https://bugs.launchpad.net/nova/+bug/1285209
16:40:56 <tjones> volumes
16:41:36 <tjones> https://bugs.launchpad.net/nova/+bug/1285158
16:42:20 <tjones> next one sounds like network to me
16:42:55 <wendar> https://wiki.openstack.org/wiki/BugTags only mentions Quantum, not Neutron yet
16:43:01 <wendar> (seems in need of a small update)
16:43:21 <tjones> https://bugs.launchpad.net/nova/+bug/1285048 this is actually a question
16:43:36 <jog0> wendar: also the real list of tags is https://bugs.launchpad.net/nova/ on the bottom right
16:43:57 <jog0> tjones: for qustions we refer people to ask.openstack.org
16:44:07 <jog0> and this is for ubuntu
16:44:13 <jog0> I'll handle this one
16:44:19 <tjones> jog0:  would you mind - yes thanks
16:44:23 <wendar> jog0: wouldn't that only be active bugs?
16:44:44 <tjones> #link https://bugs.launchpad.net/nova/+bug/1285035
16:46:08 <johnthetubaguy> looks like it could be a postgresql issue, but I thought we gated on that now?
16:46:11 <jog0> wendar: click show more tags
16:46:27 <jog0> johnthetubaguy: we do
16:46:36 <johnthetubaguy> jog0: thanks, thought so
16:46:40 <jog0> but not with fake virt
16:46:50 <wendar> jog0: okay, goes all the way down to 0 instance tags, but still only tags used before?
16:46:51 <johnthetubaguy> jog0: right, good to narrow it down
16:47:11 <tjones> johnthetubaguy: you think db then?
16:47:27 <jog0> wendar: that is the 'official' list
16:47:32 <johnthetubaguy> tjones: not sure, seems like a fake virt driver thing
16:47:35 <wendar> jog0: ok
16:47:44 <jog0> johnthetubaguy: yeah that sounds right
16:48:09 <tjones> johnthetubaguy: don't see a fake tag
16:48:21 <johnthetubaguy> tjones: don't think there is one yet
16:48:23 <jog0> johnthetubaguy: ohh hypervisor version is an int
16:48:26 <jog0> i'll fix this one now
16:48:34 <johnthetubaguy> jog0: ah, that would do it, thanks
16:48:48 <tjones> jog0: i shoulda caught that.  we had the same prob
16:49:02 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284990
16:49:02 <jog0> ^_^
16:49:21 <tjones> thats docker
16:49:40 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284788
16:50:12 <tjones> scheduler??  im guessing here
16:50:31 <johnthetubaguy> no, its compute I think
16:50:34 <johnthetubaguy> I added live-migrate
16:50:39 <johnthetubaguy> its a grey area for sure
16:51:03 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284761
16:51:03 <johnthetubaguy> I think its a duplicate actually
16:51:05 <tjones> docker
16:51:09 <claudiub> the one about docker - that issue seems to appear on a windows environment, but there is no windows tag
16:51:31 <tjones> thanks claudiub - please add
16:51:50 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284741
16:51:58 <tjones> ec2
16:52:19 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284733
16:52:51 <johnthetubaguy> api
16:52:52 <johnthetubaguy> ish
16:53:31 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284719
16:53:38 <tjones> another migration one - so compute?
16:53:59 <tjones> i mean live-migrate
16:54:11 <johnthetubaguy> yeah
16:54:14 <johnthetubaguy> I can add that
16:54:19 <tjones> no live-migrate tag?
16:54:42 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284709
16:54:43 <johnthetubaguy> I keep using it, but its not official
16:54:52 <johnthetubaguy> we could add it, I can own those
16:55:01 <tjones> clearly network (johnthetubaguy can we add it?  looks useful)
16:55:21 <johnthetubaguy> sure, give me an action
16:55:32 <johnthetubaguy> #action johnthetubaguy add live-migrate and network tag
16:55:32 <tjones> #action johnthetubaguy add live-migrate tag
16:55:38 <johnthetubaguy> oops
16:55:38 <tjones> heh
16:55:42 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284708
16:55:50 <tjones> compute
16:56:27 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284431
16:56:30 <tjones> compute
16:56:51 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284424
16:57:08 <tjones> compute?
16:58:15 <wendar> kind of network
16:58:37 <johnthetubaguy> well, I think its compute
16:58:45 <johnthetubaguy> its the instance quota getting out of sync
16:59:19 <tjones> put them both and let the teams decide :-)
16:59:28 <tjones> #link https://bugs.launchpad.net/nova/+bug/1284202
16:59:34 <johnthetubaguy> wendar: why network?
17:00:09 <johnthetubaguy> that one is network I think
17:00:11 <claudiub> it could also be because of a dirty database caused by some errors. without the logs, you can't really tell
17:00:13 <wendar> the cause of the problem is a network outage, i.e. not re-establishing properly
17:00:33 <johnthetubaguy> wendar: sure, but its nothing to do with nova-network or quantum
17:00:38 <wendar> the effect is in compute though, so I'd take that
17:01:01 <johnthetubaguy> no worries, I get your thinking though, I just think network = nova-network/neutron
17:01:40 <wendar> johnthetubaguy: makes sense
17:01:59 <tjones> ok - we are at 9:00 (PST) now.  so lets wrap up.  Folks - if you can continue periodically on these untagged ones - we only have 17.  then we can start the big pile of untriaged next week.  please feel free to give me feedback on running this meeting better so it helps us get through these as efficiently as possible
17:02:29 <jog0> tjones: so now that we are using tags better, we need to follow up with the latter steps of triage as well
17:02:32 <jog0> thanks tjones
17:02:49 <wendar> thanks tjones
17:03:15 <tjones> thanks all of you for attening even through the time is not great for pretty much everyone ;-)
17:03:18 <tjones> #endmeeting