14:00:06 <efried> #startmeeting nova-scheduler
14:00:06 <openstack> Meeting started Mon Mar 11 14:00:06 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:16 <mriedem> o/
14:00:20 <takashin> o/
14:00:24 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Agenda_for_next_meeting
14:00:26 <gibi> o\
14:01:50 <efried> jay is on a plane, so all action items go to him.
14:01:56 <efried> #topic last meeting
14:01:56 <efried> #link last minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2019/nova_scheduler.2019-03-04-14.00.html
14:02:05 <efried> any old bidniss?
14:02:14 <edleafe> \o
14:02:42 <efried> #topic specs and review
14:02:42 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003625.html
14:02:42 <efried> #link blueprint tracking https://etherpad.openstack.org/p/nova-stein-blueprint-status
14:03:14 <efried> I guess since we're after FF, perhaps we should stop looking at blueprints.
14:03:14 <efried> or start looking at them from the perspective of reproposing and landing things in Train.
14:03:28 * efried notices that etherpad could use a scrub
14:03:47 <mriedem> i've just updated launchpad
14:03:53 <mriedem> https://blueprints.launchpad.net/nova/stein
14:04:00 <mriedem> the only thing remaining in question is tetsuro's
14:04:05 <mriedem> https://blueprints.launchpad.net/nova/+spec/negative-aggregate-membership
14:04:13 <efried> nice
14:04:17 <efried> coming to that...
14:04:18 <mriedem> i'm not comfortable landing new api changes post feature freeze
14:04:22 <mriedem> ok
14:04:27 <efried> #link DRY/clean up placement objects phase 2 https://review.openstack.org/#/q/topic:cd/de-list-phase2+(status:open+OR+status:merged)
14:05:00 <efried> This is progressing nicely. It's all refactors, no functional changes. Not sure how folks feel but I'm comfortable continuing to land those at this stage.
14:05:19 <mriedem> i'm also uncomfortable continuing to land those at this point
14:05:22 <mriedem> but that's going to be a theme with me
14:05:34 <mriedem> if it's not a bug fix, i don't see why it can't just wait for train
14:05:36 <edleafe> API changes are high risk. Refactors with tests not nearly as high
14:05:48 <mriedem> that series did introduce at least one regression right?
14:05:53 <mriedem> something mel hit in her counting quotas stuff
14:06:10 <efried> yes, casting something to int
14:06:46 <efried> though that was a rather more dramatic rework (removing OVO) than what's going on now (moving methods from one place to another).
14:06:47 <mriedem> it's all fun and games until you ship a nasty regression
14:06:58 <mriedem> ok,
14:07:07 <mriedem> i guess i haven't been involved to know where that is at now
14:07:35 <efried> this series of patches is literally cut/paste method from one module to another, or reshuffling within a module.
14:07:57 <efried> we could wait, sure, but it has momentum and seems very low risk.
14:08:31 <efried> anyway, without cdent here to defend himself, not sure we can come to a conclusion, so moving on...
14:08:34 <efried> #link negative aggregate membership https://review.openstack.org/#/q/topic:bp/negative-aggregate-membership
14:08:42 <edleafe> I would prefer not to hold them, but Mel gets the final call
14:09:33 <efried> This is a feature, an API change. I would tend to agree to hold off here. tetsuro is fine with that. But we can still review it and get it ready to land early.
14:09:35 <mriedem> as i said in the ML i'm also -1 on landing that api change post FF
14:09:58 <mriedem> if there is agreement to not land it, can someone put a procedural hold on it?
14:10:29 <efried> yeah, lemme go do that.
14:12:06 <efried> Lemme do that after the meeting. I want to provide links so it doesn't look like I'm just randomly contradicting Chris.
14:12:18 <efried> #action efried to put a procedural hold on the negative aggregate membership series.
14:12:52 <efried> Any other specs or reviews to highlight at this time?
14:13:08 <efried> #topic Extraction
14:13:08 <efried> #link Extraction https://etherpad.openstack.org/p/placement-extract-stein-5
14:13:40 <efried> Since this is effectively done, I'm considering removing it from the agenda as a topic.
14:13:40 <efried> That said, we still want to track e.g. the tripleo stuff, so ^ not yet.
14:13:52 <efried> anyone have anything to say here?
14:13:53 <edleafe> efried: +1  on removing it
14:14:30 <efried> noted
14:14:34 <efried> #topic bugs
14:14:34 <efried> #link Placement bugs (launchpad) https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:14:34 <efried> #link Placement storyboard https://storyboard.openstack.org/#!/project_group/placement
14:15:37 <mriedem> as cdent said in the ML pupdate,
14:15:42 <mriedem> sb is going to take some getting used to
14:15:46 <mriedem> since it's totally free-form
14:16:38 <efried> Yeah
14:16:40 <efried> I don't like it
14:16:42 <efried> but then
14:16:49 <efried> I don't like lp either
14:17:10 <efried> so whatever
14:17:12 <edleafe> But doesn't if feel good to be upstanding OpenStack citizens?
14:17:17 <mriedem> efried only likes RTC
14:17:25 <efried> oh, f rtc
14:17:31 <mriedem> edleafe: heh i don't feel that way about using SB no :)
14:17:42 <efried> I would suffer a whole month of lp+sb before spending an hour on RTC
14:18:09 <efried> moving on
14:18:18 <efried> any bugs to highlight?
14:19:00 <efried> From last week:
14:19:00 <efried> #link https://bugs.launchpad.net/nova/+bug/1696830
14:19:01 <openstack> Launchpad bug 1696830 in OpenStack Compute (nova) "nova-placement-api default config files is too strict" [Low,In progress] - Assigned to Corey Bryant (corey.bryant)
14:19:01 <efried> #link https://bugs.launchpad.net/nova/+bug/1778591
14:19:03 <openstack> Launchpad bug 1778591 in OpenStack Compute (nova) "GET /allocations/{uuid} on a consumer with no allocations provides no generation" [Medium,In progress]
14:19:09 <efried> These were flagged as "what do we do with this"
14:19:19 <efried> and I'm not sure they've been looked at yet.
14:20:11 <efried> that could be something to do now that we're past FF
14:20:33 <efried> moving on
14:20:33 <efried> #topic opens
14:20:33 <efried> (From last last last week) Format of this meeting - new PTL to query ML
14:20:33 <efried> (From last last last week) Placement team logistics at PTG - new PTL to query ML
14:20:33 <efried> #link post-extraction plans for placement specs/bps/stories http://lists.openstack.org/pipermail/openstack-discuss/2019-February/003102.html
14:20:42 <efried> Opens, anyone?
14:21:26 <efried> okay then
14:21:32 <efried> quiet day
14:21:46 <efried> bye all
14:21:46 <efried> o/
14:21:46 <efried> #endmeeting