14:00:34 <efried> #startmeeting nova-scheduler
14:00:35 <openstack> Meeting started Mon Jan 21 14:00:34 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:39 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:58 <edleafe> \o
14:01:05 <cdent> o/
14:01:06 <takashin> o/
14:01:15 <tetsuro> o/
14:01:21 <gibi> o/
14:02:18 <gryf> \o
14:02:33 <mriedem> o/
14:03:04 <efried> It's a "bank holiday" in the US today, so I expect light attendance from Americans. Though edleafe and mriedem are here, so...
14:03:12 <efried> Okay, let's get started.
14:03:32 <efried> #topic last meeting
14:03:32 <efried> #link last minutes: http://eavesdrop.openstack.org/meetings/nova_scheduler/2019/nova_scheduler.2019-01-14-14.01.html
14:05:11 <efried> Out of the three #actionZ from last week, one is done (bandwidth call was scheduled, and happened); one has half happened (Jay and I bugged belmoreira about our respective patches; but haven't yet heard back that they've been tried); and one is still on the table (I promised to compile a list of n-sch/placement related blueprints for us to track in these meetings).
14:05:50 <jaypipes> o/\
14:05:50 <efried> I'll try to get to that last one this week - but I'm off today and traveling W-F, so it may not happen.
14:06:11 <gibi> for the bandwidth call, there is a summary on the ML and there is some issue from dansmith about the second microversion
14:06:11 <efried> #action efried to compile a list of approved sch/placement-related specs to at least stuff in the agenda page
14:06:22 <efried> #action efried to keep saying ^ this until it's actually done.
14:07:08 <gibi> bandwidth call summary: #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001879.html
14:07:27 <efried> #link this month's bandwidth review guide ML posts http://lists.openstack.org/pipermail/openstack-discuss/2019-January/#1350
14:07:40 <efried> Any other old business?
14:08:17 <efried> #topic specs and review
14:08:17 <efried> #link latest pupdate: http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001872.html
14:08:29 <efried> Any specs or reviews to highlight?
14:08:52 <jaypipes> not from me.
14:09:02 <cdent> I've got a few easy placement changes that just need something to say "eh, okay":
14:09:16 <cdent> #link: irrelevant files perfload: https://review.openstack.org/#/c/624047/
14:09:30 <cdent> #link document api error codes: https://review.openstack.org/#/c/624705/
14:09:48 <cdent> #link matt's ensure consumers status check: https://review.openstack.org/#/c/631671/
14:10:02 <cdent> that latter is at the end of the stack adding online migrations (which has all merged)
14:10:19 <gibi> I will check the consumers status patch, the rest is +2 from me
14:10:37 <cdent> there's also eric's rp uuid log info: https://review.openstack.org/#/c/631055/
14:11:04 <cdent> thanks gryf
14:11:23 <efried> #link reportclient-to-placement traffic reduction series starting at https://review.openstack.org/#/c/615677/
14:11:23 <efried> bottom patch is in the recheck whirligig. Remaining patches all have +2 from jaypipes. Couple at the top are +A, the rest need a second +2.
14:11:55 <cdent> that whirligig is nowhere near as fun as the name suggests
14:12:00 <gryf> cdent, no problem.
14:12:31 <efried> Imagine the terror the word evokes to someone with vertigo/motion sickness.
14:13:42 <efried> mriedem has that series on his radar, but the patches should be pretty easy for anyone else to pick up, and mriedem is pretty loaded, ahem, busy these days.
14:14:04 <gibi> efried: I put it on my list
14:14:12 <efried> Thanks gibi, I was hoping you would say that :)
14:14:25 <efried> Any other patches or specs to highlight?
14:14:51 <efried> #topic Extraction
14:14:56 <efried> cdent: care to take this chunk?
14:15:09 <cdent> oh sure
14:15:27 <cdent> we had the meeting and worked out that there are some things to do which were summarized by matt to the mailing list:
14:15:41 <efried> #link extraction meeting ML series http://lists.openstack.org/pipermail/openstack-discuss/2019-January/#1712
14:15:44 <cdent> thanks
14:15:54 <efried> least I can do after blindsiding you with an agenda item.
14:16:16 <cdent> lbragstad is in the hot seat for a lot of it, so we should all volunteer to either help him or buy him drinks
14:16:33 * efried has been trying to get him back into jiu jitsu
14:16:44 * lbragstad has been failing
14:16:45 <cdent> the online migration stuff listed above was also in the critical path, but is nearly done
14:17:50 <cdent> of course when I say lbragstad I really mean lyarwood
14:18:01 <efried> I was wondering
14:18:02 <cdent> this thing with contractions also extends to inital phonemes
14:18:21 <cdent> (thanks again gryf )
14:18:32 <cdent> but we can buy drinks for lbragstad too
14:18:38 <gryf> :)
14:18:41 <lbragstad> for a second i thought we were talking about something else... by l<tab><tab><tab> happens
14:18:59 <cdent> that's all I got on extraction, back to you efried
14:19:06 <efried> \o/
14:19:29 <efried> #link libvirt reshaper https://review.openstack.org/#/c/599208/
14:19:29 <efried> Pretty sure mriedem is refactoring this ^
14:19:44 <efried> mriedem: if you're getting overwhelmed, lmk and I can probably take that one off your hands.
14:20:05 <gibi> I've proposed a functional test for the reshape https://review.openstack.org/#/c/631559/
14:20:30 <gibi> this relevant for both the libvirt reshaper series and for the placement extraction
14:20:32 <efried> thanks gibi, saved me finding that :)
14:20:33 <mriedem> efried: we want your +2 remember
14:20:37 <mriedem> so yeah i'll do it this week
14:21:05 <efried> mriedem: Yeah, I know, but if it comes down to it, we could find another core rather than burn you out.
14:21:15 <efried> I don't want to see what it looks like for mriedem to burn out.
14:21:24 <efried> He might, like, express a second emotion.
14:21:54 <efried> #topic bugs
14:21:55 <efried> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:22:05 <efried> any bugs to highlight?
14:22:35 <efried> #topic opens
14:22:59 <efried> I have moved my home office to a room facing the back yard where I can watch the baby goats, and they are merry.
14:23:13 <cdent> pics or it didn't happen
14:23:48 <cdent> I sent mail to a few of you about this, but my involvement for the next few weeks will be limited due to internal-to-work concerns. Main change is that I may be slow to respond or show up.
14:24:46 <efried> Anything else?
14:25:00 <cdent> $random_inane_crap
14:25:13 <efried> ah, good, thanks cdent
14:25:24 <efried> though I thought the goat thing took care of that.
14:25:30 <efried> later y'all
14:25:33 <efried> #endmeeting