14:01:27 <efried> #startmeeting nova-scheduler
14:01:28 <openstack> Meeting started Mon Jan 14 14:01:27 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:31 <openstack> The meeting name has been set to 'nova_scheduler'
14:01:51 <edleafe> \o
14:01:52 <takashin> o/
14:02:00 <mriedem> o
14:02:41 <tetsuro> o/
14:02:45 <jaypipes> o/
14:03:39 <efried> sorry kids, I started that a few minutes early - my system clock, which is supposed to do the automatic sync with the world, apparently isn't.
14:03:58 <gibi> o/
14:04:08 <efried> will give it three or four minutes before we get started.
14:04:29 <mriedem> i've got 8:04...
14:05:13 <jaypipes> I've got freckle past a hair.
14:06:25 <efried> Okay, let's go.
14:07:00 <efried> Caveat: I've had like two hours of real work since I've been back, which was after a forced hiatus of a month, so still grinding back into knowing what's going on.
14:07:43 <efried> #topic last meeting
14:08:31 <efried> I think cdent ran it, but I don't see the minutes in the usual spot. Anyone want to recap, summarize, or mention anything that needs to be followed up on today?
14:08:54 * jaypipes wasn't in last, like, 4 meetings...
14:09:05 <mriedem> the nova meeting minutes say,
14:09:08 <mriedem> read the last pupdate,
14:09:12 <mriedem> and there is a hangout this week
14:09:18 <mriedem> to talk about what's left to declare extraction done
14:09:39 <gibi> yeah that was the content of the last meeting
14:10:24 <efried> Sorry, I'm silly
14:10:24 <efried> #link last meeting minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2019/nova_scheduler.2019-01-07-14.00.html
14:10:45 <efried> Cool. AFAIK (though I haven't been through my list mail yet this morning) that meeting is not yet scheduled?
14:11:34 <gibi> as far as I know cdent is planning to have it on Wednesday 17:00 UTC
14:12:43 <efried> Did that hit the ML somewhere?
14:13:05 <gibi> efried: I only have an irc discussion with cdent from last week
14:13:07 <efried> oh, I see it as suggested in the pupdate, to be confirmed today.
14:13:18 * gibi did not read the pupdate carefully
14:13:24 <efried> so - is that time good for all present?
14:13:30 <gibi> works for me
14:13:54 <edleafe> +1
14:14:10 <mriedem> wfm
14:14:25 <jaypipes> wfm2
14:14:33 <tetsuro> +1
14:15:20 <takashin> +1
14:16:06 <efried> good for me too.
14:16:06 <efried> I guess I'll report the consensus of these people to cdent and let him send out a confirming note once he's polled anyone else who should be involved (like melwitt?)
14:16:30 <efried> moving on.
14:17:32 <efried> #topic specs and review
14:17:37 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001666.html
14:19:41 <efried> For next time, I plan to...
14:19:41 <efried> #action efried to compile a list of approved sch/placement-related specs to at least stuff in the agenda page
14:20:27 <efried> #link reshaper patches https://review.openstack.org/#/q/topic:bp/reshape-provider-tree+status:open
14:20:48 <efried> These have stalled. I for sure owe reviews here. Hope to get to that this week.
14:21:15 <efried> #link bandwidth resource provider https://review.openstack.org/#/q/topic:bp/bandwidth-resource-provider
14:21:34 <efried> I would like to review this series too, but may have bandwidth restrictions of my own.
14:21:36 <mriedem> i don't know if the reshaper ones have active owners at this point
14:21:46 <efried> oh?
14:21:47 <mriedem> gibi is setting up a hangout this week as well for the bw series
14:21:54 <gibi> yepp
14:22:01 <mriedem> naichuan is gone from citrix as of awhile ago
14:22:14 <efried> okay. looks like there may be some rebasing needed as well. gibi, anything else to report while we're here?
14:22:27 <efried> mriedem: But the libvirt one, that's bauzas?
14:22:34 <jaypipes> mriedem: regardless of Citrix, we should at the very least have bauzas' work on libvirt for reshaper, no?
14:22:38 <mriedem> yes, but i don't know what kind of priority it is for him
14:22:38 <gibi> efried: so hangouts expected this week as there are some discussion about microversion and patch ordering on the ML
14:22:40 <jaypipes> efried: jinx. :)
14:23:16 <efried> okay. Is the hangout scheduling discussed in the "review guide" thread (on which I'm seriously behind)?
14:23:41 <mriedem> it will be
14:24:02 <mriedem> i'm also ~30 minutes into being back from vacation for a week...
14:24:15 <efried> okay. I assume that's
14:24:15 <efried> #action gibi to post to ML to schedule hangout to discuss bandwidth series
14:24:19 <gibi> efried: I will
14:24:24 <efried> neat
14:24:25 <gibi> efried: still gathering the possible time slots
14:25:09 <efried> next
14:25:39 <efried> #link series to reduce placement traffic and do other sensible cleanup in how the resource tracker / report client operates, starting at https://review.openstack.org/#/c/615677
14:25:48 <jaypipes> efried: currently on that series...
14:25:56 <jaypipes> mostly great stuff.
14:26:17 <bauzas> I'm there, sorry folks
14:26:46 <efried> Thanks for the reviews jaypipes. I also wanted to bring this to mriedem's attention because he recently did some work in the same neigborhood to consolidate the number of instances of the report client and stuff.
14:26:52 <bauzas> lemme check but I don't think the libvirt reshape change needs a rebase, right?
14:26:55 <efried> I know this because of all the merge conflicts I had to resolve on Friday.
14:27:13 <efried> bauzas: I don't think so. I think it just needs reviews, including from me.
14:27:23 <bauzas> unfortunately, the change is owned by mriedem so sometimes I don't verify it
14:27:23 <mriedem> efried: i had looked at some of the changes before https://review.openstack.org/#/c/615677 but was waiting for the ironic stuff to be ironed out in there before getting into it since it's not trivial
14:27:44 * alex_xu lurks
14:27:59 <efried> bauzas: https://review.openstack.org/#/c/599208/ has your -W on it currently. But no merge conflicts.
14:28:12 <bauzas> oh shit, right
14:28:17 <efried> bauzas: looks like you're going to take some action based on artom's feedback.
14:28:21 <bauzas> artom asked to modify the methods
14:28:53 <efried> mriedem: Roger that. I hopefully ironed out ironic on the latest PS, but haven't looked at the substance of jaypipes's -1 yet this morning.
14:29:50 <efried> Last I heard, tssurya/belmoreira were about to start deploying this code with their ironic nodes. Would be nice to get this into their env when they do that.
14:30:39 <mriedem> ok then someone please ping me when it's ready for me to review - when jaypipes is +2 or whatever
14:30:47 <mriedem> i have a lot of catching up to do today and tomorrow
14:30:59 <jaypipes> no worries, mriedem, will do.
14:31:06 <efried> nod
14:31:53 <jaypipes> there is also this patch: https://review.openstack.org/#/c/623558/. I was hoping belmoiro or tssurya would be able to test that perf fix out on CERN
14:34:08 * mriedem takes his kid to the bus stop
14:34:39 <efried> #action efried and/or jaypipes to lurk around looking for tssurya/belmoreira to ask about getting these sniffed by CERN.
14:35:56 <efried> Looks like belmoreira is in -nova, I pinged him.
14:36:06 <efried> Next
14:36:06 <efried> #topic Extraction
14:36:14 <efried> cdent isn't here. Anyone want to comment?
14:36:40 <efried> (besides about the hangout, already discussed)
14:37:39 <efried> #link latest iteration of the extraction etherpad https://etherpad.openstack.org/p/placement-extract-stein-5
14:38:10 <efried> #topic bugs
14:38:10 <efried> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:38:22 <efried> Anyone want to highlight any bugs?
14:39:02 * efried pictures cockroach with foil on antennae under one of those salon heat lamp thingies
14:39:18 <efried> #topic opens
14:39:34 <efried> Anyone?
14:40:36 <efried> Okay. Go forth and... schedule things.
14:40:39 <efried> #endmeeting