14:00:42 <cdent> #startmeeting nova-scheduler
14:00:43 <openstack> Meeting started Mon Dec 10 14:00:42 2018 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:46 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:48 <mriedem> o/
14:00:51 <takashin> o/
14:00:51 <gibi> o/
14:01:08 <cdent> #chair mriedem gibi takashin edleafe efried_cya_jan
14:01:09 <openstack> Current chairs: cdent edleafe efried_cya_jan gibi mriedem takashin
14:01:33 <cdent> #link prior meeting minutes http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-12-03-14.00.html
14:01:42 <cdent> #topic old biz
14:02:01 <cdent> The one main action item from last week was that edleafe was to seed os-resource-classes repo. That's in progress at
14:02:12 <edleafe> \o
14:02:27 <cdent> #link infra config for os-resource-classes: https://review.openstack.org/#/c/621666/
14:02:40 <cdent> I've started the placement-use of at
14:02:58 <cdent> #link placement using os-resource-classes https://review.openstack.org/#/c/623556/
14:03:05 <cdent> it works, locally
14:03:26 <cdent> some changes needed to os-resource-classes itself once it lands in its new home
14:03:32 <cdent> any other old biz?
14:04:00 <cdent> #topic new biz
14:04:05 <cdent> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000722.html
14:04:41 <cdent> matt had a followup about allocation handling and aggregates
14:04:49 <cdent> #link aggregates and allocations http://lists.openstack.org/pipermail/openstack-discuss/2018-December/000730.html
14:05:33 <cdent> anything else from the pupdate?
14:06:27 * edleafe like to watch cdent talk to himself
14:06:40 <cdent> indeed
14:06:46 <cdent> the reshaper series is important
14:06:51 <cdent> #link libvirt reshaper https://review.openstack.org/#/c/599208/
14:06:51 <cdent> #link xen reshaper (middle of series) https://review.openstack.org/#/c/521041
14:07:22 <cdent> it would be nice to get the placement fixture in nova stuff merged:
14:07:27 <cdent> #link placement fixture in nova https://review.openstack.org/#/c/617941/
14:08:17 <cdent> eric's series to reduce traffice between nova and placement is also important
14:08:28 <cdent> #link reduce calls to placement https://review.openstack.org/#/c/615677/
14:08:43 <mriedem> that is hung up on dealing with ironic
14:08:52 * cdent nods
14:09:08 <edleafe> Wow, just noticed that the placement fixture change is +558, -18013
14:09:27 <cdent> another thing that is sort of hung up is tetsuro's work to fix the root_provider_id
14:09:33 <cdent> #link fix root provider id https://review.openstack.org/#/c/619126/
14:09:47 <cdent> there are different opinion on how to do the data migration
14:10:00 <cdent> edleafe: yeah, I needed to remove the existing tests, otherwise it was too noisy/confusing
14:10:30 <cdent> the child of that one is +4, -12133
14:11:08 <edleafe> schweet
14:11:20 <cdent> the difference of opinion on root provider id seems to go back into the depths of time
14:11:41 <cdent> which suggests it needs multiple eyes to determine the best outcome
14:11:55 <tetsuro> about 619126: I'm thinking about bringing the contract/expand migration concepts to placement according to Dan's comment
14:12:18 <cdent> mriedem: can you link in your report client maybe-singleton changes, please?
14:12:35 <mriedem> #link https://review.openstack.org/#/c/623246/
14:13:07 <cdent> tetsuro: I think that's a reasonable concept, but this particular migration doesn't really fit into that model: it neither expands nor contracts the schema, it just fills in a hole that's already there
14:14:09 <cdent> (which I believe dan acks in his comments and the concerns are more from a precedence settting rather than immediate issues standpoint)
14:14:19 <cdent> (thanks mriedem )
14:14:38 <mriedem> note that i'm likely stuck/stalled on that scheduler report client change,
14:14:56 <mriedem> as i'm not crazy about making SchedulerReportClient a global singleton and inspecting all uses of the cache to see what needs locking,
14:15:03 <mriedem> for the very simple thing i'm trying to do in the api
14:15:30 <cdent> is there a now fix that can have a todo laid down next to it?
14:15:44 <cdent> for sake of velocity, pragmatism, etc
14:16:10 <mriedem> i could make it a singleton in the api - jay also wants the lock removed on scheduler report client init
14:17:19 * cdent opens a tab
14:17:41 <mriedem> or just remove the lock on init and *not* care about the fact we create 70 of these objects on nova-api startup
14:17:54 <cdent> seems...odd
14:18:05 <mriedem> we construct one per api extensions, per worker
14:18:13 <mriedem> so it's about ~70 objects in memory,
14:18:19 <mriedem> and only like 3 APIs will actually use it
14:18:22 <cdent> I know that's what we do, it just seems odd to not change it
14:18:55 <mriedem> maybe i'll just remove the lock to make jay happy and defer any singleton to eric
14:19:17 <mriedem> i'm not a huge fan of globals
14:19:39 <cdent> iteration for the win
14:20:02 <cdent> bauzas: are you around, or is france away for xmas already? what's your status on the libvirt reshaper stuff?
14:20:21 <mriedem> it's a wip to address artom's comments to rewrite the methods
14:20:48 * cdent buys a lottery ticket
14:21:19 <cdent> any other reviews people would like to bring up?
14:21:31 <mriedem> just an fyi on a previous thing,
14:21:41 <mriedem> i abandoned https://review.openstack.org/#/c/617040/ in favor of https://review.openstack.org/#/c/623596/ as people wanted
14:21:51 <mriedem> for fixing that shelve consumer delete / allocation gate race bug
14:21:52 <gibi> mriedem: thanks for that
14:22:13 <cdent> #link allocations remove before shelved offload https://review.openstack.org/#/c/623596/
14:23:06 <cdent> #topic opens
14:23:13 <cdent> any other anything?
14:24:02 <cdent> do we want one of these next week (17th) or should we shut it down until the 7th?
14:24:16 <mriedem> i'll be around next week yet but doesn't matter to me if we hold a meeting
14:24:37 <edleafe> I'll be around too
14:24:39 <gibi> I'm not sure I will be around next week
14:24:51 <cdent> i'll likely be around too
14:25:10 <cdent> how about if we feel like it we will, otherwise, will close it quick?
14:25:29 <mriedem> wfm
14:25:30 <gibi> +1
14:25:32 <edleafe> sure
14:25:51 <cdent> #agreed meet and see on 2018-12-17
14:26:07 <cdent> done?
14:26:54 <edleafe> looks like it
14:27:00 <cdent> done
14:27:04 <cdent> thanks for coming everyone
14:27:06 <cdent> #endmeeting