14:00:09 <efried> #startmeeting nova-scheduler
14:00:10 <openstack> Meeting started Mon Aug 20 14:00:09 2018 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:16 <mriedem> o/
14:00:28 <alex_xu> \o
14:00:29 <takashin> o/
14:00:29 <cdent> o/
14:00:32 <edleafe> \o
14:00:49 <efried> Good UGT morning, folks :)
14:00:50 <efried> #link Agenda https://wiki.openstack.org/wiki/Meetings/NovaScheduler#Agenda_for_next_meeting
14:01:01 <efried> #topic last meeting
14:01:02 <efried> #link last minutes: http://eavesdrop.openstack.org/meetings/nova_scheduler/2018/nova_scheduler.2018-08-13-14.00.html
14:01:02 <efried> Any old business?
14:01:03 <tetsuro_> o/
14:01:20 <efried> #topic specs and review
14:01:20 <efried> #link latest pupdate: http://lists.openstack.org/pipermail/openstack-dev/2018-August/132852.html
14:01:20 <efried> Nobody has picked this up. I still feel the loss. But haven't gotten off my kiester and done anything about it :(
14:01:48 <efried> Any comments on pupdate (or lack thereof)?
14:02:16 <efried> #link reshaper series: https://review.openstack.org/#/q/topic:bp/reshape-provider-tree+status:open
14:02:16 <efried> Stein is open, so let's get this merged ASAP.
14:02:16 <efried> #action efried to respin in response to jaypipes comments
14:02:31 <efried> Questions, comments, or concerns on reshaper?
14:02:43 <mriedem> feel free to ping me on reshaper reviews this week
14:02:48 <mriedem> i'd like to have that merged by the ptg
14:02:56 <efried> mriedem: Roger that. Consider yourself gepinged
14:03:47 <efried> If you want to wait until I've addressed jay's comments, I can buzz you then. But it's in a reviewable state (most of the patches have had approvals at some point already).
14:03:58 <cdent> (I intend/expect to get back to the pupdates either just before or just after the ptg)
14:04:08 <efried> ++
14:04:48 <efried> mriedem: General note on reshaper: bottom patch (placement microversion) is -2 in case top reveals things we need to change about the API, so waiting to have series approved before lifting.
14:05:04 <efried> #link Gigantor SQL split and debug logging: https://review.openstack.org/#/c/590041/
14:05:05 <efried> Has one +2, needs approval. (jaypipes and efried are authors and can't approve)
14:06:23 <efried> We've had positive feedback from a couple of the folks who were vocal in the ML thread. And we've demonstrated there is (probably) no significant negative impact to performance. So let's merge it.
14:06:46 <cdent> ++
14:06:46 <efried> Planning/Doing support in nova/report client for:
14:06:46 <efried> #link consumer generation handling (gibi): https://review.openstack.org/#/q/topic:consumer_gen+(status:open+OR+status:merged)
14:06:46 <efried> #link ML thread on consumer gen conflict handling: http://lists.openstack.org/pipermail/openstack-dev/2018-August/133373.html
14:07:20 <efried> I believe gibi_off is _off, but anyone have anything to bring up on nova-side consumer gen handling?
14:07:46 <efried> #link nested and shared providers for initial & migration (and other?) allocations: https://review.openstack.org/#/q/topic:use-nested-allocation-candidates+(status:open+OR+status:merged)
14:08:19 <efried> This is riding above the consumer gen series. Will need a rebase eventually, but no hurry.
14:08:20 <mriedem> ^ isn't a bp?
14:08:54 <mriedem> or, i see it's used by gibi's bw aware scheduling series
14:08:55 <mriedem> so nvm
14:08:58 <efried> It's the end game of the multi-release nrp effort. Not sure if it needs a(nother) blueprint.
14:10:08 <efried> #link Spec: Placement modeling of PCI devices ("generic device management") https://review.openstack.org/#/c/591037/
14:12:04 <efried> This has been getting some healthy discussion in IRC. A couple of the interesting subtopics:
14:12:04 <efried> - Generated traits. Which things should we generate traits for? How do we determine "ownership" of traits (generated vs. user-specified)?
14:12:04 <efried> - Grouping "identical" devices as inventory units in the same RP, vs. one RP per (physical) device/function.
14:12:29 <efried> Anyone want to delve into any of that here?
14:13:12 <cdent> not me
14:13:17 <efried> #topic bugs
14:13:17 <efried> #link placement bugs: https://bugs.launchpad.net/nova/+bugs?field.tag=placement&orderby=-id
14:13:19 <efried> #link Concurrency issue with aggregate creation https://bugs.launchpad.net/nova/+bug/1786703
14:13:22 <openstack> Launchpad bug 1786703 in OpenStack Compute (nova) "Placement duplicate aggregate uuid handling during concurrent aggregate create insufficiently robust" [Medium,In progress] - Assigned to Jay Pipes (jaypipes)
14:13:28 <efried> Exposed by
14:13:28 <efried> #link perf/load script in nova-next job (merged) https://review.openstack.org/#/c/591367/
14:13:28 <efried> #link fix (under review) https://review.openstack.org/#/c/592654/
14:13:57 <efried> I think I owe a +2 here ^ - need to catch up on recent comments & test results.
14:14:24 <efried> Anyone have other bugs to highlight/discuss?
14:14:51 <cdent> i hope to create some more soon
14:15:01 <efried> Good
14:15:01 <cdent> when I get back to experimenting
14:15:14 <efried> #topic opens
14:15:14 <efried> Extraction
14:15:25 <efried> #link extraction etherpad: https://etherpad.openstack.org/p/placement-extract-stein
14:15:25 <efried> #link extraction ML thread (when should it happen? what should the status/position of the project be?) http://lists.openstack.org/pipermail/openstack-dev/2018-August/133445.html
14:16:16 * mriedem is behind on all of that
14:16:24 <efried> I'm sort of curious how a formal decision is going to be made here.
14:16:55 <efried> Is it a vote? Who gets to vote? Does everone's vote count equally?
14:17:10 <efried> Do we need to ask some governing body to shepherd the process?
14:17:37 <cdent> efried: I'm not able to answer that, in either capacity, unfortunately
14:18:04 <edleafe> Everyone's vote better count equally. If you're an active contributor to the placement code, you should be able to vote.
14:18:39 <efried> I fear the initiative getting "bogged down in committee" and not happening, even if a majority (by any calculation) are in favor.
14:18:41 <cdent> once mriedem catches up, that will help, and I'll probably check in with other tc people at tomorrow's office hours as this looks like something the tc is actually for
14:18:51 <mriedem> there is a difference between being able to vote and weight
14:19:09 <mriedem> since joe schmo 1 time patch person's vote doesn't mean a lot to me if i'm a maintainer of a thing
14:19:14 <mriedem> not saying i'm a placement maintainer
14:19:38 <edleafe> mriedem: it's the same philosophy as voting for PTL, voting for TC/UC
14:19:40 <efried> well, that's not how e.g. PTL votes work.
14:19:42 <mriedem> i also don't really think this is the TC's call
14:19:43 <cdent> yeah, I don't know if we want to go that direction. becuase if so I get all the votes
14:20:04 <mriedem> *all* the votes huh?
14:20:10 <cdent> >50%
14:20:25 <cdent> depending on how you count of coufrse
14:21:11 <cdent> I'd much rather have at least a somewhat open and fair discussion and decision
14:21:59 <mriedem> sure
14:22:07 <mriedem> my point about vote weight,
14:22:18 <mriedem> is that maintainers of a thing, IMO, should have more weight on technical direction,
14:22:34 <mriedem> it's like the random annual "bfv should take volume type" from people that aren't regular contributors
14:22:58 <mriedem> sure we can add anything we want, it's all code, but there are a much much smaller % of people that maintain the thing
14:23:33 <efried> Okay, but is there enough volume from that kind of contributor in this issue to be more than random noise, in reality?
14:23:39 <cdent> mriedem: that's why that list of people that I made in my long message is what it is: those are the people who have demonstrated some appearance of "maintainership"
14:23:48 <cdent> efried: you're right, there isn't
14:23:54 <efried> IMO engaging an outside arbiter like the TC could be a good plan, because politics. Not saying they should decide; saying they could decide how *we* will decide. Mechanics and logistics.
14:23:58 <cdent> we have a relatively small number of contributors on placement, in total
14:24:10 <mriedem> again, haven't read the thread yet
14:24:12 <efried> So we don't, for example, have to argue who gets how much say.
14:24:18 <mriedem> <1 cup of coffee on first day back working in this TZ
14:24:32 * cdent shines a bright blue light on mriedem
14:24:46 <mriedem> the TC also elects their own chair, but ....
14:24:52 <mriedem> it's not all apples to apples
14:25:01 <mriedem> anywho
14:25:03 <mriedem> i'll shut up
14:25:10 <efried> cdent, edleafe, others: which outside governing body do you think would be most appropriate to ask to shepherd this process?
14:25:11 <cdent> mriedem: probably worth reading the thread, as what you're sayign doesn't seem to map to what the rest of us already know
14:25:14 <efried> (if any)
14:25:37 <edleafe> efried: I don't think outside governance would work
14:25:46 <cdent> if shepherding is required (I'm not sure if it is), this is very much in the domain of the tc (to shepherd, not decide)
14:26:00 <efried> Even if we don't end up going that route, I would like to be able to approach them and discuss.
14:26:11 <cdent> yeah
14:26:22 <efried> And by "I" I really mean "we".
14:26:24 <efried> of course
14:26:39 <cdent> yes, but I feel obliged to recuse myself
14:26:52 <edleafe> It really comes down to the perception among some Nova cores that if placement were to separate, that a) it would somehow reduce the amount of focus on important Nova efforts, or b) the newly-independent Placement would not want to work cooperatively with Nova
14:27:29 <cdent> does anyone (besides the people who mentioned it) consider those concerns warranted?
14:27:38 <cdent> s/concerns/perceptions/
14:29:02 <efried> I do not.
14:29:08 <cdent> nor me
14:30:05 <efried> When's the next TC meeting? Or do they even do that? Is there a dedicated IRC channel? Office hours? (/me clearly knows nothing about the TC)
14:30:06 <cdent> do we have an idea of next steps, besides mriedem and gibi_off getting caught up?
14:30:36 <cdent> efried: office hours are listed here https://governance.openstack.org/tc/#office-hours
14:30:46 <cdent> thursday afternoon is the one that is most attended
14:30:54 <d4rks1d3> TC means traffic control?
14:31:01 <cdent> technical committee
14:31:06 <d4rks1d3> Thanks
14:31:26 <cdent> efried: several members are already watching the thread closely, so if you say (more) there, it will be seen
14:31:40 <cdent> but if you want synchronous chat, thursday is probalby the way to go
14:33:02 <efried> If the goal is to find out if/how the TC could help this process, do you think that's the best approach? And/or do you think explicitly asking that question on the ML would work?
14:33:11 <cdent> various tc people, including notably doug, have said that email is the way to include the most people and have a record
14:33:28 <cdent> efried: if you just show up in #openstack-tc and ping tc-members you can ask
14:33:40 <cdent> anyone who is around will answer
14:33:56 <efried> roger that. I'll try it.
14:34:22 <efried> Any further discussion on extraction for now?
14:34:34 <fungi> some of them will answer in here too, clearly ;)
14:35:09 <efried> fungi: Welcome. Anything to add, since you're here?
14:35:09 <edleafe> hey, who let fungi in??
14:35:19 <efried> edleafe: The problem with "open"...
14:35:25 <edleafe> heh
14:35:51 <fungi> nah, just saw the ping
14:35:55 <cdent> efried: on extraction there are tools is the oslo_tools repo that may help with the repo trimming. the size of nova will make them slow, but that's expected. I've linked some more info to the extraction etherpad
14:36:11 <fungi> and i agree #openstack-tc is a better venue for such interaction
14:36:25 <efried> fungi: Ack, thanks.
14:36:25 <efried> cdent: "repo trimming" - what is that?
14:37:02 <cdent> line 56 ish and below on https://etherpad.openstack.org/p/placement-extract-stein
14:37:17 <cdent> sorry, oslo.tools, not oslo_tools
14:39:10 <efried> okay, neat.
14:39:29 <efried> Anything else for extraction?
14:39:38 <cdent> not from me
14:39:46 <efried> Any further open discussion topics?
14:40:09 <efried> Okay then. Thanks, all.
14:40:11 <efried> #endmeeting