14:00:10 <edleafe> #startmeeting nova_scheduler
14:00:11 <openstack> Meeting started Mon Dec 11 14:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:16 <jaypipes> o/
14:00:19 <ttsiouts> o/
14:00:26 <edleafe> Welcome to the next-to-last scheduler meeting of 2017!
14:00:29 <cdent> o/
14:01:09 <mriedem> o/
14:01:34 <edleafe> Let's get started
14:01:41 <edleafe> #topic Specs and Reviews
14:02:03 <edleafe> jaypipes: status on n-r-p?
14:02:35 <jaypipes> edleafe: bottom of stack is here: https://review.openstack.org/#/c/517119/
14:02:50 <jaypipes> edleafe: I am going to need to change a number of things on that
14:02:59 <edleafe> #link nested resource provider series starts with https://review.openstack.org/#/c/517119/
14:03:13 <edleafe> jaypipes: such as... ?
14:03:14 <jaypipes> edleafe: and then review the remainder of that series (mostly from alex_xu, efried_cya_jan and ttsiouts)
14:03:41 <jaypipes> edleafe: such as removing the giant block of func tests that are unrelated that were added in there.
14:04:19 <edleafe> ok
14:04:56 <edleafe> On the alternate hosts front, good progress last week, thanks to mriedem spending a lot of time reviewing the patches
14:05:05 <mriedem> that's on the docket again today
14:05:17 <jaypipes> ++
14:05:22 <edleafe> Several early ones in the series have merged, and there are 4 more to go
14:06:00 <edleafe> I'll push an update to fix the merge conflict on them in a bit
14:06:26 <mriedem> bottom 2 should be ok to review right?
14:06:38 <edleafe> they all should be ok to review
14:06:48 <mriedem> they aren't in merge conflict i mean
14:07:05 <mriedem> but i can wait for a rebase
14:07:08 <edleafe> I can update the merge conflict along with any fixes you find
14:07:12 <edleafe> ok, either way
14:07:41 <edleafe> cdent: since efried_cya_jan is gone, are you picking up the granular resource request series?
14:08:17 <cdent> edleafe: that was secondary to the providertree related stuff, so it really depends on how much headway I make on any of that
14:08:38 <edleafe> ok, sounds good
14:08:41 <cdent> It would be good if we can figure out what features we’re actually targetting, we have a lot in flow
14:08:46 <edleafe> how's the provider tree stuff looking
14:08:57 <cdent> all of which has impact on the queries behind /allocation_candidates
14:09:13 <cdent> traits, granular queries, n-r-p, etc
14:09:48 <edleafe> IIRC, traits and n-r-p were the priorities
14:10:03 <cdent> I haven’t done anything other than talk with eric on friday about the provider tree stuff, enough now to know what it is actualy intending to do (which wasn’t clear to me before). I intend to write that summation down somewhere where other people can find it.
14:10:20 <cdent> Right, but traits and n-r-p kind of require at least some aspcts of provider tree and granular resources
14:11:28 <edleafe> understood. Not a straight line path through them
14:11:49 <cdent> #action cdent write down a summation of conversatin with eric about provider summaries
14:12:10 <edleafe> once the alternate host stuff is done, I should be able to help out with that
14:12:59 <edleafe> Anyone have anything else to discuss for specs/reviews?
14:14:33 <mriedem> nope
14:15:05 <edleafe> #topic Bugs
14:15:11 <edleafe> #link Placement bugs https://bugs.launchpad.net/nova/+bugs?field.tag=placement
14:15:53 <edleafe> One new bug this week
14:16:04 <edleafe> #link https://bugs.launchpad.net/nova/+bug/1736101
14:16:05 <openstack> Launchpad bug 1736101 in OpenStack Compute (nova) "nova placement resource_providers DBDuplicateEntry when moving host between cells" [Undecided,New]
14:16:42 <mriedem> well,
14:16:50 <edleafe> anything else bug-wise to report?
14:17:00 <mriedem> moving computes between cells isn't something we really plan for,
14:17:16 <mriedem> so in that bug i'd say you need to delete the compute node record and anything related to it in placement before "moving" it to another cell
14:17:24 <mriedem> we don't have any direct way to delete compute node records thoguh
14:17:26 <mriedem> *though
14:18:13 <edleafe> yeah, definitely didn't sound like a high priority
14:18:41 <edleafe> ok, moving on
14:18:46 <edleafe> #topic Open Discussion
14:19:01 <edleafe> Anything on your mind?
14:19:12 <edleafe> Don't be scared; this is a safe space!
14:19:58 <cdent> I would like to see my two pending microversion merge soon as I’d prefer to fight with myself over microversion conflicts only one more time
14:20:14 <cdent> #link limit allocation cand: https://review.openstack.org/#/c/513526/
14:20:27 <cdent> #link cache headers https://review.openstack.org/#/c/513526/
14:20:39 <mriedem> i think i can probably get through cache headers soonish
14:20:45 <mriedem> i haven't looked at the limits one at all yet
14:20:48 <cdent> yay!, thanks.
14:21:54 <jaypipes> cdent: yeah, I can do reviews on both those
14:22:10 <takashin> o/
14:22:42 <edleafe> takashin: hi
14:22:56 <takashin> edleafe: Hi
14:22:59 <edleafe> takashin: did you have something to discuss?
14:23:07 <takashin> No.
14:23:52 <edleafe> Ah, ok, just checking
14:23:59 <edleafe> So I think we're done?
14:24:02 <takashin> Yes.
14:24:02 <efried_cya_jan> Hey, I can talk about granular if you like.
14:24:12 <edleafe> No, you're not supposed to be here
14:24:13 <efried_cya_jan> I'm here for a minute or two.
14:24:39 <edleafe> efried_cya_jan doesn't know how to do vacation right
14:24:43 <efried_cya_jan> Just to mention that granular is also waiting on traits affordance in GET /allocation_candidates
14:26:16 <edleafe> efried_cya_jan: ok, thanks. Now go back to your real life!  :)
14:26:27 * efried_cya_jan waves
14:26:29 <cdent> so yeah, quite a tree of dependencies to untangle
14:27:51 <edleafe> Well, then, let's go out there and start untangling!
14:27:56 <edleafe> #endmeeting