14:00:19 <edleafe> #startmeeting nova_scheduler
14:00:19 <openstack> Meeting started Mon Feb  6 14:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:23 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:29 <edleafe> Good UGT morning!
14:00:31 <_gryf> o/
14:00:32 <mriedem> o/
14:00:35 <edleafe> Who's here today?
14:00:51 * bauzas waves for 25 mins
14:00:55 <alex_xu> o/
14:01:03 <cdent> o/
14:01:08 * edleafe thinks bauzas's arm will get tired
14:01:13 * cdent worries bauzas is going to get tired
14:01:14 <cdent> aw
14:01:17 <bauzas> heh
14:01:17 <cdent> jinx
14:01:29 <johnthetubaguy> o/
14:01:36 <edleafe> nice to see everyone concerned about bauzas comfort
14:01:41 <diga> o/
14:02:08 <bauzas> well, I'm not a Patriots quarterback, but my arm is still strong
14:02:39 <edleafe> ok, let's get started
14:02:46 <edleafe> #topic Specs & Reviews
14:02:48 <jaypipes> o/
14:02:57 <edleafe> Nobody added anything to the agenda
14:03:11 <edleafe> Anyone want to bring something up for discussion?
14:03:20 <cdent> everybody is tired and confused and disoriented?
14:03:37 <edleafe> Otherwise, we could get more confused by discussing https://review.openstack.org/#/c/404472/
14:04:02 <bauzas> I think I need rest after last week
14:04:03 <johnthetubaguy> I think I am in a better place with the current revision
14:04:10 <diga> https://review.openstack.org/#/c/423872/3/specs/pike/approved/placement-notifications.rst can you go through this spec,  I know its not an priority for ocata but need some inputs from you
14:04:18 <johnthetubaguy> I just have a niggle over setting the inventory where its not needed
14:04:56 <edleafe> johnthetubaguy: I think there's a lot of "just to be on the safe side" calls that really aren't needed
14:05:10 <edleafe> And that's throughout the placement work, not just this patch
14:05:32 <edleafe> I can see a lot of cleaning up in Pike
14:05:39 <diga> cdent: Thanks for your inputs :)
14:06:03 <cdent> "I can see a lot of cleaning up in Pike" aye
14:06:11 <diga> I was on leave for couple of days so didn't get chance to go through
14:06:16 <diga> Yes
14:06:22 <edleafe> But the only way to determine that is if we have a clear understanding of the code paths for the various scenarious
14:06:38 <edleafe> s/scenarious/scenarios
14:06:48 <johnthetubaguy> agreed, but my problem is that is inconsistent with the current allocation setting logic elsewhere in the client
14:07:06 <johnthetubaguy> i.e. it sets allocations assuming the inventory is already updated
14:07:23 <edleafe> jaypipes: can you respond on the review?
14:07:27 <johnthetubaguy> (which is nice, so we don't have two different places where we try to update the inventory)
14:07:39 <jaypipes> edleafe: yes
14:07:45 <edleafe> thx
14:08:11 <johnthetubaguy> cdent: I am curious how we power forward with the performance enhancements, if we do them early, its possible some might be sensible backports?
14:09:00 <cdent> johnthetubaguy: I think if we want to do that, we'll have to push hard on creating sensible tests so we know what we're not blowing things up
14:09:28 <cdent> so much of the resource tracker appears to be "we'll do this just to be sure, but we're not sure why and the people who were may be gone now"
14:09:45 <edleafe> So that kind of aligns with the desire to determine all the code paths
14:09:50 <cdent> yes
14:10:00 <johnthetubaguy> cdent: very true, tests first would make sense
14:10:03 <edleafe> We need to be sure that we have functional tests for each such scenario
14:10:21 <cdent> yeah, hard to write tests for scenarios without first knowing the scenarios
14:11:03 <edleafe> cdent: well, we know several. It's the less obvious cases that we need to document
14:11:29 <edleafe> I'm thinking of the bug last week with inventory not being removed when a compute node is destroyed
14:12:05 <jaypipes> ya
14:12:15 <bauzas> agreed
14:12:31 <johnthetubaguy> cdent: you are right though, regression risk may be too high
14:12:47 <johnthetubaguy> too high for the backport, that is
14:13:13 <edleafe> So how do we document? My first instinct is "etherpad!", but those never seem to stay relevant for long
14:13:37 <edleafe> A post to the ML is great, but hard to update
14:13:50 <johnthetubaguy> ML post with a link to an etherpad?
14:14:40 <johnthetubaguy> looks like cdent got some good data on some smoking guns, I guess its a case of working out how we work through those, and split up the work
14:15:25 <bauzas> we should probably start drafting what we realistically want for Pike
14:15:58 <edleafe> bauzas: I assume that will be a big focus at the PTG
14:16:15 <bauzas> sure, but preparing it before could be nice, nope ? :)
14:16:24 <edleafe> of course
14:16:31 <johnthetubaguy> was going to say, great to start with a proposal we can discuss
14:18:17 <bauzas> violent silence ?
14:18:34 <edleafe> OK, then how about this:
14:18:34 * jroll walks in late as heck
14:18:40 <cdent> bauzas: when you say "what we realistically want" do you mean what we want to fix in what already exists, or what features are we hoping to accomplish, or something else?
14:19:04 <bauzas> cdent: just trying to make sure we don't want too much features
14:19:11 <edleafe> bauzas and johnthetubaguy start with that proposal. edleafe and cdent to start documenting the needed functional test scenarios
14:19:26 <bauzas> but rather trying to see which ones are really important for Pike so we are sure we have review traction
14:19:32 <edleafe> And then we have something to chew on at the next meeting
14:20:57 <johnthetubaguy> honestly, I am only going to be good for reviewing proposals at this point, currently worrying about quota and policy things
14:22:00 <edleafe> jaypipes: would you have bandwidth to help bauzas with this?
14:22:24 <johnthetubaguy> macsz: could you help out bauzas at all?
14:23:05 <bauzas> fine, just ping me next hour
14:23:19 <edleafe> Since bauzas has to leave soon, do you have anything else, Sylvain>
14:23:19 <bauzas> because I need to opt out since I have to go to the child school
14:23:22 <edleafe> ?
14:23:24 <johnthetubaguy> (he may not be here, its early)
14:23:32 <bauzas> edleafe: not really
14:23:39 <edleafe> ok, just checking
14:23:40 <diga> bauzas: I can help you if you want
14:24:06 <bauzas> diga: macsz: jaypipes: okay, ping me around 1500UTC
14:24:13 <bauzas> and we'll see
14:24:15 <macsz> johnthetubaguy: sure, just give me a sec to catch up
14:24:15 <edleafe> cdent: you cool with documenting the needed functional scenarios with me?
14:24:16 <diga> bauzas: okay
14:24:36 <cdent> edleafe: yes
14:25:03 <edleafe> #action edleafe and cdent to document functional scenarios and post that to the ML
14:25:09 <cdent>14:25:32 <edleafe> #action bauzas, diga and macsz to begin defining the goals for Pike
14:25:48 <diga> +1
14:26:19 <edleafe> Moving on...
14:26:22 <edleafe> #topic Bugs
14:26:27 <edleafe> ANything to discuss here?
14:26:57 <cdent> just for reference I think the discussion this bug is interesting:
14:27:18 <cdent> https://bugs.launchpad.net/nova/+bug/1661570
14:27:18 <openstack> Launchpad bug 1661570 in OpenStack Compute (nova) "Failed to create resource provider record in placement API" [Undecided,New]
14:27:18 <johnthetubaguy> I am curious about RC2 candidates if there are any that are spotted
14:27:41 <cdent> It's about some failing tests where placement was suggested as the problem, because n-cpu is warning
14:27:51 <cdent> but there's no actual placement problem, it's an ordering issue
14:27:55 <cdent> (see my comment, the last one)
14:28:13 <edleafe> #link https://bugs.launchpad.net/nova/+bug/1661570
14:29:56 <edleafe> Any other bugs spotted? Especially RC blockers?
14:29:59 <cdent> johnthetubaguy: i'm not yet aware of any rc2 stuff
14:30:30 <johnthetubaguy> cdent: cool
14:31:04 <edleafe> Finally...
14:31:05 <edleafe> #topic Open Discussion
14:31:18 <edleafe> Anyone have anything else on their mind?
14:32:12 <cdent> that looks like a big no
14:32:12 <alex_xu> I want to ask is there any more expectation except poc for traits
14:32:21 <cdent> anti-jinx!
14:32:29 <alex_xu> before PTG
14:32:39 <edleafe> alex_xu: I doubt it
14:32:55 <cdent> We're still reviewing the spec, yeah?
14:33:14 <alex_xu> cdent: yea, and PoC is up https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/resource-provider-tags
14:33:21 * cdent nods
14:33:22 <edleafe> alex_xu: I'm hoping to get more focus on traits in Pike now that the guts of placement are in
14:33:50 <alex_xu> just try to make sure I provide enough info for people disucss traits in PTG
14:34:02 <alex_xu> edleafe: cool
14:34:10 <edleafe> Heh - you should change the BP name :)
14:34:20 <alex_xu> edleafe: yes, sir!
14:34:41 <alex_xu> ok, so I just continue poc and change bp name, and I need to update spec now
14:35:06 <edleafe> alex_xu: thanks for pushing ahead on traits. I've been ignoring that in favor of the resource provider stuff
14:35:37 <edleafe> alex_xu: but every time we hit flavor extra-specs I scream inside
14:35:40 <alex_xu> np, people already super busy on the release
14:35:53 <alex_xu> heh
14:36:55 <edleafe> Anything else?
14:37:12 <alex_xu> that is all from me
14:37:30 <edleafe> OK, then it's back to work/play/sleep!
14:37:33 <edleafe> #endmeeting