14:00:34 <n0ano> #startmeeting nova-scheduler
14:00:35 <openstack> Meeting started Mon Sep 28 14:00:34 2015 UTC and is due to finish in 60 minutes.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <openstack> The meeting name has been set to 'nova_scheduler'
14:00:42 <n0ano> anyone here to talk about the scheduler?
14:01:03 * bauzas waves, like a surf prorider
14:01:19 <n0ano> bauzas, hang ten dude :-)
14:01:44 <bauzas> :)
14:01:49 <edleafe> \o
14:02:16 <n0ano> #topic Mitaka planning
14:02:43 <n0ano> so we're getting close to the summit, I hope we can get everything about the scheduler discussed that we want
14:03:03 <n0ano> I can think of a few items we should talk about:
14:03:16 <n0ano> 1) finishing the current cleanup efforts
14:03:25 <n0ano> 2) doing the scheduler split
14:03:40 <n0ano> 3) removing flavors from the scheduler API
14:03:59 <n0ano> are there any others people want to address?
14:04:25 <bauzas> some ML discussion was about how to get resources from other projects
14:04:33 <edleafe> how about allocating the work more evenly?
14:04:44 <edleafe> seemed like bauzas got most of it dumped on him
14:04:50 <edleafe> in liberty
14:05:02 <n0ano> bauzas, good one, that would be a cross project effort, perfect for the summit
14:05:31 <bauzas> n0ano: well, I'm not super convinced on that given all the feedback we had from the other summits, but we can surely ask for it again
14:05:35 <n0ano> edleafe, +1 but was that just a one time thing for liberty or do we need to do something specific to address it
14:06:11 <lxsli> o/
14:06:12 <bauzas> edleafe: well, we surely are a team, but we can't just allocate our time like this :)
14:06:31 <edleafe> I think that we need to think about the overall effort required for each piece
14:06:39 <bauzas> that said, I should be pretty free from the scheduler standpoint for this release :D
14:07:01 <bauzas> since our focus IMHO is to finish the work
14:07:13 <edleafe> I had a lot more bandwidth available for scheduler in liberty
14:07:17 <bauzas> ie. merge reqspec-object and resource-objects
14:08:14 <bauzas> we're really blocked from getting further until we have those 2 blueprints implemented
14:09:02 <edleafe> bauzas: agreed. I was wondering if we could have split up that work better so that you weren't stuck with doing all the req spec stuff
14:09:43 <bauzas> edleafe: well, I had 1 BP implemented and merged, 1 BP implemented waiting reviews and 1 BP approved
14:09:53 <bauzas> edleafe: I don't think it was a good release for me :D
14:09:56 <bauzas> uh
14:09:59 <bauzas> s/good/bad
14:10:15 <edleafe> bauzas: that's the point
14:10:22 <edleafe> you were very busy and productive
14:10:37 <edleafe> while others had to look elsewhere to keep busy
14:10:45 <edleafe> I would have rather focused on scheduler stuff
14:11:24 <bauzas> okay, what do you propose ? :)
14:11:25 <n0ano> edleafe, I think the problem was the cleanup, while a little big, was fairly focused not that decomposable
14:11:47 <n0ano> so we didn't have much choice but to let bauzas and jay do the heavy lifting
14:12:06 <n0ano> all comes down to, if we can split the scheduler out I think things we be more manageable
14:12:14 <edleafe> n0ano: perhaps, but I don't remember that being known ahead of time.
14:12:43 <edleafe> I'm just thinking that maybe we should consider the load involved in the assigned tasks
14:13:08 <n0ano> edleafe, +1
14:13:17 <bauzas> soooo
14:13:27 <n0ano> I think it's a learning process and we just need to try and remember that going forward
14:13:43 <bauzas> now that we've said that
14:14:03 <edleafe> n0ano: exactly
14:14:30 <bauzas> there are still some stuff to do with the scheduler
14:14:40 <bauzas> #1 polish up the interfaces
14:14:56 <bauzas> #2 address how we request the scheduler
14:15:15 <bauzas> #3 identify how to provide some x-project resources to the scheduler
14:15:27 <bauzas> #4 see how we can scale the scheduker
14:15:52 <bauzas> now, I can understand that people miss some homework, but I'd appreciate if you could just comment out a few stuff
14:16:28 <bauzas> #link https://review.openstack.org/#/c/192260/
14:16:46 <bauzas> #link https://review.openstack.org/#/c/191914/
14:17:18 <bauzas> because I'm very happy to share my homework too, but I'd like to know thoughts from the group
14:17:26 <bauzas> also, we're having 21 open bugs
14:17:44 <bauzas> uh, even 30
14:18:04 <bauzas> in particular, I beg the attention of the team since we're in RC period, bugs are very important
14:18:13 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=scheduler
14:19:20 <n0ano> well, I know a a new team whose major goal right now is bug fixing so I'll see if I can get them to look into some of the scheduler bugs
14:20:04 <bauzas> fixing bugs is as much as important as creating bugs (ie. writing features)
14:20:05 <bauzas> :)
14:22:45 <n0ano> not sure where we want to go from here
14:24:16 <n0ano> I'm thinking that reviewing and commenting on https://review.openstack.org/#/c/192260/ is fairly crucial, shall we go do that and be ready to discuss it next week?
14:25:07 <bauzas> n0ano: what I'd like to see is the subteam providing feedback to johnthetubaguy indeed
14:25:37 <bauzas> because before speaking of implementation, we need to agree on a path to follow
14:25:47 <n0ano> #action all to review/comment on https://review.openstack.org/#/c/192260/
14:28:15 <johnthetubaguy> reviews on that would be helpful, its been on the etherpad of important reviews for a little while
14:28:26 <johnthetubaguy> its really trying to capture the consensus
14:28:32 <johnthetubaguy> not change the direction
14:28:50 <johnthetubaguy> so it easier for folks to get the context of what is currently being worked on, and join in
14:33:45 <n0ano> sorry about that, network drop
14:34:10 <n0ano> I think we're done for today so tnx everyone, talk to you later
14:34:15 <n0ano> #endmeeting