17:00:56 <gibi> #startmeeting nova notification
17:00:56 <openstack> Meeting started Tue May 31 17:00:56 2016 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:00 <openstack> The meeting name has been set to 'nova_notification'
17:01:15 <gibi> hi
17:01:21 <macsz> hi!
17:01:24 <pumaranikar> hi
17:01:24 <sneti> hi
17:01:25 <syjulian> hello!
17:01:37 <johnthetubaguy> gibi: so I have to run in a sec but I wanted to quickly check about specs, if possible
17:01:38 <siva_krishnan> hi
17:01:53 <gibi> johnthetubaguy: quick update. the transformation spec in merged
17:02:06 <gibi> the json schema generation spec is merged in oslo
17:02:19 <johnthetubaguy> also, wanted to introduce some of the fine folks from OSIC I work with who are hoping to help out speed things up :)
17:02:33 <johnthetubaguy> gibi: great, that sounds like the big pieces
17:02:52 <gibi> there are specs out there proposing new notifications
17:02:59 <johnthetubaguy> just worried about the deadline on thursday for nova-specs
17:03:09 <johnthetubaguy> yeah, do we have a good list of those somewhere?
17:03:34 <gibi> johnthetubaguy: https://etherpad.openstack.org/p/nova-versioned-notifications L15
17:03:50 <gibi> this is the list of bps I'm aware off
17:03:54 <gibi> of
17:03:55 <johnthetubaguy> gibi: ah, cool, yeah, I see that now, linked from the main etherpad
17:04:31 <gibi> I tried to review them and will do a review round if needed tomorrow
17:04:56 <johnthetubaguy> looks like only one is left
17:05:01 <johnthetubaguy> hypervisor notifications
17:05:04 <johnthetubaguy> an its marked WIP
17:05:14 <gibi> that is cool
17:05:25 <johnthetubaguy> honestly, feels like https://review.openstack.org/#/c/286675/ would be a great for this cycle, getting it complete that is
17:06:12 <johnthetubaguy> awesome, sorry to derail, just wanted to make sure nova-specs-core isn't blocking progress
17:06:42 <gibi> johnthetubaguy: we have code up for 80% of that spec
17:06:55 <johnthetubaguy> oh, wow
17:06:58 <gibi> johnthetubaguy: so I think we have a good chance to make it so
17:07:15 <johnthetubaguy> I was expecting more work for long tail of things, but I guess most of it goes through that single until method
17:08:09 <gibi> johnthetubaguy: it is not that simple as I thought but still managable
17:08:34 <gibi> the biggest thing is we have now is https://review.openstack.org/#/c/313654/
17:08:54 <johnthetubaguy> ah, so you are only doing the two example ones so far?
17:09:04 <johnthetubaguy> well, two or three example ones
17:09:10 <gibi> yes, only that was in the spec
17:09:19 <gibi> sorry making false hopes for the whole transformation
17:09:22 <gibi> :)
17:09:32 <gibi> I ment that 80% of the 3 example in the spec
17:09:53 <johnthetubaguy> OK, gotcha, I was expecting us to start doing the others, I think sneti, macsz, siva_krishnan and pumaranikar might be able to help with that
17:10:03 <johnthetubaguy> but clearly, we need the basic ones solid first
17:10:23 <gibi> I think the solid base is now up
17:10:50 <gibi> if there are more people to help then I can make a list of transformation top of that patch to be done
17:10:53 <johnthetubaguy> OK, so maybe they could help try apply this to something like reboot? or snapshot?
17:10:57 <johnthetubaguy> yeah, that sounds good
17:11:18 <gibi> I will write up a list of candidates that are very similar to the instance.delete
17:11:28 <gibi> most of the code will be test for those
17:11:36 <macsz> great :)
17:12:32 <johnthetubaguy> yeah, its a bit like APIs, well it is an API basically
17:12:39 <gibi> #agreed gibi will write up a list on the etherpad to about the easy transformations and send a mail to the ML
17:12:44 <johnthetubaguy> awesome, thanks
17:12:54 <johnthetubaguy> lets see if we can make more progress
17:13:02 <johnthetubaguy> I think we should limit the number we are doing somehow
17:13:22 <johnthetubaguy> it would be good to get the initial stuff over the line to start with I guess
17:13:24 <gibi> yeah I think no more than 3-5
17:13:28 <johnthetubaguy> or at least, some level of +2
17:13:36 <johnthetubaguy> gibi: sounds perfect
17:14:03 <johnthetubaguy> OK, so sorry to jump in, and dominate then run off... but I need to head off so I can get online for the TC meeting later on
17:14:05 <gibi> if you have time to look at the patches then we can have some level of +2 soon
17:14:17 <gibi> johnthetubaguy: no problem
17:14:35 <johnthetubaguy> gibi: yeah, totally hope to look at those soon, its on our trello board for OSIC, I think
17:14:36 <gibi> johnthetubaguy: will give an update on the nova meeting as well
17:14:43 <johnthetubaguy> gibi: perfect
17:14:57 * johnthetubaguy bravely runs away...
17:15:02 <gibi> :)
17:15:25 <gibi> I think we covered the initial update on the patches
17:15:37 <gibi> does anybody has a spec up that needs review from the subteam?
17:16:10 <sjmc7> hi gibi, sorry i’m late
17:16:17 <gibi> sjmc7: hi, no worries
17:16:36 <sjmc7> some folks on the searchlight team had reviews for flavor and hypervisor notifications that’ll use the versioned notifications
17:16:47 <sjmc7> just specs at this state
17:16:51 <sjmc7> stage
17:17:42 <sjmc7> ah, looks like the hypervisor one got merged
17:17:51 <gibi> I think the flavor one has a -1 from me
17:18:00 <gibi> https://review.openstack.org/#/c/321336/
17:18:16 <sjmc7> yep, that’s the one. ok, thanks for lookgin at it, just wanted to mention them in case they got lost
17:18:47 <gibi> spec deadline is close, so just ping me when my comments is answered and I will rereview
17:19:21 <sjmc7> will do, thanks
17:19:54 <gibi> anybody else has a spec to look at?
17:20:59 <gibi> great
17:21:33 <gibi> as I already mentioned the transformation already has some code up
17:22:03 <gibi> this is the topic: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/versioned-notification-transformation-newton
17:22:19 <gibi> reviews are welcome :)
17:22:57 <gibi> those who want to help the transformation will find the basic pattern what to do in this patches
17:23:10 <gibi> especially in https://review.openstack.org/#/c/313654/
17:23:29 <gibi> besides that
17:23:31 <pumaranikar> thanks gibi , I will have a look.
17:24:09 <gibi> julian started to implement the schema generation for ovos here https://review.openstack.org/#/c/318950/
17:25:02 <gibi> we are reviewing it with rlrossit
17:25:22 <gibi> does anybody has any code up we should look at it?
17:26:44 <macsz> OSIC just started looking into this, so from OSIC side - not right now :)
17:28:14 <AndChat-140625> For the list of notifications to transform, would those be in the ehterpad? -Julian
17:28:42 <gibi> could you put the irc handle of the OSIC guys to the etherpad https://etherpad.openstack.org/p/nova-versioned-notifications ? so that I will know who to ping with work :D
17:29:34 <macsz> sure, we will sign in
17:29:59 <gibi> AndChat-140625: I will put the list of easy transformations to the etherpad first and send a mail to ML, let's see if it works well or not
17:30:05 <gibi> macsz: thanks
17:31:47 <macsz> done, thats everone from OSIC, i think
17:32:10 <gibi> macsz: great addition, thanks
17:32:48 <gibi> if you have any questions then you can find me on irc, I work in UTC+2 timezone
17:33:17 <gibi> rlrossit works from the USA you can turn to him as well
17:33:19 <macsz> i miss this TZ, left it 2 months ago :(
17:33:49 <gibi> OK
17:33:51 <siva_krishnan> thanks gibi
17:34:12 <gibi> any other issues we have to discuss today?
17:34:32 * gibi doesn't have anyithing else
17:35:07 <macsz> great, thanks, gibi
17:35:36 <gibi> It feels we are done for today
17:35:54 <gibi> thanks for showing up
17:36:02 <gibi> see you around
17:36:11 <macsz> cheers!
17:36:18 <sjmc7> have a good evening
17:36:23 <gibi> #endmeeting