17:59:58 <markus_z> #startmeeting nova-bugs-team
17:59:59 <openstack> Meeting started Tue Jul 12 17:59:58 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:03 <openstack> The meeting name has been set to 'nova_bugs_team'
18:00:26 <mriedem> o/
18:00:27 <markus_z> hello folks, anyone here?
18:00:57 <markus_z> OK, let's wait for a minute
18:01:44 <auggy> o/
18:01:44 <aihuaedwardli> Hello
18:01:50 <markus_z> #topic info-round
18:02:02 <markus_z> cool, let's start
18:02:05 <markus_z> #info 642 overall open bug reports
18:02:10 <markus_z> #info 42 untriaged bug reports
18:02:21 <markus_z> #info 1 critical (for aarch64/s390x): https://bugs.launchpad.net/nova/+bug/1598370
18:02:21 <openstack> Launchpad bug 1598370 in OpenStack Compute (nova) "Got AttributeError when launching instance in Aarch64" [Critical,In progress] - Assigned to Kevin Zhao (kevin-zhao)
18:02:30 <markus_z> #info 188 bug reports expired: http://lists.openstack.org/pipermail/openstack-dev/2016-July/098792.html
18:02:46 <markus_z> ^ no one complained to me yet *woho*
18:03:05 <markus_z> #topic bug skimming
18:03:15 <markus_z> #help need volunteer for next week: https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
18:03:18 <aihuaedwardli> hello, I am new to here.
18:03:29 <mriedem> if https://bugs.launchpad.net/nova/+bug/1598370 is just for a single virt driver, it's not critical
18:03:29 <openstack> Launchpad bug 1598370 in OpenStack Compute (nova) "Got AttributeError when launching instance in Aarch64" [Critical,In progress] - Assigned to Kevin Zhao (kevin-zhao)
18:03:36 <mriedem> we don't do critical bugs for optional configurations
18:03:40 <markus_z> aihuaedwardli hi
18:04:00 <markus_z> mriedem: OK, I wasn't sure, I'll reduce the importance
18:04:14 <aihuaedwardli> Hi, don't want to interrupt, but I would like to review a bug that I filed.
18:04:16 <mriedem> just did
18:04:17 <markus_z> ah, you're faster
18:04:34 <aihuaedwardli> https://bugs.launchpad.net/nova/+bug/1597596
18:04:34 <openstack> Launchpad bug 1597596 in OpenStack Compute (nova) "network not always cleaned up when spawning VMs" [Medium,In progress] - Assigned to Aihua Edward Li (aihuaedwardli)
18:04:36 <markus_z> aihuaedwardli: at the end is an open round, just a few minutes
18:04:39 <auggy> fyi next week is the midcycle, so we could probably set aside a skimming-a-thon
18:04:56 <auggy> set aside time for a... is what i meant to say :)
18:05:26 <markus_z> right, midcycle. Not sure if they find time during the midcycle, but I can ask for that on the ML
18:05:55 <markus_z> #action markus_z ask on ML if the midcycle can skim bug reports
18:06:00 * auggy keeps double checking her calendar cuz omg it's already here!!
18:06:03 <mriedem> honestly i think we're going to be full
18:06:23 <markus_z> yeah, guess so, but asking doesn't hurt
18:06:48 <auggy> if there are any new contributors that show up and are looking for things to do, i can take some time to walk them through it if it makes sense
18:07:02 <markus_z> yes, sounds great
18:07:06 <auggy> during the Mitaka midcycle, the last day was pretty unstructured
18:07:38 <auggy> mostly people pairing up to work on specific things and such, if that happens this time and there are new folks looking lost, i'm happy to jump in and get them started on skimming
18:07:41 <markus_z> I can start my day a little later next week in case there are questions
18:07:51 <markus_z> s/day/days
18:08:37 <markus_z> moving on
18:08:45 <markus_z> #last weeks action items
18:08:50 <markus_z> #topic last weeks action items
18:09:13 <markus_z> #info review pipeline: http://lists.openstack.org/pipermail/openstack-dev/2016-July/099096.html
18:09:20 <markus_z> ^ comments and critics welcome
18:09:40 <auggy> i responded just before the meeting
18:09:57 <auggy> thanks for taking the time to address this issue and think about solutions!
18:10:10 <markus_z> Ah, I haven't read it yet, I'll respond after the meeting
18:10:28 <markus_z> I didn't had the chance to go over the stale reports, I'm going to spend tomorrows morning on that.
18:10:33 <auggy> np, basically i just asked if it made sense to tag in Launchpad instead of Gerrit since the bugs should be linked
18:10:40 <mriedem> i was about to reply to the thread, but then didn't
18:10:41 <markus_z> #action markus_z check stale bug reports
18:10:44 <pumaranikar> auggy, let me know if you find anything to work on for new contributors
18:10:48 <mriedem> i think i prefer #2 over #3
18:11:46 <mriedem> we have dashboards for bugs,
18:11:54 <mriedem> we could work starred changes into that
18:12:57 <markus_z> yes. My concern was the "single-point-of-failure"
18:13:41 <markus_z> 2) would also allow more control. But we can discuss this on the ML
18:13:46 <auggy> we could have a few people that could have starred items be included for redundancy
18:14:13 <markus_z> yep, makes sense
18:14:17 <mriedem> yeah i'd say more than one person
18:14:47 <auggy> we can keep that list on the nova subteams etherpad maybe, under the bugs subteam
18:15:03 <auggy> the list of people who have stars in the filter i mean
18:15:22 <mriedem> i do sometimes star stuff to come back to it, but not a bug fix
18:15:37 <mriedem> so if i had star power that could mess things up
18:15:47 <mriedem> unless we filter out changes without Closes-Bug in the commit message
18:15:57 <auggy> i'm guessing it would filter on starred by x and has closes-bug or some such
18:16:02 <mriedem> yeah
18:16:05 <markus_z> agreed ^
18:16:05 <auggy> with both conditions necessary
18:16:08 <auggy> lol star power
18:16:23 <mriedem> yes,
18:16:25 <mriedem> in other words
18:16:34 <mriedem> temporary invincibility against turtles and mushrooms
18:16:43 <auggy> she-ra!
18:17:22 <markus_z> did she used stars? I have to watch the old cartoons again
18:17:29 <markus_z> s/used/use
18:17:39 <auggy> she just had all the power
18:18:27 <markus_z> hm, I google that at home, the internet is a weird place
18:18:40 <markus_z> #topic open round
18:19:13 <auggy> maybe sailor moon would be a more appropriate metaphor ;)
18:19:44 <markus_z> aihuaedwardli: your turn
18:21:39 <markus_z> aihuaedwardli: Seems like you have a patch up https://review.openstack.org/#/c/335788/
18:21:50 <aihuaedwardli> hi, this is the bug
18:21:54 <aihuaedwardli> https://bugs.launchpad.net/nova/+bug/1597596
18:21:54 <openstack> Launchpad bug 1597596 in OpenStack Compute (nova) "network not always cleaned up when spawning VMs" [Medium,In progress] - Assigned to Aihua Edward Li (aihuaedwardli)
18:22:11 <markus_z> It has already some attention from reviewers
18:22:46 <markus_z> It takes a little patience in Nova to get fixes merged
18:22:47 <aihuaedwardli> This bug is happening in our production environment. I have put a patch, but would like to see how to make it go forward.
18:24:02 <mriedem> aihuaedwardli: well first comment is all bug fixes require tests
18:24:15 <markus_z> Unfortunately the review backlog is quite huge and most people are still reviewing the functional changes
18:24:22 <mriedem> my earlier comments are really i'm not sure this is the right way to fix this, but i don't have great suggestions either
18:25:25 <mriedem> i've got to run to another meeting
18:25:35 <markus_z> ok
18:25:39 <aihuaedwardli> I run unit test locally with no errors.
18:26:05 <markus_z> aihuaedwardli: yes, we need additional unit tests which check the code paths you changed
18:26:51 <auggy> aihuaedwardli: is there a test path in the unit and functional test coverage for the additional code path you added?
18:27:35 <auggy> so if "self.network_api.cleanup_instance_network_on_host" doesn't return, do you have a test that covers the case where that doesn't return and then runs your additional logic instead?
18:27:35 <aihuaedwardli> I simulated this in my environment and verified the change locally
18:28:30 <auggy> aihuaedwardli: test coverage is not guaranteed. it is possible your code path is never getting executed in our tests.
18:28:31 <aihuaedwardli> you mean to add a unit test for the new path?
18:28:38 <markus_z> yes
18:28:55 <aihuaedwardli> o.k. let me work on that.
18:29:10 <auggy> if there is no test case where the "self.network_api.cleanup_instance_network_on_host" fails to return, then your code will never be executed in our tests
18:30:32 <markus_z> aihuaedwardli: I haven't looked at it in detail, but I guess you will find more info on how to do it here: https://github.com/openstack/nova/blob/d498645806cc203e5471b08f833c3cc0566eeeb3/nova/tests/unit/network/test_api.py#L528-L528
18:30:46 <markus_z> At least in that module
18:31:22 <aihuaedwardli> o.k. thanks
18:31:54 <markus_z> Anything else from anyone?
18:32:45 <markus_z> OK, closing in 3...
18:33:01 <auggy> nope, thanks markus_z !
18:33:14 <markus_z> Thanks for your time! Next meeting coming Tuesday: https://wiki.openstack.org/wiki/Meetings/Nova/BugsTeam#Next_meeting_dates
18:33:21 <markus_z> #endmeeting