08:00:13 <markus_z> #startmeeting nova-bugs-team
08:00:14 <openstack> Meeting started Tue Jul  5 08:00:13 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:00:17 <openstack> The meeting name has been set to 'nova_bugs_team'
08:00:35 <markus_z> good morning everyone
08:00:38 <markus_z> anyone around?
08:00:41 <takashin> o/
08:00:55 <markus_z> hey takashin
08:01:00 <takashin> Hello
08:01:06 <markus_z> let's wait a minute for others to join
08:01:11 <takashin> ok
08:02:20 <markus_z> well, ok, let's get started
08:02:32 <markus_z> just a few infos
08:02:44 <markus_z> #info 824 open bugs overall
08:02:59 <markus_z> #info 31 untriaged new bugs
08:03:15 <markus_z> #info 1 critical https://bugs.launchpad.net/nova/+bug/1598370
08:03:15 <openstack> Launchpad bug 1598370 in OpenStack Compute (nova) "Got AttributeError when launching instance in Aarch64" [Critical,In progress] - Assigned to Kevin Zhao (kevin-zhao)
08:03:30 <markus_z> the author of the root cause is working on that
08:03:56 <markus_z> #info I'm going to expire old bug reports today
08:04:39 <markus_z> #link The expiration script: https://github.com/openstack-infra/release-tools/blob/master/expire_old_bug_reports.py
08:05:01 <markus_z> #topic bug skimming
08:05:12 <johnthetubaguy> markus_z: expiring is really going to help us :)
08:05:35 <markus_z> johnthetubaguy: yeah, I hope so. Will affect ~185 bug reports
08:05:52 <johnthetubaguy> thats a good percentage of the 824
08:05:57 <markus_z> yep
08:06:20 <markus_z> We would need volunteers for the bug skimming duty
08:06:45 <markus_z> no one volunteered yet: https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
08:07:06 <markus_z> takashin did already play the role
08:07:33 <markus_z> If anyone knows a volunteer, that would be great
08:08:05 <markus_z> #topic cleanup tasks
08:08:38 <markus_z> we have a lot of potentially stale in progress/incomplete bug reports
08:08:45 <markus_z> #link stale in progress: http://45.55.105.55:8082/bugs-dashboard.html#tabInProgressStale
08:08:59 <markus_z> #link stale incomplete: http://45.55.105.55:8082/bugs-dashboard.html#tabIncompleteStale
08:09:14 <markus_z> #action markus_z cleanup stale bug reports
08:09:37 <markus_z> #topic open questions
08:09:50 <markus_z> anyone items you want to discuss?
08:10:59 <markus_z> ok, none. If you have something later, just ping in #openstack-nova
08:11:08 <markus_z> #topic reviews for bug fixes
08:11:27 <markus_z> Anyone knows about open changes for bug fixes which would need more attention?
08:11:37 <markus_z> Anything old and mergeable?
08:11:53 <johnthetubaguy> got a question on the dashboard
08:12:01 <markus_z> sure, which one?
08:12:03 <johnthetubaguy> this is the list of bugs with a patch
08:12:26 <johnthetubaguy> http://45.55.105.55:8082/bugs-dashboard.html#tabPatch
08:12:49 <johnthetubaguy> oh, I see, they have a patch, but not marked in progress
08:13:17 <markus_z> hm, maybe my query is wrong?
08:13:41 <johnthetubaguy> thats probably correct, I just got a bit confused
08:13:53 <johnthetubaguy> I was thinking we have way more patches for bugs in review
08:14:07 <markus_z> Ah, I see were you're coming from
08:14:20 <johnthetubaguy> so I just updated my old script yesterday
08:14:21 <johnthetubaguy> http://5885fef486164bb8596d-41634d3e64ee11f37e8658ed1b4d12ec.r44.cf3.rackcdn.com/nova-openreviews.html
08:14:26 <markus_z> These are bug reports with a patch file attached
08:14:42 <johnthetubaguy> so it shows the top bug patches that have been waiting around a long time
08:15:24 <markus_z> I can include that into the dashboard if you like?
08:15:42 <johnthetubaguy> so I don't quite keep that up to date enough right now
08:15:50 <johnthetubaguy> reviews.johngarbutt.com is the nice URL to find that
08:16:03 <johnthetubaguy> oops
08:16:09 <johnthetubaguy> reviews.johnthetubaguy.com
08:16:51 <markus_z> ah, cool, I'm going to look into it.
08:17:56 <markus_z> hm, the reviews distribution among the contributors... would be nice if that's not the burden of only 20 people...
08:18:17 <markus_z> well, I cannot change that (besides doing more reviews myself :))
08:18:56 <markus_z> #link reviews.johnthetubaguy.com
08:19:34 <johnthetubaguy> yeah, lots more good reviews from lots more people would really help, given the number of contributors
08:20:25 <markus_z> I'm also thinking about focusing reviews (about bug fixes) more.
08:20:25 <johnthetubaguy> note the average age of a patch sitting in the queue is now over 66 days :(
08:20:47 <markus_z> A pipeline of 10 changes which get the focus
08:20:50 <johnthetubaguy> yeah, I have asked in the OSIC/Intel bugsmash to just review bug fixes for Nova
08:21:06 <markus_z> Then review->change->review->change in a fast pace until this very few items are really done
08:21:10 <johnthetubaguy> yeah, I think a focused pipeline would work well, assuming both submitters and reviews get on board
08:21:29 <markus_z> right, it doesn't work if the submitter waits for a week for the next ps
08:21:32 <johnthetubaguy> so far we only ever got once side of that at any one time
08:21:49 <johnthetubaguy> but if it becomes normal, that should be easier
08:22:42 <markus_z> Let me word up an email and discuss it on the ML. We somehow have to change the velocity.
08:23:35 <markus_z> #action markus_z discuss a review pipeline for bug fixes on the ML (goal: increase throughput)
08:24:17 <johnthetubaguy> I like the idea of more foucs
08:24:22 <johnthetubaguy> and having someone maintain that list
08:24:41 <johnthetubaguy> the ops folks wanted to do that, but honestly, they are just too slammed to maintain that list
08:24:44 <johnthetubaguy> at least it seems that way
08:25:35 <markus_z> yeah, I have to consider the maintenance costs, that's true
08:26:02 <markus_z> takashin: If you have time, would you switch those to "fix released"? http://45.55.105.55:8082/bugs-dashboard.html#tabFixCommitted
08:26:12 <takashin> ok
08:26:21 <markus_z> ^ we don't use "fix committed" anymore.
08:26:22 <markus_z> thanks!
08:26:56 <markus_z> ok, anything else on your plate?
08:27:12 <markus_z> #action takashin cleanup "fix committed" bug reports
08:28:07 <markus_z> Closing in 3...
08:28:50 <markus_z> Thanks for your time and participation! Next meeting, July 12th 2016 1800 UTC
08:28:55 <markus_z> #endmeeting