18:00:52 <markus_z> #startmeeting nova-bugs-team
18:00:53 <openstack> Meeting started Tue Mar  8 18:00:52 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:53 <sridhar_ram> markus_z: np
18:00:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:57 <openstack> The meeting name has been set to 'nova_bugs_team'
18:01:30 <markus_z> soo, anyone around?
18:01:40 <auggy> I am!
18:01:51 <markus_z> hey auggy, how are you?
18:02:14 <markus_z> let's wait a minute for others to join
18:02:16 <auggy> hey markus_z pretty good, still in a bit of pain from the back injury :(
18:02:37 <markus_z> oh, I'm sorry to hear that
18:02:40 <auggy> today is my last day on the hard painkillers so i should be more productive soon :)
18:02:44 <markus_z> the pain I mean
18:02:54 <auggy> it's better than it was before!
18:02:56 <markus_z> hehe, the head will become clear
18:03:06 <markus_z> that's good to hear :)
18:03:10 <auggy> it just means i haven't done much with bug maintenance :(
18:03:21 <markus_z> ok, let's face it, no others will come right now
18:03:35 <markus_z> auggy: that's ok, you've done more than a lot of other folks :)
18:03:54 <auggy> other people stepped in this week, mriedem and sdague
18:03:57 <auggy> last week rather
18:04:14 <markus_z> yeah, I've seen that there was action happening, dims did a lot of work too
18:04:17 <auggy> they really got the list down, and it looks like dims did a bunch of pruning on the in progress
18:04:21 <auggy> yeah!
18:04:29 <markus_z> #link http://45.55.105.55:3000/dashboard/db/openstack-bugs echelon is listening...
18:04:44 * auggy bookmarks
18:04:52 <markus_z> yep, dims left two impressive marks in the data
18:05:15 <markus_z> so, I thought we can go to some of the old incomplete things to close them
18:05:32 <auggy> ok!
18:05:49 <auggy> i'll add that to my things to do this week and try to spend a bit of time on it
18:05:56 <markus_z> #link https://wiki.openstack.org/wiki/Nova/BugTriage consolidation of the tags as described in a previous meeting
18:06:34 <auggy> i updated the info per last week's nova team meeting, to remind people to tag things as *-backport as appropriate
18:06:37 <markus_z> I added a list to the etherpad https://etherpad.openstack.org/p/nova-bugs-team and will just add my name to the ones I will take a look at
18:07:03 <markus_z> do you have a link for that?
18:07:20 <auggy> yeah i think i put it in the main bug wiki where the backport tags were defined
18:07:41 <auggy> i added it to the one you just linked
18:07:50 <auggy> kilo-backport-potential and liberty-backport-potential
18:08:05 <auggy> just a reminder that if the bug was reported against a previous build to tag it as backport-potential
18:08:08 <markus_z> uha, I hope I didn't delete it?
18:08:35 <auggy> oh the liberty one got deleted
18:08:41 <auggy> it's ok i'll add it back
18:08:47 <markus_z> ok, cool, sorry
18:09:03 <auggy> #action auggy to re-update liberty-backport-potential tag definition on wiki
18:09:13 <markus_z> I added myself for the "needs-attention" tag but could solve them right now. Still a todo for me.
18:09:21 <markus_z> Do you have any open questions so far?
18:09:35 <auggy> not so far, like i said i haven't done much in the way of bug-work
18:09:48 <auggy> one thing i will say, a liberty release was just submitted
18:09:53 * auggy looks for the link
18:09:58 <markus_z> ok, just wanted to double-check if something came up
18:10:06 <auggy> so any bugs reporting those issues should be checked against that i think
18:10:34 <auggy> https://review.openstack.org/#/c/288772/
18:10:45 <auggy> oh i did have one question
18:10:46 <markus_z> You mean if they are included in the new liberty version?
18:10:58 <auggy> yeah, if there's a fix for the problem in the new liberty version
18:11:08 <markus_z> yeah, makes sense
18:11:16 <auggy> i have a bug i've had on my todo list to reproduce that reports an issue with nova-network
18:11:27 <auggy> if i'm not able to repro it using neutron, should i recommend the poster use neutron?
18:11:39 <auggy> like, are we supporting fixes to nova-network right now?
18:12:00 <auggy> i'm trying to figure out when it's valid to fix nova-network since i thought the idea was we're moving away from that?
18:12:13 <markus_z> AFAIK it is not decomitted because it is still widely used in the field
18:12:40 <markus_z> #todo markus_z figure out roadmap and support behavior of nova-network
18:12:43 <auggy> ok so i guess i'll try to repro it using nova-network and if i can then i'll just say yes this happens and let the bug triage person decide the priority
18:12:59 <auggy> and i'll also mention if it works in neutron and suggest the poster use that if i can get it to work as a workaround
18:13:46 <markus_z> we could start with a prio which we thing is appropriate, I don't know the details
18:13:57 <markus_z> The triager can increase/decrease that everytime
18:14:06 <auggy> https://bugs.launchpad.net/nova/+bug/1475786
18:14:06 <openstack> Launchpad bug 1475786 in OpenStack Compute (nova) "Cannot ping to a same subnet VM via floating IP" [Undecided,New]
18:14:08 <auggy> ok
18:14:08 <markus_z> A first best guess is good enough I think
18:14:19 <auggy> i've had this on my to-do list to repro for some time :/
18:14:57 <markus_z> To figure out if neutron behaves the same is valuable. AFAIK the migration path from nova-network to neutron is a bit bumpy.
18:14:59 <auggy> i have 3 bugs on my list to reproduce, so my goal this week is to get through those and get them updated
18:16:33 <markus_z> The bug you linked is odd, I would assume that would cause more attention if this is the case
18:16:46 <auggy> yeah i suspect it's a local config issue
18:17:12 <markus_z> Tomorrow is my team colleague available you knows the networking area a bit. I'll ask him.
18:17:30 <markus_z> #todo markus_z Investigate if https://bugs.launchpad.net/nova/+bug/1475786 is valid
18:17:30 <openstack> Launchpad bug 1475786 in OpenStack Compute (nova) "Cannot ping to a same subnet VM via floating IP" [Undecided,New]
18:17:38 <auggy> okay sounds good. I'll work on trying to reproduce that today
18:17:44 <auggy> and i'll update the bug with my findings
18:17:49 <markus_z> ok, cool, sounds very good
18:18:52 <markus_z> ah, one thing
18:18:57 <markus_z> #info  We will now get bug reports for merged changed with "DocImpact" in the commit message. http://lists.openstack.org/pipermail/openstack-dev/2016-March/088382.html
18:19:10 <auggy> yes, i skimmed one the other week!
18:19:40 <auggy> my understanding is we need to make sure there's enough info for the Doc team and then add the docs project to the bug
18:19:44 <markus_z> They will become more, we should be aware of that.
18:19:50 <markus_z> Right, an example: https://bugs.launchpad.net/nova/+bug/1550525
18:19:50 <openstack> Launchpad bug 1550525 in openstack-api-site " Abort an ongoing live migration" [Undecided,Confirmed] - Assigned to Andrea Rosa (andrea-rosa-m)
18:20:18 <markus_z> I poked the author of the patch in IRC and asked for details. Annoying but I don't see another way.
18:20:32 <auggy> yah the one i had skimmed was from bauzas
18:21:03 <auggy> and i poked him for details, i just updated the bug with what he told me on irc, it was a small change the help section explanation he added was sufficient for the doc team
18:21:19 <auggy> or if it wasn't then they could say something but yeah
18:21:40 <auggy> at least i understood it well enough from that ;)
18:21:42 <markus_z> Theoretically there shouldn't be a merged change without an explanation after "docimpact".
18:21:55 <auggy> yeah, maybe we can remind the team at the meeting this week
18:21:58 <markus_z> yeah, it's a case by case decision
18:22:15 <markus_z> yep, we should do that
18:22:29 <markus_z> It takes some weeks until it will become a habit
18:22:36 <auggy> yeah definitely :)
18:24:38 <markus_z> I'd use the rest of the meeting time to get through some of the stale incomplete bug reports.
18:24:48 <markus_z> Did I miss any open point?
18:24:48 <auggy> ok, that sounds good
18:24:55 <auggy> i don't think so
18:25:15 <markus_z> ok, I'll end the meeting if no one complains in the next minute
18:26:00 <markus_z> #info next meeting is at March 15th 2016 1000 UTC, #openstack-meeting-4
18:26:04 <markus_z> #endmeeting