18:00:44 <markus_z> #startmeeting nova-bugs-team
18:00:45 <openstack> Meeting started Tue Feb  9 18:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is markus_z. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:49 <openstack> The meeting name has been set to 'nova_bugs_team'
18:01:09 <markus_z> soo, is actually anybody here besides me?
18:01:19 <chhavi> chhavi here
18:01:33 <chhavi> i joined for then nova bug meetings
18:02:03 <markus_z> chhavi: ok, cool :) let's wait another minute, maybe someone else joins
18:03:12 <markus_z> #topic status of action items from last week
18:03:17 <auggy> o/
18:03:23 <markus_z> well, first meeting, so no action items from last week
18:03:27 <markus_z> auggy: hi!
18:03:38 <auggy> hi markus_z!
18:03:41 <kashyap> markus_z: Didn't realize the meeting time, have to head out of this coffee shop (as it's closing now) :-(
18:04:16 <markus_z> kashyap: ah, to bad
18:04:17 * kashyap will read the scroll after heading back home (20 min walk)
18:04:26 <markus_z> #topic decide action items for bug reports which need further attention
18:04:56 <markus_z> auggy: You did the bug skimming in the last days/weeks, do you have some bug reports you wanna talk about?
18:05:00 <kashyap> markus_z: Quick comment on the topic we discussed on #openstack-nova, I still need to file a BluePrint for this - https://bugs.launchpad.net/nova/+bug/1509304
18:05:01 <openstack> Launchpad bug 1509304 in OpenStack Compute (nova) "Add support for 'l2-cache-size' (a QCOW2 run time option for metadata cache size) for drives" [Undecided,Invalid]
18:05:30 <markus_z> kashyap: yepp, I still think that a bp would be the best there.
18:05:33 <auggy> markus_z: yeah, i had asked in channel but never got a response
18:05:52 <markus_z> auggy: About that bug?
18:05:57 <auggy> so when people report problems with nova-network, how much are we actually supporting nova-network
18:06:03 <auggy> versus suggesting they move to neutron?
18:06:14 <auggy> i have to find the bug
18:06:26 <markus_z> auggy: http://docs.openstack.org/openstack-ops/content/nova-network-deprecation.html That's the statement of direction I have
18:06:35 <auggy> https://bugs.launchpad.net/nova/+bug/1475786
18:06:36 <openstack> Launchpad bug 1475786 in OpenStack Compute (nova) "Cannot ping to a same subnet VM via floating IP" [Undecided,New]
18:06:56 <auggy> ok cool
18:06:58 <markus_z> in short, nova-network is still supported but development is low
18:07:15 <auggy> with that bug i just pasted, basically i figured i'd just try to repro it in neutron
18:07:26 <auggy> if it couldn't repro it, i'd suggest the reporter try that instead
18:07:30 <auggy> and close it as invalid
18:08:51 <markus_z> auggy: yeah, the steps to reproduce are missing. Switching to "incomplete" maybe first, and if not response comes, closing it.
18:09:06 <auggy> ok cool, yeah that makes sense too
18:09:46 <auggy> another question i have is generally if a bug is reported to affect multiple projects, like Cinder
18:10:07 <auggy> and there's work being done by cinder, but there's a question around how nova, say, is calling cinder,
18:10:14 <auggy> is it ok to mark as Confirmed?
18:10:37 <auggy> because that's what i've been doing assuming the bug would go to triage and someone with more idea would be able to determine if there's specifically any nova impact
18:10:39 <auggy> or should i be doing that?
18:10:45 <auggy> determining if there's specifically Nova impact?
18:11:35 <markus_z> not sure if I get it right
18:11:55 <auggy> i'll see if i can find a specific example, i just skimmed one yesterday
18:12:04 <markus_z> if the interaction of nova-cinder is in question, it is fair to mark Nova as affected project
18:12:49 <auggy> yeah, but then the bug is in "new" status on the nova side
18:12:49 <markus_z> a further analysis is necessary to make a "invalid"/"confirmed" statement
18:12:58 <markus_z> which is often not possible during the bug skimming
18:13:30 <auggy> will it still get triaged if it's marked as "New" and not "Confirmed"?
18:13:50 <auggy> here's an example, it's a bug reported in horizon - https://bugs.launchpad.net/horizon/+bug/1530830
18:13:52 <openstack> Launchpad bug 1530830 in OpenStack Compute (nova) "Instance Console Crashes : Unable to enter credentials at Instance Console " [Undecided,Confirmed]
18:13:52 <markus_z> Yes, it should
18:14:40 <auggy> ok so in this case i wasn't sure what to do as bug skimmer, so i marked it as confirmed and left a comment that someone needed to dig in further
18:14:45 <chhavi> markus_z: there are bugs which are more than a year old: https://bugs.launchpad.net/nova/+bug/1439855 what should be done for such bugs
18:14:46 <openstack> Launchpad bug 1439855 in OpenStack Compute (nova) "encrypted iSCSI volume fails to attach, name too long" [Medium,In progress] - Assigned to Nha Pham (phqnha)
18:15:03 <markus_z> auggy: yep, that's ok what you did there.
18:15:24 <markus_z> I don't yet have someone which has deeper knowledge in the networking area.
18:15:58 <markus_z> chhavi: It's on the agenda, I come to that in a minute
18:16:08 <chhavi> ok
18:16:52 <auggy> ok cool, i'll just try to use my best judgement and if it's unclear, tag it and make a comment that it needs further research before it can be marked as "Confirmed" on the nova side
18:17:18 <auggy> that way at least it comes up to the top as having been recently touched and someone in triage knows we looked at it
18:17:30 <markus_z> auggy: yep, that's the best you can do with the amount of incoming reports
18:18:07 <auggy> i think so far that is all my questions but i'll go over the bugs i've skimmed and see if there is anything else
18:18:19 <auggy> i'll send you an email for next week's meeting, since it's at like 2am for me i probably won't be there ;)
18:18:36 <markus_z> auggy: I had to cancel next weeks meeting
18:18:39 <auggy> oh right i knew that
18:18:41 <auggy> ;D
18:19:23 <auggy> i'll follow up via email later with any other questions and if it seems relevant to others, i can post it to the mailing list
18:19:31 <markus_z> auggy: I added the tag "needs-attention" which you (or other bug skimmer) can use for such bug reports in question
18:19:38 <auggy> ah great!
18:20:29 <auggy> i think that will be useful especially when it's not possible to reproduce a reported issue due to lack of environment resources (like Ceph)
18:20:57 <markus_z> yep
18:21:18 <markus_z> ok, more open bugs which are a bit unclear?
18:22:11 <markus_z> #topic expire bugs which are hit by the expiration-policy unless someone disagrees
18:22:45 <markus_z> #link https://bugs.launchpad.net/nova/+bug/1227575 is an example of an incomplete bug which got closed to due inactivity
18:22:47 <openstack> Launchpad bug 1227575 in OpenStack Security Notes "DoS style attack on noVNC server can lead to service interruption or disruption" [High,Fix released] - Assigned to CloudDon (sriramhere)
18:23:18 <markus_z> At the bottom of that bug report is a template you could use.
18:23:41 <markus_z> Basically it's about closing "incomplete" bugs which are not closed automatically by Launchpad
18:24:44 <markus_z> If anyone want to help there, ping me in #openstack-nova
18:24:49 <auggy> do you have a link to the query to create a list of those posted anywhere?
18:25:12 <markus_z> #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&search=Search&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&fi
18:25:12 <markus_z> eld.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&orderby=date_last_updated&start=0
18:25:21 <markus_z> whops, that's long, one sec
18:25:41 <markus_z> #link http://bit.ly/1Q5C98F incomplete bugs which are stale
18:26:21 <markus_z> auggy: Is that the query you're asking or a list of bugs which are closed to due inactivity?
18:26:53 <auggy> the thing you had mentioned, incomplete bugs which are not closed automatically by launchpad
18:27:01 <auggy> where we need to post that template response and close and wontfix
18:27:15 <markus_z> ah, that's the last link
18:28:02 <markus_z> One has to read those to double-check if they are really incomplete or if they maybe have a review but are in the wrong state.
18:28:27 <markus_z> I use 30 days as a threshold to switch from "incomplete" to "won't fix"
18:29:15 <chhavi> 30 days will be a very short time, considering nova bugs
18:29:42 <markus_z> chhavi: 30 days after the switch to incomplete where a list of input was asked for
18:30:21 <auggy> i think that's fair, the reporter can always reopen it later
18:30:28 <chhavi> ok, so if the bug is in incomplete state with no updates for more than 30 days we can switch to won't fix.
18:30:31 <chhavi> got it
18:30:35 <markus_z> chhavi: After that its unlikely that new information is provided. And we can always switch back from "won't fix" to "new" when new facts are delivered.
18:30:48 <thorst_> markus_z: what if the hold up is reviews?
18:30:48 <markus_z> chhavi: yep, right
18:31:01 <chhavi> markus_zL i would like to help here to skim through some bugs
18:31:02 <markus_z> thorst_: The review is still alive?
18:31:04 <auggy> thorst_: i'm guessing that's why we need to manually review it
18:31:21 <thorst_> yeah
18:31:23 <auggy> if there's a review pending, we should probably see what's going on and leave a comment maybe?
18:31:39 <thorst_> well sometimes its just a new developer not sure how to move forward.
18:31:49 <markus_z> yep. If there is a living review, mention it in the bug report if not yet done.
18:31:55 <auggy> yeah, they may not realize they need to get attention
18:31:59 <thorst_> ahh, that was the disconnect for me
18:32:00 <thorst_> thanks
18:32:20 <thorst_> 30 days, no reviews out -> mark won't fix
18:32:30 <markus_z> thorst_: After 2 weeks without review I start poking people in the #openstack-nova channel
18:32:47 <markus_z> thorst_: if "incomplete", yes
18:32:55 <thorst_> yeah...I was not sure what the etiquette there was.  That sounds reasonable
18:33:20 <markus_z> it's odd at the beginning but that's the only way I know
18:33:21 <chhavi> if there is no progress on review, in that case
18:33:36 <markus_z> thorst_: It's also fair to mention it here, then we have a list where I can poke folks
18:33:45 <auggy> yeah it makes sense to bring it to the attention of the larger group in the bug report
18:34:00 <auggy> someone may have some context as to why that review may never be approved
18:34:41 <markus_z> chhavi: If you want to help with the bug skimming, there is this wiki page: https://wiki.openstack.org/wiki/Nova/BugTriage#Weekly_bug_skimming_duty
18:34:58 <markus_z> thorst_: Do you have a review which needs attention?
18:35:05 <chhavi> ok
18:35:09 <thorst_> markus_z auggy: so maybe a portion of the meeting for 'stuck' reviews and the what not.  I've only got one right now, on behalf of someone else
18:35:12 <thorst_> let me get it quick
18:35:26 <thorst_> https://bugs.launchpad.net/nova/+bug/1355171
18:35:28 <openstack> Launchpad bug 1355171 in OpenStack Compute (nova) "Can not have IPv4 or IPv6 only interfaces injected via /etc/network/interfaces." [Medium,In progress] - Assigned to Jialiang (jialiang-song517)
18:35:34 <thorst_> old bug...recent proposed fix.
18:36:10 <thorst_> I believe Jialiang needs it for lxc work, but I also need it for PowerVM driver stuff.
18:36:48 <markus_z> thorst_: the -1 from jenkins has to get away, otherwise nobody will look
18:37:04 <thorst_> bah...didn't realize that popped back up
18:37:22 <thorst_> will work with Jialiang again.  He wants to drive this one (and I think its a good opportunity for him)
18:37:51 <thorst_> sorry!
18:37:51 <markus_z> #action markus_z needs contacts for the network area
18:38:03 <markus_z> thorst_: no worries
18:38:24 <markus_z> #topic reset In Progress bugs if no patch is available
18:38:35 <markus_z> chhavi: That's the question you had before
18:38:53 <chhavi> yes
18:39:21 <markus_z> #link http://bit.ly/20myY24 Potentially stale "in progress" bugs
18:39:49 <markus_z> #link https://bugs.launchpad.net/nova/+bug/1391029 example of resetting "in progress" bugs which are stale
18:39:50 <openstack> Launchpad bug 1391029 in OpenStack Compute (nova) "compute manager update_available_resource interval needs to be configurable" [Wishlist,Confirmed]
18:40:26 <markus_z> chhavi: Basically, if the bug report has an assignee, there should be a patch in review within 2 weeks after the assignee was set.
18:41:06 <chhavi> ok
18:41:23 <markus_z> we have around 400 "in progress" bugs, funnily enough that amount is pretty constant within the last months
18:41:49 <auggy> markus_z: do we have a wiki page or etherpad with these bug maintenance tasks along with the searches?
18:41:57 <auggy> if not i can put that together after this meeting
18:42:11 <markus_z> it's fair to take over after 2 weeks or to reset the bug report to "confirmed"
18:42:17 <markus_z> #link https://wiki.openstack.org/wiki/Meetings/Nova/BugsTeam#Queries
18:42:38 <markus_z> auggy: ^ that one
18:42:43 <auggy> ok cool, i can update with a description of what we're looking for and what needs to happen in each case
18:43:04 <markus_z> that would be awesome!
18:44:03 * auggy added a card to her Trello board ;)
18:44:16 <markus_z> unfortunately one has to read the bug reports to decide what's happening. They are not always consistent.
18:44:42 <markus_z> #action markus_z to double-check if it makes sense to use Trello for managing nova bugs
18:45:02 <auggy> #action auggy to add descriptions to the bug team queries on the wiki
18:45:12 <markus_z> #topic check if we need new tags for functional areas
18:45:44 <auggy> during the midcycle, i added "quotas" to the official list
18:46:05 <markus_z> ah, yes, "quotas" is a good one
18:46:23 <markus_z> #link https://wiki.openstack.org/wiki/Nova/BugTriage#Step_2:_Triage_Tagged_Bugs The list of nova bug tags with owners
18:46:59 <auggy> ah ok, i added it here - https://wiki.openstack.org/wiki/Bug_Tags#Nova
18:47:25 <markus_z> #action markus_z pester again folks in Nova who want to help triage bugs
18:47:48 <markus_z> #link https://bugs.launchpad.net/nova/+manage-official-tags Launchpad official bug tag list
18:48:12 <markus_z> hm, having two wiki pages is not good
18:48:47 <markus_z> #action markus_z unify https://wiki.openstack.org/wiki/Bug_Tags#Nova + https://wiki.openstack.org/wiki/Nova/BugTriage#Step_2:_Triage_Tagged_Bugs
18:48:59 <auggy> oh wow, i didn't even know that "manage" page existed
18:49:15 <markus_z> LP does a good job to hide such things
18:49:38 <markus_z> "quotas" is already there, which is good
18:50:03 <markus_z> auggy: Did you see a pattern in the latest bug reports? A specific area which doesn't yet have an own tag?
18:50:06 <auggy> yeah, i have been using the bug list on the wiki page i linked as reference to what is a valid link
18:50:23 <auggy> not yet, everything seems to fall into the categories we have from what i can tell
18:50:37 <auggy> but i'll keep an eye out this week as i'm skimming
18:50:44 <markus_z> ok cool
18:50:48 <auggy> also i'm still new to things so i might be missing these subtleties ;)
18:51:04 <markus_z> the job cannot be done perfectly, that's ok
18:51:08 <markus_z> #topic get one or more volunteers for the rotating bug-skimming-duty
18:51:49 <markus_z> hm, I lost chhavi, too bad
18:51:58 <auggy> i think if more than one person is on skimming duty, we should share a list with each other so we can peer review each other
18:52:21 <auggy> i find it helpful to make sure i'm doing it right and didn't miss anything, but maybe that's too much time spent on this
18:52:30 <markus_z> #link https://etherpad.openstack.org/p/nova-bugs-team Etherpad for the nova bugs team
18:52:40 <markus_z> auggy: You can use this etherpad if you like ^
18:52:49 <auggy> ok cool
18:53:00 <markus_z> just add a section where you like
18:53:01 <auggy> i usually comment on the bugs i skim so they show up in my launchpad profile
18:53:22 <auggy> since lp won't show bugs you've just tagged or updated the status of, which is annoying
18:53:26 <markus_z> There is another hidden LP link for that, right?
18:53:31 <auggy> is there?
18:54:14 <markus_z> I thought I had a link
18:54:50 <markus_z> https://bugs.launchpad.net/~mzoeller
18:55:11 <markus_z> That's it, your LP username at the end
18:55:41 <markus_z> #link https://bugs.launchpad.net/~<your-lp-username> A list of bugs you left a comment
18:55:52 <auggy> https://bugs.launchpad.net/~auggy/+commentedbugs
18:56:04 <markus_z> uh, even better
18:56:19 <auggy> "all related" doesn't show bugs you only tagged
18:56:34 <auggy> i can't remember if it shows ones where you just updated the status and tagged
18:57:58 <markus_z> #topic reviews for bug fixes which needs attention
18:59:11 <markus_z> #action thorst make https://review.openstack.org/#/c/264157/ +1 again and we find reviewers
18:59:32 <markus_z> #topic discuss open points
18:59:40 <markus_z> Well, 1 min left
19:00:07 <auggy> thanks markus_z for reviving this!
19:00:23 <thorst> +2  Thanks markus_z!
19:00:39 <markus_z> auggy: thanks a lot for your help on the bug skimming front
19:00:50 <markus_z> thanks for coming
19:01:05 <markus_z> #info next meeting is at February 23rd
19:01:10 <markus_z> #endmeeting