#openstack-meeting-4: nova api

Meeting started by alex_xu at 13:00:04 UTC (full logs).

Meeting summary

    1. https://review.openstack.org/#/c/301372/ (alex_xu, 13:02:29)
    2. http://developer.openstack.org/api-ref/networking/v2/#security-groups-security-groups (mriedem, 13:07:44)
    3. https://etherpad.openstack.org/p/ocata-nova-security-groups (johnthetubaguy, 13:18:42)
    4. https://review.openstack.org/#/c/350277/ (alex_xu, 13:23:57)
    5. HELP: need someone to write the spec for exposing the standardized instance diagnostics out of the REST API (mriedem, 13:34:12)
    6. ACTION: alex_xu to work on generic diagnostics spec (sdague, 13:34:46)
    7. ACTION: johnthetubaguy to sketch out what an ideal security group workflow looks like in the nova api now with neutron as the presumed backend (sdague, 13:35:39)
    8. ACTION: mriedem to write up spec for os-virtual-interface deprecation (sdague, 13:36:07)
    9. ACTION: alex_xu to write a spec for deprecating the proxy api to set/delete image metadata (mriedem, 13:39:43)
    10. ACTION: mriedem to follow up with gmann about testing swap-volume in tempest (mriedem, 13:42:05)
    11. ACTION: sdague to start in on a capabilities spec (sdague, 13:51:53)
    12. https://review.openstack.org/#/c/280539/ (claudiub, 13:54:21)


Meeting ended at 13:59:21 UTC (full logs).

Action items

  1. alex_xu to work on generic diagnostics spec
  2. johnthetubaguy to sketch out what an ideal security group workflow looks like in the nova api now with neutron as the presumed backend
  3. mriedem to write up spec for os-virtual-interface deprecation
  4. alex_xu to write a spec for deprecating the proxy api to set/delete image metadata
  5. mriedem to follow up with gmann about testing swap-volume in tempest
  6. sdague to start in on a capabilities spec


Action items, by person

  1. alex_xu
    1. alex_xu to work on generic diagnostics spec
    2. alex_xu to write a spec for deprecating the proxy api to set/delete image metadata
  2. johnthetubaguy
    1. johnthetubaguy to sketch out what an ideal security group workflow looks like in the nova api now with neutron as the presumed backend
  3. mriedem
    1. mriedem to write up spec for os-virtual-interface deprecation
    2. mriedem to follow up with gmann about testing swap-volume in tempest
  4. sdague
    1. sdague to start in on a capabilities spec


People present (lines said)

  1. mriedem (105)
  2. sdague (57)
  3. johnthetubaguy (46)
  4. alex_xu (26)
  5. claudiub (11)
  6. mtreinish (3)
  7. prateek (3)
  8. diga_ (3)
  9. openstack (3)
  10. cdent (1)
  11. jichen (1)
  12. bauzas (1)
  13. edleafe (1)


Generated by MeetBot 0.1.4.