12:00:05 <alex_xu> #startmeeting nova api
12:00:06 <openstack> Meeting started Tue Nov 10 12:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is alex_xu. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:00:09 <openstack> The meeting name has been set to 'nova_api'
12:00:15 <alex_xu> who is here today?
12:00:17 <jichen> o/
12:00:26 <gmann_> hi
12:00:33 <Kevin_Zheng> hi
12:00:59 <alex_xu> hello everyone
12:01:41 <sdague> o/
12:02:16 <alex_xu> ok, let's start the meeting
12:02:23 <alex_xu> #topic actions from last meeting
12:02:27 <tangchen_> hi
12:02:31 <alex_xu> gmann_ create bp for microversion top bottom and changed testing
12:02:41 <alex_xu> actually this is from before summit
12:02:50 <gmann_> alex_xu, yes, Done today
12:03:01 <alex_xu> gmann_: cool, do you have link?
12:03:56 <gmann_> #link https://blueprints.launchpad.net/nova/+spec/nova-microversion-functional-tests
12:04:08 <alex_xu> gmann_: cool, thanks
12:04:27 <sdague> gmann_: looks great
12:04:43 <alex_xu> so there will be spec later?
12:05:02 <johnthetubaguy> I don't think we need a spec for that, so I approved it
12:05:05 <gmann_> alex_xu, do we need spec for that? or we can do direct
12:05:15 <gmann_> johnthetubaguy, yea
12:05:26 <alex_xu> ok, cool, got it
12:05:34 <alex_xu> so let's move on
12:06:19 <alex_xu> wait, so this will have a lot of work, right? do you need people help on that?
12:06:57 <johnthetubaguy> honestly, I want us to focus on the docs instead of this testing
12:07:10 <johnthetubaguy> I am tempted to make it low priority for now
12:07:42 <gmann_> johnthetubaguy, sounds good. even i ws thinking to start this after all extesnion tests work
12:07:56 <gmann_> so that it will be easy to share sample files in mocroversion testing also
12:08:11 <alex_xu> ok, cool
12:08:17 <alex_xu> #topic API Documentation
12:08:24 <gmann_> alex_xu, but should not reuire much work, we can do after doc thing done
12:08:37 <alex_xu> gmann_: ok, got it
12:08:41 <alex_xu> API concept doc and API reference
12:08:46 <alex_xu> #link https://etherpad.openstack.org/p/nova-v2.1-api-doc
12:08:55 <alex_xu> I wrote down the workflow and expectation for existed api refer, I wonder hope give feedback about whether is ok before I advert it out.
12:09:07 <alex_xu> Basically it focus on improve the description of each api and parameter, after we have swagger, we can port them into the nova code directly. But that is huge number works.
12:10:33 <johnthetubaguy> that looks good to me
12:10:34 * alex_xu guess people busy on read my notes
12:10:45 <alex_xu> johnthetubaguy: cool, thanks
12:11:07 <gmann_> alex_xu, nice plan to import to code from there.
12:11:09 <sdague> I was wondering if it would be helpful to try to jump start this with something like a 2 day virtual doc sprint
12:11:12 <johnthetubaguy> sorry folks I have to run now, my food is ready, not used to the daylight savings changes yet
12:11:24 <johnthetubaguy> sdague: thats a very good idea
12:11:26 <alex_xu> gmann_: thanks
12:11:29 <gmann_> sdague, +2
12:11:31 <alex_xu> sdague: interesting idea
12:11:41 <gmann_> we can clean up a lot in that
12:11:42 <jichen> +1
12:11:48 <alex_xu> johnthetubaguy: no problem
12:11:48 <Kevin_Zheng> +1
12:12:11 <sdague> so, my suggestion for that would be to do it the first week of December some time
12:12:21 <sdague> because there is a holiday in the US the end of nov
12:12:37 <sdague> and that whole week will be patchy
12:12:47 <gmann_> sdague, Thanks giving?
12:12:51 <sdague> gmann_: yep
12:13:01 <alex_xu> that week is Mitaka-1, will people busy on spec freeze?
12:13:10 <sdague> alex_xu: hmmm good point
12:13:18 <sdague> maybe week after then?
12:13:30 <gmann_> yea after M-1 it will be good
12:13:31 <alex_xu> yea, that will be good
12:13:57 <alex_xu> what process for that? send email advert it
12:14:36 <sdague> yeh, so I'd say pick 2 days. Try to get commitments from folks in advance that they'll contribute during it.
12:15:20 <alex_xu> ok
12:15:29 <sdague> Have an etherpad with things people should be working on, stuff ready for review, and we'll try to just go heads down and push through a bunch during that
12:15:45 <sdague> it will be virtual sprint so it will be those 2 days in local timezone for folks
12:16:01 <gmann_> yup
12:16:11 <alex_xu> sounds cool
12:16:54 <sdague> ok, alex_xu you up for organizing it?
12:17:06 <sdague> or any other volunteers to organize
12:17:13 <sdague> anyone could take the lead on that
12:17:47 <alex_xu> sdague: yea sure, I happy to help on, but I may need ask many question to you, as I haven't experience on organize those thing
12:18:06 <tangchen_> Hi, is it a work to improve the doc and cleanup ?  I'd like to be part of it.
12:18:17 <sdague> sure, no probably, feel free to ask me about it any time
12:18:24 <alex_xu> sdague: thanks
12:18:29 <alex_xu> tangchen_: yea
12:18:35 <gmann_> tangchen_, yes.
12:18:45 <gmann_> alex_xu, I can also help if you need.
12:18:53 <tangchen_> OK, please let me join.
12:18:59 <alex_xu> gmann_: cool, thanks
12:19:13 <sdague> #info alex_xu to organize nova doc virtual sprint for 2nd week of Dec
12:19:16 <alex_xu> also thanks jichen and Kevin_Zheng, I saw them already work on the api refer
12:19:35 <Kevin_Zheng> alex_xu: NP
12:19:50 <alex_xu> API Review guideline
12:19:51 <sdague> alex_xu: yep
12:19:54 <jichen> alex_xu: so this will be bundle together and virtual sprint will handle them all ?
12:20:16 <sdague> jichen: I'd say keep up the good work now
12:20:23 <alex_xu> yea
12:20:30 <alex_xu> needn't wait the virtual sprint
12:20:34 <sdague> this is more about trying to pull in more people and push a bunch of work through quickly
12:20:34 <gmann_> jichen, we keep doing those and try to finish in sprint
12:20:36 <jichen> sdague: yea, that's my thought too, ok got it
12:20:38 <gmann_> yea
12:21:18 <alex_xu> ok, let's move on
12:21:33 <alex_xu> the api review guide is bring up in the summit
12:21:48 <alex_xu> anyone sign up to work on it?
12:22:37 <alex_xu> emm...if not, I guess that will be my work, although I'm not good at English ;)
12:22:48 <tangchen_> alex_xu: Sorry, I didn't go to the summit. What do you mean by "sign up" ?
12:23:04 <alex_xu> tangchen_: I mean any volunteers to work on it
12:23:11 <Kevin_Zheng> It need more experiance I guess
12:23:35 <alex_xu> yea, so let me try when I have time
12:23:36 <tangchen_> alex_xu: I'd like to. But currently, I don't what to do in detail.
12:23:47 <alex_xu> tangchen_: yea, I know
12:23:51 <alex_xu> so let's move on
12:23:55 <alex_xu> Swagger Doc Generate
12:24:00 <alex_xu> Thanks oomichi discussed swagger with me at summit, and we summary something in the etherpad
12:24:07 <alex_xu> Thanks oomichi discussed swagger with me at summit, and we summary something in the etherpad
12:24:11 <alex_xu> #link https://etherpad.openstack.org/p/mitaka-nova-swagger
12:24:20 <alex_xu> oops
12:24:26 <alex_xu> #link https://review.openstack.org/243365
12:24:31 <alex_xu> And work out the initial version nova-spec, still need some detail to put in.
12:25:04 <alex_xu> appreciate gmann_ and oomichi_ if you guys can help me input some tempest consideration in the spec
12:25:13 <gmann_> alex_xu, i did not get chance to look into that. I will look tomorrow and add if needed from Tempest side etc
12:25:24 <gmann_> alex_xu, yea, sure
12:25:25 <alex_xu> gmann_: thanks a lot
12:25:35 <alex_xu> and Next is I should work out more PoC to show how to doc in the code.
12:26:04 <alex_xu> #action alex_xu update the PoC to show more example
12:26:17 <gmann_> alex_xu, Also will check with swagger team about request sample example in spec
12:26:29 <alex_xu> gmann_: ok, cool
12:27:06 <alex_xu> I think swagger can't support that in short time, we can try add some extend field into the swagger to support request sample example
12:27:45 <gmann_> and those can by picked by UI ?
12:27:59 <alex_xu> yea, UI is coded by doc team
12:28:18 <alex_xu> #link https://github.com/russell/fairy-slipper
12:28:21 * edleafe yawns
12:28:24 <alex_xu> gmann_: this one I guess ^
12:28:26 <gmann_> yea,
12:28:31 <gmann_> alex_xu, cool
12:29:06 <alex_xu> actually I hope the Russell give some input how to support microversions and actions, but I didn't get response from him
12:29:33 <alex_xu> and looks like Anne isn't here today also :(
12:30:11 <alex_xu> anyway, any more question on swagger?
12:30:55 <alex_xu> if not, let's move on, this is all about api doc
12:30:59 <alex_xu> #topic Service Catalog
12:31:01 <gmann_> alex_xu, it will be good if we can have some fairy-slipper thing  also with your POC or patches for those
12:31:23 <gmann_> so that we can see how those going to be looks like and improve at early stage if needed
12:31:35 <gmann_> but as you said need input from doc team on those
12:31:43 <alex_xu> gmann_: yea, I should catch Anne get some input
12:32:00 <gmann_> alex_xu, ok cool
12:32:11 <alex_xu> for this part is about remove project_id from URL
12:32:17 <alex_xu> #link https://etherpad.openstack.org/p/removing-project-id-in-nova-urls
12:32:30 <alex_xu> sdague: ^ anything you want to talk about?
12:33:21 <alex_xu> I saw part of patches isn't ready for review yet
12:34:42 <alex_xu> I guess sdague busy on other things
12:34:45 <gmann_> yea
12:35:12 <alex_xu> any more question on this, otherwise let's move on
12:35:12 <sdague> yeh, sorry, baby just got up
12:35:16 <sdague> back now
12:35:28 <sdague> so, I think it's largely doable in one patch
12:35:39 <alex_xu> sdague: yea, baby is more important :)
12:35:45 <sdague> mmmpork is assisting getting that patch into shape with tests
12:36:00 <gmann_> sdague, devtsack patch also will be landed right? - https://review.openstack.org/#/c/233079/3
12:36:05 <sdague> https://review.openstack.org/#/c/233076/
12:36:07 <gmann_> sdague, means not actualy WIP
12:36:15 <sdague> gmann_: yes, it requires the nova patch though
12:36:19 <gmann_> yea
12:36:43 <alex_xu> a novaclient patch already merged
12:36:53 <sdague> right
12:37:22 <sdague> we need the novaclient patch in a released version before we can change devstack as well
12:37:35 <sdague> otherwise things like nova flavor-list blow up
12:37:37 <alex_xu> ok, so I guess we just waiting for the nova patch ready to review
12:37:45 <sdague> because of the microversion detection going a bit haywire
12:38:06 <sdague> #action sdague to circle with mmmpork today on nova patch
12:38:18 <sdague> #action sdague to circle with mmmpork today on nova patch for optional project_id
12:38:19 <alex_xu> sdague: cool, thanks
12:38:53 <alex_xu> ok, cool, so if no more question, let's move on
12:39:14 <alex_xu> #topic Novaclient
12:39:37 <alex_xu> there is one work bring up by sdague, it is about Caching the version negotiation.
12:40:02 <alex_xu> at least for now, there isn't any assignee yet
12:40:21 <sdague> yes, that was a "nice to have" from the API session to reduce our round trips
12:40:55 <sdague> I think that if no one else takes a look I'll see if mmmpork is up for it
12:41:13 <gmann_> alex_xu, sdague what is that actually?
12:41:15 <alex_xu> sdague: ok, cool
12:41:50 <gmann_> do we have some etherpad/bug etc so that i can look tomorrow
12:42:03 <sdague> gmann_: so, we're doing up to 3 round trips for every nova cli call now
12:42:10 <sdague> because of the microversion negotiation
12:42:28 <sdague> but the microversions supported on the server don't change very often
12:42:36 <alex_xu> #link https://etherpad.openstack.org/p/mitaka-nova-api
12:42:41 <alex_xu> gmann_: there are some notes ^
12:43:00 <sdague> so we should ideally cache that result for like 24hrs
12:43:29 <gmann_> sdague, ah i see.
12:43:45 <gmann_> alex_xu, Thanks for link
12:43:54 <alex_xu> gmann_: np
12:44:03 <sdague> anyway, we should move on. It's a pretty low priority thing, just a nice to have
12:44:11 <alex_xu> ok, let's move on
12:44:19 <alex_xu> #topic Testing
12:44:29 <alex_xu> #link https://review.openstack.org/#/c/169126/
12:44:47 <alex_xu> I saw this spec about test Microversion in tempest side
12:45:15 <alex_xu> Emm...ken'ichi isn't here
12:45:33 <alex_xu> I think people just need to review it
12:45:57 <gmann_> alex_xu, yea
12:46:12 <gmann_> sdague, has +2 on it.
12:46:12 <alex_xu> another thing about test is merge all extension for sample test
12:46:22 <alex_xu> https://blueprints.launchpad.net/nova/+spec/api-sample-tests-with-all-extensions
12:46:24 <gmann_> in parallel we have started implementation also
12:46:34 <alex_xu> gmann_: cool
12:46:49 <gmann_> alex_xu, and for all extesnion-
12:46:56 <alex_xu> gmann_: anything update for all extension?
12:47:03 <gmann_> started for image and flavor merging
12:47:06 * alex_xu jump too fast...
12:47:06 <gmann_> #link https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/api-sample-tests-with-all-extensions,n,z
12:47:16 <gmann_> reviews are welcome
12:47:32 <alex_xu> gmann_: cool!
12:47:36 <gmann_> manly i need feedback about patch size. if it is ok to do by resource vise
12:47:58 <gmann_> because flavor one looks large but easy to review
12:48:04 <sdague> I'll take a look later
12:48:13 <gmann_> sdague, Thanks.
12:48:18 <alex_xu> yea, me too
12:48:29 <alex_xu> ok, let's move on
12:48:29 <gmann_> alex_xu, Thanks
12:48:35 <alex_xu> time is tight again
12:48:36 <sdague> something that mmmpork pointed out last night was that we still have a very different validation model in api samples from the jsonschema
12:48:41 <sdague> get_regexes
12:48:49 <sdague> might be a thing to clean that up
12:49:11 <gmann_> sdague, ok, need to look on verfication part
12:49:46 <alex_xu> yea, good point
12:50:00 <gmann_> sdague, once we do validation with response schema (in swagger work) then we can clean up
12:50:31 <gmann_> then we might get rid of validation based on regex
12:51:25 <alex_xu> gmann_: ok
12:51:39 <alex_xu> I need get into the code to know how to clean up it
12:51:48 <alex_xu> 10 mins left, let's move on
12:51:54 <alex_xu> #topic API Deprecations
12:51:57 <sdague> so, the swagger work seems really abstract to me still. Is there a piece of code that takes something from the tree and publishes it to docs.openstack.org anywhere to see it all in action?
12:52:56 <alex_xu> sdague: not yet, the swagger ui is still in progress https://github.com/russell/fairy-slipper
12:53:02 <gmann_> sdague, do not have for docs.openstack.org thing.
12:53:04 <gmann_> yea
12:53:41 <gmann_> if russell can hook things with swagger POC then it wil be nice
12:53:48 <alex_xu> yea
12:54:08 <alex_xu> need poke doc team to give some feedback
12:54:40 <alex_xu> sdague: any thought, or you see some risk?
12:54:41 <sdague> ok, so we should set a date of when that POC will be there, it should be before the doc sprint
12:55:02 <sdague> because it will help encourage people if their work hits docs.openstack.org immediately
12:55:02 <alex_xu> sdague: ok, I will busy on it
12:55:28 <sdague> so I would say the status of that publishing pipeline should be a standing item on this agenda
12:56:33 <alex_xu> sdague: yea, this really talk with doc team
12:56:44 <alex_xu> s/really/really need/
12:56:56 <sdague> alex_xu: ok, you have the action for this?
12:57:27 <alex_xu> #action alex_xu contact the doc team about how to swagger stuff
12:57:38 <alex_xu> #undo
12:57:39 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9943790>
12:57:54 <alex_xu> #action alex_xu contact the doc team about swagger stuff
12:58:10 <edleafe> Sorry, busy getting the family off to work/school. I'll read through the scrollback and see if there is anything I can help with.
12:58:13 <alex_xu> ok two mins left...
12:58:22 <alex_xu> edleafe: no prolbme
12:58:41 <alex_xu> sdague: anything we need to for deprecated the ec2 and legacy api for now?
12:58:55 <alex_xu> I mean any actions from summit?
12:59:45 <sdague> alex_xu: not yet
12:59:55 <sdague> we don't have feedback from operators yet on using them
12:59:56 <alex_xu> sdague: ok, cool
13:00:12 <sdague> I guess I have an action on asking about the stackforge project
13:00:18 <sdague> and how it's working for folks
13:00:24 <alex_xu> so I guess we talk all of mitaka tasks today
13:00:34 <alex_xu> sdague: ok
13:00:40 <alex_xu> sorry, it's time to close meeting
13:00:45 <alex_xu> thanks all
13:00:53 <alex_xu> #endmeeting