16:00:45 <bauzas> #startmeeting nova
16:00:45 <opendevmeet> Meeting started Tue Mar 19 16:00:45 2024 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:45 <opendevmeet> The meeting name has been set to 'nova'
16:00:48 <bauzas> heyho
16:00:52 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:26 <fwiesel> o/
16:01:30 <elodilles> o/
16:01:41 <auniyal> o/
16:01:56 <gibi> o/j
16:02:25 <bauzas> okay, let's sofly start
16:02:31 <sean-k-mooney> o/
16:02:36 <grandchild> o/
16:03:32 <bauzas> #topic Bugs (stuck/critical)
16:03:50 <bauzas> #info No  Critical bug
16:03:56 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 63 new untriaged bugs (-2 since the last meeting)
16:04:01 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:04:15 <bauzas> gibi: could you please take the baton for this week ?
16:04:56 <gibi> bauzas: sorry I cannot promise to do meaningful triage this week either
16:05:03 <gibi> can we skip me?j
16:05:27 <bauzas> okay
16:05:34 <gibi> I hope I will have more time in the coming months
16:05:51 <bauzas> melwitt is the next in the queue
16:05:57 <bauzas> melwitt: would you be okay ?
16:07:14 <bauzas> okay, anyone else wanting to take the baton ? if not, I'll take it again... :)
16:08:13 <bauzas> okay
16:08:20 <elodilles> i'd rather wait until we release 2024.1 Caracal o:)
16:08:28 <bauzas> #info bug baton is bauzas
16:08:50 <bauzas> moving on
16:08:55 <bauzas> #topic Gate status
16:08:59 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:09:03 <bauzas> #link https://etherpad.opendev.org/p/nova-ci-failures-minimal
16:09:07 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fnova&project=openstack%2Fplacement&pipeline=periodic-weekly Nova&Placement periodic jobs status
16:09:13 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:09:24 <bauzas> anything to discuss about the gate ?
16:09:27 <bauzas> oh, one point
16:09:48 <bauzas> I just saw slaweq's email on bare rechecks
16:10:01 <Uggla> o/
16:10:22 <bauzas> as a reminder, please avoid to say only "recheck" when you have a gate failure
16:10:38 <dansmith> or "recheck unrelated"
16:10:45 <bauzas> and please add a good comment explaining what's the root problem
16:10:47 <dansmith> it can be unrelated, but at least say why
16:10:52 <bauzas> and try to find a second to understand the reason
16:11:17 <bauzas> yeah, or at least please tell in the comment which job fails and with which exception
16:11:59 <bauzas> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/7L6DSFN6GB65FBVHQATTLSQ7HWGBZJHM/
16:12:13 <sean-k-mooney> honestly i dont think calling this out here helps
16:12:14 <bauzas> #info please avoid bare rechecks
16:12:34 <dansmith> sean-k-mooney: really? the tc has asked PTLs and other project leaders to help get this word out
16:12:37 <sean-k-mooney> the people that are here already know we should avoid it
16:13:06 <bauzas> not only folks discussing here look at our meetings :)
16:13:08 <sean-k-mooney> dansmith: sure but doing this in the team metting i dont think helps
16:13:25 <dansmith> sean-k-mooney: it's exactly what we've asked for, AFAIK
16:13:28 <sean-k-mooney> ok but we disucssed about stoping to do this here in the past
16:13:29 <bauzas> I know some folks look at our minutes
16:13:37 <dansmith> and I think it does help because as bauzas says, people might not be here but read the minutes
16:13:59 <sean-k-mooney> ok but we stopped doing it in meeting becasue we didnt think it was working
16:14:12 <dansmith> sean-k-mooney: 15% on nova are still bare, and a higher proportion are "recheck unrelated" so there's still work to do
16:14:13 <sean-k-mooney> we can go back to doing it
16:14:24 <bauzas> 16% is a bad value IMHO
16:14:38 <dansmith> bauzas: better than some projects for sure, but still work to do yeah
16:14:42 <bauzas> so I'll then discuss this every meeting
16:15:04 <sean-k-mooney> do we have the list of those because i dont think just callign it out here is going to have an impact
16:15:26 <bauzas> #action bauzas to tell about the bare rechecks every week in our meeting
16:15:43 <bauzas> sean-k-mooney: please look at the link above
16:15:50 <sean-k-mooney> i have the email open
16:16:25 <bauzas> we had 16 bare rechecks against 105 rechecks, so we have 15%
16:16:46 <sean-k-mooney> i might see if i can pull out the bare rehceck and see what there were
16:16:49 <bauzas> fwiw, I can find which changes have bare rechecks
16:16:57 <bauzas> this is quite simple
16:17:20 <bauzas> but I don't want to ping folks saying "dude, don't do it"
16:17:30 <sean-k-mooney> there are a few poepl that tend to only review +1
16:17:41 <sean-k-mooney> and i wonder if its the same subset that are blind rechecking
16:17:51 <sean-k-mooney> i did ask one person to stopp rechecking
16:18:01 <sean-k-mooney> becuase there was an actual issue
16:19:51 <sean-k-mooney> anyway lets move on we can chat about this after the meeting
16:20:20 <bauzas> okay
16:20:43 <bauzas> #topic Release Planning
16:20:47 <bauzas> #link https://releases.openstack.org/caracal/schedule.html#nova
16:20:50 <bauzas> #info RC1 delivered this morning
16:20:52 <bauzas> \œ/
16:21:06 <bauzas> #info master branch is now on Dalmatian
16:21:16 <elodilles> \o/
16:21:47 <bauzas> as a reminder, we won't accept backports for the caracal branch until GA unless they are regression fixes
16:22:20 <bauzas> ditto with other stable backports given you need to have it in Caracal too
16:22:39 <bauzas> (unless of course the backports are from a caracal merged change)
16:22:47 <elodilles> +1
16:23:08 <bauzas> #link https://etherpad.opendev.org/p/nova-caracal-rc-potential
16:23:26 <bauzas> I'll continue to provide this etherpad for the possible new Caracal RC tags
16:23:45 <bauzas> I just hope we won't find a regression
16:24:09 <bauzas> any question about RC phases or Dalmatian ?
16:25:22 <bauzas> looks not, moving on
16:25:48 <bauzas> #topic Review priorities
16:26:01 <bauzas> #action bauzas to provide a new etherpad for Dalmatian
16:26:13 <bauzas> for the moment, we don't have priorities
16:26:21 <bauzas> I'll start to look at some spec changes next week
16:26:40 <bauzas> #topic Stable Branches
16:26:43 <bauzas> elodilles: go for it
16:26:47 <elodilles> o/
16:26:50 <elodilles> #info stable/2024.1 branch is open for bugfix backports
16:27:01 <elodilles> of course as bauzas wrote: only rc critical
16:27:04 <elodilles> for this time
16:27:11 <elodilles> #info stable gates seem to be OK
16:27:45 <bauzas> cool
16:27:56 <elodilles> (as we discussed, there are jobs that fail intermittently :/)
16:28:05 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:28:33 <elodilles> that's it from me about stable branches
16:29:38 <bauzas> cool thanks
16:29:45 <bauzas> #topic vmwareapi 3rd-party CI efforts Highlights
16:29:47 <bauzas> fwiesel: ?
16:29:57 <fwiesel> #info CI comments on openstack/nova CR confirmed to be working.
16:30:06 <fwiesel> Best maybe seen here:
16:30:08 <fwiesel> #link https://review.opendev.org/dashboard/36571
16:30:32 <fwiesel> #info Fixed FIPs instability. Tests quite reproducible. Only one error left with all proposed patches applied.
16:30:54 <fwiesel> The issue and fix were in retrospect easy... we have now a working pipeline.
16:31:01 <bauzas> \o/
16:31:28 <fwiesel> Just with the new branches came in some instability, as it expects all service to actually have the branch.
16:32:00 <fwiesel> I.e. it fails now to check out stable/2024.1 for requirements, but we have it in nova. Not sure, if I should do something about that one.
16:32:14 <fwiesel> Missed that one:
16:32:15 <fwiesel> #link http://openstack-ci-logs.global.cloud.sap/sapcc-nova--nmllh/tempest.html
16:32:29 <fwiesel> The tempest test with the last open problem.
16:32:30 <elodilles> now ~everything should have branched (well, requirements, devstack and grenade will be created around end of week)
16:32:38 <bauzas> are you sure you use the requirements from the stable releases ?
16:32:55 <bauzas> fwiesel: awesome about where you are
16:33:32 <fwiesel> Missing now are hopefully only cleaning up the rough edges... A nicer UI with linkable lines we still are missing.
16:34:45 <bauzas> okay, anything else ?
16:34:52 <fwiesel> No, not from my side.
16:35:00 <fwiesel> Questions?
16:35:41 <fwiesel> One remark: A test run with fixes in place takes roughly 20minutes in total.
16:35:42 <bauzas> nope
16:35:51 <bauzas> wow
16:36:27 <fwiesel> bauzas: Back to you then
16:36:43 <bauzas> cool, that will be short
16:36:51 <bauzas> #topic Open discussion
16:36:55 <bauzas> anyuthing anyone ?
16:37:04 <dansmith> a tempest run takes 20 minutes? that would be shockingly fasty
16:37:52 <fwiesel> Well, it is a hefty machine, and I run it as parallel as I can.
16:38:19 <bauzas> ok guys, I think I can close the meeting
16:38:21 <bauzas> thanks all
16:38:23 <bauzas> #endmeeting