16:00:01 <bauzas> #startmeeting nova
16:00:01 <opendevmeet> Meeting started Tue Jul  5 16:00:01 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:01 <opendevmeet> The meeting name has been set to 'nova'
16:00:10 <bauzas> sean-k-mooney: sorry had to start the meeting
16:00:18 <bauzas> hello 'veryone
16:00:21 <gibi> o/
16:01:17 <elodilles> o/
16:01:43 <bauzas> as I said to gibi, I'll need to leave in 40 mins
16:01:52 <bauzas> so, I'll leave the chair to gibi
16:01:54 <bauzas> #chair gibi
16:01:54 <opendevmeet> Current chairs: bauzas gibi
16:02:21 <bauzas> maybe we should start
16:02:47 <bauzas> #topic Bugs (stuck/critical)
16:02:57 <bauzas> #info One Critical bug
16:03:02 <bauzas> #link https://bugs.launchpad.net/nova/+bug/1979047 Centos 9 Stream bug failure
16:03:19 <bauzas> that being said, the root cause seems to be fixed on C9S
16:03:38 <bauzas> now, we have a revert from gibi
16:03:41 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/848352 revert of the n-v job patch
16:03:56 <bauzas> for making the C9S job voting again
16:04:19 <bauzas> that being said, I have a concern I'd like to discuss with the team
16:04:59 <bauzas> https://bugzilla.redhat.com/show_bug.cgi?id=2092856 is the C9S BZ
16:05:15 <bauzas> if you look at it, it took about 3 weeks in order to be fixed
16:05:45 <bauzas> and released
16:05:53 <bauzas> now, my concern is about the job
16:06:17 <bauzas> given now Centos9 is a stream, that means that we can't just merge a fix without verifying it
16:06:23 <bauzas> we = RHEL team
16:07:16 <bauzas> so, here my concern : instead of voting again, should this job be a periodic-weekly one ?
16:07:36 <sean-k-mooney> well technially the centos core team could but rhel team will want it to go though qe first
16:07:49 <sean-k-mooney> im +1 on moving to periodic-weekly
16:08:02 <sean-k-mooney> i orginally did not want it to be voting this cycle
16:08:07 <bauzas> if we agree on it, I propose to look at the job by every week during our meeting, like we do for both placement and nova-emulation
16:08:08 <gibi> if we promise to look at it as part of our weekly agenda then I'm OK to move it to periodic
16:08:19 <sean-k-mooney> when i raised the topic at the ptg it was for ti to be nonvoting until at least m2
16:08:41 <bauzas> ok, any other thoughts ?
16:08:47 <gibi> this way we can detect breaking changes, but probably we wont detect race coditions, as there wont be enough runs for it
16:09:06 <bauzas> gibi: yeah
16:09:14 <sean-k-mooney> we can also put it in experimental
16:09:19 <sean-k-mooney> so we can trigger if we need too
16:09:31 <sean-k-mooney> but that runs more then we would like
16:09:32 <bauzas> gibi: what I'd also like is to find some C9S folks we could be pinging if we find an issue
16:09:38 <elodilles> sounds OK to be a periodic-weekly, we even free up some resource with that, right?
16:09:43 <sean-k-mooney> its too bad we can trigger periodics via a comment
16:09:57 <sean-k-mooney> elodilles: yes since it wont be per patch
16:10:04 <sean-k-mooney> but we can still review it regurally
16:10:05 <elodilles> ++
16:10:30 <bauzas> sean-k-mooney: yeah we could also have a experimental job if we want
16:10:31 <sean-k-mooney> if its perodic-weekly we might even be able to add more variants in the futre
16:10:45 <gibi> I'm fine loosing the race condition detection, so I'm OK to move it to periodic
16:11:09 <bauzas> ok, I don't see any argue
16:11:13 <bauzas> so...
16:11:49 <bauzas> #agreed moving the centos9s job to be a periodic-weekly job instead of voting for every change
16:12:13 <bauzas> #agreed bauzas to add this periodic job to our weekly meeting topic for the gate
16:12:33 <bauzas> #agreed we could add this job to the experimental pipeline
16:12:45 <bauzas> folks, ok ?
16:12:53 <bauzas> thanks gibi, sean-k-mooney and elodilles for your thoughts
16:13:21 <sean-k-mooney> its ok with me to move on
16:13:26 <gibi> let move on
16:13:28 <bauzas> k
16:13:34 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 10 new untriaged bugs (+2 since the last meeting)
16:13:50 <bauzas> eventually we only had 8 bugs last week :(
16:13:59 <bauzas> but eventually this week we had a lof of new ones
16:14:14 <bauzas> #link https://etherpad.opendev.org/p/nova-bug-triage-20220628
16:14:19 <bauzas> #link https://etherpad.opendev.org/p/nova-bug-triage-20220621
16:14:47 <bauzas> if people want, they can look at what I triaged
16:15:09 <bauzas> but I don't want to discuss one of them by now
16:15:22 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 27 open stories (+0 since the last meeting) in Storyboard for Placement
16:15:28 <bauzas> #info Add yourself in the team bug roster if you want to help https://etherpad.opendev.org/p/nova-bug-triage-roster
16:15:48 <bauzas> so, the next folk in the roster is artom
16:16:16 <bauzas> artom: can you be the next bug baton owner, or anyone else ?
16:17:46 <bauzas> mmm, looks like artom isn't around
16:17:59 <sean-k-mooney> that means we can give them more work to do right
16:18:04 <gibi> right :)
16:18:17 <bauzas> hah
16:18:18 <gibi> he had on PTO last week so he is well prepared ;)
16:18:28 <bauzas> I triaged for two weeks
16:18:33 <bauzas> I paid my duty :D
16:18:59 <elodilles> i'm not that efficient as others, and probably will be afk 1 day, but can try to have the baton
16:19:03 <bauzas> (well, actually I triaged every Yoga week, until gibi told we should have a triage team :) )
16:19:24 <gibi> I think we can convice artom to take it :)
16:19:35 <elodilles> gibi: that also works for me :)
16:19:36 <gibi> he is just probably busy with someting else right now
16:19:40 <bauzas> let me gently force artom to get the baton :)
16:19:50 <bauzas> not in a passive aggressive way
16:19:51 <gibi> lets but it on artom tentatively and we can re-think if he rejects it
16:19:57 <bauzas> but rather talking with him in French
16:20:38 <bauzas> cool
16:20:46 <bauzas> #info Next bug baton is passed to artom
16:20:53 <bauzas> moving on
16:20:55 <bauzas> #topic Gate status
16:21:00 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:21:17 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:21:21 <bauzas> #link https://zuul.opendev.org/t/openstack/builds?job_name=nova-emulation&pipeline=periodic-weekly&skip=0 Emulation periodic job runs
16:21:28 <bauzas> both weekly jobs run fine
16:21:46 * dansmith stumbles in late
16:22:03 <bauzas> #info Please look at the gate failures and file a bug report with the gate-failure tag.
16:22:08 <bauzas> #info STOP DOING BLIND RECHECKS aka. 'recheck' https://docs.openstack.org/project-team-guide/testing.html#how-to-handle-test-failures
16:22:14 <bauzas> oh, I forgot to add in the agenda
16:22:18 <bauzas> we have numbers
16:22:39 <bauzas> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029363.html
16:23:02 <bauzas> #undo
16:23:02 <opendevmeet> Removing item from minutes: #link https://lists.openstack.org/pipermail/openstack-discuss/2022-July/029363.html
16:23:06 <sean-k-mooney> ya nova was not too bad but there are still some
16:23:27 <bauzas> #link https://lists.openstack.org/pipermail/openstack-discuss/2022-June/029342.html
16:24:04 <bauzas> #info 57.75% of rechecks were without a reason, please refrain this wrong behaviour
16:24:12 <dansmith> ++
16:24:52 <bauzas> moving on
16:24:56 <bauzas> #topic Release Planning
16:25:00 <bauzas> #link https://releases.openstack.org/zed/schedule.html
16:25:05 <bauzas> #info Zed-2 is in 1.5 weeks
16:25:09 <bauzas> #info Spec review day today
16:25:18 <bauzas> well, this was actually a quiet review day
16:25:27 <bauzas> only 3 specs are currently open to reviews
16:25:36 <dansmith> I spent a lot of time on the ironic one,
16:25:43 <bauzas> dansmith: appreciated a lot
16:25:51 <dansmith> although I'm not sure I'd even call it a spec
16:25:52 <gibi> yeah the ironic one is the hard piece
16:26:05 <bauzas> dansmith: I tried to look at it and then I had to stop b/c I had to do bug triage
16:26:21 <bauzas> dansmith: we basically agreed on the fact this isn't purely a spec
16:26:27 <dansmith> it's really just brainstorming, so has nothing to do with the spec deadline, IMHO
16:26:38 <bauzas> it's a document trying to identify all the corner cases about the proposed implementation
16:26:42 <gibi> depending on an agreed solution we might need a real spec :)
16:26:45 <bauzas> dansmith: agreed
16:26:54 <bauzas> on the existing document
16:26:57 <gibi> but agreed to brainstorm first
16:27:06 <bauzas> I don't feel it's constrained by the spec approval freeze
16:27:14 <sean-k-mooney> yep i have not looked at it in a while but its on my todo list at the end
16:27:16 <sean-k-mooney> after the rest
16:27:29 <bauzas> but yeah, as gibi said, depending on the consensus we may achieve, this would require some design stage. Or not.
16:27:43 <dansmith> anything we do would need a spec I'm quite sure,
16:28:03 <dansmith> I'm just saying, there's no reason to spend time reviewing it instead of other specs before the deadline
16:28:06 <bauzas> I'll make clear on the gerrit change this one isn't impacted by our deadlines
16:28:15 <dansmith> I didn't really realize that until it was too late for me, but SAVE YOURSELVES
16:28:16 <dansmith> :P
16:28:26 <bauzas> dansmith: honestly, besides this one which is hairy, we only have two opens
16:28:32 <bauzas> one is about to be merged
16:28:33 <dansmith> I threw a -1 on it for visibility since all the others were just +0 comments
16:28:42 <bauzas> and the other one potentially misses resources to work one
16:28:44 <bauzas> on*
16:28:46 <dansmith> cool
16:29:05 <bauzas> so I just feel we can spend brain cycles on the rebalance issue
16:29:11 <dansmith> ack
16:29:14 <sean-k-mooney> since it was a braninstromign doc i just didn nto +/- since it did not have any singel proposal
16:29:32 <bauzas> sean-k-mooney: I'll clarify the purpose of this document in a gerrit comment
16:29:34 <sean-k-mooney> but yes ack on the -1
16:30:18 <dansmith> sean-k-mooney: yeah and that's fair, but someone could stumble in thinking it was needing review before the deadline with no other signaling :D
16:30:39 <bauzas> I'll send the signal
16:30:45 <dansmith> ++
16:30:56 <bauzas> ideally, I asked CERN folks to jab into it
16:31:05 <bauzas> but, this is just an ask
16:31:26 <bauzas> they're impacted by the rebalancing issue as they don't use the ironic feature
16:31:40 <sean-k-mooney> so in terms of other specs
16:31:42 <bauzas> so I'd also like to understand whether we could have a mitigation
16:31:54 <sean-k-mooney> im expecting artom to update theres later this week
16:32:05 <sean-k-mooney> and ill try and updte teh power managment one
16:32:11 <sean-k-mooney> but im aware both are late
16:32:13 <sean-k-mooney> and may slip
16:32:23 <bauzas> sean-k-mooney: I left a comment on artom's spec, there could be effort to spend on the EC2 compatible API
16:32:44 <sean-k-mooney> well ok but im not sure we care about ec2 compat
16:33:01 <bauzas> sean-k-mooney: maybe, but the spec was saying we were given ec2 compat for free
16:33:08 <bauzas> which isn't true
16:33:13 <sean-k-mooney> ack
16:33:39 <bauzas> for the power management spec, you still have one week to push it
16:33:57 <bauzas> given we lack of open specs, I could be able to quickly jump into it
16:33:58 <sean-k-mooney> main issue is reloading context i have not worked on it since febuary
16:34:02 <bauzas> me too
16:34:23 <bauzas> but, given Berlin, I think this would be a net win to have it in Nova
16:34:29 <sean-k-mooney> Uggla's spec i think is close it have one issue with it but it could be adressed in a followup
16:34:35 <bauzas> cool
16:34:42 <bauzas> let's wrap on the spec discussion
16:34:50 <bauzas> I'll need to leave the chair soon
16:34:55 <bauzas> and we can follow up tomorrow
16:35:03 <bauzas> #topic Review priorities
16:35:09 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:35:25 <bauzas> #link https://review.opendev.org/c/openstack/project-config/+/837595 Gerrit policy for Review-prio contributors flag. Waiting for approval
16:35:53 <bauzas> we should ping the project-config cores
16:36:05 <bauzas> #link https://docs.openstack.org/nova/latest/contributor/process.html#what-the-review-priority-label-in-gerrit-are-use-for Documentation we already have
16:36:16 <sean-k-mooney> i can do that after the meeting
16:36:20 <bauzas> thanks
16:36:31 <bauzas> #topic Stable Branches
16:36:34 <bauzas> elodilles: your time
16:36:43 <elodilles> #info stable nova releases are out: yoga (25.0.1), xena (24.1.1) and wallaby (24.1.1)
16:36:51 <elodilles> #info stable/train is blocked, fix exists but hasn't merged yet due to intermittent failures
16:37:05 <elodilles> #info stable branch status / gate failures tracking etherpad: https://etherpad.opendev.org/p/nova-stable-branch-ci
16:37:14 <elodilles> that's it, to be quick
16:37:37 <bauzas> thanks
16:38:02 <bauzas> elodilles: as again, don't be afraid of pinging me for reviews
16:38:06 <bauzas> #topic Open discussion
16:38:11 <bauzas> (bauzas) Team Sign-up for the next PTG
16:38:15 <bauzas> so, official ask
16:38:16 <gibi> yes please
16:38:23 <gibi> :)
16:38:31 <bauzas> should we have a PTG room ?
16:38:39 <bauzas> which would be physical this time ?
16:38:46 <bauzas> :)
16:38:47 <gibi> can we have a window on the room? :)
16:38:57 <bauzas> I don't know the logistics yet
16:39:16 <bauzas> I can imagine the Foundation asking the teams to be agile and proposing some remote live connection
16:39:23 <sean-k-mooney> i would be happy with one in dark basment if it has white bords
16:40:00 <sean-k-mooney> yes if we have an ok netowrk
16:40:04 <bauzas> there is a remarks/feedback field in the survey
16:40:05 <sean-k-mooney> we can likely have a remote stream too
16:40:07 <bauzas> https://openinfrafoundation.formstack.com/forms/oct2022_ptg_team_signup
16:40:13 <bauzas> I'll fill it up
16:40:22 <bauzas> but I could mention those two things
16:40:27 <gibi> to stream it we need mics and optional a camera
16:40:42 <sean-k-mooney> yep neutron have done that in the past
16:40:45 <bauzas> yeah and everytime we tried, this was a hard experience
16:41:10 <bauzas> I'll leave some notes
16:41:17 <bauzas> that's it for me, I need to leave
16:41:21 <gibi> bauzas: o/
16:41:28 <gibi> so we have one more thing on the agenda
16:41:29 <sean-k-mooney> it works fine for neutron as far as i can tell but they more have the stream so people can listen and then respond via etherpath/irc
16:41:31 <bauzas> I have another item to discuss but let's punt it for next week
16:41:35 <gibi> (bauzas) Opportunities for low-hanging-fruits, anyone ? (only if we have time left)
16:41:39 <gibi> ahh OK
16:41:41 <gibi> then it is punted
16:41:44 <bauzas> thanks
16:41:50 * bauzas rushes off
16:41:52 <gibi> does anyone here has an extra topic for today?
16:41:58 <bauzas> gibi: feel free to wrap the meeting
16:42:02 <gibi> bauzas: will do
16:42:10 <bauzas> ++
16:42:17 <sean-k-mooney> not really but i will think about low haning fruit for the next one
16:42:49 <gibi> OK, so if nothing else today then I will close the meeting
16:42:54 <gibi> thanks for all joining
16:42:58 <gibi> #endmeeting