16:00:27 <bauzas> #startmeeting nova
16:00:27 <opendevmeet> Meeting started Tue Jan  4 16:00:27 2022 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <opendevmeet> The meeting name has been set to 'nova'
16:01:37 <bauzas> #link https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
16:01:45 <ganso> o/
16:01:47 <bauzas> hi everyone and happy New Year
16:02:00 <gmann> o/
16:02:04 <gmann> happy new year
16:02:04 <artom> ~o~
16:02:12 <lyarwood> \o
16:02:25 <bauzas> ok let's start
16:02:28 <bauzas> #topic Bugs (stuck/critical)
16:02:34 <bauzas> #info No Critical bug
16:02:39 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New 33 new untriaged bugs (+9 since the last meeting)
16:02:43 <bauzas> #help Nova bug triage help is appreciated https://wiki.openstack.org/wiki/Nova/BugTriage
16:02:57 <bauzas> yeah, looks like some new bugs appeared when I was off :)
16:03:53 <bauzas> looking at some, it seems they can be closed
16:04:21 <bauzas> but I'll do my homework tomorrow
16:04:30 <bauzas> #link https://storyboard.openstack.org/#!/project/openstack/placement 25 open stories (+0 since the last meeting) in Storyboard for Placement
16:04:40 <bauzas> nothing to say about placement, it's winter then
16:04:42 <bauzas> there*
16:05:07 <bauzas> any bug to raise in particular, except gate issues ?
16:06:15 <bauzas> looks not, moving on
16:06:19 <bauzas> #topic Gate status
16:06:25 <bauzas> #link https://bugs.launchpad.net/nova/+bugs?field.tag=gate-failure Nova gate bugs
16:06:29 <bauzas> #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly Placement periodic job status
16:06:36 <bauzas> #info Please look at the gate failures, file a bug, and add an  elastic-recheck signature in the opendev/elastic-recheck repo (example: https://review.opendev.org/#/c/759967)
16:06:51 <bauzas> nothing new on the gate side
16:07:05 <bauzas> and the placement periodic jobs run fine
16:07:22 <bauzas> so I guess we can go to the next topic
16:07:40 <bauzas> unless someone wants to say something
16:08:31 <bauzas> guess no
16:08:39 <bauzas> #topic Release Planning
16:08:46 <bauzas> #info Yoga-2 is due Jan 6th
16:08:53 <bauzas> #link https://releases.openstack.org/yoga/schedule.html#y-2
16:09:33 <artom> That's spec freeze, yeah?
16:09:39 <bauzas> correct but,
16:09:47 <bauzas> that was my next question
16:10:00 <bauzas> do people want to punt the spec freeze until next week ?
16:10:09 <bauzas> gibi isn't around, melwitt as well
16:10:39 <bauzas> or, we can just accept some spec approval exceptions if needed
16:10:43 <sean-k-mooney> i think that makes sense
16:10:53 <sean-k-mooney> to move it to next week
16:10:57 <bauzas> lemme look at the number of open specs we have
16:11:23 <bauzas> #link https://review.opendev.org/q/project:openstack/nova-specs+is:open
16:11:52 <sean-k-mooney> we have ~10
16:12:05 <sean-k-mooney> although i do not expect all of them to be approved this cycle
16:12:08 <bauzas> looks like we have around 7 specs open for this cycle
16:12:43 <sean-k-mooney> that sound about right
16:12:53 <bauzas> we already have 11 accepted specs for this cycle
16:12:57 <bauzas> #link https://specs.openstack.org/openstack/nova-specs/specs/yoga/approved/
16:13:13 <sean-k-mooney> https://review.opendev.org/c/openstack/nova/+/821606 may need a spec unless we agree it shoudl be a specless blueprint or its too late to conisider this cycle
16:13:34 <bauzas> last cycle, we had 19 accepted specs
16:13:51 <bauzas> so, yeah, we can accept more open specs
16:14:01 <bauzas> sean-k-mooney: agreed
16:14:02 <sean-k-mooney> lightbitslabs are lookign to upstream there nova,cinder and os-brick driver
16:14:17 <sean-k-mooney> but im not sure we will get everthing inline by next week for it to happen this cycle
16:14:51 <bauzas> sean-k-mooney: at least we need to discuss this blueprint in a new meeting
16:15:02 <bauzas> and see whether we need a spec or not
16:15:36 <bauzas> ok, do people have concerns if we punt the spec freeze to Jan 13st ?
16:15:38 <artom> sean-k-mooney, kinda off-topic, but they better have solid future-rpoof CI
16:16:16 <sean-k-mooney> they have some downstream ci and said they were workign on a third party ci
16:16:26 <sean-k-mooney> but ya those are the kind fo thing we woudl need to work out
16:16:43 <bauzas> this will mean that we will only have 6 weeks between spec freeze and feature freeze, but I don't think it's a problem
16:16:57 <bauzas> if we accept to punt the spec freeze to next week
16:17:03 <bauzas> any concerns ?
16:17:21 <bauzas> 1...
16:17:23 <bauzas> 2...
16:17:27 <bauzas> 3...
16:17:27 <sean-k-mooney> i would suggest punting to next week but plan to not have excptions
16:17:32 <bauzas> accepted
16:18:16 <bauzas> #agreed Nova Spec freeze is moved to Jan 13st but after this limit, we won't accept exceptions
16:18:30 <bauzas> I'll write a ML email about it
16:18:34 <sean-k-mooney> ++
16:18:46 <bauzas> moving on
16:18:54 <bauzas> #topic Review priorities
16:19:02 <bauzas> #link https://review.opendev.org/q/status:open+(project:openstack/nova+OR+project:openstack/placement+OR+project:openstack/os-traits+OR+project:openstack/os-resource-classes+OR+project:openstack/os-vif+OR+project:openstack/python-novaclient+OR+project:openstack/osc-placement)+label:Review-Priority%252B1
16:19:07 <bauzas> waaah, this link became large
16:20:06 <gmann> mine are easy one, yoga testing runtime
16:20:21 <bauzas> sean-k-mooney: you marked a few os-vif and os-traits changes as priority but they are still open after 3 months, do you want to remove the label ?
16:20:30 <bauzas> gmann: good point, I'll review it
16:20:52 <gmann> thx
16:21:14 <sean-k-mooney> bauzas: just looking at them now
16:21:21 <sean-k-mooney> i think i did that because i wanted other to review
16:21:27 <bauzas> sean-k-mooney: the changes in question are https://review.opendev.org/c/openstack/os-vif/+/765912 https://review.opendev.org/c/openstack/os-vif/+/765970 and https://review.opendev.org/c/openstack/os-traits/+/786999
16:22:22 <sean-k-mooney> ill review them again today and see where they are
16:22:46 <bauzas> thanks
16:23:24 <bauzas> sean-k-mooney: I'm half present this week for good reasons (/me looks at Uggla ;) ) , but please ping me if you want me to review them
16:23:59 <sean-k-mooney> the os vif one s are train backports the os-traits on need a respin
16:24:11 <bauzas> oh
16:24:24 <bauzas> ok, let's skip this and revisit it tomorrow then
16:24:31 <bauzas> #link https://review.opendev.org/c/openstack/nova/+/816861 bauzas proposing a documentation change for helping contributors to ask for reviews, needs a second +2
16:24:58 <bauzas> we have two approvals already, thanks gmann and gibi
16:25:13 <bauzas> gmann had good concerns, will provide a FUP
16:25:41 <bauzas> #topic Stable Branches
16:25:56 <bauzas> elodilles said he won't be around for this meeting
16:26:12 <bauzas> but I guess the updates are the same from last meeting
16:26:18 <bauzas> which were
16:26:19 <bauzas> stable gates are not blocked
16:26:24 <bauzas> though on some branches (wallaby, victoria?) we need many rechecks to be able to merge patches
16:26:30 * bauzas loves copy/paste
16:27:06 <bauzas> unless someone saw something popping up on the stable gates, I guess we can move on
16:28:49 <bauzas> finishing up
16:28:51 <bauzas> #topic Sub/related team Highlights
16:28:56 <bauzas> Libvirt (lyarwood)
16:29:14 <bauzas> well, I guess there was no activity during the last weeks
16:29:31 <lyarwood> Nope nothing
16:29:41 <bauzas> #topic Open discussion
16:29:41 <lyarwood> and as discussed before the break we need someone else to take this section forward or drop it
16:29:57 <bauzas> I think someone stepped up :)
16:30:53 <bauzas> actually, my brain is fucked
16:30:59 <bauzas> https://meetings.opendev.org/meetings/nova/2021/nova.2021-12-07-16.00.log.html#l-162
16:31:08 <bauzas> I guess we will demote this gang
16:32:16 <bauzas> #action bauzas to officially remove the libvirt subteam topic from the nova meeting
16:32:21 <bauzas> voila
16:32:38 <bauzas> at anytime, someone can step up if he/she wishes
16:32:51 <bauzas> last topic
16:33:00 <bauzas> #topic Open discussion
16:33:04 <bauzas> (ganso) Raising awareness before Freeze: https://review.opendev.org/q/topic:%22bp%2Fmultiqueue-flavor-extra-spec%22%20(status:open%20OR%20status:merged)
16:33:08 <ganso> o/
16:33:33 <bauzas> ganso: you probably were confused by our internal milestone namings
16:33:54 <ganso> so, as the title says, just raising awareness. I know it is not super important to be among the review priority items, and most reviewers are focused on spec review which has an earlier deadline, but just raising some awareness. I am not aware of any pending items, so it is just waiting for reviews
16:33:59 <bauzas> in 2 days, we were about to no longer accept specs to be appoved
16:34:16 <ganso> bauzas: I actually meant feature freeze, sorry, I wasn't clear which freeze it was
16:34:27 <bauzas> but approved bps and specs can have their code merged until yoga-3 which is in 7 weeks
16:34:46 <bauzas> ganso: no worries, our namings are somehow confusing
16:34:59 <bauzas> this is a design gate, not an implementation freeze
16:35:18 <bauzas> feature implementation freeze will happen in 7 weeks
16:35:32 <ganso> thanks!
16:35:34 <bauzas> at yoga-3 time
16:35:40 <bauzas> no worries
16:36:25 <bauzas> for the audience, https://blueprints.launchpad.net/nova/+spec/multiqueue-flavor-extra-spec is already approved as a specless BP
16:36:40 <sean-k-mooney> ya i think this is not contovertial
16:36:42 <bauzas> btw. stephenfin was marked as owner
16:36:52 <bauzas> ganso: would you mind if I put you as an assignee ?
16:37:04 <sean-k-mooney> i think there is a good change we can land this in the next few weeks
16:37:07 <ganso> bauzas: sure
16:37:33 <sean-k-mooney> this is the minimal change https://review.opendev.org/c/openstack/nova/+/792356
16:37:34 <bauzas> ganso: just to be sure, what's your Launchpad ID ?
16:37:42 <sean-k-mooney> and then the rest are docs update and some clean up
16:37:43 <ganso> bauzas: rodrigo-barbieri2010
16:37:55 <bauzas> ganso: ta, noted, will change the ownership
16:38:24 <ganso> bauzas: thanks!
16:38:31 <bauzas> last imra
16:38:37 <bauzas> oh damn fingers
16:38:40 <bauzas> last item
16:39:01 <bauzas> (bauzas) please welcome Uggla as a new Nova contributor :)
16:39:28 <ganso> Uggla: welcome!
16:39:38 <Uggla> :) thx
16:40:00 <artom> Uggla, you'll have to explain the nick :P
16:40:34 <bauzas> does it require hallways and beers ?
16:40:59 <Uggla> artom, the only word of swedish I know Uggla --> owl (thanks Ikea)
16:41:51 <bauzas> I pretend to have most of the Ikea products at home, but I never heard this :p
16:42:03 <bauzas> anyway, welcome
16:42:04 <artom> Huh, so the French "how are you" ("ca va?") phonetically sounds like the Russian for "owl" ("sava" - "сова")
16:42:30 <artom> Which means there's some Illuminati mystery going on here
16:42:33 <bauzas> :)
16:42:34 <Uggla> bauzas, I will send you a picture.
16:42:45 <bauzas> anyway, ending the meeting
16:42:47 <bauzas> thanks all
16:43:05 <sean-k-mooney> https://www.ikea.com/ie/en/p/vandring-uggla-glove-puppet-50216093/
16:43:06 <gmann> thanks
16:43:08 <bauzas> and happy 2022 again (hopefully with physical events this year)
16:43:11 <bauzas> #endmeeting