16:00:15 <gibi> #startmeeting nova
16:00:16 <openstack> Meeting started Thu May 20 16:00:15 2021 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'nova'
16:00:21 <gibi> \o
16:00:27 <stephenfin> o/
16:00:30 <lyarwood> \o
16:00:37 <bauzas> \o
16:00:44 <artom> ~o~
16:00:52 <elod> o/
16:01:44 <gibi> lets roll
16:01:46 <gibi> #topic Bugs (stuck/critical)
16:02:01 <gibi> no critical bugs
16:02:06 <gibi> 8 new untriaged bugs (-4 since the last meeting): #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
16:02:18 <gibi> triage backlog looks healthy
16:02:28 <gibi> is there any bug we need to discuss?
16:03:15 <gibi> good
16:03:16 <gibi> :)
16:03:16 <gmann> o/
16:03:20 <gibi> gmann: o/
16:03:22 <gibi> #topic Gate status
16:03:27 <gibi> Placement periodic job status #link https://zuul.openstack.org/builds?project=openstack%2Fplacement&pipeline=periodic-weekly
16:03:32 <gibi> placement periodic seems green
16:03:45 <bauzas> huzzah
16:03:50 <gibi> also I saw things merging to master
16:03:59 <gibi> so the master gate should be in an OK state
16:04:20 <gibi> is there any gate issue we need attention?
16:05:28 <gibi> #topic Release Planning
16:05:39 <gibi> Milestone 1 is 27th of May, which is next week
16:05:45 <gibi> I proposed a spec review day for 25th of May, next Tuesday. #link http://lists.openstack.org/pipermail/openstack-discuss/2021-May/022436.html
16:06:02 <gibi> shout please if the date is not good for you
16:06:07 <bauzas> lgtm
16:06:28 * bauzas needs to create a new spec
16:06:52 * stephenfin too
16:07:11 <gibi> any other release releated topic to discuss?
16:07:44 * gmann too
16:07:56 <gibi> gmann, bauzas, stephenfin: can we merge the existing ones first please? (joking)
16:08:14 <stephenfin> no.
16:08:17 * stephenfin has spoken
16:08:19 <stephenfin> ;)
16:08:19 <gmann> :)
16:08:21 <gibi> :D
16:08:32 <gibi> then moving o
16:08:33 <gibi> n
16:08:39 <gibi> #topic Stable Branches
16:08:45 <gibi> copying elod's notes
16:08:50 <gibi> "final train release" is out (20.6.1) - train-em patch is updated and ready for review & merge ( https://review.opendev.org/790761 )
16:08:55 <gibi> rocky / queens / pike blocked, due to grenade job failure, workaround proposed in devstack ( https://review.opendev.org/791246 )
16:09:00 <gibi> however wallaby..stein is not blocked, there are too many random failure: no merge happened in the last ~ two weeks... needs investigation
16:09:09 <gibi> EOM
16:09:36 <gmann> I pinged another devstack core for https://review.opendev.org/c/openstack/devstack/+/791246/
16:09:36 <stephenfin> once those are merged, we should fixup the release notes
16:09:50 <stephenfin> and squash them for the eol releases
16:09:52 <elod> gmann: thanks!
16:10:13 * stephenfin will try find time to do that and reap the faster build time rewards
16:10:40 <lyarwood> gmann: https://review.opendev.org/c/openstack/devstack/+/792108 is also an issue on stable/wallaby FWIW
16:11:07 <lyarwood> and I'd really like to get the device detach stuff landed on wallaby as we are still seeing failures with the old logic there
16:11:11 <gmann> lyarwood: ack, will check thi9s
16:11:29 <gibi> lyarwood: I'm kicking the recheck button on the detach one
16:11:46 <lyarwood> gibi: ack I'll try to spend more time on stable next week
16:11:54 <gibi> thank you all.
16:12:27 <gibi> if you see failures that are also on master (use the logstash while we still have it) then let me know and I will try to spend some time on them
16:12:54 <gibi> anything else about stable?
16:13:20 <elod> nothing from me :X
16:14:04 <gibi> #topic Sub/related team Highlights
16:14:08 <gibi> Libvirt (bauzas)
16:16:13 <stephenfin> I'm guessing bauzas has gone afk
16:16:25 <gibi> ok
16:16:27 <gibi> moving on
16:16:30 <gibi> #topic Open discussion
16:16:34 <gibi> (artom) Follow up on the IRC meeting schedule change.
16:16:42 <gibi> thanks artom for the poll
16:16:52 <gibi> it seems we have two possible slots on Tuesday
16:16:57 * stephenfin has an item here that wasn't on the agenda in time and will pipe up later
16:17:23 <gibi> stephenfin: ack
16:17:29 <bauzas> whoops, sorry was otp
16:17:33 <bauzas> nothing to report, sir.
16:17:37 <gibi> bauzas: ack thanks
16:17:39 <bauzas> (this ran fast)
16:17:54 <gibi> so for the meeting
16:18:04 <gibi> Tuesday from 15:00 UTC of from 16:00 UTC
16:18:21 * bauzas nods
16:18:32 <gibi> everybody was happy with both slot
16:18:44 <bauzas> use your stick
16:18:59 <gibi> then it is 15:00 UTC so I get off earlier :)
16:19:06 <artom> So the earlier one is 7:00 for dansmith and melwitt
16:19:14 <artom> Ah, no, 8:00
16:19:20 <artom> 11 - 3 is 8, not 7
16:19:43 <bauzas> correct, but it's 7am for 2 weeks AFAICR
16:19:48 <bauzas> every 6 months
16:20:00 <gibi> hm, that still means 7 during the winter, isnt it?
16:20:23 <gmann> yeah
16:20:39 <bauzas> 4pm for me in winter means 7am for west coast folks, indeed
16:20:41 <artom> Yeah, with the meeting pinned to UTC we go from -4 to -5 during winter here on the East coast
16:20:53 <artom> So it'd go from 8:00 to 7:00 for the folks on NA west coast
16:21:04 <bauzas> or ask them to move to France
16:21:05 <bauzas> ?
16:21:13 <bauzas> I'm sure dansmith would appreciate the relocation
16:21:29 * dansmith is double booked ... again :)
16:21:42 <bauzas> no worries, we just said you have to move
16:21:49 <gibi> dansmith: is it UTC 15:00 or UTC 16:00 on Tuesday is better for you for the weekly meeting?
16:22:01 <bauzas> but... no kidding, we can do 1600, this sounds better
16:22:09 <dansmith> it's okay, won't work when DST ends,
16:22:11 <dansmith> but okay for now
16:22:17 <bauzas> and less invasive, as we usually took this slot on Thursdays
16:22:28 <gmann> yeah after DST it will be 1 hr early
16:22:41 <bauzas> so it would only be a straight 48 hours move
16:22:45 <gibi> OK, then let's have it from 16:00 UTC on Thuesday
16:22:52 <gibi> any last words?
16:23:01 <gibi> on the meeting time :)
16:23:11 <gmann> nothing
16:23:13 <bauzas> maybe we could run office hours as asked by some contributors ?
16:23:19 <gibi> #action gibi to move the meeting slot to Tuesday 16:00 UTC
16:23:36 <bauzas> like, I can reasonably assess to be around on 0800 UTC every week
16:23:37 <gibi> bauzas: yes, I offered multiple option on the ML to the dev from China, but no response yet
16:24:03 <bauzas> my dog will just have to pee earlier on winter
16:24:09 <gibi> I'm also happy to run formal meeting during one of the mornings one a month if that is usefull
16:24:23 <gibi> s/one/once/
16:24:34 <bauzas> well, maybe not 'official' meetings
16:24:42 <bauzas> but some kind of recorded office hours
16:25:04 <bauzas> and people could use this slot for reaching the nova community
16:25:22 <bauzas> no official decisions be made tho
16:25:40 <bauzas> hence the 'office hours' terminology
16:25:45 <bauzas> best of both worlds
16:26:02 <gibi> bauzas: you are right we need keep the decision in this slot
16:26:09 <gibi> where we have corum
16:26:23 <bauzas> quorum* but yeah :)
16:26:31 <gibi> that one yes
16:26:38 <gibi> my greek is bad :D
16:26:57 <bauzas> mine is just one word better than yours :p
16:27:08 <gibi> ok moving on
16:27:11 <bauzas> okay, sold
16:27:15 <gibi> stephenfin: you wanted to say something
16:27:51 <stephenfin> yup, looking for specless BP approval
16:28:07 <gibi> do you have a link ?:)
16:28:10 <stephenfin> https://review.opendev.org/c/openstack/nova/+/792356/2
16:28:16 <stephenfin> sorry, had to grab it
16:28:23 <stephenfin> and BP is here
16:28:53 <stephenfin> https://blueprints.launchpad.net/nova/+spec/multiqueue-flavor-extra-spec
16:29:06 <gibi> so it is a new flavor extra_spec
16:29:13 <stephenfin> yup
16:29:16 <gibi> for me this sounds OK
16:29:19 <gibi> any objections?
16:29:20 <stephenfin> we provide a way to enable multiqueue via image metadata props
16:29:43 <stephenfin> I'd like to extend that to the flavor. Patch is trivial and it helps operators (no need to rebuild)
16:29:48 * bauzas looks at the spec
16:29:56 <bauzas> well, the bP
16:30:08 <bauzas> ah lol
16:30:17 <stephenfin> bauzas: the patch is better - that's where I have it explained https://review.opendev.org/c/openstack/nova/+/792356/2
16:30:23 <stephenfin> I can copy paste that to the BP also :)
16:30:32 <bauzas> I think we said in the past that extra specs don't really need a spec, but there are things we need to consider
16:31:03 <bauzas> since we now have validation, would that mean a difference on the api side ?
16:31:15 <stephenfin> There's nothing really new here. We already allow this to be configured via image metadata property
16:31:29 <stephenfin> Yes, I've added a validator for that
16:31:32 <bauzas> (in the past, as those weren't constrained, we were free to add as much as we wanted, without care)
16:31:42 <artom> stephenfin, wait, did we consider the resize case?
16:31:55 <stephenfin> artom: wdym?
16:32:05 <bauzas> stephenfin: I'm not an API specialist, but would this validator make a different experience between two clouds ?
16:32:10 <artom> 'cuz now you can resize to/from that extra spec
16:32:11 <bauzas> gmann: thoughts on interop ?
16:32:24 <stephenfin> bauzas: yeah, we've discussed that quite a few times before. Extra specs aren't part of the microversion
16:32:25 <artom> stephenfin, just... if there are any implications
16:32:30 * stephenfin should write this down somewhere
16:32:49 <bauzas> stephenfin: yeah, that's the point I recall
16:33:32 <bauzas> we decided that the same flavor on two clouds getting two different return codes for the same instance isn't a problem and doesn't require some signal
16:33:43 <bauzas> and I'm OK with this
16:34:23 <dansmith> bauzas: gibi: sorry for the late reply, I was on the other meeting that conflicts with this now. My TZ math was off, even 1500UTC works for me in non-DST, so I'm good with either on tuesday and can move my conflict that is there easily enough
16:34:26 <stephenfin> bauzas: yeah, there's already massive interop things with flavors. For example, different virt drivers support different things or treat the same spec differently
16:34:35 <stephenfin> so we've chosen to ignore that
16:34:49 <gibi> dansmith: ack, thanks. we go with 16:00 UTC
16:34:55 <dansmith> cool
16:35:05 <bauzas> stephenfin: we discussed this when we introduced the extra spec validation framework but I wanted to speak here loud
16:35:05 <stephenfin> artom: as for implications, the only one I'm aware of is that (I think) you'd need to use ethtool to configure the number of queues in the guest
16:35:52 <stephenfin> I don't think that's done/doable by default, but sean-k-mooney can correct me
16:35:56 <stephenfin> or would if they were here
16:35:57 <gmann> bauzas: stephenfin right. that is what we already have in existing extra specs so it is not new from interop side too
16:36:19 <gibi> stephenfin: so we allow resizing in both direction off -> on and on -> off. This is fine with me
16:36:33 <stephenfin> yup
16:36:43 <gibi> the same thing could happened already with rebuild to new image
16:36:48 <stephenfin> also yup
16:37:09 <stephenfin> (fwiw, I seriously doubt people will ever go on -> off, mind you - multiqueue is nearly always the thing you'd want nowadays)
16:37:35 <stephenfin> I'm trying to document that but artom is being (correctly) annoying :P
16:37:57 <artom> \o/
16:38:06 <gibi> any objection before I approve this specless bp?
16:38:31 <bauzas> nope.
16:38:49 <gibi> then it is approved
16:39:10 <gibi> stephenfin: please add the bp link to the commit message of the implementation
16:39:20 <stephenfin> ack, will do
16:39:30 <stephenfin> and thanks
16:39:55 <gibi> any other topic for today/
16:39:55 <gibi> ?
16:41:03 <gibi> if nothing else then I go an play with the meeting schedule to move our meeting
16:41:24 <gibi> I will drop a mail to the ML
16:41:29 <gibi> o/
16:41:33 <stephenfin> o/
16:41:35 <elod> o/
16:42:05 <gibi> #endmeeting