16:00:15 <gibi> #startmeeting nova
16:00:16 <openstack> Meeting started Thu Nov  5 16:00:15 2020 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:20 <openstack> The meeting name has been set to 'nova'
16:00:26 <gibi> o/
16:01:01 <dansmith> o/
16:01:16 <elod> o/
16:01:30 <bauzas> \o
16:01:48 <gibi> #topic Bugs (stuck/critical)
16:01:55 <gibi> we have on critical bug
16:01:59 <gibi> #link https://bugs.launchpad.net/nova/+bug/1902925
16:02:00 <openstack> Launchpad bug 1902925 in OpenStack Compute (nova) "Upgrades to compute RPC API 5.12 are broken" [Critical,In progress] - Assigned to Sylvain Bauza (sylvain-bauza)
16:02:04 <gibi> fix is up # link https://review.opendev.org/#/c/761458/
16:02:08 <dansmith> I just +Wd
16:02:15 <dansmith> really nice catch by bauzas
16:02:20 <gibi> we will need a victoria point release once the fix merged to stable/victoria
16:02:47 <bauzas> will be providing the stable changes once it's merged
16:03:04 <gibi> as we discussed on #openstack-nova we need to be more careful about reviewing RPC changes in the future
16:03:37 <gibi> anything else about this bug?
16:04:03 <bauzas> nope, let's discuss if people wish on how we could avoid it in the future
16:04:20 <bauzas> at least by requiring functional tests that would set the rpc pins
16:04:33 <bauzas> but moving on for now
16:04:34 <gibi> I
16:04:39 <gibi> OK
16:04:46 <gibi> #link 10 new untriaged bugs (+3 since the last meeting): #link https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
16:05:04 <gibi> this number is slowly growing
16:05:12 <gibi> I blame the summit and PTG weeks
16:05:14 <gibi> :)
16:05:43 <gibi> as we discussed on the PTG I addedd extra bug queriest to the agenda
16:05:49 <gibi> #link 19 bugs in fix-commited state (+0 since last meeting): #link https://bugs.launchpad.net/nova/+bugs?field.searchtext=&search=Search&field.status%3Alist=FIXCOMMITTED
16:06:06 <gibi> these bugs seems to be in invalid state, they should be in fix-released state
16:06:07 <dansmith> there is an obvious fix here,
16:06:14 <dansmith> disable the bug tracker during PTG and summit weeks.
16:06:23 <gibi> dansmith: seconded :D
16:06:35 <dansmith> :P
16:06:57 <gibi> I will go through this 19 bugs and move them to fix-released
16:07:15 <gibi> another query
16:07:16 <gibi> #link 72 bugs are in INPROGRESS state without any tag: #link https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=INPROGRESS
16:07:30 <gibi> these are potentially untriaged bugs
16:07:37 <bauzas> yup
16:07:43 <bauzas> certainly they are
16:07:45 <gibi> we could check them to see if they are valid
16:07:51 <bauzas> I can take it
16:07:56 <gibi> bauzas: thanks!
16:08:38 <gibi> if you have other bug query idea just plug it on the agenda and I will start to follow it when I update the agenda for the next meeting
16:09:23 <gibi> any other bug to talk abou?
16:10:41 <gibi> then a new permanent agenda topic based on the PTG
16:10:42 <gibi> #topic Gate status
16:10:56 <gibi> 15 (+0 since the last meeting) unclassified gate failures, classification rate 46% (+0 since the last meeting) #link http://status.openstack.org/elastic-recheck/data/integrated_gate.html
16:11:13 <gibi> Please look at the gate failures, file a bug, and add an elastic-recheck signature in the opendev/elastic-recheck repo (example: #link https://review.opendev.org/#/c/759967)
16:11:36 <gibi> I have one failure I want to highlight here
16:11:59 <gibi> https://bugs.launchpad.net/nova/+bug/1902696
16:12:00 <openstack> Launchpad bug 1902696 in oslo.messaging "nova-compute fails with Unhandled error: TypeError: _wrap_socket_sni() got an unexpected keyword argument 'ca_certs'" [Undecided,New]
16:12:11 <gibi> it is visible in kolla jobs
16:12:30 <gibi> as I guess our jobs are not using ssl for RPC
16:13:08 <gibi> there is a workaround requirement pin patch #link https://review.opendev.org/#/c/761194/
16:14:01 <gibi> melwitt: reported another gate failure on the ML http://lists.openstack.org/pipermail/openstack-discuss/2020-November/018543.html
16:14:25 <gibi> #link https://bugs.launchpad.net/devstack/+bug/1902002
16:14:27 <openstack> Launchpad bug 1902002 in devstack "Fail to get default route device in CI jobs" [Medium,In progress] - Assigned to Nate Johnston (nate-johnston)
16:14:41 <gibi> fix has been proposed here #link https://review.opendev.org/#/c/761178/
16:15:11 <gibi> any other gate issue we should aware of?
16:17:44 <gibi> then moving on
16:17:53 <gibi> #topic Release Planning
16:17:59 <gibi> Wallaby Milestone 1 is on 3rd of December, which is 4 weeks from now
16:18:12 <gibi> We should focus on updating / reviewing spec based on the PTG discussions
16:19:09 <gibi> any other release specific topic to discuss?
16:19:14 <bauzas> and maybe do a specs review day ?
16:19:29 <bauzas> like in 2 weeks from now ?
16:19:52 <gibi> good ida
16:19:53 <bauzas> we would be half term from FF, a reasonable amount of time left for implementing
16:19:54 <gibi> idea
16:20:39 <gibi> #action gibi to propose an spec review day for somewhere in the week starting at 16th of Nov
16:21:40 <gibi> #topic Stable Branches
16:21:54 <gibi> elod left some info on the agenda
16:22:11 <gibi> the number of patches in stable branches, that are waiting for review, is growing
16:22:25 <gibi> final release for Stein before the transition to Extended Maintenance -- https://review.opendev.org/#/c/761614/
16:22:37 <gibi> also it's a good time to release on newer branches -- https://review.opendev.org/#/q/project:openstack/releases+is:open+intopic:nova
16:22:42 <bauzas> ack, on my tasks then
16:22:42 <gibi> (in case of victoria release, wait for bugfix of bug/1902925 to land first)
16:22:52 <gibi> EOM
16:23:34 <gibi> I will look at the Stein release patch tomorrow
16:23:35 <elod> so, stein EM transition deadline is next Wednesday
16:24:13 <elod> if anyone see any patch that would be good to land in Stein before the final release happens, this is the last occasion :)
16:24:51 <elod> otherwise i think we are good
16:25:35 <gibi> the moving forward
16:25:37 <gibi> #topic Sub/related team Highlights
16:25:44 <gibi> API (gmann)
16:27:49 <gibi> Libvirt (bauzas)
16:27:57 <bauzas> hmmmm
16:28:06 <bauzas> haven't prepared it
16:28:24 <bauzas> well, afair, nothing to report
16:28:31 <bauzas> s/o else wants to raise ?
16:30:58 <gibi> moving on then
16:30:59 <gibi> #topic Open discussion
16:31:07 <gibi> I have two items here
16:31:14 <gibi> (gibi): we said on the PTG that the cyborg bp https://blueprints.launchpad.net/nova/+spec/cyborg-shelve-and-unshelve is OK but we thought at that time that this is spec re-propose. It is actually a specless bp that we approved for Victoria. Are we OK to approve it to Wallaby?
16:31:31 <gibi> ready to review implementation patch: #link https://review.opendev.org/#/c/729563/
16:32:57 <bauzas> this time, the RPC changes look good :p
16:33:11 <gibi> and sure we will ask for a func test :)
16:33:42 <bauzas> well, if we said specless for evacuate, I can't see how we could say "spec!" for shelve
16:34:30 <gibi> yeah. I wanted to bring it up to clarify the missunderstanding from the PTG
16:34:42 <bauzas> except the RPC changes, I don't see any DB changes ?
16:34:42 <gibi> so if no objection then I will approve it for wallaby
16:34:55 <gibi> bauzas: no db change as far as I understand
16:34:55 <bauzas> and the API is just removing a 40x ?
16:35:11 <bauzas> hence no microversion asked ?
16:35:46 <bauzas> if so, we have our answer
16:36:25 <gibi> no new microversion
16:36:33 <gibi> and I don't here any objection
16:36:39 <gibi> so I will approve it after the meeting
16:36:57 <bauzas> we're returning an extra 403 instead of a 409, but that's OK to me
16:37:08 <bauzas> so yeah, no microversion hence no spec
16:37:36 <gibi> OK
16:37:42 <gibi> the next one is a bit similar
16:37:43 <gibi> (gibi) there is another specless bp from cyborg https://blueprints.launchpad.net/nova/+spec/cyborg-suspend-and-resume this is a new one. Are we OK to approve the bp to Wallaby?
16:37:54 <gibi> WIP patch: #link https://review.opendev.org/#/c/729945/
16:38:31 <gibi> it has basically the same impacts as the previous one
16:38:43 <gibi> RPC bump, no API microversion
16:39:34 <gibi> the manager side RPC handlers have a new, optional, param
16:40:27 <gibi> if no objection then I will approve this as well as a specless bp for W
16:41:01 * bauzas rolls eyes :)
16:41:21 <gibi> I don't see any objections
16:41:28 <gibi> so I will do the paperwork after the meeting
16:41:35 <gibi> any other topic for today?
16:42:24 <gibi> then thanks for joining today
16:43:03 <gibi> #endmeeting