16:00:24 <gibi> #startmeeting nova
16:00:24 <openstack> Meeting started Thu Jul 16 16:00:24 2020 UTC and is due to finish in 60 minutes.  The chair is gibi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:27 <openstack> The meeting name has been set to 'nova'
16:00:31 <gibi> o/
16:00:38 <dansmith> o/
16:00:51 <stephenfin> o/
16:01:54 <dansmith> well, plenty of room for social distancing in this meeting!
16:01:59 <gibi> it seems
16:02:10 <gibi> but then we can be quick
16:02:14 <dansmith> yes please :)
16:02:17 <gibi> #topic Bugs (stuck/critical)
16:02:22 <gibi> No Critical bugs
16:02:28 <gibi> #link 34 new untriaged bugs (+6 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
16:02:32 <gibi> please look at the untriaged bug list and try to push some bugs forward
16:02:41 <gibi> I'm also guilty this week not looking at bugs
16:03:10 <gibi> is there any bug we need to talk about?
16:03:33 <gibi> #topic Runways
16:03:37 <gibi> etherpad #link https://etherpad.opendev.org/p/nova-runways-victoria
16:03:42 <gibi> he bp/add-emulated-virtual-tpm was removed from a slot
16:03:49 <gibi> the bp/use-pcpu-and-vcpu-in-one-instance made good progress so I extended the slot by a week
16:04:00 <gibi> the bp/provider-config-file did not get feedback during this week, it still has a week in the slot
16:04:06 <gibi> the cyborg patches #link https://review.opendev.org/#/q/(topic:bp/nova-cyborg-interaction+OR+topic:bp/cyborg-rebuild-and-evacuate)+status:open did not get feedback during this week, it still has a week in the slot
16:04:15 <gibi> so this is not the greates week for runway itmes
16:04:17 <gibi> item
16:04:18 <gibi> s
16:04:26 <gibi> I'm blaming the summer
16:04:28 <dansmith> I have been focusing on glance/rbd things,
16:04:46 <dansmith> and neglecting others, but that's winding down so hope to jump on things like the cyborg patches at least
16:04:59 <gibi> cool
16:05:19 <gibi> I also promised review both on cyborg and provider config
16:05:39 <gibi> any other things related to runways?
16:06:21 <gibi> #topic Release Planning
16:06:26 <gibi> 2 weeks until Victoria M2 which will be a spec freeze
16:06:40 <gibi> bauzas raised the question to have a spec review day
16:06:59 <gibi> we don't have much open so it is pretty cheap to dedicate a day
16:07:15 <gibi> what about next week Tuesday as a spec review day?
16:07:25 <stephenfin> wfm
16:07:29 <gibi> if no objection then I will post on the ML tomorrow
16:08:01 <gibi> #action gibi to post the review day on the ML
16:08:24 <gibi> I will be PTO during the week of M2 so I need a volunteer to be my stand in
16:08:39 <gibi> bauzas is also on PTO at that time :/
16:08:48 <dansmith> to do the releases push?
16:08:56 <gibi> yes, check the release push
16:09:15 <gibi> I can declare the spec freeze the next Monday
16:09:20 <dansmith> is that just a "verbal" sign-off so someone on the release team can +2?
16:09:35 <gibi> it is a +1 vote on the release patches
16:09:52 <dansmith> yeah, and do we have to propose the release patch or is it done automatically?
16:10:01 <gibi> it is automatical I belive
16:10:09 <gibi> I will talk to the release team about it
16:10:15 <dansmith> ack, okay I'll be glad to do that
16:10:21 <gibi> thank you
16:10:22 <dansmith> which day specifically? 30th?
16:10:55 <gibi> 30th yes
16:11:07 <dansmith> cool, will mark
16:11:09 <gibi> thanks
16:11:22 <gibi> any other issue about the coming release?
16:12:08 <gibi> #topic Stable Branches
16:12:28 <gibi> do we have somebody from stable land?
16:12:42 <elod> yep, I'm here
16:12:52 <elod> stable gate is ok, back till Pike
16:12:58 <gibi> \o/
16:13:11 <elod> otherwise I don't think there's anything else
16:13:22 <gibi> thanks
16:13:39 <gibi> #topic Sub/related team Highlights
16:13:44 <gibi> API (gmann)
16:14:48 <gibi> I guess gmann is not here today
16:14:55 <gibi> Libvirt (bauzas)
16:15:21 <gibi> bauzas let me know before the meeting that there is one bugfix from aarents #link https://review.opendev.org/#/c/696084/ that would need a set of eyes
16:15:43 <gibi> #topic Stuck Reviews
16:15:49 <gibi> nothing on the agenda
16:15:56 <gibi> any stuck review to raise?
16:16:24 <gibi> #topic Open discussion
16:16:30 <gibi> nothing here either
16:16:32 <tosky> if I may
16:16:34 <dansmith> I have a thing
16:16:37 <gibi> tosky: go
16:17:00 <tosky> hi! I'm the coordinator for the "zuul v3 porting" community goal
16:17:19 <tosky> https://governance.openstack.org/tc/goals/selected/victoria/native-zuulv3-jobs.html , just in case
16:17:52 <tosky> nova is in a pretty good shape, but there are a few jobs that needs to be ported, and I remember some discussion not long ago on #openstack-nova
16:18:22 <tosky> I haven't sent a proper report on the list (waiting on a documentation patch to land) but I can share the etherpad with the status: https://etherpad.opendev.org/p/goal-victoria-native-zuulv3-migration
16:18:37 <tosky> go to line 187 to find nova
16:18:58 <gibi> tosky: thanks for the list
16:19:02 <tosky> I sent out https://review.opendev.org/740447 (it's recent, so not stuck) to clean one job
16:19:02 <lyarwood> tosky: ACK I still want to work on migrating nova-live-migration FWIW
16:19:10 <tosky> lyarwood: yep, I remember that one
16:19:19 <tosky> the other jobs are:
16:20:02 <tosky> - nova-grenade-multinode, which is not the usual grenade job, it does a lot of thing in a post-hook script; while it could be quickly ported, maybe it could be made a bit more ansible/zuul-friendly
16:20:12 <tosky> I haven't checked the other two jobs,
16:20:22 <tosky> - legacy-grenade-dsvm-neutron-multinode-zero-downtime
16:20:28 <tosky> - legacy-tempest-dsvm-nova-libvirt-kvm-apr
16:21:35 <gibi> the last two is in the experimental queue I believe
16:21:42 <tosky> thanks lyarwood - I haven't noticed the review for nova-live-migration, please try to use the  native-zuulv3-migration  gerrit topic
16:21:49 <tosky> gibi: right, but they are potentially running
16:22:20 <tosky> so that's the full status (nova-dsvm-multinode-base is a base job that can be removed when the children are ported)
16:22:24 <gibi> tosky: true, but I have no memory about those so I will ask gmann maybe he know how important they are
16:22:50 <gibi> tosky: thanks for yor reminder that we need to work on these
16:23:07 <tosky> that's it from my side; I'm around for review (I can't help too much on the project-specific logic, but I can help with the general porting)
16:23:11 <lyarwood> tosky: ack done, I'll push it along ahead of M2
16:23:15 <tosky> thanks!
16:23:21 <gibi> tosky: thanks
16:23:27 <gibi> dansmith: you had a thing too.
16:24:16 <dansmith> yeah, so after a loooot of changes, some nova, many glance, some more devstack, this job is now passing which adds multistore and store-copying testing: https://review.opendev.org/#/c/734184/
16:24:17 <dansmith> gmann is already +2 on it,
16:24:25 <dansmith> would like to get a +W and land it before anything regresses that it is covering
16:24:45 <dansmith> basically, subclasses the existing ceph job and just adds multiple stores and more realistic config
16:25:30 <dansmith> (that's all)
16:25:33 <gibi> added to my list but I'm not a ceph person so if there are better reviewer candidates then don't wait for me
16:26:03 <dansmith> there's not really much to review honestly.. it's a bunch of glance config that unless you're a glance expert won't mean much
16:26:19 <dansmith> gmann did an extensive review of checking that all the new things are happening, which might be useful
16:26:48 <dansmith> the review is one of his last comments on this patch: https://review.opendev.org/#/c/740322/10
16:26:56 <dansmith> has links to logs and stuff that you can follow
16:26:57 <gibi> cool, I will check
16:27:17 <dansmith> anyway,
16:27:38 <dansmith> point being, it looks hairy because of all the glance config and I don't want it to get ignored and have things regress before we can get that landed
16:27:51 <dansmith> because nova, glance, devstack all needed changes to make this work, so lots of exposure
16:28:04 <dansmith> glance and the ceph plugin will add this to their gate too once it's landed, but they can't until it is
16:28:50 <gibi> ack, try to hit it tomorrow
16:29:06 <dansmith> thanks
16:29:18 <gibi> anything else for today?
16:30:20 <gibi> then thanks for joining today
16:30:28 <gibi> #endmeeting