21:01:23 <efried> #startmeeting nova
21:01:24 <openstack> Meeting started Thu Sep 12 21:01:23 2019 UTC and is due to finish in 60 minutes.  The chair is efried. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:27 <openstack> The meeting name has been set to 'nova'
21:01:37 <takashin> o/
21:01:43 <dansmith> o/
21:01:58 <stephenfin> o/
21:02:24 <mriedem> o/
21:02:47 <aspiers> o. (only half here)
21:04:14 <dansmith> efried: ?
21:04:21 <efried> #link agenda https://wiki.openstack.org/wiki/Meetings/Nova#Agenda_for_next_meeting
21:04:28 <sean-k-mooney> o/
21:04:37 <efried> #topic Last meeting
21:04:37 <efried> #link Minutes from last meeting: http://eavesdrop.openstack.org/meetings/nova/2019/nova.2019-09-05-14.01.html
21:05:03 <efried> action fup from last time, I deferred several blueprints
21:05:52 <efried> The ones remaining
21:05:52 <efried> #link train blueprints https://blueprints.launchpad.net/nova/train
21:05:52 <efried> are either merging, or can be merged after FF (mox removal)
21:06:10 <mriedem> umm,
21:06:15 <efried> uh, I think auto converge needs deferral
21:06:27 <mriedem> can we close the mox-removal one and not actively merge more of those after FF?
21:06:31 <mriedem> there isn't 0 risk in those,
21:06:35 <dansmith> for sure
21:06:44 <mriedem> especially after RC1 b/c those make backports a PITA
21:06:46 <efried> there isn't?
21:06:55 <dansmith> zero risk in mox removals?
21:06:57 <dansmith> there's tons of risk
21:07:01 <dansmith> they're really hard to validate
21:07:07 <mriedem> after FF we should be pretty conservative since we only have 2 weeks
21:07:07 <dansmith> and if they're wrong, they uncover code
21:07:22 <mriedem> 2 weeks to RC1 i mean
21:07:53 <stephenfin> efried: tbh, I reviewed most of them but I think we should probably wait til we fork too
21:07:55 <sean-k-mooney> we are n-4 weeks form GA right
21:08:02 <efried> okay, #undo #undo #undo Most of the remaining blueprints are merging, a couple still need to be deferred
21:08:02 <efried> #action efried to scrub train blueprints next week.
21:08:40 <dansmith> sean-k-mooney: we're two weeks from being at the point where any changes are hard
21:08:53 <efried> #topic Release News
21:08:53 <efried> Feature freeze is today
21:09:38 <efried> many things are merging, but of course the gate a) is chock-full of stuff that's merging, b) shat on itself last night, exponentially blowing up the queue
21:09:55 <sean-k-mooney> FN was down for a router swap
21:10:00 <sean-k-mooney> and vexhost was down
21:10:06 <sean-k-mooney> because we were not cleaning up
21:10:09 <efried> and there was a configparser dep issue
21:10:10 <sean-k-mooney> bfv instanfes
21:10:31 <sean-k-mooney> FN is back so hopefully the gate will get less jamed
21:10:51 <mriedem> sean-k-mooney: not cleaning up?
21:11:07 <sean-k-mooney> ya we hit qutoa with vexhost
21:11:18 <sean-k-mooney> because nodepool was not properly cleaning up
21:11:22 <mriedem> we = openstack/zuul?
21:11:23 <mriedem> ok
21:11:25 <mriedem> anyway
21:11:27 <sean-k-mooney> infra re looking at ti now
21:11:45 <efried> Things +A by EOB today we should be allowed to recheck, rebase (even manual if trivial) and re+W, etc. until at least Monday. At that point we can reassess.
21:11:48 <mriedem> i don't know if it's just FF week that the gate always explodes or because of that, but this always happens
21:11:53 <efried> ikr
21:12:16 <efried> #link Release todos: https://etherpad.openstack.org/p/nova-train-release-todo
21:12:25 <efried> thanks for starting that ^ ... mriedem?
21:13:00 <mriedem> yes
21:13:13 <mriedem> i needed to write down some stuff
21:13:54 <efried> stephenfin said he was gonna do the cycle highlights, but he's been headless-chicken/one-armed-paperhanger/one-legged-man-in-ass-kicking-contest
21:14:01 <efried> so if someone else wanted to volunteer for that...
21:14:29 <mriedem> i can push a patch
21:14:30 <mriedem> to start it up
21:14:35 <efried> thanks mriedem
21:14:37 <mriedem> i dumped more stuff in the prelude etherpad,
21:14:41 <mriedem> based on the train blueprints in lp
21:14:43 <stephenfin> crap. I forgot :(
21:14:48 <efried> #action mriedem to start cycle highlights
21:14:53 <mriedem> stephenfin: i've got it
21:14:56 <efried> #link https://etherpad.openstack.org/p/nova-train-prelude
21:15:00 <stephenfin> thanks
21:15:31 <efried> Anything else release-y?
21:15:59 <efried> #topic Bugs (stuck/critical)
21:15:59 <efried> No Critical bugs
21:15:59 <efried> #link 76 new untriaged bugs (+0 since the last meeting): https://bugs.launchpad.net/nova/+bugs?search=Search&field.status=New
21:15:59 <efried> #link 3 untagged untriaged bugs (-1 since the last meeting): https://bugs.launchpad.net/nova/+bugs?field.tag=-*&field.status%3Alist=NEW
21:15:59 <efried> Anyone have anything important to bring up here?
21:16:22 <efried> #topic Gate status
21:16:22 <efried> sucky
21:16:22 <efried> next topic
21:16:38 <efried> #topic Reminders
21:16:38 <efried> #link Call for release highlights: http://lists.openstack.org/pipermail/openstack-discuss/2019-September/009137.html - due on feature freeze (today)
21:16:38 <efried> #link Release note prelude: https://etherpad.openstack.org/p/nova-train-prelude
21:16:38 <efried> ^ we just talked about
21:16:43 <efried> #link September 20 is the deadline for Forum topic submissions: https://cfp.openstack.org/
21:16:47 <stephenfin> I think I have one, but I'll post it on #openstack-nova shortly
21:17:01 <efried> stephenfin: have one what?
21:17:11 <stephenfin> important bug
21:17:23 <stephenfin> (we can't book if we request any traits)
21:17:26 <stephenfin> *boot
21:17:39 <efried> psshhht, why should THAT matter?
21:17:50 <stephenfin> that's the spirit
21:18:00 <efried> so yeah, that would seem like an important bug.
21:18:09 <efried> um, should we talk about it here?
21:18:27 <stephenfin> sec - incoming
21:18:42 <efried> #topic Stable branch status
21:18:42 <efried> gonna skip over this unless mriedem something critical?
21:18:58 <mriedem> efried: nope
21:20:25 <melwitt> o/
21:20:30 <efried> stephenfin: we can't boot if we *don't* request any traits?
21:20:40 <stephenfin> if we _do_
21:20:42 <efried> anyway, yeah, can discuss in the review
21:21:36 <efried> #topic Sub/related team Highlights
21:21:36 <efried> Placement (cdent)
21:21:36 <efried> #link latest pupdate http://lists.openstack.org/pipermail/openstack-discuss/2019-September/009160.html
21:21:36 <efried> Consumer Types: cdent continuing this work
21:21:36 <efried> #link consumer types (in progress) https://review.opendev.org/#/q/status:open+project:openstack/placement+branch:master+topic:bp/support-consumer-types
21:22:23 <efried> and tetsuro will be ussuri PTL http://lists.openstack.org/pipermail/openstack-discuss/2019-September/009274.html https://review.opendev.org/#/c/681226/
21:22:45 <efried> anything else placementy?
21:23:37 <efried> API (gmann)
21:23:37 <efried> #link microversion 2.78 is merged: https://review.opendev.org/#/c/621476/
21:23:37 <efried> #link policy-defaults-refresh deferred to ussuri https://review.opendev.org/#/c/674038/
21:23:43 <efried> I didn't see anything on the ML
21:23:58 <efried> #topic Stuck Reviews
21:24:01 <efried> any?
21:24:17 <efried> #topic Review status page
21:24:17 <efried> skipping
21:24:25 <efried> #topic Open discussion
21:24:25 <sean-k-mooney> i think just the ones waiting on zuul to +2
21:24:26 <mriedem> 2.79 was also merged,
21:24:36 <mriedem> the 2.80 api change is sitting,
21:24:43 <mriedem> mel and i have been over it, but i haven't been over the latest
21:24:52 <mriedem> and i'm not sure how much i feel like rushing that in tonight
21:24:59 <mriedem> but i wouldn't be surprised if brinzhang asks for a FFE
21:25:14 <efried> #link 2.80 https://review.opendev.org/#/c/674243/29
21:25:26 <efried> meh, what possible risk in an API change?
21:25:29 <melwitt> I'm +2 on it pending if mriedem is happy with it
21:26:09 <efried> any opens?
21:27:08 <efried> Okay, back to life.
21:27:08 <efried> o/
21:27:08 <efried> #endmeeting